Jump to content


Photo

Magic Staggers and Completely Stun-Locks My Character. It gets stranger though..

magic stagger script bug

  • Please log in to reply
5 replies to this topic

#1 Gunkin

Gunkin

    Prisoner

  • Members
  • 22 posts

Posted 23 February 2016 - 06:31 PM

    To start off, Here's  My Load Order & My Plugin Order . I'm using Mod Organizer, and my Specs are in my Signature  =D

 

As you can gather from the title, I am getting completely Perma-Staggered anytime I am affected by harmful magic.

 

Example: A Necromancer casts Flames at me. Each time I take damage there will be a "Clanking" sound, akin to the sound of Metal or a Ward Spell, and I will become unable to move. It becomes an ongoing cycle, even with Projectile Magic, as the Stagger keeps me in place, unable to block or dodge the next Projectile, and so on.. effectively Stun-Locking me.

 

I first noticed this while doing LOD testing before I officially started my playthrough, when I got attacked by a Mage in the wilderness, but I guess I dismissed it. However now, Combat is essentially un-playable, and I would REALLY appreciate some help. I have been doing a lot of reading, searching, and troubleshooting and I have found that it seems​ to be something happening with the Scripts in my Save.

 

Things I have tried: the short version

Disabled groups of Mods at a time, to rule out any that would be Problematic

 

Once I could not find any solution doing that I re-enabled everything, cut-pasted all Saves into a new Backup Folder, restarted PC (because why not) and then Started a New Game.

 

Player.Advskill leveled my skills until I had a new character that was the same Level, in the same type of Armor, and had the same Skill-Progression. Then I spawned a Necromancer, allowed him to let-loose on me, and I did not stagger once.

 

This made it clear that it was an issue with my specific SaveGame somehow.

I got SGSC (SaveGameScriptCleaner), and went to work trying to clean various things. Each time I used a copy of the Original Save, and I started with just cleaning Orphan Scripts. Didn't Work.

 

Each time, using a fresh copy, I tried to then clean Orphans + Other,  Orphans + Other + Broken Actives, So on & so forth. After each new copy was cleaned, I would try it out, and nothing Fixed the issue.

 

Eventually I had tried every cleaning option, including using them all at once. Still didn't work.

 

 

I desperately want to save this SaveGame and not have to trash it, is there anything I'm missing, or any suggestions?

I'm no Modding Guru or anything, but I understand enough (at least I think)  So if I have to do anything unconvential, or complicated I'm willing to do so, I just have no idea what to do next, of if this is even Fixable.

 

I'm not sure what other info I should provide aside from this, but if anything is needed let me know! 

I greatly appreciate ANY help that anyone can give, Thanks!


  • 0

#2 cooldown

cooldown

    Prisoner

  • Members
  • 3 posts

Posted 09 October 2017 - 02:16 PM

Have you found a solution to this? I'm at a loss with the same issue. There was an advice to use another ward spell so that it "overwrites" the existing ward but that didn't help me.


  • 0

#3 Kelmych

Kelmych

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,822 posts

Posted 09 October 2017 - 05:42 PM

There have been comments on similar problems for a long time when a magic script “sticks” to a character. The best known is the LvlPredatorScript problem (which was fixed a while ago) but there are other similar problems that have seen mentioned once in a while. It is a save game problem (an engine problem) not a mod problem. I don’t remember exactly where I found a solution when I had a related problem.

#4 cooldown

cooldown

    Prisoner

  • Members
  • 3 posts

Posted 10 October 2017 - 05:33 PM

There have been comments on similar problems for a long time when a magic script “sticks” to a character. The best known is the LvlPredatorScript problem (which was fixed a while ago) but there are other similar problems that have seen mentioned once in a while. It is a save game problem (an engine problem) not a mod problem. I don’t remember exactly where I found a solution when I had a related problem.

I suspected that it was because of the save file because that issue never appeared on other characters. If I use papyrus logs, can I find out what script is causing this? Or this is completely a matter of guessing?


  • 0

#5 Kelmych

Kelmych

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,822 posts

Posted 10 October 2017 - 06:36 PM

One set of script problems does involve spamming the papyrus script logs, but these script errors usually involve CTDs at some point. Did you try using player.dispelallspells in the console; sometime this works? The sovengard glow bug is similar and searching for posts on it with google might lead you to a solution for your problem. The Nexus thread on "TUTORIAL: REMOVING UNWANTED MAGIC EFFECTS FROM THE PLAYER" might have some ideas.



#6 cooldown

cooldown

    Prisoner

  • Members
  • 3 posts

Posted 11 October 2017 - 06:30 PM

One set of script problems does involve spamming the papyrus script logs, but these script errors usually involve CTDs at some point. Did you try using player.dispelallspells in the console; sometime this works? The sovengard glow bug is similar and searching for posts on it with google might lead you to a solution for your problem. The Nexus thread on "TUTORIAL: REMOVING UNWANTED MAGIC EFFECTS FROM THE PLAYER" might have some ideas.

So far I've tried (combined in order):

  • using a spell ward to overwrite the existing hidden one
  • dispelallspells on self
  • recycleactor on self
  • visual effects cleaning manual from Nexus (the issue here is that it's not a visual bug)
  • changing race "safely" (via showracemenu alternative mod)
  • changing race unsafely (via showracemenu)
  • changing the race, saving, exiting, loading the new save, saving again, exiting again, loading again ("clean save" procedure, kinda)

Even after all that a completely ruined gameplay-wise character is still getting staggered.

I checked the Papyrus log (all logging options enabled) while getting staggered (game running in the background) but it had no messages.
I decided to do a quicksave right as a spell hits me and I get staggered and then check it out with PDTWrapper.

There were 6 active script threads: 2 from undeath, 1 from campfire, 1 from asis, 1 from skyrim-misc (hearthfires stuff) and 1 from EFFcore. I disabled all those mods (ouch) and still got staggered.

I then saved in the same circumstances again and ran the save cleaner tool and used all options except the ones in "advanced", and got the same result. Then I also used the "advanced" options and that didn't help too. Also waiting 30 days for everything to reset didn't help too.

 

I'll search for ways to trace active scripts in real time tomorrow and report what I find.

 

I know this issue is very rare, based on what I've found so far so I'll do my best to log everything I do for future reference.


Edited by cooldown, 11 October 2017 - 06:38 PM.

  • 0



Also tagged with one or more of these keywords: magic, stagger, script bug

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users