Jump to content


Photo
Issue

Wiki pages are very slow



  • Please log in to reply
76 replies to this topic

#16 JUNKdeLUXE

JUNKdeLUXE

    Commander

  • Members
  • PipPipPipPip
  • 318 posts

Posted 15 June 2016 - 03:36 AM

Boyaaa.. Great work s4n
  • 0

#17 z929669

z929669

    Ixian Inventor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,258 posts

Posted 15 June 2016 - 12:16 PM

We had a 4X increase in normal traffic, and had a configuration issue that was rectified. Should be performing a lot better since yesterday early evening.

Still really slow for me right now. Might want to check MySQL (DB size) and caching. Pingdom tests are not so good.



#18 stoppingby4now

stoppingby4now

    Sleepy

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,281 posts

Posted 15 June 2016 - 07:39 PM

Current caching is good. I can't test during the day, but during lower peak usage, the wiki is loading fast for me. The larger culprit is being driven by a spike in in-bound connections that starts just after 9AM server time. This directly impacts server load. Increasing the number of processes to handle more connections will also directly impact server load, potentially more negatively than the current state.

 

You also have to take Pingdom with a grain of salt to a certain extent. It is connecting as if it is a first time user, which means there is no benefit of client side caching of all of the resources such as CSS, JS, images, and initial page view. There are a lot more resources being loaded for the Wiki compared to the Forum. A test via Pingdom in the past 10 minutes reported a little over 10 second load time, but a refresh in my browser was under 3 seconds.

 

There are some things I can look at implementing to help reduce the stress further, but will take some time to setup and test.



#19 TirigonX

TirigonX

    Guard

  • Members
  • PipPip
  • 191 posts

Posted 16 June 2016 - 11:11 AM

Right now I can't access the wiki at all. Page keeps loading and loading until I get a 504 Gateway Time-out


  • 0

#20 ghostwalkr

ghostwalkr

    Prisoner

  • Members
  • 8 posts

Posted 20 June 2016 - 03:42 PM

Good afternoon.. 

Not sure if this thread is still active, but I wanted to pass along that the pass day or so I've been getting a 504 Gateway Time-out whenever I try to access the main wiki page.

As others in this thread have stated, the forums are working just fine.

[ghost]


  • 0

#21 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,102 posts

Posted 20 June 2016 - 03:48 PM

They have been slow today. I've been updating some content and loads take a while.



#22 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,591 posts

Posted 20 June 2016 - 04:24 PM

Yeah, its really bad today, I cant even load SRLE



#23 Darth_mathias

Darth_mathias

    Dragon King

  • Pack Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,869 posts

Posted 20 June 2016 - 04:28 PM

nor have I been able load SRLE Extended since about 3pm GMT.


  • 0

#24 A_Simple_Farmer

A_Simple_Farmer

    Prisoner

  • Members
  • 10 posts

Posted 20 June 2016 - 07:56 PM

I'm a new to this site (been on for a little over a week).  I thought the slow site was normal.  It's usually faster in the evening for me.


  • 0

#25 Neovalen

Neovalen

    Talos

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,659 posts

Posted 21 June 2016 - 11:33 AM

Site is slow as molasses right now... 9ish AM Pacific Time.


  • 0

#26 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,102 posts

Posted 21 June 2016 - 11:59 AM

Yeah, it's happening during the daytime, but the problem is that S4N said he can't check it in the daytime. If this is all resource related and not software, we may have to start looking into new server. Can only wait for S4N to check it out.



#27 JUNKdeLUXE

JUNKdeLUXE

    Commander

  • Members
  • PipPipPipPip
  • 318 posts

Posted 21 June 2016 - 02:42 PM

The forum has started acting slow as well.

 

Posting a rather simple reply (link here) took 20 seconds to post.


  • 0

#28 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,102 posts

Posted 22 June 2016 - 06:14 PM

Time to do something! I'm now being contacted on other outlets (Facebook for now) about the slow or inaccessible wiki. Plus 3 pages about this and reports over it. Whatever needs to be done we should discuss it here or in the Admin forums.

#29 stoppingby4now

stoppingby4now

    Sleepy

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,281 posts

Posted 22 June 2016 - 11:53 PM

Testing is in the works to get a solution in place to help with the slowness. Likely won't be able to fully implement till the weekend assuming my testing pans out OK. Either way, there will be a last minute maintenance to implement when I'm ready, since I don't know when I'll be fully ready and I want to get this setup ASAP.



#30 z929669

z929669

    Ixian Inventor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,258 posts

Posted 24 June 2016 - 11:24 AM

Slowness pertains only to the wiki and has to do with recent spike in wiki-page requests. As s4n stated, a fix is under development for implementation this weekend, which should resolve the wiki issue until we ramp up a new server later this year.





Also tagged with one or more of these keywords: Issue

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users