Jump to content


Photo

Skyrim Redesigned: Putting Money Bags and Alchemy Table textures through DDSopt?


Best Answer TechAngel85 , 26 June 2016 - 09:28 AM

Change this iTexMipMapSkip=1 to this iTexMipMapSkip=0 in your SkyrimPrefs.ini under [Display] and test to see if the issue persists.

Go to the full post


  • Please log in to reply
10 replies to this topic

#1 Tykune

Tykune

    Citizen

  • Members
  • Pip
  • 90 posts

Posted 26 June 2016 - 08:40 AM

So I've been having an issue with the money bags and alchemy table having black and rainbow textures, but then i read somewhere that putting them through DDSopt can fix it? How do I go about doing this to fix the texture? Or is there another way of going about it?


  • 0

#2 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,107 posts

Posted 26 June 2016 - 09:21 AM

Here's our DDSOpt Guide: http://wiki.step-pro...om/Guide:DDSopt

 

It's strange that only certain users have this issue. I've never seen it myself.



#3 Tykune

Tykune

    Citizen

  • Members
  • Pip
  • 90 posts

Posted 26 June 2016 - 09:24 AM

Here's our DDSOpt Guide: http://wiki.step-pro...om/Guide:DDSopt

 

It's strange that only certain users have this issue. I've never seen it myself.

From what I've researched up, users with low to medium graphic settings get these issues, but those using high settings have no issues with it. Looking into the texture files, I noticed that alchemyworkbench01.dds and moneybag01.dds are missing mipmap textures. Could this be the issue?


  • 0

#4 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,107 posts

Posted 26 June 2016 - 09:24 AM

Now, I'm curious if this is caused by a rogue INI tweak.

 

Can you post your Skyrim.ini and SkyrimPrefs.ini ?



#5 Tykune

Tykune

    Citizen

  • Members
  • Pip
  • 90 posts

Posted 26 June 2016 - 09:26 AM

Now, I'm curious if this is caused by a rogue INI tweak.

 

Can you post your Skyrim.ini and SkyrimPrefs.ini ?

Sure thing.

Attached Files


  • 0

#6 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,107 posts

Posted 26 June 2016 - 09:28 AM   Best Answer

Change this iTexMipMapSkip=1 to this iTexMipMapSkip=0 in your SkyrimPrefs.ini under [Display] and test to see if the issue persists.



#7 Tykune

Tykune

    Citizen

  • Members
  • Pip
  • 90 posts

Posted 26 June 2016 - 09:32 AM

Change this iTexMipMapSkip=1 to this iTexMipMapSkip=0 in your SkyrimPrefs.ini under [Display] and test to see if the issue persists.

Fix confirmed. I wasn't even aware such an option existed in SkyrimPrefs. What exactly was this doing?


  • 0

#8 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,107 posts

Posted 26 June 2016 - 09:43 AM

According to our INI Guide:
 

 

iTexMipMapSkip sets the texture quality (determined by the number of mipmaps to skip). It is recommended to be set to 0 to preserve full texture fidelity.



#9 Kesta

Kesta

    Thane

  • Mod Authors
  • PipPipPipPipPipPip
  • 471 posts

Posted 26 June 2016 - 09:50 AM

Yes, any textures missing proper mipmaps will glitch heavily if iTexMipMapSkip is set to anything else than 0.

 

0 is default for ultra (and maybe high) settings. Not a "rogue" ini tweak, but definitely a bad idea (performance impact is close to 0)

 

 

 

I believe iTexMipMapSkip set the number of mipmap to skip from the default's size when fully rendered. So if a texture is 2k (2048x2048), and have all of its mipmap (1024x1024, 512x512, 256x256, 128x128, ...):

iTexMipMapSkip = 0 will use all of the mipmaps, when lookep up close the texture will be the 2K one

iTexMipMapSkip = 1 will use all of the mipmaps, but not the original size (no matter how close you look at the texture n-gaùme, it's max resolution will be 1024x1024)

iTexMipMapSkip = 2 will skip both the 1024x1024 and the 512x512

etc...

 

Which would explain why textures without mipmaps glitch when this setting is set to anything else than 0. An interesting experiment would be to generate textures with a single mipmap (a 2K texture with a single 1K mipmap), and see if iTexMipMapSkip = 1 is still ok but iTexMipMapSkip=2 glitch. That would basically validate the above hypothesis.

 

 

This setting serve as a quick way to reduce the rendered texture's quality to slightly help performances. However, textures are still loaded completely and thus eat the same amount of VRAM regardless of this setting (only Fallout 4 with its optimized mipmaps chunk in its .ba2 archive can go around this), which is why the tweak isn't helping performances much. Better always have it to 0 and pick your textures size using your brain.


Edited by Kesta, 26 June 2016 - 09:50 AM.

  • 0

#10 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,107 posts

Posted 26 June 2016 - 09:50 AM

It's likely still due to an issue with the mipmaps and running DDSOpt on the textures will still likely fix the issue.

 

@Kesta... :ninja: :ninja:



#11 Tykune

Tykune

    Citizen

  • Members
  • Pip
  • 90 posts

Posted 26 June 2016 - 09:57 AM

Yes, any textures missing proper mipmaps will glitch heavily if iTexMipMapSkip is set to anything else than 0.

 

0 is default for ultra (and maybe high) settings. Not a "rogue" ini tweak, but definitely a bad idea (performance impact is close to 0)

 

 

 

I believe iTexMipMapSkip set the number of mipmap to skip from the default's size when fully rendered. So if a texture is 2k (2048x2048), and have all of its mipmap (1024x1024, 512x512, 256x256, 128x128, ...):

iTexMipMapSkip = 0 will use all of the mipmaps, when lookep up close the texture will be the 2K one

iTexMipMapSkip = 1 will use all of the mipmaps, but not the original size (no matter how close you look at the texture n-gaùme, it's max resolution will be 1024x1024)

iTexMipMapSkip = 2 will skip both the 1024x1024 and the 512x512

etc...

 

Which would explain why textures without mipmaps glitch when this setting is set to anything else than 0. An interesting experiment would be to generate textures with a single mipmap (a 2K texture with a single 1K mipmap), and see if iTexMipMapSkip = 1 is still ok but iTexMipMapSkip=2 glitch. That would basically validate the above hypothesis.

 

 

This setting serve as a quick way to reduce the rendered texture's quality to slightly help performances. However, textures are still loaded completely and thus eat the same amount of VRAM regardless of this setting (only Fallout 4 with its optimized mipmaps chunk in its .ba2 archive can go around this), which is why the tweak isn't helping performances much. Better always have it to 0 and pick your textures size using your brain.

Thanks for the explanation. I will definitely remember it for picking texture options in the future.


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users