Jump to content


Photo

Skyrim CTD BEFORE Bethesda Logo with ENB

enboost skse.ini

  • Please log in to reply
12 replies to this topic

#1 SayidD

SayidD

    Prisoner

  • Members
  • 6 posts

Posted 11 August 2016 - 11:29 PM

Hello S.T.E.P community, I hope somebody can help with my problem:

 

Previous Info.:

RAM: 8192 MB

VRAM: 4037 MB

Graphic card: NVIDIA Geforce GX 750

Directx: Version 11

System: Windows 8.1 pro 64bits

             Intel ® core™ i5- 4440 CPU @ 3.10 Ghz (4 CPUs)

 

Using Mod Organizer

Using SKSE Memory patch

Crash fixes.ini from Mr. meh321(

Good Load order using LOOT as a base.

If anyone is curious

Master files cleaned

Several TES5EDIT patches for conflicts (then merging all of this plugins)
Using TES5Merged patch
Using wrye bash patch
Using DynDOLOD

 

This is my Skyrim.ini config

 

This is my Skyrimprefs.ini config

 

This is my SKESE.ini config

 

This is my CrashFixPlugin.ini config

I can play the game, already have 30 minutes playing, everithing smooth,but I get some CTD for what i suppose clash with the 3.1gb limiter, im getting this error message thanks to the mod CRASH FIXES from the mod´author meh321 on Nexus:

 
Skyrim has failed to allocate memory! Possibly running out of memory. Size/alignment of object being allocated was 67109039/0. Some things you can try:
1. Make sure ReduceSystemMemoryUsage=true is set in enblocal.ini - if you dont habe ENB then install ENBoost and enable this option.
2.Try set AlignHeapAllocate=0 in CrashFixPlugin.ini - if you get additional crashes then put back to 1.
3. If its during showracemenu then close the meno from time to time to free memory.

4. Enable CustomMemoryBlock in CrashFixPlugin.ini to reduce memory fragmentation. 

So I follow that instruction and downloaded the ENB binaries and follow the STEP tutorial (http://wiki.step-project.com/ENBoost), Because I already tried the N° 2 and 4; N° 3 wasnt the case.

 

Also I used the recommendations here: https://www.reddit.c...immods/wiki/enb

here: http://forum.step-pr...roubleshooting/

here: http://wiki.step-pro...ab=Installation

Prior to the CTDs I deactivated ONE TWEAK MOD, uncheck window mode in the skyrim launcher, put back the 1440x900 res, AA and AF always off before and after put and config. the enblocal.ini

 

NOTE: My graphic setup in the skyrim launcher is "normal", when I put to "low" before using enblocal.ini I get similar CTDs...weird I avoid this issue  IGNORE THIS PLEASE 

NOTE: the VRamSizeDX9.exe tool gave me the number that I put down below

NOTE 2: Yes I installed the Dirext 9 runtimes

NOTE 3: CTDs occurs in open places, obviously cause all the things that are charging in the game 

 

This is my enblocal.ini

 

 

PLease help, I have a clue that it have to be a conflict between the .ini  (enblocal.ini and the others), cause I really can load my saves without enblocal.ini but with CDTs that im trying to sovle with the enblocal.ini.

Thanks in advance T-T

Any info. that I skip and it will help to dilucidate this issue I will give it righ away!


Edited by SayidD, 11 August 2016 - 11:40 PM.

  • 0

#2 disi

disi

    Prisoner

  • Members
  • 47 posts

Posted 12 August 2016 - 08:04 AM

What I noticed, hope this helps:

 

Since you use the system memory allocator (UseOSAllocators=1) and not the blocks from the Skyrim engine, remove these lines from SKSE.ini:

[Memory]
DefaultHeapInitialAllocMB=768
ScrapHeapSizeMB=256

I know it should not matter and be ignored, but I had to do it in my setup.

 

You use the custom memory clock for small bits, but it is set very low in the CrashFixPlugin.ini:

CustomMemoryBlockTotalSizeMb=64

I myself need something close to 128. You can go ingtame and open the console (`), this will show the percentage of usage. It should be somewhat 80% for all.


  • 0

#3 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,493 posts

Posted 12 August 2016 - 08:49 AM

http://wiki.step-pro...Troubleshooting

Look under "CTD on game launch"



#4 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,493 posts

Posted 12 August 2016 - 08:59 AM

You can also try running memory blocks log to see if you're reaching your limit for "DefaultHeapInitialAllocMB". Also you shouldn't be using both the SKSE and CrashFixes memory fixes together. Use one or the other, not both.



#5 Nebulous112

Nebulous112

    High King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,451 posts

Posted 12 August 2016 - 11:10 AM

Hmm, did you install the SKSE Plugin Preloader in the root Skyrim folder? That is needed for UseOSAllocators=1. I assume you did, but thought I would check since you didn't mention it.

Also, fantastic report asking for help. THAT is how it should be done, people. Almost all the information we could want. :-)

#6 SayidD

SayidD

    Prisoner

  • Members
  • 6 posts

Posted 12 August 2016 - 09:19 PM

Grattitude Mr. Nebulous112, yes SKSE Plugin prelaoder installed correctly and thanks for the kind works n.n/

Will try with Mr. disi´recommendations then the one from Mr. Akatosh, and back with the results!

 

Again thanks.


  • 0

#7 SayidD

SayidD

    Prisoner

  • Members
  • 6 posts

Posted 13 August 2016 - 12:40 AM

I cant...I just cant believe this... Grrr, just Grrr

 

The first think that i did was uninstall DynDOLOD then I follow Mr. akatosh recomendation and "delete" (actually just moved to my desktop) the skse.ini and change the CustomMemoryBlockTotalSizeMb=64 to 128 as Mr. disi recommended (in the crashpluginfix.ini).

But still I was getting CTD before bethesda logo.

 

Then I got a Talos premonition.... "¿Why dont change the resolution in the skyrim launcher to the value that appears after uncheck windowed mode?"

So I tried that, change the 1440x900 to 1280x800 (the second option that I have and the only one before 1440x900)

And now magically I enter the menu! the ENB info. appeared in the corner, then the red message about the speedhack been activated appears, then menu loaded :D, then I create a new game (via the MCM menu of Skyrim Unbound mod), then I enter the game!!!

 

 

Now objetive info.:

I tried open the console (`), to see the percentage of usage. and I got this:

....

....

....

Memory block (16) current: 43.24% highest: 43.29%

Memory block (32) current: 40.24% highest: 40.25%

I can see  downgrade in the quality of textures  (they not see like 2K) is very clear that the AA  and AF options are off.

 

If Mr. disi have 80% aprox.  I suppose I can upgrade some tweaks in the .INIs?

Recommendations please as the only think that I change was delete the skse.ini? Perhaps should I install DynDOLOD again? I would prefer to get nice textures, and -I assume- if the new memory block usage % is not so high could Install again DynDOLOD?

Thanks in advance :)


Edited by SayidD, 13 August 2016 - 12:45 AM.

  • 0

#8 Greg

Greg

    Dragonborn

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1,777 posts

Posted 13 August 2016 - 12:44 PM

Put your skse.ini file back in place and delete the memory section. You need the other settings in skse.ini:

 

[General]
ClearInvalidRegistrations=1

[Display]
iTintTextureResolution=2048


#9 SayidD

SayidD

    Prisoner

  • Members
  • 6 posts

Posted 14 August 2016 - 04:11 AM

Hello Mr Greg, I did what you wrotte and got CTDs after clicked the "New" (game) option in the menu :/


  • 0

#10 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,493 posts

Posted 14 August 2016 - 08:54 AM

Please verify your local game cache in Steam: https://support.stea...=2037-QEUH-3335



#11 SayidD

SayidD

    Prisoner

  • Members
  • 6 posts

Posted 14 August 2016 - 11:46 PM

Mr Akatosh good ngiht, I did it, then put again the skse.ini as Mr. dragonborn recomm.
But still got rough border textures :/

 

Actual Skyrimprefs.ini

 

Actual enblocal.ini

 

Weird...
I used this recomm. from Mr. Sthaagg on nexus:

UseSMAA injector instead.


  1. Open archive
  2. Extract content of d3d9 folder
  3. Rename d3d9.dll to d3d9_smaa.dll,
  4. Copy/paste all files to your skyrim's root directory.
  5. Open enblocal.ini and set it as below :

[PROXY]
EnableProxyLibrary=true
InitProxyFunctions=true
ProxyLibrary=d3d9_smaa.dll


  • 0

#12 SayidD

SayidD

    Prisoner

  • Members
  • 6 posts

Posted 15 August 2016 - 01:00 AM

EDIT 2: So i figure somethign out, my windows desktop res is 1440x900, but in skyrim prefs.ini is 1280x800 (cause in 1440x900 i get the CTDs of this initial post), the result rough borders in textures.
If I change my windows res. to the same of the skyrimprefs I got nice textures ingame, but.. a blurry as hell windows, mircrosoft word etc D:
Any idea? please


  • 0

#13 Greg

Greg

    Dragonborn

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1,777 posts

Posted 15 August 2016 - 06:42 PM

It's not a good idea to download and overwrite skyrim.ini and skyrimprefs.ini (or even enblocal.ini) because (as you just discovered) some of the settings are specific to your system. At this point I think you should run Skyrim Launcher to let it generate your ini files fresh and then download and run BethINI to safely optimize the skyrim.ini and skyrimprefs.ini settings.





Also tagged with one or more of these keywords: enboost, skse.ini

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users