Jump to content


Photo

FWE Alternative start, don't start.


  • Please log in to reply
10 replies to this topic

#1 varrgas

varrgas

    Citizen

  • Members
  • Pip
  • 71 posts

Posted 13 August 2016 - 01:18 PM

Hello.

 

Well, i tried to fix this since a week and still have this issue. When i start the game, no crash, in work really well even with tone of mod (close to all of you guide) and just some little other mod who isn't in the list (but without impact on my issue, or i am blind ?).

Well, i start the game, a new game, i have the born scene, JIP selective fire ask for tutorial and i select "SKIP", then i have the gender choice, my name choice, my look (i don't select a Race from FCO, i know i must do this after leaving the vault) and then the scene over.

I must technically have the choice for alternative travel at this moment, just before the scene with me as a baby and my father in front of me, and before the message say "a year later" (i think it is this in english or close to)

 

But, if i have the message and selection option without any problem until the "Metro Map mods selection" part, when i use the mod after this point, MMM and even with all the blackned patch and wasteland collection patch.

If everything seems perfect in LOOT and even if the game start without issue and smooth in game with no issue (i don't see anything).

 

I can't have the choice box for alternative start.

 

 

 

In fact that not a real problem but i am afraid that , there is other thing who didn't work maybe, and i cant really check everything until i face it in game.

 

I am not a modder at all, i don't know how to create a mod or how to make a script but i learn some little thing about programming at school, the basic, and more later with the time, moding game etc.

I understand enough to be able to find where the issue is and sometime how to fix it if not to difficult.

 

Well, i found (with xEdit) the Script for Alternative Start from "FO3 Wanders Edition - Main File.esm"

In "Script" at the FormID : 0C0043E2, there is: AltStartSelectorScript

 

And in it at: SCTX - Script Source:

scn AltStartSelectorScript

short iState
short iButton
short iStartOption    ;Use by other quests (e.g., CG00) to determine the selected start
float fDelay

begin GameMode
    if iState == 0
        set fDelay to GetSecondsPassed
        set fDelay to 2
        set iState to 2
    elseif iState == 2
        set fDelay to FDelay - GetSecondsPassed
        if fDelay <= 0
            set iState to 3
            ShowMessage altStartSelect    
        endif
    elseif iState == 3
        set iButton to GetButtonPressed
        ; wait for user to select
        if iButton  > -1
            set iState to 2
            StopQuest AltStartSelector
            if iButton  == 0  
                set iStartOption to 1
                setstage CG01 0
            elseif iButton  == 1
                set iStartOption to 2
                ; set player date and position
                set gameyear to 2274
                set gamemonth to 7
                set gameday to 3
                set gamehour to 10
                Player.MoveTo AltStartMarker
                ; undo the settings from CG00 (birth) that prepared for CG01
                EnablePlayerControls
                ClearNoActivationSound    ;turns off the baby cry
                SetPCYoung  0
                StartQuest AltStart ;SetStage AltStart 0
            endif
        endif
    endif
end

it seems that all of this are condition to launch the alternative start Box because at this entries in the "References" section, there is the link to:

- AltStartSelector [QUST:0C0043E1]"

- AltStartSelect "choose your destiny" [MESG:0C0043E0]

 

 

I understand the End of this Script, who saying that if this or this option is select ,then teleport me at the Marker in the place where there is the Terminal to setup our alternative start Character, Or if we continue like always.

i understand that there is a delay in second before showing the box, then waiting the player choice etc etc.

 

But... when i go in xEDIT, there is no conflict at all with all entries linked between them about Alt tart. Not at all !

 

And my personal mod addition are... well, they do nothing, there is 2 basic Armor from Gopher, there is 2 follower compatible with JIP (amata and Sarah lyon), there is 3 house player mods and finally some texture without .esp ... And if i use all of them with FWE etc etc, until i am at the Metro Maps section, i have the Alternative start box and i can make a choice and all work fine. So my additional mods do nothing (i think)

 

I took a look in the patch installed after this point in xEDIT but there is nothing who conflict with those entries either...

 

I am totally lost.

 

 

I think there is nothing more that a little issue with the alternative start box but i am not sure. Any one have an idea ? a solution ? something to do ?

 

 


  • 0

#2 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,909 posts

Posted 13 August 2016 - 06:02 PM

It's a little vague as to what is actually wrong here, sorry.

From what I glean from this is you are not being presented with the alternate start option, is that correct? If so the answer is not in the script within FWE. Simply put if there was an error in that script it would have been found many years ago as that mod is quite old and used in many installations.

 

You will need to recheck that you have followed through with the installation of each mod in it's correct spot as outlined in the guide. Then check any patches that you have created.



#3 varrgas

varrgas

    Citizen

  • Members
  • Pip
  • 71 posts

Posted 13 August 2016 - 08:28 PM

sorry, my english is so bad ... i was maybe not enough clear.

 

With a fresh new game, during the introduction born scene, when you select your gender, name, look, with FWE i must have a text box with 2 option, "continue to dream" and "Wake Up", to continue the normal way or start the alternative start from FWE.

 

But... i have it unti close to the end of the Guide, but with MMM and the compatibility patch at the end of the Guide, even with a Bashed Patch or an xEdit merged Patch (i never use both at the same time, the xEdit was just to test), whatever i do, i don't have it anymore and the news mods are only from the Guide.

 

 

 

 

i have 1st remade the DL of the mods and do a full fresh install of everything, even the tools, the Game etc with CC cleaner for key register cleaning etc etc. (and the first time i was a fresh new clean install too).

I follow each step, slowly, really slowly, reading each line again and again, checking, keep all backup when i do edit in xEDIT.

I have read the installation instruction and watch all the video linked on the guide.

 

Like i said, everything is fine "until" i have to install MMM and the other thing after this point, and i have check again and again ... no conflict at all.

 

I have tested with MMM and the compatibility mod between MMM and the other mod, and if i instal them, no alternative start text box and selection choice.

If i remove them, i can use alternative start...

 

Maybe that one of the patch at the end of the guide but i cant really know because without some of them, the game crash, so ... hard to know if something that i need to have remove the alternative start or not.

 

What i experiment and... "feel", is like the script seems to need some time but the next scene come too fast, maybe just a feeling.


Edited by varrgas, 13 August 2016 - 08:29 PM.

  • 0

#4 Kelmych

Kelmych

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,809 posts

Posted 14 August 2016 - 09:04 PM

I haven't had any problems with Alternate Start, but I'll run some tests and see if I can duplicate your problem.



#5 varrgas

varrgas

    Citizen

  • Members
  • Pip
  • 71 posts

Posted 15 August 2016 - 12:36 PM

Thanks, i know that close to all the time, that an issue when someone didn't follow well instruction, maybe that my case, and i know how boring it is when someone tell you "yeah i did it well, many time check etc etc", and in fact, this guy have miss something... But i took close to 10h just to read again and again, one by one each of the instruction in my mod list ... and i don't understand.

Even without my personal mod addition, i have this issue.

 

This the files who can maybe help you:

 

Load Order : http://pastebin.com/NDbbj0cR

Modlist : http://pastebin.com/N63bQrYg

Plugins : http://pastebin.com/H5uZmpVD

 

(there is plugins translated in french, but i can duplicate my problem even without the translated version with all the original esp in english)

 

Ps: Don't wast too mush time on the issue, you help many people a lot, my issue isn't that big and the alternate start isn't something i want to use at 100% sur.

 

The thing who afraid me is: There is other thing who did or will not work anymore ? or that just the alternate start feature ?

 

I doesn't want to realise that my 50hours or 100hours and more game is out because of this.


  • 0

#6 Kelmych

Kelmych

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,809 posts

Posted 17 August 2016 - 02:41 PM

I used my current profile and tried creating a new game, and I did get the Alternate Start menu at the end of the intro sequence. My profile includes many plugins that you are not using so the load order from LOOT is a bit different. The main plugins you include that I don't use are Fallout Character Overhaul, Robco Certified, and companion mods. Have you tried starting a game without these? I also don't use the same Millenia replacer plugins and some weapon plugins that you use, but I don't see how these could affect the intro sequence.



#7 varrgas

varrgas

    Citizen

  • Members
  • Pip
  • 71 posts

Posted 21 August 2016 - 12:48 AM

For milena etc, i don't see too.

 

Sadly, i tried without and with FCO, in both case i can have the Alternate start menu, same test for companion mod, with and without, and still have the Alternate stat menu in both.

 

For Robco Certified, i have it in mod organizer but not activated.

 

 

When i try with and then without a mod, i test around 5 time for each case, and i try each case with and Without the MMM mod and the other compatibility patch.

 

 

 

I want to notice something really strange ... at a moment (i was raging a lot) i have deactivate all mod except FWE, (not only uncheck .esp, really deactivate all the mod, one by one, starting byt the one the lower in the mod installation tab)

And so i start the game with only FWE (and fose, Fallout stuter remover, FNV anti-crash)

 

And... no Alternate start menu ... that was ... weird... because when i have test with only FWE before there wasn't issue and the .esp was still the same, nothing change, no edit at all.

 

So i deactivate everything, then re-activate FWE and check .esp are "on" ... and ... nothing again ... no alternate start menu ... but when i continue the game (not loading a old save) and until i exsit the vault, i can see that FWE is activated...

That was really frustrating and i was thinking that my FWE translated .esp was ****ed maybe, so i remove them, and i use the orignal .esp in English from the mod page.

But again, no alternate start menu.

 

Then i was thinking that maybe that was my MO profile who have an issue.

I create a new profile, refresh my F3 ini as default and edited as mentioned in the guide and copy past them in MO profile too.

I install and activate "only" FWE from the nexus.

 

Now it work again ! the Alternate start menu is there, but things don't stop there. I switch to the profile who seems to be buggy, and before doing a refresh of the ini or else, i start the game again with FWE activated, (the older one already installed, not the new fresh downloaded for the new profile before).

 

And it work again ! So i use my translated FWE .esp again, and yes it work !

 

At this point i don't understand, so i try to activate all my mod one by one and after Each mod i test the game (yeah, i take a lot of time ...)

Like before, until before Mart's Mutant mod, no issue and the Alternate Start menu is there.

And if i activate the MMM Mod and the compatibly patch, no ... with or without FWE translated .esp.

 

So... i was thinking that the profile have issue.

I have Delete Everything !

Installed a new MO somewhere else and new Mod directory at new location.

DL again all mod

Following the guid carefully

But i have the same issue again.

 

 

I don't ask you to take more time to find the issue, i cant let you wast your time on this, that just a menu after all and i can deal with it.

But that really a Weird issue.

 

If anybody have an idea or have the same issue, you can PM me anytime.

 

Thanks for your time Kelmych and sorry for the wasted time.


  • 0

#8 Kelmych

Kelmych

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,809 posts

Posted 21 August 2016 - 05:49 PM

I agree it is very weird. I'm not sure what to suggest.



#9 YaroslavKh

YaroslavKh

    Prisoner

  • Members
  • 15 posts

Posted 04 September 2016 - 11:12 PM

 

"Ties that Bind - a narrative companion mod" - disables FWE's Alternative Start.


  • 0

#10 Kelmych

Kelmych

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,809 posts

Posted 05 September 2016 - 04:39 PM

Thanks for the comment; this isn't mentioned on the Nexus page for the mod. It will be added to the guide.



#11 varrgas

varrgas

    Citizen

  • Members
  • Pip
  • 71 posts

Posted 20 September 2016 - 04:42 PM

"Ties that Bind - a narrative companion mod" - disables FWE's Alternative Start.

Thanks ...

It's a lot late but i don't care, many thanks, i was really want to know why this happen.
I thinking about this mod who maybe disable the alternative start because of the quest line in this mod, but there nothing about it and (maybe my knowledge isn't enough) with xEdit i found nothing conflicting with alternative start. Script things seems really not easy to understand for casual mode customer :/

by the way, i am happy asking this if there is now a note and advice on the amazing Kelmych guide, this wasn't usless and wasted time finaly ;)

PS: Many love again Kelmych <3 <3 <3 i am still in my F3 same save since 50 hours and the game is fantastic with your guide !


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users