Jump to content


Photo

d3d9 - UsePatchSpeedhackWithoutGraphics Troubles


  • Please log in to reply
5 replies to this topic

#1 TheSonOfSkyrim

TheSonOfSkyrim

    Prisoner

  • Members
  • 1 posts

Posted 06 September 2016 - 06:57 AM

Hello, I've recently been learning about modding skyrim as well as testing the limits of what I can mod with my laptop. I love the game and love many of these mods. I am trying to install ENBs and have recently set a base mod setup with MO with a complete STEP installation that I can modify. I've noticed that when I have the d3d9.dll in my skyrim directory my game crashes upon SKSE launching TESV.exe. I have looked at every page step offers with ENBoost and ENB Setups. Also adding the ENB 0.308 and currently trying to use Vividian since its recently updated after failed attempts with RealVision and Project ENB. They have all been installed correctly, I checked over it atleast 5 times, into the correct directory.

 

The one thing that allows me to load skyrim is setting "UsePatchSpeedhackWithoutGraphics=true" in my ENBlocal.ini, obviously which disables graphics modifications. I still get the ENB information on the top left on the logo screen by boris, followed by the red warning of disabled graphic modifications. I set my enblocal.ini to the ENBoost except with the proper exceptions to use the ENB, also changed my skyrimprefs based on the ENB instructions. Even with these modifications the game runs normally if I have the SpeedhackWithoutGraphics on or no d3d9.dll in the directory. Otherwise it crashes, same with injector.

 

I've scoured for information, installed all the directx runtimes I could. Even did my full windows 10 update which it has directx 12 installed. My friend who uses windows 10 with directx 12 can handled ENBs no problems although his computer is way better than mine and he has no idea. Before I admit defeat that my laptop cannot run an ENB, I'm trying to figure out what is causing this problem. I'm aware there are some programs that interfere with d3d9.dll and currently working on finding if I have one, I do not have any of the programs Ive seen on forums that other players have that conflicted.

 

I adjusted my ini's exactly how step and vividian suggest. Could it be other ini settings that cause the d3d9 to fail? But the game simply runs by turning on the UsePatchSpeedhack?

 

My laptop is Intel Core i3-5020U CPU @2.20 GHz. 8.00GB installed RAM, 64bit operating system, x64 base processor. Intel HD Graphics card 5500 stock updated drivers 4064 GB memory, also stated by vramsizetestdx9.exe. 128mb dedicated vram (which I don't know how to change, Lenovo is a weird computer)

 

I will attach my current skyrim.ini, skyrimprefs.ini and enblocal.ini

 

Thanks in advance for whatever help I can get, gonna continue to look for a solution.

 

Attached File  Skyrim.ini   1.11KB   2 downloads

Attached File  SkyrimPrefs.ini   3.17KB   1 downloads

Attached File  enblocal.ini   1.64KB   0 downloads


  • 0

#2 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,493 posts

Posted 06 September 2016 - 07:43 AM

Try to use the previous version of ENBSeries. Many users seem to be crashing when using v.308.



#3 Joat_Mon

Joat_Mon

    Guard

  • Guests
  • PipPip
  • 194 posts

Posted 06 September 2016 - 08:24 AM

Per Boris about Skyrim + ENBSeries on Intel integrated graphics. 5/5/2014:

 

"Intel unsupported, it's not have hardware features required for the game."


  • 0

#4 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,493 posts

Posted 06 September 2016 - 01:30 PM

I totally missed the graphics card being used.

#5 inpursuitofknowledge

inpursuitofknowledge

    Prisoner

  • Members
  • 4 posts

Posted 05 November 2016 - 02:48 AM

lol literally just posted in another thread about this same issue. i see it came down to your Graphics card, which is unfortunate but fortunate at the same time as you now have a solution. Me on the other hand, im sitting here with a GTX 970 and cant run an ENB to save my life. Its even more frustrating because this is new. Ive been able to run ENB's no problem before with the same card....same setup. 


  • 0

#6 inpursuitofknowledge

inpursuitofknowledge

    Prisoner

  • Members
  • 4 posts

Posted 05 November 2016 - 03:18 AM

Okay so F this gay earth.haha 

 

Not really. I had bitdefender on and it was the problem. Turned it off(unistalled) and lo and behold my game starts with all the little ENB stuff in the top left corner :} 

Maybe this helps. I hope so. This was truly frustrating. 


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users