Jump to content


Photo

FNV Quirks and Possible Fixes

stutter lag frame drop issue fnv fallout_nv

  • Please log in to reply
6 replies to this topic

#1 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,584 posts

Posted 17 September 2016 - 08:52 PM

So I've been poking around with TTWOEE a little bit and found a few issues with a few possible fixes in hopes that this helps someone or spawns some sort of discussion.

Also, lets focus on finding a "fix" rather than suggesting to "deal with it", "reduce textures" or "reduce mods".

Typically, these may be non issues with different hardware, but they are with my setup.

Here are some things to note:

  • my CPU is not stressed even per core
  • its not related to HT as I have set up affinity correctly
  • its not GPU as the game cant even utilize 50% of what it is capable of
  • its not IO bottleneck as I am on an NVMe SSD(not SATA), yes this is connected with full 32GB/sec via PCIe 3.0 x4

 

ENBoost is pretty much a need when it comes to dx9 games and ridiculous texture sizes. For a reason or another, ENBoost has some issues like stuttering, lack of MSAA support and so on.

For example, I only want ENBoost and no other effects. Here is the relevant file.

Reasons for some specific settings

ExpandSystemMemoryX64=false
No noticeable difference in performance but it may cause some blacked out textures or some other sort of memory corruption.
ReduceSystemMemoryUsage=true

Enable ENBoost

DisableDriverMemoryManager=false
No noticeable difference
DisablePreloadToVRAM=false

No noticeable difference

EnableUnsafeMemoryHacks=true

This seems to alleviate the unbearable stutter

ReservedMemorySizeMb=64 

No need to have it higher, doesnt affect the feel of the game at all. 

VideoMemorySizeMb=4064 

This is just a starting point, but the game never really reaches the limit of 4096 though.

EnableCompression=true 

I left it enabled as it doesnt affect the feel of the game. Probably reduces VRAM consumption but I don't notice it. 

AutodetectVideoMemorySize=true 

Left it enabled if I boot the game in win7. The game never really reaches the limit of 4096 though.

 

After spending quite a bit of time on finding some sort of solution to the stuttering I found the only fix to alleviate the issue was to enable EnableUnsafeMemoryHacks. After doing some brief research it seems this can cause other applications cache to break or something rather and alt-tabbing is broken. I think this sacrifice is well worth it.

 

 

 

For some reason, when iMinGrassSize is set to about 40 or lower, I noticed that the framerate would drop tremendously(~20-40) when rotating the camera.

If set to 50 the side effect isn't that noticeable but its still kind of there. With a setting of 20 the game turns into a slide show when rotating the cam.

I looked into this quite a bit.

Posts online suggest that Heap Replacement from NVSR helps but it breaks the game for me.

It doesnt seem to be the actual grass generation part as I suppressed the seeding in NVSR(if it does what I think it does).

When standing still, the framerate is fine, so it isnt GPU related.

When the grass is toggled the issue is completely gone.

I've tried using the NVSR profile to find the specific thread or any correlation with thread vs FPS but I couldnt find anything.

The only "fix" that I've found is to set the size to something like 50 as it seems to have a fair representation of what I believe the landscape would look like. I would almost consider this a non issue but it's still there, it would be nice to know of some fix.

 

 

 

With Realistic Wasteland Lighting Enhancement I get this horrible framedrop when its raining. Setting iNumHWThreads=4(rather than 2 that is commonly suggested) seems to alleviate this issue but there may be other side effects. Removing the value also fixes the slowdown but I am unsure of any side effects.

 

 

 

MSAA is by far the best form of AA for FNV but ENBoost breaks the built in version. Well if you have nVidia(AMD probably has some equivalent) you can apply a few easy tweaks in nVidia Inspector to get it. First disable any other form of AA like SMAA, Edge AA, etc., in ENB, you must disable EnableAmbientOcclusion and EnableDetailedShadow, and then in nvidia inspector, find Fallout New Vegas' profile and apply these settings. 

 

1. Set "Antialiasing Compatibility" to "0x00400041"

The other (DX1x) setting is irrelavent as FNV is DX9. Also, Im curious to what the binary flags are.

2. Set "Antialiasing - Behavior Flags" to "None"

3. Set "Antialiasing - Line gamma" to "Enabled"

This probably isnt needed.

4. Set "Antialiasing - Mode" to "Override any application setting"

5. Set "Antialiasing - Setting" to "4x [4x Multisamping]"

You can experiment with other types but any "cv samples" seems to make the game not show the menu.

6. Set "Antialiasing - Transparency Multisampling" to "Enabled"

Not required to get MSAA to work but it does has a nice effect.

7. Set "Antialiasing - Transparency Supersampling" to "4x Sparse Grid Supersampling"

You can experiment with other settings.

 

 

 

ENB AO is nice but any MSAA will break the game in a fantastic way. Heres another nVidia specific feature that is awesome. Then in nvidia inspector, find Fallout New Vegas' profile and apply these settings. 

 

1. Set "Ambient Occlusion Setting" to "High Quality"

You can experiment with other settings.

2. Set "Ambient Occlusion usage" to "Enabled"

 

 

 

The 4GB patch causes some minor side effects. Supposedly with the built in MSAA, some textures will shimmer a very faint white transparent block. Not really sure why but it is indeed odd.

nVidia owners can get around this by disabling the built in version and use the tweaks above. Please note that the common arguement recommendation will not work because the EXE nae is different. I'd recommend removing the custom args and let the patch do its own thing.

To allow this to work with ENBoost, you need to install the files(atleast d3d9.dll, enbhost.exe, enblocal.ini and enbseries.ini) into the exe's folder and the Fallout NV game folder. I think it has something to do with the dll needed to hook with the exe in the exe folder but the other files in the main folder for enb to know where they are. If they are not in both then then ENB doesnt hook or ENBoost isnt running and the game almost instantly crashes.

 

 

 

Game slows down over time is believed to be caused by poor memory management but I cannot confirm this. After browsing the web and trying different things I noticed that the heap replacement in NVSR seems to help quite a bit, about a difference of about 40 fps to 55 under the specific set of conditions I tested with. I left it on the sixth algorithm but I changed the size to 450. For some reason the game will not launch for me with it set to 500+ which is strange because I see reports of the game running at 768 but is very unstable. My guess is something is hard-coded near the end of the allocation that either causes some memory corruption or some other ill effects.

 

I've been told that this is a known issue and isnt related to NVSE, NVAC, NVSR.

My guess is that its thread related but I do not have anything to back it up.

 

 

 

I'll add things as I find them



#2 generalmx

generalmx

    Citizen

  • Members
  • Pip
  • 59 posts

Posted 13 October 2016 - 10:56 PM

Thanks, I used this thread in combination with the TTW Performance Guide to improve my performance while using Fear & Loathing and in general: https://taleoftwowas...rformance-guide

 

However I would like to note the TTW Performance Guide says to disable VSync by setting iPresentInterval to 0 but I had all sorts of problems with this (mainly increased tearing/shimmering and "dancing NPCs"), even though with it disabled things were a bit smoother while it was just NVSR limiting my framerate. I remember in Skyrim modding that setting iPresentInterval to 0 caused problems too--especially with scripts.

 

Also notable: updated 2016 Ogg Vorbis library files for FNV (and other games) can be found here, which may fix some crashes due to audio issues as mentioned in the TTW guide -- http://www.nexusmods...as/mods/61265/?


Edited by generalmx, 13 October 2016 - 10:59 PM.

  • 0

#3 theApe

theApe

    Citizen

  • Members
  • Pip
  • 76 posts

Posted 20 October 2016 - 04:14 AM

thanks for this. I had the same issue with iMinGrassSize, set it back to 80. Still get the occasional freeze if I try to make an on the dime 180 degrees turn, but I can live with that. Might be turning on ambient occlusion causes some drops for me too... will test with it off.

 

question: is it better to turn off games vsync and turn on Nvidia┬┤s?


  • 0

#4 MonoAccipiter

MonoAccipiter

    Jarl

  • Mod Authors
  • PipPipPipPipPipPipPipPipPip
  • 917 posts

Posted 20 October 2016 - 02:29 PM

I think it might cause some bugs, because the engine is really touchy when it comes to VSync (things actually happen faster with higher fps in Gamebryo IIRC).


  • 0

#5 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,584 posts

Posted 20 October 2016 - 07:07 PM

Basically the kicker is don't let it go above 60

People claim that physics jitter but I've never observed anything abnormal that with adaptive.

I don't toggle the iPresetInterval as there is no need.

 

I use adaptive vsync because its no vsync while under 60 and by doing this the annoying micro stutter is gone when not at a multiple of 60 (30, 20, 15, etc), but anything above 60 become the traditional vsync.

 

Some use limiters which are terrible because the tearing and the microstutter when it bounces(like a rev limiter). 

Don't use nVidia's Fast vsync for gamebryo games as the game is still uncapped but what you see are specific frames to produce an even 60fps which feels fantastic at 120fps+



#6 generalmx

generalmx

    Citizen

  • Members
  • Pip
  • 59 posts

Posted 13 November 2016 - 05:51 AM

Also forgot to mention: for those that may have a slight CPU or I/O bottleneck -- especially on laptops -- I highly recommend trying out the free tool Process Lasso and setting "falloutnv.exe" and "fnv4gb.exe" as Game Processes / exclude them from Pro-Balance Restraint and always at least High Priority. Link: https://bitsum.com/

 

I've successfully gotten more frames out of Oblivion, Skyrim, etc. before on lesser hardware. One can do this all manually but Process Lasso makes it pretty easy.

 

Also, there's one more slight tweak that probably should be mentioned: setting "Max Pre-rendered Frames" to "1" in the Fallout: New Vegas Nvidia Profile via Nvidia Inspector. This is apparently because the game sets it to 3, which is 1 more than what Triple Buffering requires and thus can add in a slight amount of input lag. Source:http://https://taleo...5#comment-44965


Edited by generalmx, 13 November 2016 - 05:59 AM.

  • 0

#7 boycad

boycad

    Prisoner

  • Members
  • 37 posts

Posted 30 December 2016 - 04:15 AM

 

Also notable: updated 2016 Ogg Vorbis library files for FNV (and other games) can be found here, which may fix some crashes due to audio issues as mentioned in the TTW guide -- http://www.nexusmods...as/mods/61265/?

Ive been looking for a way to improve the sound quality for radio-listening purposes.  Sorry if this is off topic, but do you know of any way to allow for the game to play stereo tracks at good quality, eg. mp3@320, or even better?


  • 0



Also tagged with one or more of these keywords: stutter, lag, frame drop, issue, fnv, fallout_nv

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users