Jump to content


Photo

Windows Update Getting Stuck

windows 10 sucks

  • Please log in to reply
2 replies to this topic

#1 SparrowPrince

SparrowPrince

    High King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,210 posts

Posted 19 October 2016 - 12:45 PM

Has anyone have any experience with getting W10 to actually update and not get stuck on X percentage while updating?

 

I still don't have the Anniversary Update because I have been trying every now and again for a few months to get it to install, but it always gets stuck.

 

Having looked on the internet, it seems like I am not the only one with this problem, and I have tried every little (perhaps stupid) thing that has been suggested. I tried mounting to an ISO, Windows Update and the downloadable installation program from MS.

 

Today I set it going from 6am and when I came home at 4:30 it was stuck at 91%. I tried it again at 5pm and it seemed to get stuck at 82% a few hours later. The only thing I can think of doing is leaving it all night and day.

 

I can't recall this ever happening with any other versions of Windows, but apparently it does. Maybe it's because this update is rather large?

 

Edit: Trying ISO again because the update manager from MS just cancels itself now and Windows Update can't find any new updates at all. W10 is just horrible.


Edited by SparrowPrince, 19 October 2016 - 12:49 PM.

  • 0

#2 Kelmych

Kelmych

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,949 posts

Posted 19 October 2016 - 01:15 PM

It downloaded and installed without any problems for me. I have had problems with the update with Fallout 3. Another thread discusses these problems.

#3 SparrowPrince

SparrowPrince

    High King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,210 posts

Posted 19 October 2016 - 01:57 PM

Okay, the thing that worked for me was to grab an official MS ISO that some server admin uploaded to a torrent site. Not sure if that is in anyway related, but it just worked first try. I'm a bit confused myself.
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users