Jump to content


Photo

Release: StepperUpper


  • Please log in to reply
167 replies to this topic

#31 airbreather

airbreather

    Guard

  • Developers
  • PipPip
  • 109 posts

Posted 15 November 2016 - 08:52 AM

I've been using this for my latest STEP install, and I'm seeing some missing terrain surrounding the road from Riften to Fort Dawnguard. I've tried reinstalling and disabling everything else, and there's something wrong with the cleaned Dawnguard ESM being generated.

 

Screenshots

Looks pretty damning.  I'll see if I can reproduce the issue and then figure out what's wrong.

 

#27.

 

Interesting anecdote, I did an "outlaw in the wilds" start arbitrarily, and LAL plunked me right into Broken Helm Hollow which has this problem... I got spooked thinking it was all over the place and that I completely missed a huge problem somehow even though I did fly around a bunch earlier on, but then I realized Broken Helm Hollow is right along the road to Fort Dawnguard.


  • 0

#32 remlnx

remlnx

    Citizen

  • Members
  • Pip
  • 65 posts

Posted 15 November 2016 - 09:56 AM

@ airbreather Thank you! that was more easy than i expected. Really appreciate your help on better understand how it work. Going to give it a try this night

Sent from my SM-G925F using Tapatalk
  • 0

#33 Venom

Venom

    Prisoner

  • Members
  • 8 posts

Posted 15 November 2016 - 04:21 PM

I'm also getting the missing terrain problem around all three of the hearthfire property locations. If you do a game start using the "I own property" option and choose one of the hearthfire properties (Heljarchen Hall, Lakeview Manor, or Windstad Manor). You appear inside the property, but as soon as you step out, there is no terrain. I had assumed I had done something wrong with all the extra bits I have bolted on top, but get the same problem when I strip it back to just a Core + Extended install. I was going to mess around some more with it, but I am now wondering if it is linked in to the Dawnstar texture issue. I haven't tried running it with uncleaned ESM's for the DLC, but will probably try that next to see what happens.


  • 0

#34 Venom

Venom

    Prisoner

  • Members
  • 8 posts

Posted 15 November 2016 - 04:51 PM

OK, a little bit more tinkering around. Restoring the original uncleaned ESM's for Hearthfire and Dawnguard also restored the missing textures. Manually cleaning the restored ESM's with TES5Edit did not remove the textures, so there would appear to be some issue with the process used by StepperUpper to clean the DLC ESM's. I have not had chance to test the Dragonborn ESM yet.

 

For reference, the Hearthfire ESM cleaned by StepperUpper is 3,522,161 bytes, while the manually cleaned one is 3,456,759 bytes. The Dawnguard ESM cleaned by StepperUpper is 24,749,539 bytes, while the manually cleaned one is 24,483,440 bytes.

 

The next thing I am going to try is starting off Dragonborn using the StepperUpper cleaned ESM.


  • 0

#35 Venom

Venom

    Prisoner

  • Members
  • 8 posts

Posted 15 November 2016 - 05:17 PM

Right, that answers that. I kicked off the Dragonborn quest, and travelled to Windhelm Docks to catch the boat. Only problem was that the boat was completely missing. However, the quest marker was there, along with a floating cart and a few other bits and pieces. Restoring the original ESM also restored the boat. Also, just like the other DLC ESM's, manually cleaning it did not break the textures.


  • 0

#36 Venom

Venom

    Prisoner

  • Members
  • 8 posts

Posted 15 November 2016 - 05:52 PM

If it helps any, I have uploaded my ESM cleaning log to the following link; http://pastebin.com/9REar5tj

 

I am off to bed now, as it is late over here in the UK. I will catch up on this in the morning. Goodnight all.


  • 0

#37 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,833 posts

Posted 15 November 2016 - 05:55 PM

Thing to keep in mind with the cleaning of the ESMs. On some machines xEdit via MO "replaces" the existing DLC instead of making edited "copies" of them and this means they are found in the actual 'Data' folder, not inside MO's VFS.

We haven't been able to definitively pinpoint what are the criteria for this behaviour, best bet so far is the speed of the save is a factor, ie. how fast your drives are.

 

Not saying this has anything to do with the problems discussed so far, it just reminded me of it.



#38 airbreather

airbreather

    Guard

  • Developers
  • PipPip
  • 109 posts

Posted 15 November 2016 - 06:30 PM

Thing to keep in mind with the cleaning of the ESMs. On some machines xEdit via MO "replaces" the existing DLC instead of making edited "copies" of them and this means they are found in the actual 'Data' folder, not inside MO's VFS.

We haven't been able to definitively pinpoint what are the criteria for this behaviour, best bet so far is the speed of the save is a factor, ie. how fast your drives are.

 

Not saying this has anything to do with the problems discussed so far, it just reminded me of it.

The problem is 100% StepperUpper.  I wrote my own version of the "plugin cleaning" business that uses an exact description of the changes that need to be made and then just makes them.  I have an idea about what the problem might be, I just need to get an uninterrupted span of a few hours to fix it.

 

And you need to have unmodified versions of the Bethesda *.esm files in your Skyrim/Data folder at the start of the process, or else StepperUpper will put them into the "missing files" bucket and give you a steam:// link to the store page.

 

Until I fix it in StepperUpper, the workaround for this issue is to overwrite the *.esm files in "ModOrganizer/mods/Cleaned * ESM" with manually cleaned versions of them.

 

If I can't fix it properly, plan B is another set of AutoHotkey scripts that go into the "Finalize" files to run through the cleaning process the hard way.  I'm not looking forward to that.


  • 0

#39 remlnx

remlnx

    Citizen

  • Members
  • Pip
  • 65 posts

Posted 15 November 2016 - 06:59 PM

Ok i got an issue, seems the Xedit linked isnt found by the Stepper, keep telling me it's missing, i did try both the link pointing to the Fallout4 (missing.html linked that) and the Tes5Edit 3.1.3, with both i still get xedit is missing. Only file i miss, everything else is ready :P


  • 0

#40 airbreather

airbreather

    Guard

  • Developers
  • PipPip
  • 109 posts

Posted 15 November 2016 - 08:53 PM

Ok i got an issue, seems the Xedit linked isnt found by the Stepper, keep telling me it's missing, i did try both the link pointing to the Fallout4 (missing.html linked that) and the Tes5Edit 3.1.3, with both i still get xedit is missing. Only file i miss, everything else is ready :P

FO4Edit got an update since the then-latest version of the STEP Core XML file, and it happens to be one of those projects that deletes all the old versions from the Nexus as soon as they get newer versions up there (which drives me a bit nuts, because that means I need to be kinda on-the-ball with updating the XML files because then people like you won't be able to successfully run through StepperUpper, even with not-bleeding-edge versions of everything, until I get to it).

 

It needed me to update the XML files for the newest versions of things.  Go ahead and re-download the latest versions of the StepperUpper XML files.  I guess I'll put an auto-XML-downloader in the roadmap too.


Edited by airbreather, 15 November 2016 - 08:54 PM.

  • 0

#41 airbreather

airbreather

    Guard

  • Developers
  • PipPip
  • 109 posts

Posted 15 November 2016 - 09:47 PM

FO4Edit got an update since the then-latest version of the STEP Core XML file, and it happens to be one of those projects that deletes all the old versions from the Nexus as soon as they get newer versions up there (which drives me a bit nuts, because that means I need to be kinda on-the-ball with updating the XML files because then people like you won't be able to successfully run through StepperUpper, even with not-bleeding-edge versions of everything, until I get to it).

 

It needed me to update the XML files for the newest versions of things.  Go ahead and re-download the latest versions of the StepperUpper XML files.  I guess I'll put an auto-XML-downloader in the roadmap too.

I guess... one thing I could have mentioned, are you sure you were looking at exactly the right version of FO4Edit?  There have been at least 3 different files called FO4Edit 3.1.3, but the letters and/or numbers after "3.1.3" on the file name might differ.


  • 0

#42 remlnx

remlnx

    Citizen

  • Members
  • Pip
  • 65 posts

Posted 16 November 2016 - 02:03 AM

I guess... one thing I could have mentioned, are you sure you were looking at exactly the right version of FO4Edit?  There have been at least 3 different files called FO4Edit 3.1.3, but the letters and/or numbers after "3.1.3" on the file name might differ.

Well, there is only 1 version there FO4Edit 3.1.3 1dabbcd.
The XML requires the FO4Edit 3.1.3 bb242bc that is not there, also cant find it on Github apparently.
Unless, i was looking in the wrong place, but i dont think so.
Thanks for the XML update :)


Edited by remlnx, 16 November 2016 - 02:10 AM.

  • 0

#43 remlnx

remlnx

    Citizen

  • Members
  • Pip
  • 65 posts

Posted 16 November 2016 - 04:49 AM

Update: Worked like a charm, thank you airbreather!

I am not new to step/MO (or SRLE or SRLE Extended) countless hours build setups with MO but this.. this just save so many tedious work, very nice tool.

I still have to test if everything is on the right place while in-game, but it booted up with no issues and up to Helgen had no misplaced textures or anything else.


  • 0

#44 airbreather

airbreather

    Guard

  • Developers
  • PipPip
  • 109 posts

Posted 16 November 2016 - 07:52 AM

Well, there is only 1 version there FO4Edit 3.1.3 1dabbcd.
The XML requires the FO4Edit 3.1.3 bb242bc that is not there, also cant find it on Github apparently.
Unless, i was looking in the wrong place, but i dont think so.
Thanks for the XML update :)

Yeah, that's what I meant when I was talking about being frustrated with those projects that wipe out all traces of the old versions when they release a new version... before 1dabbcd was available, bb242bc was the only version of 3.1.3 that existed.  Now it's only 1dabbcd.  As it happens, this particular update justified exactly why I tend to require very specific versions of everything: in bb242bc, the exe file was named FO4Edit.exe, so I had to rename it to TES5Edit.exe during the extraction process.  1dabbcd changed it back to TES5Edit.exe, so it needed my intervention.

 

Update: Worked like a charm, thank you airbreather!

I am not new to step/MO (or SRLE or SRLE Extended) countless hours build setups with MO but this.. this just save so many tedious work, very nice tool.

Glad to hear everything's working out now.

 

I still have to test if everything is on the right place while in-game, but it booted up with no issues and up to Helgen had no misplaced textures or anything else.

There's a bit of a double-edged sword thing going on right about now.  On the plus side, once StepperUpper runs through the whole process successfully, you can be sure that it didn't miss a checkbox on the 92nd step that's going to bite you after you get 21 hours into your game or something silly like that... it's very consistent, so if it's working for someone else, then it's going to work for you (assuming you use the exact same XML files and the exact same version of StepperUpper).

 

On the minus side, of course, if there's a bug, especially one that's StepperUpper-specific (like the one that's been the talk of the town for the last page or so), you can be pretty much 100% sure that this bug affects your setup as well.  So you will need to do that one workaround if you want to get that juicy DLC content to work, it seems.

 

I still haven't had the opportunity to fix that bug yet.


  • 0

#45 remlnx

remlnx

    Citizen

  • Members
  • Pip
  • 65 posts

Posted 16 November 2016 - 10:29 AM

 

 

On the minus side, of course, if there's a bug, especially one that's StepperUpper-specific (like the one that's been the talk of the town for the last page or so), you can be pretty much 100% sure that this bug affects your setup as well.  So you will need to do that one workaround if you want to get that juicy DLC content to work, it seems.

 

I still haven't had the opportunity to fix that bug yet.

 

Actually, i've installed it on a slow HDD because i've the SE on my SSD and i didnt wanted another skyrim installation on the same drive.
Looking at the issue of the last page, i actually found the cleaned esm's in the MO Virtual Folder, not in my DATA (probably because the HDD being slower drive compared to SSD) so i suppose that way im not affected of that bug?


Edited by remlnx, 16 November 2016 - 10:30 AM.

  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users