Jump to content


Photo

DynDOLOD Skyrim Special Edition

dyndolod lod special edition sse

  • Please log in to reply
287 replies to this topic

#46 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,377 posts

Posted 23 April 2017 - 04:51 AM

Does the SkyrimSELargeRefGrid folder contain optional stuff? or is it something that DynDOLOD.exe is already using?


There is no such thing as a SkyrimSELargeRefGrid folder. Large Reference data is stored in the world record. Read the included documentation. DynDOLOD uses it to generate correct static LOD.

Edited by sheson, 23 April 2017 - 05:14 AM.

  • 0

#47 Xibbe

Xibbe

    Prisoner

  • Members
  • 4 posts

Posted 02 May 2017 - 03:16 PM

So in the resources for SE, the files in "meshes\architecture\windhelm\" don't have any buildings, unlike the corresponding vanilla meshes. After DynDOLOD is done, these buildings stay missing. Am I missing some step here?


  • 0

#48 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,377 posts

Posted 03 May 2017 - 02:28 AM

So in the resources for SE, the files in "meshes\architecture\windhelm\" don't have any buildings, unlike the corresponding vanilla meshes. After DynDOLOD is done, these buildings stay missing. Am I missing some step here?

The 4 files in the DynDOLOD Resources SE meshes\architecture\windhelm\ update existing vanilla files.

Other than those files, DynDOLOD does not need to change any other full models in that folder for the buildings in Windhelm because they are already included in the vanilla files and don't any need updates.

 

I have no clue what "these buildings stay missing" means.


  • 0

#49 Xibbe

Xibbe

    Prisoner

  • Members
  • 4 posts

Posted 03 May 2017 - 04:07 AM

Well, just by installing the resources and checking out Windhelm from outside the walls, the buildings inside the walls disappear, since the area inside of Windhelm is shown through the meshes in meshes\architecture\windhelm\ (provided by the DynDOLOD SE resources) that have no buildings (the same vanilla meshes have buildings). Running DynDOLOD and installing the generation does not remedy this. The .bto files also end up missing some buildings inside of Windhelm, and when closer, the .bto files are not loaded anyway, the meshes provided by DynDOLOD resources are, and they are missing buildings. Am I supposed to uninstall the resources when I'm done, or is it an intended feature that Windhelm does not have any closeup building models when viewed from the Tamriel worldspace? If the esp is supposed to hand place them, that is not happening for me.


Edited by Xibbe, 03 May 2017 - 04:18 AM.

  • 0

#50 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,377 posts

Posted 03 May 2017 - 04:19 AM

Well, just by installing the resources and checking out Windhelm from outside the walls, the buildings inside the walls disappear, since the area inside of Windhelm is shown through the meshes in meshes\architecture\windhelm\ (provided by the DynDOLOD SE resources) that have no buildings (the same vanilla meshes have buildings). Running DynDOLOD and installing the generation does not remedy this. The .bto files also end up missing some buildings inside of Windhelm, and when closer, the .bto files are not loaded anyway, the meshes provided by DynDOLOD resources are, and they are missing buildings. Am I supposed to uninstall the resources when I'm done, or is it an intended feature that Windhelm does not have any closeup building models when viewed from the Tamriel worldspace?

The individual buildings are placed back through DynDOLO.esp after generating LOD for Tamriel. A couple buildings will not have LOD because they require dynamic LOD to work, but all those buildings are placed back by the esp when the cells are loaded.


Edited by sheson, 03 May 2017 - 04:21 AM.

  • 0

#51 Xibbe

Xibbe

    Prisoner

  • Members
  • 4 posts

Posted 03 May 2017 - 04:24 AM

How vexing. My first few generations had esps that hand placed a bunch of lods, e.g. the guardhouse in Whiterun. When I have generated after this I removed all the generated files and ran the program again, but the esps barely contain anything. Do I have to remove more than the generated files from the DynDOLOD folder if I want a proper generation?


Edited by Xibbe, 03 May 2017 - 04:30 AM.

  • 0

#52 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,377 posts

Posted 03 May 2017 - 04:31 AM

How vexing. My first few generations had esps that hand placed a bunch of lods, e.g. the guardhouse in Whiterun. When I have generated after this I removed all the generated files and ran the program again, but the esps barely contain anything. 

You edited the DynDOLOD INI for anything like Open Cities for example? 


Edited by sheson, 03 May 2017 - 04:34 AM.

  • 0

#53 Xibbe

Xibbe

    Prisoner

  • Members
  • 4 posts

Posted 03 May 2017 - 04:35 AM

Haha, thanks, I would not have remembered without you. I tried multiple things with open cities before deciding to remove it, and in the tutorial for vanilla you were supposed to remove the entire .bsa segment at some point. I did not remember that until you mentioned it. I imagine that will fix my issues. Sorry for wasting your time x)


Edited by Xibbe, 03 May 2017 - 04:37 AM.

  • 0

#54 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,377 posts

Posted 03 May 2017 - 04:56 AM

Haha, thanks, I would not have remembered without you. I tried multiple things with open cities before deciding to remove it, and in the tutorial for vanilla you were supposed to remove the entire .bsa segment at some point. I did not remember that until you mentioned it. I imagine that will fix my issues. Sorry for wasting your time x)

No worries. Just put back the original from the archive.


  • 0

#55 Departed_3

Departed_3

    Thane

  • Members
  • PipPipPipPipPipPip
  • 496 posts

Posted 06 May 2017 - 03:09 PM

Hi Sheson

 

Small problem with 2.26, I am getting an error on exit again (pretty sure we have seen this before during earlier testing of a previous version)

 

I am using DynDOLODx64

 

The following happens after all generation has completed, and when trying to exit .. But it only seems to happen if DynDOLOD is not in focus

 

Invariably I will have other windows open while DynDOLOD does its thing, on this occasion I had a windows explorer window open. After all the command windows DynDOLOD spawns, and it tries to give you the Exit options, the windows explorer window was at the front, so because I suspected DynDOLOD was at the finish stage, I clicked its title bar to bring it to the front, the Exit Options dialogue flashed three times prompting me to make a decision, and after clicking Exit and save, it did the usual saving out the plugin, but then threw an exception error as follows in the screenshot :

 

ymZj7vK.png

 

 

I do not get this exception error if I have not been doing other things. So if I had not been using the explorer window in this case, and had just left the computer alone, DynDOLOD and its finishing options prompt would have been on screen and focussed, not obscured by any other widows, and would exit without any exception error

 

So I believe there is a bug if DynDOLOD does not get to be at the front when it finishes, and has to be brought to the front.


Edited by alt3rn1ty, 06 May 2017 - 03:11 PM.

  • 0

#56 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,377 posts

Posted 06 May 2017 - 04:32 PM

Hi Sheson

 

Small problem with 2.26, I am getting an error on exit again (pretty sure we have seen this before during earlier testing of a previous version)

 

I am using DynDOLODx64

 

The following happens after all generation has completed, and when trying to exit .. But it only seems to happen if DynDOLOD is not in focus

 

Invariably I will have other windows open while DynDOLOD does its thing, on this occasion I had a windows explorer window open. After all the command windows DynDOLOD spawns, and it tries to give you the Exit options, the windows explorer window was at the front, so because I suspected DynDOLOD was at the finish stage, I clicked its title bar to bring it to the front, the Exit Options dialogue flashed three times prompting me to make a decision, and after clicking Exit and save, it did the usual saving out the plugin, but then threw an exception error as follows in the screenshot :

 

ymZj7vK.png

 

 

I do not get this exception error if I have not been doing other things. So if I had not been using the explorer window in this case, and had just left the computer alone, DynDOLOD and its finishing options prompt would have been on screen and focussed, not obscured by any other widows, and would exit without any exception error

 

So I believe there is a bug if DynDOLOD does not get to be at the front when it finishes, and has to be brought to the front.

If the error is after "exiting" there is really not much I can do about it. It doesn't matter either at that point. All open files have been closed etc.

 

Why are you running the 64bit version? I suggest to use the 32 bit version with Wrye Bash. The 32 bit is a bit faster too. The 64 bit is for 64 bit mod managers.


Edited by sheson, 06 May 2017 - 04:34 PM.

  • 0

#57 Departed_3

Departed_3

    Thane

  • Members
  • PipPipPipPipPipPip
  • 496 posts

Posted 06 May 2017 - 04:55 PM

Just testing really, I'm on a 64bit OS, running DynDOLOD from its own icon and not via Wrye Bash in any way .. Is there anything wrong with running the x64 version ?

 

UpzCNTy.png

 

Edit : Windows 10 Creators Update, x64 - And remember I have had this error before with 32 bit version, so it is not unique to whichever version, but I am pretty sure it happened in the case of the 32 bit version also when DynDOLOD had lost focus, and needed to be brought back into focus before clicking Save and Exit, then the exception error occurred also for the 32 bit version in an older version.

 

Edit 2 : Just tried with the 32 bit version of 2.26 and cannot reproduce the same issue again  :rolleyes:


Edited by alt3rn1ty, 06 May 2017 - 06:02 PM.

  • 0

#58 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,377 posts

Posted 06 May 2017 - 06:11 PM

Just testing really, I'm on a 64bit OS, running DynDOLOD from its own icon and not via Wrye Bash in any way .. Is there anything wrong with running the x64 version ?

 

Edit : Windows 10 Creators Update, x64 - And remember I have had this error before with 32 bit version, so it is not unique to whichever version, but I am pretty sure it happened in the case of the 32 bit version also when DynDOLOD had lost focus, and needed to be brought back into focus before clicking Save and Exit, then the exception error occurred also for the 32 bit version in an older version.

There is nothing wrong with either version. Whatever happens in the OS after the program shuts down with the "exit" command doesn't matter. I am not going to fix delphi :)


  • 0

#59 Departed_3

Departed_3

    Thane

  • Members
  • PipPipPipPipPipPip
  • 496 posts

Posted 06 May 2017 - 06:20 PM

~ I am not going to fix delphi :)

Ah, now I understand. Code Interpreter issue. Right going to ignore that one in future, back to more testing .. But honestly I dont think I am going to find anything else to bring to your attention, its superb as usual.


  • 0

#60 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,377 posts

Posted 06 May 2017 - 06:30 PM

Ah, now I understand. Code Interpreter issue. Right going to ignore that one in future, back to more testing .. But honestly I dont think I am going to find anything else to bring to your attention, its superb as usual.

The thing is, I do not get this error on either my dev machine or the skyrim machine, both windows 7 - putting DynDOLOD out of focus etc.

 

I use a recent enough delphi that know about windows 10 already, but it is not updated as frequently as windows 10. Could be anything really.


  • 0



Also tagged with one or more of these keywords: dyndolod, lod, special, edition, sse

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users