Jump to content


Photo

Mod Organizer 2 Development Status


  • Please log in to reply
93 replies to this topic

#76 LePresidente

LePresidente

    Prisoner

  • Mod Authors
  • 49 posts

Posted 21 October 2017 - 10:55 AM

I'm away until Sunday evening, and I am not on discord. When you had posted your fork of the umbrella project here I guess I made certain assumptions given the amount of discussion going on. I'll dive into it when I return.

No stress really, Just trying to avoid confusion that all. also never done a release on all the fixes I did for fallout4 and so on since i never did the new installer using wix lol. Also since this is a new qt version and so the minor version should jump as well. So will probably become 2.1.0 and we start from there the 2.0.8.x stuff was to get my head around the build process and release minor fixes using tannins existing codebase using the same qt version as he was


  • 0

#77 Helidoc

Helidoc

    Citizen

  • Mod Authors
  • Pip
  • 61 posts

Posted 21 October 2017 - 10:28 PM

No stress really, Just trying to avoid confusion that all. also never done a release on all the fixes I did for fallout4 and so on since i never did the new installer using wix lol. Also since this is a new qt version and so the minor version should jump as well. So will probably become 2.1.0 and we start from there the 2.0.8.x stuff was to get my head around the build process and release minor fixes using tannins existing codebase using the same qt version as he was

Sticking with the 2.0.8.x  line was where I kept it due to me building it off the umbrella not just off the base MO code, where I got the QT 5.9.x it was what you had set up in your version of the config.py file for the umbrella so I figured it was a safe bet that was where you were at in the code.. my bad there, old coder habits so I stuck with what you called out in the config for the build with only minor point differences. Heck I come from a period when we used punch cards :P On another note I did notice that the master code for MO was not the MO2 code but I had already pushed my changes to my GitHub, I will rectify that when I return from this trip so it will not be confusing. This was more or less a retirement project for me as it had seemed with all the changes to windows and the game it needed the work. As I said in my sticky post if either you or Tannin wish for me to stop work on it all you have to do is say so, I do not wish to tarnish anything the two of you have done. Thanks


  • 0

#78 Helidoc

Helidoc

    Citizen

  • Mod Authors
  • Pip
  • 61 posts

Posted 21 October 2017 - 11:02 PM

Ok after the Creator Late Update

Microsoft Windows [Version 10.0.16299.19] 

 MO start working really better :)

 

I've removed all files from the WebCache folder, but still gives me these errors on start

ydM1JLM.png

About the only thing I can suggest if you have the above mentioned files is to check your firewall rules with MO. Changing offline_mode=true in ModOrganizer.ini see if that goes away and after deleting and resetting all firewall rules for the installation path/ModOrganizer.exe then switching back to offline_mode=false .


  • 0

#79 MaximilianPs

MaximilianPs

    Citizen

  • Members
  • Pip
  • 54 posts

Posted 22 October 2017 - 02:58 AM

I was missing two dlls: 

 libeay32.dll and ssleay32.dll

 

now the problem is gone, thanks to LePresidente's post  :)


  • 0

#80 BuddyKidd

BuddyKidd

    Prisoner

  • Members
  • 22 posts

Posted 22 October 2017 - 08:10 AM

Download this and extract to your dlls folder 

https://mega.nz/#!Rd...i97f2bbv2jdQ79M

 

*Wait nvm those files are in his latest zip*

That fixed those two error messages for me.  Thanks.


  • 0

#81 GSDFan

GSDFan

    Jarl

  • Moderators
  • PipPipPipPipPipPipPipPipPip
  • 853 posts

Posted 22 October 2017 - 09:02 AM

Changing MO to offline stopped that error for me, although I now have SKSE component has stopped working.



#82 Helidoc

Helidoc

    Citizen

  • Mod Authors
  • Pip
  • 61 posts

Posted 22 October 2017 - 05:04 PM

I was missing two dlls: 

 libeay32.dll and ssleay32.dll

 

now the problem is gone, thanks to LePresidente's post  :)

Those were in the zip file perhaps your av nailed them just checked what I have uploaded and they are in the zip LP even confirmed it. Same openssl version as well (shrugs) glad its working for you now though.


Changing MO to offline stopped that error for me, although I now have SKSE component has stopped working.

Did you reset your firewall and after try to put it back online?


  • 0

#83 NewYears1978

NewYears1978

    Citizen

  • Members
  • Pip
  • 59 posts

Posted 22 October 2017 - 06:54 PM

I have the same HTTP errors, but I have those two files and I don't use a firewall (well it's turned off currently)

 

I also get the SKSE error when I try to run it :(

 

Will have to keep using v2.0.8.3 as it works fine (other than the weird handler problem)


Edited by NewYears1978, 22 October 2017 - 06:58 PM.

  • 0

#84 LePresidente

LePresidente

    Prisoner

  • Mod Authors
  • 49 posts

Posted 23 October 2017 - 11:44 PM

Updated main topic, Please read the 2.1.0 info


  • 0

#85 Helidoc

Helidoc

    Citizen

  • Mod Authors
  • Pip
  • 61 posts

Posted 24 October 2017 - 12:38 AM

I've pulled my releases and will submit any code updates to you to keep everything centralized.

Updated main topic, Please read the 2.1.0 info


  • 0

#86 MaximilianPs

MaximilianPs

    Citizen

  • Members
  • Pip
  • 54 posts

Posted 24 October 2017 - 02:41 AM

I'm sorry to bother but ... :)
on the first post there is 

2.0.8.3b - https://github.com/L...s/tag/v2.0.8.3b

but, the link will get you to Mod.Organizer-2.0.8.2  ::D:


  • 0

#87 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,012 posts

Posted 24 October 2017 - 02:58 AM

I'm sorry to bother but ... :)
on the first post there is 

2.0.8.3b - https://github.com/L...s/tag/v2.0.8.3b

but, the link will get you to Mod.Organizer-2.0.8.2  ::D:

Fixed!



#88 c0c0c0

c0c0c0

    Guard

  • Members
  • PipPip
  • 186 posts

Posted 24 October 2017 - 05:39 AM

Huge thanks to LePresidente, Helidoc and Silarn (and all the testers) for keeping the fires burning for MO2.  This is *still* best way to manage mods and I don't see that changing anytime soon.


  • 2

#89 wm452356923

wm452356923

    Prisoner

  • Members
  • 1 posts

Posted 29 October 2017 - 03:43 AM

When is it updated? :cry: :cry: :cry: :cry:什么时候更新啊?非常需要啊!呜呜呜呜! 


  • 0

#90 odetoio

odetoio

    Prisoner

  • Members
  • 1 posts

Posted 30 October 2017 - 11:21 AM

This gives me so much hope for the future of modding SkyrimSE! Thank-you so much for this work, I look forward to getting an Alpha or Beta of 2.1!!

 

After the release of SKSE I had come back to mod my SE, after weeks of struggling to work with MO 2.0.8 I had given up this last weekend after failing to get SkyProc stuff working. Again I attempted to use NMM yet after one night of starting to build my list from MO I gave up... really started to think SSE modded is a no go.

 

So, thank-you your work is very much appreciated!


  • 0


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users