Jump to content


Photo

FNIS Mod Organizer 2 will not work together.


  • Please log in to reply
22 replies to this topic

#1 lordrahl

lordrahl

    Prisoner

  • Members
  • 6 posts

Posted 07 March 2017 - 10:32 AM

I have used mod organizer for old skyrim and now cannot live with out it. However with SkyrimSE and Mod Organizer 2 when trying to use FNIS it just will not work. I have looked here for answers, on reddit, and any where else i could find for answers and have come up dry. I get the "outside the bounds of the array" error or "cannot find part of the path" error etc.

     I have many errors with loot as well but atleast I can get that to work. My skyrim se is installed on my H: drive not under the default drive and yes it is through steam. I have tried the solutions to some of the errors from here and from other forums as stated but nothing has worked. Please, any help with this would be greatly appreciated! :confused:


  • 0

#2 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,333 posts

Posted 07 March 2017 - 05:30 PM

FNIS 7.0 works perfectly well with MO2.

 

The errors you are getting makes me believe you haven't got the FNIS mod active in the left pane. At any rate without logs from you we will not be able to diagnose anything.



#3 remlnx

remlnx

    Citizen

  • Members
  • Pip
  • 68 posts

Posted 08 March 2017 - 08:15 AM

I second Grant answer. FNIS work with no issues on Mon for me.

Sent from my Huawei Mate 9
  • 0

#4 lordrahl

lordrahl

    Prisoner

  • Members
  • 6 posts

Posted 08 March 2017 - 10:04 PM

FNIS 7.0 works perfectly well with MO2.

 

The errors you are getting makes me believe you haven't got the FNIS mod active in the left pane. At any rate without logs from you we will not be able to diagnose anything.

 

I second Grant answer. FNIS work with no issues on Mon for me.

Sent from my Huawei Mate 9

Thanks for responding. It is clicked in the left pane and I have successfully used FNIS with Mod Organizer for a very  long time. But it has not worked for me at all with Mod Organizer 2 (it is the the 7.0 beta SE version). I have spent weeks trying to get this to work with no luck. I cannot find an error log for FNIS, but will send what ever you need me to send.


  • 0

#5 lordrahl

lordrahl

    Prisoner

  • Members
  • 6 posts

Posted 08 March 2017 - 10:32 PM

Here is the log from FNIS

 

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.DirectoryNotFoundException: Could not find a part of the path 'D:\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users\temporary_logs'.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileSystemEnumerableIterator`1.CommonInit()
   at System.IO.FileSystemEnumerableIterator`1..ctor(String path, String originalUserPath, String searchPattern, SearchOption searchOption, SearchResultHandler`1 resultHandler, Boolean checkHost)
   at System.IO.DirectoryInfo.InternalGetDirectories(String searchPattern, SearchOption searchOption)
   at System.IO.DirectoryInfo.GetDirectories()
   at GenerateFNISforUsers.FNIScommon1.FNIScommon.List_Files(String dir)
   at GenerateFNISforUsers.FNIScommon1.FNIScommon.Display_Dirs(Boolean atStart)
   at GenerateFNISforUsers.FNIScommon1.FNIScommon.FinishSub()
   at GenerateFNISforUsers.GenerateFNISUsers.Main()
   at GenerateFNISforUsers.GenerateFNISUsers.Button1_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
GenerateFNISforUsers
    Assembly Version: 7.0.0.0
    Win32 Version: 7.0.0.0
    CodeBase: file:///D:/Steam/steamapps/common/Skyrim%20Special%20Edition/data/tools/GenerateFNIS_for_Users/GenerateFNISforUsers.exe
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 14.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


 


  • 0

#6 vidalia

vidalia

    Citizen

  • Members
  • Pip
  • 64 posts

Posted 08 March 2017 - 11:18 PM

Have you tried to manually create the folder D:\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users\temporary_logs\ and then run FINIS? 


  • 0

#7 lordrahl

lordrahl

    Prisoner

  • Members
  • 6 posts

Posted 09 March 2017 - 11:28 AM

Have you tried to manually create the folder D:\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users\temporary_logs\ and then run FINIS? 

Yes, still getting error 9  outside the bounds of the array. I am at my wits end.


  • 0

#8 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,333 posts

Posted 09 March 2017 - 05:18 PM

Have you checked that you meet all the requirements for MO? .NET especially can be very troublesome at times.



#9 lordrahl

lordrahl

    Prisoner

  • Members
  • 6 posts

Posted 09 March 2017 - 07:20 PM

Have you checked that you meet all the requirements for MO? .NET especially can be very troublesome at times.

Thank you for your response, I do meet the requirements.


  • 0

#10 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,333 posts

Posted 09 March 2017 - 08:13 PM

If that is the case then perhaps Windows is messing with your install due to UAC issues. The error message shows it isn't applying the correct system files to this process so you may need to look at fixing that.

Try running everything as Admin, though I advise against this at it may cause issues later on. Or perhaps your H: drive is a NAS drive, or otherwise attached via software, and this is messing with MO's 'hooking' system.

Basically you will need to look at all the areas where your system deviates from the norm and investigate if that is causing an issue.

 

MO/MO2 is very finicky when it comes to software running in the background that may also try to make calls on the games, or game tools, running processes. Game overlays, AV software, firewalls, NAS drivers etc. all can be causes of issue.



#11 SSGCull

SSGCull

    Prisoner

  • Members
  • 33 posts

Posted 09 March 2017 - 08:29 PM

Shouldn't the path be ?:\Mod Organizer\mods\FNIS Behavior SE V7 0 Beta\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe ?

Just wondering.  I have the latest build, and have no problems with FNIS.


  • 0

#12 lordrahl

lordrahl

    Prisoner

  • Members
  • 6 posts

Posted 09 March 2017 - 10:59 PM

If that is the case then perhaps Windows is messing with your install due to UAC issues. The error message shows it isn't applying the correct system files to this process so you may need to look at fixing that.

Try running everything as Admin, though I advise against this at it may cause issues later on. Or perhaps your H: drive is a NAS drive, or otherwise attached via software, and this is messing with MO's 'hooking' system.

Basically you will need to look at all the areas where your system deviates from the norm and investigate if that is causing an issue.

 

MO/MO2 is very finicky when it comes to software running in the background that may also try to make calls on the games, or game tools, running processes. Game overlays, AV software, firewalls, NAS drivers etc. all can be causes of issue.

 

Shouldn't the path be ?:\Mod Organizer\mods\FNIS Behavior SE V7 0 Beta\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe ?

Just wondering.  I have the latest build, and have no problems with FNIS.

Thanks , I believe you are correct that it is a system problem, and will definitely try to fix that issue. The path normally, and is now set the way you say but I was at a loss so I installed it into the data directory and tried running it through MO2 that way but that didn't work either. So now I have it installed back in MO2. I have exhausted my efforts and agree something is wrong with my system and not with MO2 or FNIS Thanks for all the help!


Edited by lordrahl, 09 March 2017 - 11:00 PM.

  • 0

#13 sonnhy

sonnhy

    Prisoner

  • Members
  • 4 posts

Posted 30 April 2017 - 04:26 PM

Without creating a new topic, I have problem with FNIS and MO2 as well.

My problem is different, the window doesn't even show up after I run FNIS from MO.

 

This is what I get when I "Run" FNIS from MO. The MO log file "usvfs-2017-04-30_21-18-37.log":

23:19:06.647 [E] failed to hook GetFileVersionInfoW: No Error
23:19:06.647 [E] failed to hook GetFileVersionInfoExW: No Error
23:19:06.647 [E] failed to hook GetFileVersionInfoSizeW: No Error
23:19:06.647 [E] failed to hook GetFileVersionInfoSizeExW: No Error
23:19:06.670 [I] (proxy) instance: mod_organizer_instance
23:19:06.670 [I] (proxy) exe: 
23:19:06.670 [I] (proxy) pid: 0
23:19:06.670 [W] (proxy) not all required settings set
23:19:06.672 <3224:920> [E] failed to inject into spawned process

I've double checked the mod is checked on the left pane and that the paths are correct.

MO is installed in the same drive (C:) as the mods and as Skyrim are.

 

What is strange is that if I run the FNIS executable, alone, it does work and the window open as it should.


Edited by sonnhy, 30 April 2017 - 04:29 PM.

  • 0

#14 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,333 posts

Posted 30 April 2017 - 05:28 PM

Check to see that no AV software is stopping the execution of the FNIS exe from MO. Check the sub-forums for the thread about what software can interfere with it.



#15 BDK

BDK

    Prisoner

  • Members
  • 4 posts

Posted 26 June 2017 - 03:15 AM

i have the same issue , i have manual installed FNIS in MO  ,the filles  are in steam/steamapp/etc etc .....when i try to launch it ,it dt work  ,just gimme a black window who will be there  for 1sc before she shutherlf down  ;but when i launch it manually (FNIS) it doeas work normaly,i have no AV software or else ,so i dont really know what i should do. i really whant FNIS on my skyrim ,i have played skyrim and skyrim special edition ,i've modded my skyrim special edtion   but it wasnt the official thing,now i have buy my self skrim SE and wanted to get a clean stable mod thing  and with a lot of mods but here i am waithing to get it right !

i hope people can help me and if not  snif snif,thanks for reading this,hope you all the best (sorry for nazy grammar ,im not english)


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users