Jump to content


Photo

Step CORE or Patches installation questions/concerns


  • Please log in to reply
7 replies to this topic

#1 Ellilea

Ellilea

    Guard

  • Members
  • PipPip
  • 135 posts

Posted 16 March 2017 - 07:29 PM

Hello. I'm trying to install STEP, but I feel there's a whole bunch of things going over my head here...

I successfully followed the guide up to the "required mods" part (well, had a hiccup with cleaning Update.esm, I just moved the cleaned, smaller .esm from overwrite folder to Data and deleted the backup without making a new mod out of it - did I make a stupid?)

 

Anyway. I wanted to use STEP patches to fix things, but does that mean I have to use all those multitude of mods listed here: http://wiki.step-pro...om/STEP:2.2.9.2 ?

 

Utilities and fixes - I mostly got them all, but I want to have a "Requiem" playthrough and for instance I heard it makes "NARC" redundant and there's a possibility of some conflicts with "Consistent Older People". Also heard that "Brawls Bugs Patch" has been superseded by "Modern Brawl Bug Fix" http://www.nexusmods...im/mods/77465/?

 

Smart Souls is not recommended to run alongside Requiem as well, from what folks at their subreddit told me.

 

Then there's plenty of other mods below that I don't really need like "Lore-Based Loading Screens", for instance, and a bunch more. I want to use "Purity" and that includes some waterfall things, so I don't need the "SkyFalls and SkyMills" etc, etc.

 

Are all of those files required for the STEP patches? Or have I just utterly confused myself? I wanted to use this to build a base for a stable game with some ENB slapped on top of it and then add a bunch of mods I've selected, but MO tells me I cannot install the patches, because I lack stuff :<

 

Could someone kindly explain to me, like to a lost child with Winnie the Pooh brain, what's up? :p

 

I apologize if it's a stupid question, I mean no offense to anyone, especially people who made these packs and guides. I love the .ini config part and the initial installations and all, and I'm sure I'd love the patches too, which is why I need ask for assistance.

 

Thank you kindly.


  • 0

#2 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,107 posts

Posted 16 March 2017 - 07:44 PM

What is required for the STEP Patches is listed here in the the first post: http://forum.step-pr...ep-compilation/



#3 Ellilea

Ellilea

    Guard

  • Members
  • PipPip
  • 135 posts

Posted 16 March 2017 - 08:47 PM

Oh, that's nice. Thank you and my apologies for failing to find it on my own ;< Have a nice day over there.


  • 0

#4 kabepo

kabepo

    Citizen

  • Members
  • Pip
  • 63 posts

Posted 17 March 2017 - 02:19 AM

I think you should break down what you are doing into smaller steps (excuse the pun).

​1. Install STEP Core, following the guidelines.

​Test it and make sure everything is working OK.

​2. Copy the STEP Core profile and modify it to work with Requiem.

​Then you can always go back to the STEP Core profile later and restart if you need to.

​You say that "NARC", "Consistent Older People", and Smart Souls are not recommended to run alongside Requiem.

I follow the skyrimrequiem reddit and have not seen these mods mentioned as a problem, do you have links to the discussions?

​NARC has patches for Requiem, so I assume that means it must work fine with Requiem (with the patches loaded).

​There are STEP Packs "Requiem" and "Everything + The Kitchen Sink" and they do not mention problems using these mods.​


  • 0

#5 Kelmych

Kelmych

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,856 posts

Posted 17 March 2017 - 01:25 PM

This isn't quite how Packs work on the STEP site. The STEP team created and maintains the guides for STEP Core and Extended; these are not "Packs". This includes the individual mod pages on the Wiki for all the mods in STEP Core and Extended. The comments field for these mods do not include discussions of how these mods are affected by the presence of other mods not in STEP Core or Extended. In order to reduce problems, the recommendation for these has always been to install STEP Core or Extended starting with a vanilla Skyrim installation and to not add any other mods until these are installed and tested. Step 1, and the general idea in step 2, in the comment above is already the recommended approach in the guide when using STEP Core or Extended with any additional mods.

 

There aren't any instructions in the STEP guide on how to install other mods while installing the ones in the guide. Any comments in the STEP forums on compatibility between mods in the STEP guide and other mods such as Requiem are from forum users, not official comments from the STEP team. Generally, of course, these comments are very useful. Sometimes they are out of date, and compatibility problems discussed might have been solved.

 

At the end of the STEP guide it mentions Packs and the general concept that Packs are loaded after STEP Core or Extended is installed. The current STEP Packs include some that are intended to be installed after STEP Core or Extended is installed, and some that do not expect STEP Core or Extended to be used at all. The "Everything + The Kitchen Sink" pack does not use STEP Core or Extended. The "Requiem" pack threads haven't been updated in a long time.

 

The advanced search function on the forum is often useful in finding discussions such as the compatibility discussions you are looking for. When you find such threads you might want to post specific questions like the ones you ask above in these threads even if they are old threads; you will probably get more responses when doing so.



#6 Ellilea

Ellilea

    Guard

  • Members
  • PipPip
  • 135 posts

Posted 17 March 2017 - 02:46 PM

@Kabepo

 

"Smart Souls" are supposedly a feature that Requiem already possesses, according to the folks over here: https://www.reddit.c...ityfoolishness/

 

Same thing for "NARC", simply included in Requiem behaviors (or was that in SkyTest behaviors?). Also people say that most of the animals are even fixed in the regular patches. Either way, supposedly fixed.

 

Don't remember where the "Consistent Older People" note was, tried to find it again, but failed. My guess is, it might work similar to the visual NPC Overhaul which changes the records that Requiem also changes, meaning that Requiem will overwrite the changed looks without a patch. Could this also apply to "COP"?

 

As for the packs, I remember them being there last time I attempted an install, which was quite a while ago (last summer?). Have they been updated? Or maybe some things have changed? When it comes to NARC and SmSouls it's a matter of redundancy, not bugs.

 

@Kelmych

 

Aye, I know, I don't install any packs. I was following the general guide and somehow managed to miss when the requirements for STEP patches ended, and general recommendations began :P Which brought me here. With the new list, my concerns are gone since neither "COP" or "NARC" or "Smart Souls" are on those. I am still concerned about the Realistic Water Two, as "Purity" includes "Pure Waters" that I wanted to use :(

 

Now I'm not sure how to deal with that. Want the patch, but want "Purity"... I also don't care much for the "Audio Overhaul" mod, I'm a filthy casual when it comes to sounds and don't even notice those things hah, but I'm getting it for the sole reason of being able to install these patches to combat the plugin amount and make things as stable as possible.

 

###

 

Also, tiny question, could you tell me perhaps if I understand "Mod Organizer" right? When it comes to mods without .esp files. Say, I got 2 mods that change the look of some rock. 'Red Rock' and 'Blue Rock'. I activate them both, which takes precedence? The one I activated later, the one which has lower priority index, or the one that has a higher priority index? I tried to Google for it, but haven't found a simple answer :<

 

Thanks.


Edited by Ellilea, 17 March 2017 - 02:50 PM.

  • 0

#7 Nebulous112

Nebulous112

    High King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,433 posts

Posted 17 March 2017 - 03:04 PM

The one you install after will have a higher priority index. This means it will win conflicts with general assets (such as textures and meshes). It will be visually lower down in the list if sorting by priority.

You can see what overrides what by looking at the lightning bolt with green + signs or red - signs by the mod name. If you have a mod selected in the list, and it overrides another mod's assets, the mods it overrides or gets overriden by are highlighted in red or green.

You can also double-click a mod in the list and go to the conflicts tab to see a list of individual files that conflict with other mods.

If you have Mod Organizer managing BSAs (in the archive tab), it will show file conflicts within BSAs as well, not just loose files.

This is all "left-pane" stuff. It's basically like installation order, except you can move the order around, hide certain files if they are loose, etc.

If you want to know what wins conflicts with your mod plugins (right pane), that is dependant on your load order, which you can generally sort with LOOT. To see the conflicts themselves (and patch then if you want), you need to use xEdit.

Hopefully that makes sense. For more info on MO, see the MO Guide. http://wiki.step-pro...e:Mod_Organizer

#8 Kelmych

Kelmych

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,856 posts

Posted 17 March 2017 - 05:45 PM

 

 

@Kelmych

 

I am still concerned about the Realistic Water Two, as "Purity" includes "Pure Waters" that I wanted to use :(

 

Now I'm not sure how to deal with that. Want the patch, but want "Purity"... I also don't care much for the "Audio Overhaul" mod, I'm a filthy casual when it comes to sounds and don't even notice those things hah, but I'm getting it for the sole reason of being able to install these patches to combat the plugin amount and make things as stable as possible.
 

 

Thanks.

You can find posts in the forums about Purity and Realistic Water Two. The consensus was that they are not compatible. You can edit the STEP patch to remove the dependence on the Realistic Water Two plugin, but there hasn't been any significant testing using STEP Core or Extended substituting Purity for Realistic Water Two. Moreover, Purity includes weather effects and almost all of the testing and effort with STEP to provide compatibility with added weather mods uses Vivid Weathers.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users