Jump to content


Photo

Character animation not working; possible FNIS issue

fnis animation

  • Please log in to reply
3 replies to this topic

#1 koinuchan

koinuchan

    Prisoner

  • Members
  • 2 posts

Posted 24 April 2017 - 10:01 AM

Hi everyone; I promise I couldn't find any question about this on here, although I'm sure there may be some out there.
I'm new to modding and have been successful so far.  I've installed this mod, "Shake it"
 
It gave me a spell that i use to make me dance. but when I use it nothing happens. 
Initially, I started out with mods like Sky UI, Simply Knock, Crash Fixes, Better Message box, staff Mods and some mod that puts My Little Pony characters in game (Not really a brony, but I like anything hillarious)  And everything has been working so far.
 
And then I started putting in other mods like FNIS, some ragdoll and skeleton mods that were suggested for animation overrides.  Since I didn't have a way to see if these were working properly; I installed Shake It, which uses those mods as prerequisites, as a test for those mods.  I'm not sure if I'm using FNIS wrong or what.  Here's a screenshot of what it looks like when I update FNIS behaviour.
 
 
There's a part in there that says "Warning: Bad installation. Generator not run from <Skyrim_Data>\Tools\GenerateFNIS_for_Users.<<" that I only noticed while typing this.  I'm not sure how to fix it.  It appears that in the FNIS installation guide, the creator  installed FNIS so that  the tools folder was in steam/steamapps/common/skyrim/data
 
 
but when I installed it with Mod Organizer, it went to 
Documents\Mod Organizer v1_3_11-1334-1-3-11\ModOrganizer\mods\Fores New Idles in Skyrim - FNIS\FNIS Behavior 6.3 XXL\Data
 
Is it not supposed to be that way?  I don't know how to make it install any differently.  Perhaps I souldn't use MO.  
And would an FNIS problem be why the dance animation isn't working?  I don't know if it helps, but here's a screencap of my mods in MO

  • 0

#2 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,333 posts

Posted 24 April 2017 - 06:24 PM

A couple of issues:

  1. You've installed MO into an overly complex folder. This will impact on Windows in the future with exceeding file length limits. Also I would advice against installing into 'Documents', just make a folder somewhere else and install MO there, ie. C:|Games\MO\
  2. Secondly it looks like you have installed FNIS and then FNIS - XXL on top of that. Only one or the other is needed, best to stick with just FNIS.

That second issue also raises something you need to be aware of with some archives installed in MO. It looks like you just pressed OK in the install dialogue instead of checking to make sure the mod was installing in the 'top level'. Please check the MO wiki and watch the video tutorials on what to do with this.



#3 koinuchan

koinuchan

    Prisoner

  • Members
  • 2 posts

Posted 26 April 2017 - 09:48 AM

A couple of issues:

  1. You've installed MO into an overly complex folder. This will impact on Windows in the future with exceeding file length limits. Also I would advice against installing into 'Documents', just make a folder somewhere else and install MO there, ie. C:|Games\MO\
  2. Secondly it looks like you have installed FNIS and then FNIS - XXL on top of that. Only one or the other is needed, best to stick with just FNIS.

That second issue also raises something you need to be aware of with some archives installed in MO. It looks like you just pressed OK in the install dialogue instead of checking to make sure the mod was installing in the 'top level'. Please check the MO wiki and watch the video tutorials on what to do with this.

Hi! Thanks a bunch!  I can try to re-install MO if you think I should.  But just to clarify, my documents folder is the first folder right under my D drive; I moved it there because I didn't want documents in the default C drive location. So the MO location is basically D:/documents/Mod Organizer v1_3_11-1334-1-3-11  Would that be ok, or should I still move it? Would moving it mean I have to uninstall and reinstall the current mods?  And will that mess with the game?

 

Also, I think what you're seeing is that I have FNIS XXL and FNIS creatures; it has the word "ANIMALS" in the mod name.  I don't think I have the regular FNIS, I got the XXL instead.  As for the "top level" thing, I did get notices reminding me of that in MO.  I would use trial and error, dragging items to the top level until the message said "Looks good".  I'm about to check the videos on the MO wiki today.  Thanks a bunch! :-)


  • 0

#4 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,333 posts

Posted 26 April 2017 - 06:23 PM

On purely managerial level MO shouldn't be installed into your 'Documents' because it isn't a document! Defeats the purpose of named folders if you don't follow the schema.

However the true purpose of renaming it is due to the name of the chosen folder: "Mod Organizer v1_3_11-1334-1-3-11" . No need for the duplication of the version numbering or to have the Nexus number included in it, MO is preferred or 'Mod Organizer' if you want more.

Moving this is just a simple case of renaming the folder and then checking your INIs to see that nothing is 'hard-written' to point to the previous folder. Removing MO and installing fresh is also an option, ensuring to save your "profiles, mods and downloads" folders. 

 

Regarding FNIS, your included screenshot shows FNIS - XXL being called from:

D:/documents/Mod Organizer v1_3_11-1334-1-3-11\mods\Fores New Idles in Skyrim - FNIS\FNIS Behaviour 6.3 XXL\Data\tools\GenerateFNIS_for_user

 

This is not the location it needs. If installed correctly in MO FNIS will be called from something like:

D:\steam\steamapps\common\Skyrim\data\tools\GenerateFNIS_for_Users

MO parses the installed location to appear as though it is coming from the game's data folder, just as is done for all other mods.

 

One last thing to mention. Your screenshot also shows the game launcher set to be run, your MO should be calling SKSE as the executable to run. Doing anything else will cause your game to fail.





Also tagged with one or more of these keywords: fnis, animation

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users