Jump to content


Photo

Hang on perk select with Bashed Patch


  • Please log in to reply
2 replies to this topic

#1 Makkli

Makkli

    Prisoner

  • Members
  • 12 posts

Posted 27 April 2017 - 12:20 PM

Hello! Up front please let me say thank you to Kelmych for the amazing amount of work in this guide. I am a latecomer to Fallout and to be honest I probably wouldn't have become so in love with it if I hadn't dove in with this guide.

 

I'm having an issue I can't get to the bottom of on my own. I have an otherwise stable (well stable for FO3 in Win 7) setup until I level up. When I pick a new perk on level up the game freezes when I click Done or hit A. Through trial and error I discovered that if I save right before level up and load my MO profile sans Bashed Patch, I can pick my perk just fine.

 

Info that might be useful: 

1. I followed most of the guide up to through the first body mods in section 20. I skipped FWE and related items as well as all the addin quests mods in section 18 except Reilly. 

2. I played with that setup with no bashed patch til somewhere around level 15. (cause frankly I got excited to play and it was working and I forgot to jump to the post install bottom) 

3. I decided I needed more "pretty" and more immersion so I did a lot of picking and choosing through the subsequent sections particularly armor/body/animation mods, hi-res graphics, as well as adding in Crowded Cities, Expanded Caravans and finally got around to patches and the Bashed Patch. I didn't do any of the weapon updates.

4. The level up issue started somewhere thereafter. (big shock)

 

On a whim, I also loaded a New Start Save (just before Vault 101 exit) with the exact same MO profile and she can pick a perk at level 2 with no problem. <sigh>

 

So.....what next? Is it somehow related to her higher levels? Or some conflict that's not apparent because the newbie hasn't come across that content yet? Or is there just a bunch of wonky history in my character save because of all the mid play tweaking I've done?

 

What, if anything, do I need to provide to help others help me learn to help myself?


  • 0

#2 Kelmych

Kelmych

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,806 posts

Posted 28 April 2017 - 01:40 AM

The bashed patch doesn't affect many perks; in my game it only affects two. It's more likely that there could be some effects with the GUI used for level up. Is it one of the standard game perks or one added/modified by a mod; does it matter which perk you choose? Does it depend on where you are in the Capital Wasteland, or whether you are outdoors or indoors?

 

It's possible that at some point the game got corrupted; I had problems with that on my original playthrough years ago. I've tried to be fairly careful with the game I have running now, both in avoiding mods that have known stability problems and trying to avoid breaking game scripts.



#3 Makkli

Makkli

    Prisoner

  • Members
  • 12 posts

Posted 28 April 2017 - 05:19 PM

There doesn't seem to be any relation to location. I've been in the Wasteland open world and in Vault 87 and in Raven Rock. It doesn't seem to matter which perk or what points I alloted prior to picking the perk though I certainly didn't try them all. I didn't add any mods that affect perks because I wanted to do my first playthrough with the "original" content, just better looking. 

 

I considered it being a UI problem sine its not actually the perk pick but the clicking of Done on the perk window but it also freezes when I type A. Does the game consider that the exact equivalent? I am using DarnUI, aHUD and iHUD along with UIO. As I said, I was curious if it was something wrong with the save history itself since I did so much mid game modding and the problem only started a few levels ago, shortly after my latest round of "must have more pretty graphics!". The only consistency is that on the save with the issue if I disable only the bashed patch and try to select the perk I can select it fine. I tried it on a NewStart save that I have and that character selected a perk just fine with the identical profile and the bashed patch enabled. So that leans me toward the issue being something fubared in the save file itself that doesn't get along with the bashed patch but since I'm newish to this I didn't know if that was a reasonable speculation or where to look next.

 

Having just finished the MQ line from Vanilla I'm considering just starting over with the "fully" modded profile and NOT messing with it in the middle this time, partly cause its a pain in the ass to turn off the bashed patch every time I level and partly cause the geek in me is just too curious to test my theory that its the save. 

 

If you have any other thoughts, suggestions or things I can look at, I'm always anxious to learn.


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users