Jump to content


Photo

Stuttering in the open world


  • Please log in to reply
19 replies to this topic

#1 kechlion

kechlion

    Prisoner

  • Members
  • 14 posts

Posted 08 August 2017 - 04:30 PM

When in the open world just running around, I get some serious stuttering issues that appear to happen when a new cell loads. My FPS drops from rock solid 60 to as low as 20 on a cell load. I have double checked and I believe all of my settings are as recommended in the STEP Core guide. The mods I have installed are STEP Core with recommended texture qualities and additionally Ordinator, Wearable Lanterns, Rich Merchants, Grimy Plugin, SkyTweak, Weightless Ingrediants, 3DNPC, and Smart cast. My system specs are as follows: 

 

i7-5930k

Win 10 pro

16GB Ram

nVidia Titan X

Mods and Skyrim installed on two Samsung 850 Pros in a Raid 0.

 

I am running between the exit of Helgen caves and the Mill that's to the... west of it? Just running along the road. This is basically a new game.

 

I have changed enblocal to do windowed borderless (and not) and I have attempted to increase and decrease ReservedMemorySizeMb with no appreciable results. I'm attaching a screenshot of performance monitor with 512MB reserved memory.

 

My enblocal.ini is also attached.

 

Any help is greatly appreciated. My primary goal is to run skyrim at a rock solid 60 fps at all times. Huge performance swings really grate on me.

 

Thanks!

 

 

 

Attached Files


  • 0

#2 GSDFan

GSDFan

    Jarl

  • Moderators
  • PipPipPipPipPipPipPipPipPip
  • 867 posts

Posted 08 August 2017 - 06:23 PM

Are you by chance running a GSync monitor?



#3 kechlion

kechlion

    Prisoner

  • Members
  • 14 posts

Posted 08 August 2017 - 06:33 PM

Are you by chance running a GSync monitor?

I am - an ASUS PG279Q.


  • 0

#4 GSDFan

GSDFan

    Jarl

  • Moderators
  • PipPipPipPipPipPipPipPipPip
  • 867 posts

Posted 08 August 2017 - 09:47 PM

Ok, I have found that G-Sync needs to be turned off for Fallout 4 and I guess Skyrim also. These games do not benefit from the G-Sync technology. They need a rock steady 60FPS to function properly. The following should help.

 

Go into the Nvidia control panel and set the “Monitor technology” to “Fixed refresh” and under “Preferred refresh rate (Monitor name)”, set that to “Application-controlled” and set “Vertical Sync” to “On”.

 

Those items can also be changed in Nvidia inspector under the 2- Sync and refresh section.

  • In this section, I have the “Frame Rate Limiter” set to off, but it can be set to around the 61.8 or 62.8 if needed.
  • The “G-Sync – application Mode’ needs to be set to “Off”.
  • The “Monitor technology” is “GSYNC – Application state”, set it to “Fixed Refresh Rate.
  • The “Preferred refresh rate (Monitor name)” correlates to “Prefered Refresh Rate”, yes that is how it is spelled, set that to “Use the 3D application setting”.
  • You also need to change “Vertical Sync” to “Force ON”.
  • Change “Vertical Sync Tear Control” to “Standard”.

Also disable any Vsync and FPS limiters in ENB if you have it installed or any place for that matter.

These settings took care of my large stuttering in Fallout 4.

Attached Files



#5 kechlion

kechlion

    Prisoner

  • Members
  • 14 posts

Posted 09 August 2017 - 05:44 AM

I turned GSYNC off and set it up to match your settings as best as I could, however my inspector pane does not look the same as yours. I did not have a 'G-Sync - application Mode' setting at all. I also disabled vsync in ENB.

 

This did not fix the issue, it appeared to run basically the exact same as before. Apparently I can't upload that performance monitor picture because of filesize, but if you want I can put it in the next post showing that the performance dips were the exact same.

Attached Files


  • 0

#6 GSDFan

GSDFan

    Jarl

  • Moderators
  • PipPipPipPipPipPipPipPipPip
  • 867 posts

Posted 09 August 2017 - 06:05 AM

Search for Nvidia profile inspector version 2.13. At some point the profile inspector split from the main application, my version is 1.9.7.8.



#7 kechlion

kechlion

    Prisoner

  • Members
  • 14 posts

Posted 10 August 2017 - 05:27 AM

Either way though, turning off Gsync didn't fix the problem. Turned off in all of my available settings plus seeing my monitor's power light (changes to white if non-gsync) and still had the exact same issues. Any other suggestions? 


  • 0

#8 Kelmych

Kelmych

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,863 posts

Posted 10 August 2017 - 02:12 PM

The game engine itself contributes some stuttering. I've noticed occasional stuttering as the game loads a new cell even when the CPU and RAM usage are low, and the graphics card (GTX 1080Ti) is at about 30% usage and the VRAM usage is 100s of MB  below 4Gb. It's most noticeable when I am going fast such as with horse travel.



#9 kechlion

kechlion

    Prisoner

  • Members
  • 14 posts

Posted 10 August 2017 - 02:32 PM

Are there any mods from the STEP pack that I should turn off to avoid the stuttering? I mean, the game is gorgeous right now but I'd rather it look a bit worse than choke every time some trees load, especially when my system ought to be able to handle it.


  • 0

#10 kabepo

kabepo

    Citizen

  • Members
  • Pip
  • 65 posts

Posted 11 August 2017 - 01:49 AM

For macrostutter problems the STEP guide also recommends uninstalling Skyrim Flora Overhaul - have you tried that?


  • 0

#11 kechlion

kechlion

    Prisoner

  • Members
  • 14 posts

Posted 11 August 2017 - 05:28 AM

I uninstalled Skyrim Flora Overhaul, redid LOOT, and redid the Bashed Patch and it did not appear to make any difference.

Attached Files


  • 0

#12 kabepo

kabepo

    Citizen

  • Members
  • Pip
  • 65 posts

Posted 11 August 2017 - 11:31 PM

Try rerunning BethINI and setting the preset to the lowest setting - 'Poor'.

If that reduces stutter then it is an .ini file setting which is causing the problem.


  • 0

#13 kechlion

kechlion

    Prisoner

  • Members
  • 14 posts

Posted 12 August 2017 - 09:58 AM

I changed the BethINI settings to poor and, while it's not dropping by 20-40 frames when it stutters, it is still stuttering in roughly the same places for 5-10 frames, so the stutter is still there. Also, holy crap the draw distance with people just spawning in literally on top of me.

 

Also, Skyrim Performance Monitor link since I guess I'm hitting my cap on file size on the forum - http://imgur.com/a/GOvLK


  • 0

#14 kabepo

kabepo

    Citizen

  • Members
  • Pip
  • 65 posts

Posted 14 August 2017 - 03:07 PM

Create a new profile, and untick all the STEP mods, so you just have vanilla Skyrim.

Test vanilla Skyrim to verify there is no stutter.

Then add back mods 5 or 10 at a time until you locate the mod which is causing stutter.


  • 0

#15 Nickd1291

Nickd1291

    Prisoner

  • Members
  • 20 posts

Posted 14 August 2017 - 04:30 PM

This probably isn't an issue, but your enblocal has two [Window] subsections, one turning off and the other turning on fullscreen borderless. Also the reserved memory in it is rather low at 128mb, have you tried increasing it to 256/512? In the first post you say you were using 512 but your enblocal says differently, so I am just seeking clarification. Also follow kabepo's suggestion and make sure this isn't an issue with vanilla skyrim.

 

Skyrim has never liked my pc either, so after suffering stuttering like you for multiple years I switched to SSE 2-3 months ago and haven't looked back, imho more stable (framerate and ctd wise) than skyrim ever was.


Edited by Nickd1291, 14 August 2017 - 04:30 PM.

  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users