Jump to content


Photo

Dynamic Distant Objects LOD - DynDOLOD 2.35

dyndolod lod skyrim skyrim se

  • Please log in to reply
117 replies to this topic

#106 HeirIofIHerjeim

HeirIofIHerjeim

    Prisoner

  • Members
  • 2 posts

Posted 24 November 2017 - 05:55 PM

How to install DynDOLOD Standalone from 0:00 to 0:22

How to install DynDOLOD Resources from 0:33 to 0:44

 

Best to watch entire video though for how to install other requirements and how to use the tools to create and install a LOD mod for the load order. There is also an extensive DynDOLOD Start To Finish video and a detailed manual in the DynDOLOD Standalone archive in case you prefer the written word or need to do a bit more customization or choose different options when using the tools.

 

All in all, this is 666 times easier than anything that came before it.

Thanks for the reply Sheson! Sorry for getting back late, I had to do life stuff and hadn't had time to get back to my Skyrim modding installation till today.

 

Good to know about it being easier. I can only imagine true insidiousness can make it specifically 666 times that. You should be receiving the firstborn of Herjeim house shortly, happy thanksgiving.


Edited by HeirIofIHerjeim, 24 November 2017 - 05:57 PM.

  • 0

#107 snares

snares

    Prisoner

  • Members
  • 17 posts

Posted 30 November 2017 - 07:46 AM

Hello, i have recently updated from version 2.18 to the latest 2.35 and now have a problem: Dyndolod does not finish the process and quits with the "lodgeneratorcmd has stopped working" message.

 

I am using Skyrim LE. To update, i chose to completely delete my old dyndolod instance and remake everything. I use the ultra trees option. I searched the forum for this problem and the fix that was mentioned did not solve the issue, as i allready point dyndolod to a directory outside of MO. I am using MO 1.3.11. I have tried it with MO 2.07 and while the error message does not pop up, the dyndolod process stops after only a few minutes of running instead of the usual 30min process and shows no LOD ingame.

 

What can i do to solve the problem?


  • 0

#108 sheson

sheson

    Dragon Prince

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,686 posts

Posted 30 November 2017 - 11:05 AM

Hello, i have recently updated from version 2.18 to the latest 2.35 and now have a problem: Dyndolod does not finish the process and quits with the "lodgeneratorcmd has stopped working" message.

 

I am using Skyrim LE. To update, i chose to completely delete my old dyndolod instance and remake everything. I use the ultra trees option. I searched the forum for this problem and the fix that was mentioned did not solve the issue, as i allready point dyndolod to a directory outside of MO. I am using MO 1.3.11. I have tried it with MO 2.07 and while the error message does not pop up, the dyndolod process stops after only a few minutes of running instead of the usual 30min process and shows no LOD ingame.

 

What can i do to solve the problem?

 

See if replacing ..DynDOLOD/Edit Scripts/LODGen.exe and LODGenx64.exe with this latest version changes anything.

 

If not, try to bring the command prompt window to the front and make a screenshot of the error and check the ..DynDOLOD/Logs/LODGen_TES5_[Worldspace]_log.txt.

 

If DynDOLOD.exe stops/freezes see if setting FasterBase=0 or FasterCreate=0 makes a difference. Otherwise make a screenshot where it stopped working.

 

Make sure CPU temps and/or overclocking settings are fine and not the problem.


  • 1

#109 snares

snares

    Prisoner

  • Members
  • 17 posts

Posted 30 November 2017 - 12:03 PM

 

See if replacing ..DynDOLOD/Edit Scripts/LODGen.exe and LODGenx64.exe with this latest version changes anything.
 
If not, try to bring the command prompt window to the front and make a screenshot of the error and check the ..DynDOLOD/Logs/LODGen_TES5_[Worldspace]_log.txt.
 
If DynDOLOD.exe stops/freezes see if setting FasterBase=0 or FasterCreate=0 makes a difference. Otherwise make a screenshot where it stopped working.
 
Make sure CPU temps and/or overclocking settings are fine and not the problem.

 

Thank you very much for helping.

I tried the newer executables you provided. The same error occured, but i saw the actual error message in the lodgen.exe window: "Unhandled Exception: Unhandled Exception: OutOfMemoryException. OutOfMemoryException." All LODGen_TES5_Worldpace_log.txt end with a Code:0, but LODGen_TES5_Tamriel_log.txt is empty. The exe did not freeze, as it could be terminated with the OK button in the popup window that said "lodgeneratorcmd has stopped working". CPU temp is fine.
  • 0

#110 sheson

sheson

    Dragon Prince

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,686 posts

Posted 30 November 2017 - 05:41 PM

   

Thank you very much for helping.

I tried the newer executables you provided. The same error occured, but i saw the actual error message in the lodgen.exe window: "Unhandled Exception: Unhandled Exception: OutOfMemoryException. OutOfMemoryException." All LODGen_TES5_Worldpace_log.txt end with a Code:0, but LODGen_TES5_Tamriel_log.txt is empty. The exe did not freeze, as it could be terminated with the OK button in the popup window that said "lodgeneratorcmd has stopped working". CPU temp is fine.

Can you try to make a screenshot of the entire error message and upload it somewhere?

 

You do not have to re-run the entire process. Just change to Expert=1 in ..DynDOLOD/Edit Scripts/DynDOLOD/DynDOLOD_TES5.ini

Start DynDOLOD as always, change the drop down to Tamriel, then click "Execute LODGen.exe" button to start it directly with the already gathered LOD data.


Edited by sheson, 30 November 2017 - 06:20 PM.

  • 1

#111 snares

snares

    Prisoner

  • Members
  • 17 posts

Posted 01 December 2017 - 01:22 AM

Can you try to make a screenshot of the entire error message and upload it somewhere?

You do not have to re-run the entire process. Just change to Expert=1 in ..DynDOLOD/Edit Scripts/DynDOLOD/DynDOLOD_TES5.ini
Start DynDOLOD as always, change the drop down to Tamriel, then click "Execute LODGen.exe" button to start it directly with the already gathered LOD data.


I think i solved it, and it was probably user error.

First thing i did was run expert mode for tamriel only. Doing it this way, the "loggeneratorcmd" error did not happen and the tamriel log had content. It finished with the lines:

Finished LOD level 4 coord [4, -8] [196834/174873]
Can not get hash for shader in meshes\dyndolod\lod\trees\treepineforestsnow03_78524f29passthru_lod.nif block TreePineForestSnow03_LOD_FLAT:0
Can not get hash for vertices in meshes\landscape\plants\pineshrub02.nif block L1_PineShrub02
Log ended at 06:29:47
Code: 3005

The only mod that edits the pineshrub02.nif is USLEEP.

Then i tried the whole process again. The only thing i changed was the tree rule. I changed LOD16 to billboard instead of Static LOD16. Then the whole process finished.
  • 0

#112 sheson

sheson

    Dragon Prince

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,686 posts

Posted 01 December 2017 - 07:46 AM

I think i solved it, and it was probably user error.

First thing i did was run expert mode for tamriel only. Doing it this way, the "loggeneratorcmd" error did not happen and the tamriel log had content. It finished with the lines:

Finished LOD level 4 coord [4, -8] [196834/174873]
Can not get hash for shader in meshes\dyndolod\lod\trees\treepineforestsnow03_78524f29passthru_lod.nif block TreePineForestSnow03_LOD_FLAT:0
Can not get hash for vertices in meshes\landscape\plants\pineshrub02.nif block L1_PineShrub02
Log ended at 06:29:47
Code: 3005

The only mod that edits the pineshrub02.nif is USLEEP.

Then i tried the whole process again. The only thing i changed was the tree rule. I changed LOD16 to billboard instead of Static LOD16. Then the whole process finished.

That setting would mean it will try to use the hybrid LOD models in LOD level 16. LODGen.exe (32 bit version) might actually run out of memory because that can mean a lot of 3D data to process for a single LOD supermesh. It could also be too much data to properly fit into the supermesh nif.

 

Billboards for level 8, 16 should always be good enough visually.


Edited by sheson, 01 December 2017 - 07:46 AM.

  • 0

#113 El_Rizzo

El_Rizzo

    Prisoner

  • Members
  • 24 posts

Posted 08 December 2017 - 01:32 PM

Hey Sheson, not sure if you are already aware of this but the most recent version of ENB for SSE includes a fix for the bugged tree reflections on water that removes the black boxes around them, as you can see here: before and after. I thought this might interest you since you specifically mention this in your DynDOLOD documentation for SSE as one of the major engine bugs :)


  • 0

#114 Joat_Mon

Joat_Mon

    Guard

  • Contributors
  • PipPip
  • 155 posts

Posted 08 December 2017 - 02:02 PM

Hey Sheson, not sure if you are already aware of this but the most recent version of ENB for SSE includes a fix for the bugged tree reflections on water that removes the black boxes around them, as you can see here: before and after. I thought this might interest you since you specifically mention this in your DynDOLOD documentation for SSE as one of the major engine bugs :)

Shortcut to forum for more info:

 

http://enbseries.enb....php?f=2&t=5705


  • 0

#115 sheson

sheson

    Dragon Prince

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,686 posts

Posted 08 December 2017 - 02:16 PM

Yes, I was awaiting for this new version to be released.


  • 0

#116 combatfun

combatfun

    Prisoner

  • Members
  • 2 posts

Posted 10 December 2017 - 03:54 PM

Hi,

 

when i install this mod:

 

Beyond Reach by razorkid1
https://www.nexusmod...ition/mods/3008

 

TexGen64 fails on start up with this error:

1uyslw.jpg

 

When i Keep enter pressed, the message at the end is:

28ds9t.jpg
3oys7k.jpg
 

So i've tried the 32bit Version and the process could be completed. But DynDOLODx64 now failed on startup with a similar error. The error Code at the end was diffrent, but it was also telling me that the load order is messed up. So i've tried the 32bit version. The program runs a few minutes, until it crashes with the message "out of memory". I ran loot again, disabled overclocking, emptyed the dyndolod cache and also tried your update: https://mega.nz/#!kV...lwZ8LOJLEETtFUE

 

Without success. Than i found out, if i delete/disable Beyond Reach, the 64bit Texgen and Dyndolod runs again properly as it did several months with hundreds of mods. Has some one got an idea, why Beyond Reach isn't working with Dyndolod and what can be done to make it work?

 

thx, br

 

 

 

 


  • 0

#117 sheson

sheson

    Dragon Prince

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,686 posts

Posted 10 December 2017 - 04:14 PM

Hi,

 

when i install this mod:

 

Beyond Reach by razorkid1
https://www.nexusmod...ition/mods/3008

 

TexGen64 fails on start up with this error:

 

 

We are obviously only interested in the first exception. No surprise that there are more problems later.

No surprise that updating LODGen.exe does not change problems that happen with TexGen.exe/DynDOLOD.exe.

 

Are you using the latest version 2.35?

 

Did you check the entire load order for errors and fix them as good as possible with xEdit?

 

Post the log of the x64 start up error and the log of the x86 out of memory error if possible. Other make screenshots of the message window.


Edited by sheson, 10 December 2017 - 04:15 PM.

  • 0

#118 combatfun

combatfun

    Prisoner

  • Members
  • 2 posts

Posted 11 December 2017 - 05:22 AM

Yes, Plugins are cleaned. Thx for your fast response, but no further action is required. I had an old DynDoLOD version installed. The new 2.35 runs as it should with Beyond Reach.


Edited by combatfun, 11 December 2017 - 05:27 AM.

  • 0



Also tagged with one or more of these keywords: dyndolod, lod, skyrim, skyrim se

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users