Jump to content


Photo

What Should my v-sync settings be?


Best Answer hishutup , 17 October 2017 - 09:32 PM

For starters limiting the framerate can cause some pretty stupid microstutter just by how fps limiting and Vsync work.

 

So you can get around the physics thing by adjusting how often it updates them. Basically, reducing the maxTime seems to allow higher framerates.

I was playing with this quite a bit for ***** and giggles and yes, it correlates and causes the physics issue when a frame happens before an update, meaning more updates has the downside of more CPU load on those havok threads.

I doubt people have hit the limit for the havok threads though.

 

I have a gsync monitor, two actually. When I adjust the max time to update more often then the framerate of the monitor, the physics behave as expected.

The highest refresh monitor I have a 200Hz panel and it did fine.

 

Here is the tweak.

[HAVOK]
fMaxTime=0.009
 
The value is basically the reciprocal(1/X) of the maximum refresh rate of the monitor. I'd pad the refresh rate by a little because the only downside that I can imagine is a higher CPU load for those threads.
 
 
If people want the method I used I basically left vsync on(gsync FTW), I tested various refresh rates(15, 30, 45, 60, 100, 200) and I played with the value to make a truth table, but the values I used were (0.066, 0.033, 0.022, 0.016, 0.01, 0.005).
If the delay time between updates was too long, I got the whole flickering water/sun/swimming, flying animals, constant jump thing.
I suggest you try it out yourself and draw your own conclusions from this.
Havok is pretty much just in the runtime so I doubt any damage to a save can happen. Although, the position of any objects will be added and recorded of course.
 
Also removing or increasing the framerate of the loading screens definitely helps with load times. For some reason bethsoft ties loading to framerate, I wonder why this is...
Go to the full post


  • Please log in to reply
8 replies to this topic

#1 HyperSlayer72

HyperSlayer72

    Prisoner

  • Members
  • 17 posts

Posted 17 October 2017 - 10:53 AM

Hello, for a long time now ive been using skyrim with all forms of vsync off.  I own a 144hz monitor (dont worry I know what happens at 120fps+ with physics) and the only thing I do is cap my fps at 72 with enbseries. I personally get zero physics issues at 72fps.  However i'm more curious than anything why so many people say to enable v-sync in skyrim.  Is there a major reason why it must be done? On top of that im  confused on what v-sync options to change, ipresentinterval is in both of my games ini's, I have another vsync option in my enb ini, and I of course have the vsync setting in nvidia control-panel. Ive heard stuff about only some of the settings working. What would those be? Thanks ahead of time, detailed reply's would be great to read.


  • 0

#2 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,104 posts

Posted 17 October 2017 - 08:41 PM

Anything over 60FPS has the potential to throw the havok in the game off. For users like yourself, I typically recommend turning them all off and using the video card's framerate limiter to limit the game to 59.8 FPS.



#3 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,592 posts

Posted 17 October 2017 - 09:32 PM   Best Answer

For starters limiting the framerate can cause some pretty stupid microstutter just by how fps limiting and Vsync work.

 

So you can get around the physics thing by adjusting how often it updates them. Basically, reducing the maxTime seems to allow higher framerates.

I was playing with this quite a bit for ***** and giggles and yes, it correlates and causes the physics issue when a frame happens before an update, meaning more updates has the downside of more CPU load on those havok threads.

I doubt people have hit the limit for the havok threads though.

 

I have a gsync monitor, two actually. When I adjust the max time to update more often then the framerate of the monitor, the physics behave as expected.

The highest refresh monitor I have a 200Hz panel and it did fine.

 

Here is the tweak.

[HAVOK]
fMaxTime=0.009
 
The value is basically the reciprocal(1/X) of the maximum refresh rate of the monitor. I'd pad the refresh rate by a little because the only downside that I can imagine is a higher CPU load for those threads.
 
 
If people want the method I used I basically left vsync on(gsync FTW), I tested various refresh rates(15, 30, 45, 60, 100, 200) and I played with the value to make a truth table, but the values I used were (0.066, 0.033, 0.022, 0.016, 0.01, 0.005).
If the delay time between updates was too long, I got the whole flickering water/sun/swimming, flying animals, constant jump thing.
I suggest you try it out yourself and draw your own conclusions from this.
Havok is pretty much just in the runtime so I doubt any damage to a save can happen. Although, the position of any objects will be added and recorded of course.
 
Also removing or increasing the framerate of the loading screens definitely helps with load times. For some reason bethsoft ties loading to framerate, I wonder why this is...


#4 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,104 posts

Posted 17 October 2017 - 10:23 PM

That's more investigation than I've ever done, but I'm still running at 1920x1080 @ 60Hz. Getting the quality I like from a monitor with high specs still costs an arm and three toes for such a monitor.



#5 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,592 posts

Posted 18 October 2017 - 01:46 AM

I would highly suggest getting a 144Hz monitor with some form of adaptive sync, you'll never be disappointed.



#6 HyperSlayer72

HyperSlayer72

    Prisoner

  • Members
  • 17 posts

Posted 18 October 2017 - 10:24 AM

Awesome Fix! Was this found recently I remember no such solution around a year ago.  So in the end leaving all forms of v-sync off has no actual effect other than going above the limit of havok.  I was primarily worried that it was somehow impacting system utilization or decreasing stability.


  • 0

#7 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,592 posts

Posted 18 October 2017 - 02:00 PM

With the history of oldrim, it was never in the inis by defualt and everyone had accepted that there is no way.
When SSE was released it was there by default and people became curious.
Looking back onto oldrim, that ini tweak exists in the engine, test it and it behaves as expected. 
 
Vsync just locks the frames that leaves the buffer to every frame that the monitor is expecting, is there some other side effect(like  60fps lock) from skyrim's version, that is something that I do not know.
I leave all forms of vsync on because I was gsync to be active.
 

I was primarily worried that it was somehow impacting system utilization or decreasing stability.


This is where we get into theoretical and where my knowledge lessens...

What I'd expect from decreasing the sleep time is overall higher havok thread activity. From what I've seen, if the absurd cabbage test doesn't max that thread, I don't know what will, that is so many physics calculation happening very quickly.

I highly doubt that the havok processing it attached to something like the papyrus thread or the file I/O thread. Its still part of skyrim's process but it may run on a different core as it is somewhat asynchronous to how the render thread works, it seems they sync before or after the frame starts or is finished.

As for decreased stability, I wouldn't expect this unless system resources are really limited(single core) or an object has poor or broken physics nodes attached to it.



#8 Avastgard

Avastgard

    Citizen

  • Members
  • Pip
  • 50 posts

Posted 19 October 2017 - 12:15 PM

Pardon me, but I'm not sure I understand what this setting will fix. Will it reduce normal stuttering or only microstuttering?

 

I have recently started to experience some stuttering that I had not seen since I edited enblocal.ini according to the Step Guide. I had my game running pretty smoothly, but all of a sudden I started getting massive sutttering. I am currently trying everything I can to get rid of it or at least reduce it, but so far to no avail.


  • 0

#9 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,592 posts

Posted 19 October 2017 - 04:59 PM

I never said anything about stuttering, except the detail that it may be a side effects of vsync when limiting the framerate to something that isn't a direct factor of 60.

 

I made one correlation with the data above.

Reducing havok.fMaxTime seems to allow a higher in game framerate by alleviating the physics issues that are related to a framerate in excess of 60.

 

I've been seeing stutter once more on my system, I had it completely gone by messing with some settings(windows. enboost, skyrim), but it never seems to be consistent across reboots.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users