Jump to content


Photo

Double Window Bug

bug

  • Please log in to reply
8 replies to this topic

#1 Squiggums

Squiggums

    Prisoner

  • Members
  • 7 posts

Posted 11 December 2017 - 05:17 PM

Hi all,

DynDOLOD has been working fine for me, except for the fact that most windows in the game appear to be floating/doubled about a foot away from where the windows actually should be on the buildings. Using the console, the floating windows tell me that DynDOLOD.esp is responsible, but I also use Rustic Windows and ELFX (specifically the Exteriors) if that can help at all.

I tried googling the issue and found an old post on this very forum claiming that the floating windows are caused by the window glow settings in DynDOLOD's executable, I'm not sure if that's useful or if I should try to rebuild DynDOLOD without the window glow option ticked.

 

Annoyingly enough I don't want to just disable them with the console as the floating windows seem to have Rustic Windows' new and better textures, while the ones stuck to the buildings as they should be have vanilla textures. I suppose another solution would be to manually move the windows to where they should be by using the console, but that seems pretty time-consuming and so I hope a better option is available.

 

It DOES happen on a new game as well, so that's not the issue.

 

Any help would be greatly appreciated, thank you.

 

Attached File  ScreenShot553.jpg   276.65KB   1 downloads


  • 0

#2 sheson

sheson

    Dragon Prince

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,691 posts

Posted 11 December 2017 - 06:20 PM

Are you using the latest versions DynDOLOD 2.35  standalone and DynDOLOD Resources 2.30?

Make sure there are no files from older version lingering around.

 

Post the log from the generation.

 

Enable Papyrus logging.

Start new game by coc SolutideExterior01 from main menu.

After DynDOLOD initialized go into Solitude.

Check if there are any errors from DynDOLOD scripts in Papyrus log.


  • 0

#3 Squiggums

Squiggums

    Prisoner

  • Members
  • 7 posts

Posted 11 December 2017 - 07:24 PM

Thanks for the quick reply.
 
I am using the latest versions of the standalone and resources, yes.

 

Papyrus.0.log


  • 0

#4 Squiggums

Squiggums

    Prisoner

  • Members
  • 7 posts

Posted 11 December 2017 - 08:28 PM

Also, it seems like using the Netimmerse Override option in the MCM fixes the issue with some windows partially, but not fully. And it only seems to work on a new save at that.


  • 0

#5 sheson

sheson

    Dragon Prince

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,691 posts

Posted 12 December 2017 - 06:14 AM

There are no errors in the papyrus log.

 

If something only works on a new save, then this usually means something went wrong when updating an existing save. You can try a clean save routine where old and new esp are the same.

 

The NetImmerse option should only change the brightness of LOD windows. Make a negative test where you turn it off again and check if it consistently changes things back. Repeat to see if it always affects the same objects.

 

Verify that the scripts in ..Data\Scripts\SHESON_DynDOLOD_*.pex are the version from latest Resources archive and none are overwritten. They should all have the same date August 26 (may be off by a day depending on your time zone)

 

Make sure none of the generated files are overwritten by anything (MO overwrite folder can be sneaky sometimes)

 

Please post/upload the ..DynDOLOD\Logs\DynDOLOD_TES5_log.txt from the generation

 

Also post/upload ..skse\plugins\StorageUtilData\DynDOLOD_Tamriel_Objects.json


Edited by sheson, 12 December 2017 - 06:18 AM.

  • 0

#6 Squiggums

Squiggums

    Prisoner

  • Members
  • 7 posts

Posted 12 December 2017 - 11:33 AM

After doing some more testing, it seems like I've narrowed the issue down to script lag from too many mods that stops DynDOLOD from fully initializing on most new saves. I had to create about 3 new saves and got lucky on the third try before it 'fully' initialized, marked by the "DynDOLOD Enabled" box in the MCM being ticked automatically

Unfortunately, on my existing save that I'm about 40 hours in on, that box did not get ticked/DynDOLOD did not properly initialize when I created it and I can't manually tick it either.

 

Is there a console command for the DynDOLOD 'quest' that I can use to force another re-initialization perhaps? Otherwise, I will have to manually disable all of the offending windows, which will take some time but at least they won't appear again in this save. There appear to be no other differences between this save and a 'full' initialization when it works on a new save, aside from the floating windows.

And yes, I incorrectly assumed the Netimmerse Override solved the problem, as it does nothing of note on my existing save.

 

Also there's nothing in my MO overwrite folder that could interfere with DynDOLOD files at least.

 

The scripts in the folder are from the correct dates as well, they aren't old versions or anything.

 

Here is the DynDOLOD_TES5_log.txt: http://puu.sh/yERJ0/a506a9dab4.txt

 

Here is the DynDOLOD_Tamriel_Objects.json too: http://puu.sh/yERBf/586653c0d8.json

 

Thanks.


  • 0

#7 sheson

sheson

    Dragon Prince

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,691 posts

Posted 12 December 2017 - 12:14 PM

You can try to use the MCM toggle in Tamriel worldspace (not in any town). If it is off, go inside a building. Go out, wait a couple seconds, then toggle it on if it isn't already.

 

If that doesn't work, do the clean save routine as already suggest. Disable from menu if active. Go inside. Save, Disable esp, start game and save again, enable esp, load last save, go outside and after it loaded the exterior, wait for it to activate by itself before moving about.

 

If script lag is already bad to begin, try to generate LOD with less dynamic LOD objects. Consider some or all of these suggestions:

use low instead of medium

do not check candles or glow rules

do not check Windows high

lower size of FarGrid

 

BTW ELFX replaces the buildings models with their own new path to windows textures, which is why you won't see the rustic windows textures and DynDOLOD LOD Windows will not match perfectly.

I guess you could either remove the updated architectures models, if you want to have the rustic windows, or just not use rustic windows (run TexGen afterwards so the windows LOD textures are vanilla again, which will match the textures from ELFX better).


Edited by sheson, 12 December 2017 - 12:28 PM.

  • 0

#8 Squiggums

Squiggums

    Prisoner

  • Members
  • 7 posts

Posted 12 December 2017 - 10:30 PM

Success! Well, 99% success. The clean save routine worked fine, I had to wait around for about 10 minutes to finally get the "DynDOLOD initialized" message, and most of the offending double windows were gone!

For some reason though, some still persisted, namely the ones outside Dragonsreach and the Bards College.

Thankfully it was an easy fix to just disable them manually, and I can do the same if I come across any more in the future.

 

And yeah it's a shame that ELFX doesn't play nicely with Rustic Windows, but I don't even care at this point. RW looks great indoors and it'll save me performance outdoors by not loading the higher res window textures now.

 

Thanks so much for all of your help. Maybe put the problem I had, along with its solution, into the DynDOLOD FAQ if it's not there already?


  • 0

#9 sheson

sheson

    Dragon Prince

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,691 posts

Posted 13 December 2017 - 07:07 AM

10 minutes is quite a long time.

 

I'll update the Skyrim: Out of place objects / floating objects / flickering full models with suggestions we found out here


  • 0



Also tagged with one or more of these keywords: bug

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users