Jump to content


Photo

DynDOLOD 2.36 Skyrim SE BETA with dynamic LOD

dyndolod lod skyrim se

  • Please log in to reply
181 replies to this topic

#151 knee_arrow

knee_arrow

    Prisoner

  • Members
  • 8 posts

Posted 12 January 2018 - 01:57 PM

Okay, it worked and the wings are back. But now the mill wings @ Whiterun are gone. All JK´s Whiterun mods were disabled during the generating process.


  • 0

#152 knee_arrow

knee_arrow

    Prisoner

  • Members
  • 8 posts

Posted 12 January 2018 - 02:38 PM

Sorry, I can´t edit my previous post. In my regarding game mesh folder for the farmhouse windmills I have

 

farmhousewindmillfan.nif

farmhousewindmillfan02.nif

smfarmhousewindmillfan.nif

 

Hopefully it helps.


  • 0

#153 sheson

sheson

    Dragon Prince

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,691 posts

Posted 12 January 2018 - 04:35 PM

Okay, it worked and the wings are back. But now the mill wings @ Whiterun are gone. All JK´s Whiterun mods were disabled during the generating process.


Does that happen with a new game?
  • 0

#154 knee_arrow

knee_arrow

    Prisoner

  • Members
  • 8 posts

Posted 12 January 2018 - 05:55 PM

Does that happen with a new game?

Yes, it does. I tried a few combinations now (even SMIM esp files disabled) and everytime some wings are missing. The default "DynDOLOD_SSE_mesh_replace" doesn´t work at all with the wings as far as I can see, your workaround looks promising and works partially. At least it brought the wings in Solitude back, but at Loreius Farm near Whiterun they´re missing. I think the two differing farmhouse mill models need to be defined as well:

 

https://imgur.com/a/zUYAy

 

Sorry, I forgot to mention I use SMIM and hopefully it is not my fault, but I have no idea what else to try.


  • 0

#155 ToastyButtz

ToastyButtz

    Prisoner

  • Members
  • 3 posts

Posted 12 January 2018 - 09:23 PM

I got it to work.

Could you tell me how please? I got the exact same error.


  • 0

#156 ToastyButtz

ToastyButtz

    Prisoner

  • Members
  • 3 posts

Posted 12 January 2018 - 09:38 PM

Hello Sheson, I had the same issue Drexel had. Apparently he was able to fix it but I am posting it here just in case he didn't get my message. Attached is my log after I get the error;

Exception in unit userscript line 299: Error: No model, can not create a dynamic LOD base record for TPOS_JOKE_06 [STAT:124FFB47] in tpos_ultimate_esm.esp

Just like he had. You said something about a missing mesh, is my issue being caused by the same thing you said happened to him?


Whoops forgot to attach it, here ya go. It was too big to upload here so I put it on MEGA;


  • 0

#157 sheson

sheson

    Dragon Prince

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,691 posts

Posted 12 January 2018 - 10:12 PM

Yes, it does. I tried a few combinations now (even SMIM esp files disabled) and everytime some wings are missing. The default "DynDOLOD_SSE_mesh_replace" doesn´t work at all with the wings as far as I can see, your workaround looks promising and works partially. At least it brought the wings in Solitude back, but at Loreius Farm near Whiterun they´re missing. I think the two differing farmhouse mill models need to be defined as well:
 
https://imgur.com/a/zUYAy
 
Sorry, I forgot to mention I use SMIM and hopefully it is not my fault, but I have no idea what else to try.


Remove the first line architecture\farmhouse\farmhousewindmill\farmhousewindmillfan.nif=architecture\farmhouse\farmhousewindmill\smfarmhousewindmillfan.nif from DynDOLOD_SSE_mesh_replace.txt and generate from scratch again. See if that works better for you.

LOD works fine for me with a full SMIM installation and copying DynDOLOD_TES5_mesh_replace.txt. It should also work for you, since you reported you have smfarmhousewindmillfan.nif in that folder, but maybe something happened to that nif in your case.

All 3 files have the size and date for me.

The first replace is not needed anymore (was for SkyMills), only the second for the Solitude Mill.

Edited by sheson, 12 January 2018 - 10:13 PM.

  • 0

#158 ToastyButtz

ToastyButtz

    Prisoner

  • Members
  • 3 posts

Posted 12 January 2018 - 10:30 PM

Update, I disabled all The People of Skyrim ESP/ESM files in Mod Organizer before running DynDOLOD and it went off without a hitch, I also installed the LOD's provided by the author of TPOS. I have no idea if disabling them before running DynDOLOD will make the game look weird though, I hope not. Will update soon.


  • 0

#159 sheson

sheson

    Dragon Prince

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,691 posts

Posted 13 January 2018 - 05:42 AM

Hello Sheson, I had the same issue Drexel had. Apparently he was able to fix it but I am posting it here just in case he didn't get my message. Attached is my log after I get the error;
Exception in unit userscript line 299: Error: No model, can not create a dynamic LOD base record for TPOS_JOKE_06 [STAT:124FFB47] in tpos_ultimate_esm.esp
Just like he had. You said something about a missing mesh, is my issue being caused by the same thing you said happened to him?

Whoops forgot to attach it, here ya go. It was too big to upload here so I put it on MEGA;
https://mega.nz/#!g7...RkbXDJVAfqzEQ_U

This really is a self explanatory error message about a missing model. Just make sure all meshes of tpos are installed properly. The nif is part of the standard tpos installation

You should also check this post for a fix for the Windhelm gate wild edit problem of tpos.
 

Update, I disabled all The People of Skyrim ESP/ESM files in Mod Organizer before running DynDOLOD and it went off without a hitch, I also installed the LOD's provided by the author of TPOS. I have no idea if disabling them before running DynDOLOD will make the game look weird though, I hope not. Will update soon.

No need to disable tpos or to worry about existing LOD as it will be overwritten. Just make sure all assets of the mods you are using are installed properly and completely.


Edited by sheson, 13 January 2018 - 05:44 AM.

  • 0

#160 knee_arrow

knee_arrow

    Prisoner

  • Members
  • 8 posts

Posted 13 January 2018 - 10:56 AM

Testing all the combinations for finding the issue is quite tricky and time consuming. Before the last pass (set on "high" with your workaround filled in the SEE mesh replace ini) I set the two windmill files in the options before starting the generate process @ "original". It´s weird, either I have the SMIM wings on both farmhouse mills and the Solitude wings are missing or I have the ridiculous vanilla wings on one farmhouse model, wings in Solitude and missing wings at Loreius Farm (second farmhouse model). I still need some time for digging...

 

A new game or a save game doesn´t make any difference as far as I can see.

 

Here is my plugin list for getting a picture of my config (ignore the Dyndolod files since they´re installed after the last test)

 

 

Fortunately the generate process is handled well and fast with my rig (i7-6700k), so it lasts apr. 7-10 min to get one output. Hopefully I will find the issue....

 

BTW, why do we have a complete mill model in Solitude and a separate rotor as well?

 

https://imgur.com/a/5BX5x

 

Best regards


  • 0

#161 Drexl

Drexl

    Prisoner

  • Members
  • 8 posts

Posted 13 January 2018 - 12:16 PM

As long as TPOS overwrites everything (even seemingly minor clutter meshes in my case) the LODs generate fine @ToastyButtz.


  • 0

#162 sheson

sheson

    Dragon Prince

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,691 posts

Posted 13 January 2018 - 02:04 PM

Testing all the combinations for finding the issue is quite tricky and time consuming. Before the last pass (set on "high" with your workaround filled in the SEE mesh replace ini) I set the two windmill files in the options before starting the generate process @ "original". It´s weird, either I have the SMIM wings on both farmhouse mills and the Solitude wings are missing or I have the ridiculous vanilla wings on one farmhouse model, wings in Solitude and missing wings at Loreius Farm (second farmhouse model). I still need some time for digging...

 

A new game or a save game doesn´t make any difference as far as I can see.

 

Here is my plugin list for getting a picture of my config (ignore the Dyndolod files since they´re installed after the last test)

 

Fortunately the generate process is handled well and fast with my rig (i7-6700k), so it lasts apr. 7-10 min to get one output. Hopefully I will find the issue....

 

BTW, why do we have a complete mill model in Solitude and a separate rotor as well?

 

https://imgur.com/a/5BX5x

 

Best regards

Is the dynamic LOD even working at all? It seems really weird that you would not have fans on the silos but other dynamic LOD, regardless of the contents of the mesh_replace file.

 

With just dyndolod\lod\architecture\solituderotor.nif=architecture\solitude\swindmillrotor.nif in DynDOLOD_SSE_mesh_replace.txt, the silo fans are done as they are always done without any additional fuss:

 

DynDOLOD uses the nif defined by the base record (000FC611)  Architecture\Farmhouse\FarmhouseWindmill\FarmhouseWindMillFan.nif. It just makes a copy of the base record but uses the same nif.

In this case, it doesn't matter if SMIM is installed or not, as SMIM simply replaces physical nif file with its sail version. Adding or removing SMIM makes no difference. You might have another mod interfering with the fan references or the base record. Just check if a plugin other than DynDOLOD overwrites either.

 

The Solitude fan is different as it is part of the building nif it is attached to. Since we only want LOD for the fan, but not the building, the fans textures are disabled on the base record with a texture replacement.

Then a "hard-coded" single fan base record is created that uses dyndolod\lod\architecture\solituderotor.nif, defined by DynDOLOD_SSE_manual_base_Tamriel.txt

Then a "hard-coded" reference that places this fan onto the Solitude building is added, defined by DynDOLOD_SSE_manual_refr_Tamriel.txt

This is where the mesh_replacement comes into action, it detects if the alternative fan architecture\solitude\swindmillrotor.nif from SMIM is installed and uses it instead of dyndolod\lod\architecture\solituderotor.nif. 

This entire procedure happens if "generate DynDOLOD" is checked and LOD for Tamriel is generated.

 

Disabling the fan in the Solitude building nif and replacing it with a new single nif  file is how SkyMills did it and how compatibility is maintained with SMIM. It was done this way because the building itself has static object LOD and one couldn't just simply make it a Full LOD (neverade) without both full model and object LOD showing at the same time, with texture flicker.

 

So, I wonder if dyanmic LOD works at all, or if any other plugin might be changing the references of the fans or the base record. Maybe something happened to the other DynDOLOD config files I mentioned above.


Edited by sheson, 13 January 2018 - 02:07 PM.

  • 0

#163 13euphryos07

13euphryos07

    Prisoner

  • Members
  • 4 posts

Posted 13 January 2018 - 02:51 PM

Hello everyone,

I have very little experience with DynDOLOD so the following might be stupid, sorry if it is.

 

Running TexGen and DynDOLOD worked without error but DynDOLOD only seems to work partially. I know at least two mods which DynDOLOD did not generate LOD for (Provincial Courier Service and Skyrim Better Roads and Bridges) and there also seem to be a lot of vanilla objects only visible when I get very close. I can see this particularly in the Whiterun area, where objects like fences or stones aren't rendered. Turning DynDOLOD on and off in the MCM menu would make almost no difference. Tree LOD works correctly though. Any idea on how to fix this?

 

Log: https://pastebin.com/5gT9cHJX, https://pastebin.com/5ywf25pG, https://pastebin.com/UvYkEQ53, https://pastebin.com/icR1Hpcq, https://pastebin.com/u4ZdzuJN

 

Best regards


  • 0

#164 sheson

sheson

    Dragon Prince

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,691 posts

Posted 13 January 2018 - 05:17 PM

Hello everyone,

I have very little experience with DynDOLOD so the following might be stupid, sorry if it is.

 

Running TexGen and DynDOLOD worked without error but DynDOLOD only seems to work partially. I know at least two mods which DynDOLOD did not generate LOD for (Provincial Courier Service and Skyrim Better Roads and Bridges) and there also seem to be a lot of vanilla objects only visible when I get very close. I can see this particularly in the Whiterun area, where objects like fences or stones aren't rendered. Turning DynDOLOD on and off in the MCM menu would make almost no difference. Tree LOD works correctly though. Any idea on how to fix this?

 

Log: https://pastebin.com/5gT9cHJX, https://pastebin.com/5ywf25pG, https://pastebin.com/UvYkEQ53, https://pastebin.com/icR1Hpcq, https://pastebin.com/u4ZdzuJN

 

Best regards

See the last few message at the end of the log that say

 

Gave up waiting for C:\SteamLibrary\steamapps\common\Skyrim Special Edition\DynDOLOD\Logs\LODGen_SSE_Tamriel_log.txt to become available.

 

This is rather odd, as it didn't even seem to waited at all (should be at least some minutes). That indicates there was a problem with the spawned LODGen64.exe that generates the static object LOD.

 

Check the LODGen logs like ..DynDOLOD\Logs\LODGen_SSE_Tamriel_log.txt for clues. They should end with 

Log ended at xx:xx:xx
Code: 0

 

 

Unrelated, you should probably clean the UDRs from EconomyOverhaulandSpeechcraftImprovements.esp


Edited by sheson, 13 January 2018 - 05:18 PM.

  • 0

#165 knee_arrow

knee_arrow

    Prisoner

  • Members
  • 8 posts

Posted 13 January 2018 - 06:20 PM

Hi there,

 

now I was able to solve the issue with the missing mill wings and all of them (the SMIMy ones) are there, at least @ Solitude and different farms. The animations worked all along if they were there. When I generated the working package I unfortunately missed to note what I´ve done in particular. Sorry, my fault. I tried to reproduce it and made a second package, but it doesn´t work and the same issues appear. At least I can give you the screens of the second run and which adjustments I´ve made before generating the second Dyndolod.

 

https://imgur.com/a/WEomG

 

Oddly this run doesn´t work properly, but basically I choose the "high" setting and changed the options for the three wing models on the right side (something with the full model (original?) in use and without fade). Sorry, but I tested a lot (or better: a lod) today and one run at high settings costs apr. 30 min with my rig (medium only 10). I also realized it is quite important to start a new game (best with "LAL") or Dyndolod won´t be triggered correctly and the activation option in MCM stays grey, even outdoors. SSE engine is still kind of picky, regarding scripts even more than Oldrim...at least it seems to be.

 

Some other stuff I´ve noticed:

 

  • the small manual for updating Dyndolod in MCM is not completely readable.
  • I don´t know if "Dawnstar Overhaul" will be supported, but a part of the wall doesn´t have any lod (the little shelter on the wall is hovering until getting closer) :  https://imgur.com/a/Tq3TL

Anyways, it´s a great tool you´ve given to the community and the landscape looks pretty amazing now. Thank you very much :)

 

 


  • 0



Also tagged with one or more of these keywords: dyndolod, lod, skyrim se

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users