Jump to content


Photo

Ultra trees, uses full mesh instead of passthrough


  • Please log in to reply
9 replies to this topic

#1 CyanBC

CyanBC

    Prisoner

  • Members
  • 4 posts

Posted 14 February 2018 - 01:22 AM

Mod Organizer2, DynDOLOD 2.36

When I make my Ultra 3D Tree lods using the hybrid trees supplied either by EVT (oldrim) or DynDOLOD Resources (SSE) the TreeTundraDiftWoodTree01 does not use its hybrid mesh. A subset of my log is included below:

 

 TreeReachTree01Winterhold [TREE:00109716] meshes\landscape\trees\reachtree01.nif
            Billboard not found <textures\terrain\lodgen\skyrim.esm\treereachtree01winterhold_00109716.dds>, 3D LOD found
            LOD4: meshes\dyndolod\lod\trees\reachtree01_0b3d571cpassthru_lod.nif
          TreeReachTree02 [TREE:000B8A74] meshes\landscape\trees\reachtree02.nif
            Billboard found, 3D LOD found
            LOD4: meshes\dyndolod\lod\trees\reachtree02_cf8edf7bpassthru_lod.nif
            LOD8: textures\terrain\lodgen\skyrim.esm\reachtree02_000b8a74.dds
            LOD16: textures\terrain\lodgen\skyrim.esm\reachtree02_000b8a74.dds
          TreeReachTreeStump01 [TREE:000B8A75] meshes\landscape\trees\reachtreestump01.nif
            Billboard not found <textures\terrain\lodgen\skyrim.esm\treereachtreestump01_000b8a75.dds>, replaced tree, 3D LOD not found <reachtreestump01_706c8179> fallback Full Model
          TreeTundraDriftWoodTree01 [TREE:000B8F53] meshes\landscape\trees\tundradriftwood01.nif
            Billboard found, replaced tree, 3D LOD found
            LOD4: meshes\landscape\trees\tundradriftwood01.nif
            LOD8: textures\terrain\lodgen\skyrim.esm\tundradriftwood01_000b8f53.dds
            LOD16: textures\terrain\lodgen\skyrim.esm\tundradriftwood01_000b8f53.dds

We can see that other trees find their appropriate passthrough lods:

LOD4: meshes\dyndolod\lod\trees\reachtree01_0b3d571cpassthru_lod.nif

 

but the LOD for TreeTundraDriftWoodTree01, claims 3D LOD found, but uses :

LOD4: meshes\landscape\trees\tundradriftwood01.nif

to generate the actual LOD. ignoring the passthrough. It doens't even seem to be looking for a passthrough file, though there is one present.

 

I'm not sure if there is some way to force or set finding an appropriate passthrough_lod or another solution,

any advice or insight is appreciated.

 

This is the only tree (with a passthrough) that does this.

 

Cheers


Edited by CyanBC, 14 February 2018 - 01:25 AM.

  • 0

#2 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,202 posts

Posted 14 February 2018 - 08:44 AM

Is that meshes\landscape\trees\tundradriftwood01.nif from the clutter option of EVT?

Is the tundradriftwood01_557B4799passthru_lod.nif from EVT billoard Generator installed in the load order?

 

What happens when you set TreeFullFallBack=0?


Edited by sheson, 14 February 2018 - 08:45 AM.

  • 0

#3 CyanBC

CyanBC

    Prisoner

  • Members
  • 4 posts

Posted 14 February 2018 - 09:58 AM

It is both the tundradriftwood01.nif clutter from EVT and (with EVT disabled) DynDOLOD resources. I put all possible passthru_lod combinations in the folder for CRC matching. As we see though it does not seem to look for the appropriate passthru_lod at any rate.

 

I re-ran DynDOLOD again to shift my EVT trees from LARGE or default size. This time I set up a tundradriftwood custom entry in the main window lower than the default preset. I set this to

LOD4 =Static LOD8

LOD8 =Billboard

LOD16=Billboard

VWD=Y

NearLOD

Unchanged

This time it worked.

 

I re-ran the process again (since I thought putting my own entry in is what made the difference), as this:

LOD4 =Static LOD4

LOD8 =Billboard

LOD16=Billboard

VWD=Y

NearLOD

Unchanged

 

It did not work.

 

I checked to see if any worldspace was using the proper passthru_lod on the one that failed:

          [00:00:00.191]    
[00:00:00.209]    Doing LOD for Tamriel added by Skyrim.esm
[00:00:00.229]      Options 00000001011111001000000000
[00:00:00.452]      Dimensions -57, 62, -43, 51
[00:00:00.049]    [DynDOLOD.esm] Adding master "Skyrim.esm"
[00:00:00.086]    [DynDOLOD.esp] Adding master "Skyrim.esm"
[00:00:00.086]    [DynDOLOD.esp] Adding master "DynDOLOD.esm"
[00:00:00.499]    Loading D:\MOD Storage\SkyrimSpecialEditionMOD\SSERunningMOD\DynDOLOD\Edit Scripts\DynDOLOD\DynDOLOD_SSE.ini
[00:00:00.529]    Found D:\MOD Storage\SkyrimSpecialEditionMOD\SSERunningMOD\DynDOLOD\Edit Scripts\DynDOLOD\DynDOLOD_SSE_childworldlod_Tamriel.txt
[00:00:00.585]    Loaded 83 references to ignore in child worlds
[00:00:00.617]    New bunch of numbers: 2N6O7S8E8H1S6O4T47T6I2M3B1U3S8 in DynDOLOD.esp
[00:00:00.646]    New bunch of numbers: 2N6O7S8E8H1S6O4T47T6I2M3B1U3S8 in DynDOLOD.esm
[00:00:00.678]    Reading DynDOLOD.esm with 12 records for Tamriel
[00:00:00.696]    Reading DynDOLOD.esp with 1 records for Tamriel
 
TreeTundraDriftWoodTree01 [TREE:000B8F53] meshes\landscape\trees\tundradriftwood01.nif
            Billboard found, replaced tree, 3D LOD found
            LOD4: meshes\dyndolod\lod\trees\tundradriftwood01passthru_lod.nif
            LOD8: textures\terrain\lodgen\skyrim.esm\tundradriftwood01_000b8f53.dds
            LOD16: textures\terrain\lodgen\skyrim.esm\tundradriftwood01_000b8f53.dds
 

 

One of them is, I think only the larger LOD levels are checking for the passthru for this particular entry, at a guess. Which is why setting the LOD4=Static LOD8 seemed to actually use the hybrid model at LOD4.

 

So I ran it again, this time using Large trees from EVT. Setting tundradriftwood LOD4=Static LOD8 worked again.

 

I confirm which model was used by opening a Tamriel object in nifskope:

DynDOLOD_Output\meshes\terrain\Tamriel\Objects\Tamriel.4.0.-4.nif

Which has several of these trees.


  • 0

#4 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,202 posts

Posted 14 February 2018 - 04:58 PM

It is both the tundradriftwood01.nif clutter from EVT and (with EVT disabled) DynDOLOD resources.


You can only have one full model at a time. So what do you mean with "It is both"?
Since the log says "replaced tree" it can not be the vanilla tree. DynDOLOD Resources only has 3D tree LOD model for vanilla trees.
 

I put all possible passthru_lod combinations in the folder for CRC matching. As we see though it does not seem to look for the appropriate passthru_lod at any rate.


Each full model tree can have only one CRC32 matching LOD tree. I have no idea how manage to produce the log lines and I can not replicate what ever it is you doing.
The folder where LOD models are, usually does not matter. All meshes folders are scanned in a specific order.
Do you have a meshes\dyndolod\lod\trees\tundradriftwood01passthru_lod.nif from any other mods?

Instead of making things more complex by adding countless random files, make things more simple:
There is only one tundradriftwood01.nif in Enhanced Vanilla Trees-76086-1-6-9.7z for Skyrim. Make sure that one is the one in the load order for meshes\landscape\trees\tundradriftwood01.nif
There are two identical tundradriftwood01_557B4799passthru_lod.nif in BillBoards Generator for Enhanced Vanilla Trees-76086-1-3-9BG.7z for Skyim. Make sure this one exists in the load order.

Then there should be no problem that it is found, works for me here no problem.
 

I re-ran DynDOLOD again to shift my EVT trees from LARGE or default size.


Usinf large/default install options no difference, as there is only one version of tundradriftwood01.nif in EVT that only gets installed when using the clutter option.
 

This time I set up a tundradriftwood custom entry in the main window lower than the default preset.


What is the "default preset". You mean the second to last mesh rule for "tree"?
 

I set this to
LOD4 =Static LOD8
LOD8 =Billboard
LOD16=Billboard
VWD=Y
NearLOD
Unchanged
This time it worked.


What does "it worked" mean? Dod the log show it uses tundradriftwood01_557B4799passthru_lod.nif?
Static LOD8 usually means it looking to use LOD nifs ending with *_lod_1.nif. It will automatically fall back to use *_lod.nif (or *_0_lod.nif) in case a *_lod_1.nif is not found.
 

I re-ran the process again (since I thought putting my own entry in is what made the difference), as this:
LOD4 =Static LOD4
LOD8 =Billboard
LOD16=Billboard
VWD=Y
NearLOD
Unchanged
 
It did not work.


What does "It did not work" mean? Did the log show it did not use tundradriftwood01_557B4799passthru_lod.nif but something else again?
 

I checked to see if any worldspace was using the proper passthru_lod on the one that failed:


The LOD model assignment happens before any worldspaces are scanned and is independent of the selected worldspaces.


The problem might be because there are files with the same filename in different folders. It is not how Bethesda keeps their file and folder structure - each file has a unique name - but it happens with mods.

You could check ..DynDOLOD\Edit Scripts\DynDOLOD\cache\DynDOLOD_SSE_staticlodfiles.txt for the LOD level assignments:

For the EVT tree it should look like this
tundradriftwood01_557b4799passthru=meshes\dyndolod\lod\trees\tundradriftwood01_557b4799passthru_lod.nif;meshes\dyndolod\lod\trees\tundradriftwood01_557b4799passthru_lod.nif;meshes\dyndolod\lod\trees\tundradriftwood01_557b4799passthru_lod.nif
If the tree is the vanilla full model it looks like this
tundradriftwood01passthru=meshes\dyndolod\lod\trees\tundradriftwood01passthru_lod.nif;meshes\dyndolod\lod\trees\tundradriftwood01passthru_lod.nif;meshes\dyndolod\lod\trees\tundradriftwood01passthru_lod.nif
I wonder if you have more lines for tundradriftwood01* or what they look like when it "does not work" in order to replicate the problem.

Edited by sheson, 14 February 2018 - 04:59 PM.

  • 1

#5 SparrowPrince

SparrowPrince

    High King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,210 posts

Posted 15 February 2018 - 03:55 AM

I just want to say while I am here sheson that it's fantastic all the support you offer for your mod. I notice it every time I am around and you are super patient and helpful. Just wanted to finally say that as I am sure it can feel unforgiving and thankless sometimes.


  • 2

#6 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,202 posts

Posted 15 February 2018 - 07:50 AM

Thanks, you are welcome.


  • 0

#7 CyanBC

CyanBC

    Prisoner

  • Members
  • 4 posts

Posted 15 February 2018 - 10:39 PM

Hello Sheson,

 

To clarify, I love what you've made with DynDOLOD, my issue is this particular (crappy) tree taking up more resources that it was worth. I'll try to respond as thoroughly as I can, I don't have much testing time what with a new baby and all.

You obviously know more about this than anyone, so I apologize if I can't be more clear.

 

Also I've solved the problem to my satisfaction, setting Static LOD8 for this tree effectively dealt with the issue. I'm not sure though, if there might be a bug somewhere, that might help others if squashed.

 

 

You can only have one full model at a time. So what do you mean with "It is both"?
Since the log says "replaced tree" it can not be the vanilla tree. DynDOLOD Resources only has 3D tree LOD model for vanilla trees.

-I believe that EVT and SMIM come with full models of this tree, while EVT and DynDOLOD Resources come with the hybrid models. When I say both, I mean that I have run trees through EVT SSE, EVT Oldrim, SMIM+DynDOLOD Resources. all separately with the same result. I think I ticked "replace tree" to see if I could get DynDOLOD to look for (or tell me that it's looking for) the hybrid model. In either case, I tried it with both replaced, and unchanged.

 

 

Each full model tree can have only one CRC32 matching LOD tree. I have no idea how manage to produce the log lines and I can not replicate what ever it is you doing.
The folder where LOD models are, usually does not matter. All meshes folders are scanned in a specific order.
Do you have a meshes\dyndolod\lod\trees\tundradriftwood01passthru_lod.nif from any other mods?

Instead of making things more complex by adding countless random files, make things more simple:
There is only one tundradriftwood01.nif in Enhanced Vanilla Trees-76086-1-6-9.7z for Skyrim. Make sure that one is the one in the load order for meshes\landscape\trees\tundradriftwood01.nif
There are two identical tundradriftwood01_557B4799passthru_lod.nif in BillBoards Generator for Enhanced Vanilla Trees-76086-1-3-9BG.7z for Skyim. Make sure this one exists in the load order.

 

-I don't remember where all the versions of this tree came from, but I have about 4 identical hybrid trees of this with different names. The issue for me is that at Static LOD4 this (and only this) tree does not seem to look for the hybrid model at all. Or it does but it decides that the full model is the hybrid model. I only run EVT, or Vanilla+SMIM+Dyndolod Resources.

 

 

Usinf large/default install options no difference, as there is only one version of tundradriftwood01.nif in EVT that only gets installed when using the clutter option.

-I sort of mean this as to say "I have tried this many times", I'm not sure what all the differences would be, but I've tried many variations on those differences if they actually exist.

 

 

What is the "default preset". You mean the second to last mesh rule for "tree"?

-When I was first doing this the naive - easy - way I noticed this tree always used a full model. In my versions for DynDOLOD SSE, If I clicked "Load Preset" and chose the one called "Default", it added in the tundradriftwood entry to the main list. I worked off of that, and my limited knowledge.

 

What does "it worked" mean? Did the log show it uses tundradriftwood01_557B4799passthru_lod.nif?
Static LOD8 usually means it looking to use LOD nifs ending with *_lod_1.nif. It will automatically fall back to use *_lod.nif (or *_0_lod.nif) in case a *_lod_1.nif is not found.

-When I use Static LOD8 where Static LOD4 should go, It looks for (and finds) tundradriftwood01passthru_lod.nif, no CRC number attached as per my log. I don't think I have any lods that have "*_lod_1.nif".

 

 

What does "It did not work" mean? Did the log show it did not use tundradriftwood01_557B4799passthru_lod.nif but something else again?

- The log shows that "3D Lod found" but points it to "tundradriftwood01.nif" as the 3D LOD, the full model, instead of passthru (when set to Static LOD4, in LOD4 settings)

 

 

You could check ..DynDOLOD\Edit Scripts\DynDOLOD\cache\DynDOLOD_SSE_staticlodfiles.txt for the LOD level assignments

-I'll need to check this. Again limited time, baby, no sleep, dying.

 

Thank you again for this magnificent tool.


  • 0

#8 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,202 posts

Posted 16 February 2018 - 05:20 AM

Thanks for the detailed answer. I am trying to replicate the issue so I can find out what is happening and fix the bug if there is one.
 
It would be helpful if you could upload/post ..DynDOLOD\Edit Scripts\DynDOLOD\cache\DynDOLOD_SSE_staticlodfiles.txt, then I can check that last detail myself.

Enjoy the game and the baby.
  • 0

#9 CyanBC

CyanBC

    Prisoner

  • Members
  • 4 posts

Posted 16 February 2018 - 09:38 AM

Okay Checking the log when it works:

 

tundradriftwood01passthru=meshes\dyndolod\lod\trees\tundradriftwood01passthru_lod.nif;meshes\dyndolod\lod\trees\tundradriftwood01passthru_lod.nif;meshes\dyndolod\lod\trees\tundradriftwood01passthru_lod.nif
 

tundradriftwood01_557b4799passthru=meshes\dyndolod\lod\trees\tundradriftwood01_557b4799passthru_lod.nif;meshes\dyndolod\lod\trees\tundradriftwood01_557b4799passthru_lod.nif;meshes\dyndolod\lod\trees\tundradriftwood01_557b4799passthru_lod.nif

When it doesn't:

 

tundradriftwood01passthru=meshes\dyndolod\lod\trees\tundradriftwood01passthru_lod.nif;meshes\dyndolod\lod\trees\tundradriftwood01passthru_lod.nif;meshes\dyndolod\lod\trees\tundradriftwood01passthru_lod.nif

 

tundradriftwood01_557b4799passthru=meshes\dyndolod\lod\trees\tundradriftwood01_557b4799passthru_lod.nif;meshes\dyndolod\lod\trees\tundradriftwood01_557b4799passthru_lod.nif;meshes\dyndolod\lod\trees\tundradriftwood01_557b4799passthru_lod.nif

From the log, of the model I built just now to test Static LOD4 again (associated with the "when it doesn't" just above:

 

TreeTundraDriftWoodTree01 [TREE:000B8F53] meshes\landscape\trees\tundradriftwood01.nif
            Billboard found, replaced tree, 3D LOD found
            LOD4: meshes\landscape\trees\tundradriftwood01.nif
            LOD8: textures\terrain\lodgen\skyrim.esm\tundradriftwood01_000b8f53.dds
            LOD16: textures\terrain\lodgen\skyrim.esm\tundradriftwood01_000b8f53.dds
 

 

Now that wasn't helpful. I can visually confirm (nifskope) that the second run did not use the passthru for Tamriel at LOD4. Proof file is the .nif attached.

 

I reiterate that these are with the exact same settings, mods, textures, load list being the same. In this case with EVT (oldrim), but my other tests without it had the same outcomes.

 

Settings for this tree (in order):

Not working:

tundradriftwood - StaticLOD4 - Billboard - Billboard - Yes - Near LOD - Unchanged

working:

tundradriftwood - StaticLOD8 - Billboard - Billboard - Yes - Near LOD - Unchanged

 

Here is a link (I don't see a place to put attachments here) to a .7z file with failure and success logs (.txt (4), .nif (2)) as well as the mesh generated by DynDOLOD

https://expirebox.co...16f61b6e65.html


  • 0

#10 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,202 posts

Posted 16 February 2018 - 12:38 PM

Thanks, I will see if I can find out anything.
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users