Jump to content


Photo

Skyrim (32-bit) and Creation Kit Script Saving


  • Please log in to reply
2 replies to this topic

#1 Haravikk

Haravikk

    Prisoner

  • Members
  • 2 posts

Posted 07 July 2018 - 03:18 PM

I updated to Mod Organizer 2 after discovering that Mod Organizer 1 is no longer connecting to Nexus Mods for me. For the most part everything works just fine, except that I'm having a problem with Creation Kit.

 

 

The problem I'm experiencing is essentially that I can save one, and only one*, script per session, after which I will start getting the following error:

 

Unable to create or write temporary file for compilation

 

The source file saves back to my mod folder just fine, but at this point I now can't compile any more scripts until I close down Creation Kit, reopen it, and reload my mod. As you can probably imagine this isn't ideal, as what used to be five minutes of light editing is now going to be approximately 63 million years worth of waiting for CK to reopen and reload.

 

Anyone have any ideas what might be happening here? I used to use a version of PapyrusCompiler.exe edited to run only in 32-bit mode (which used to be the only way to run it with MO1), but I've tried both that version, and an unedited copy, both are affected.

 

Any alternatives or workarounds I could use? I don't really want to use MO1 just for Creation Kit as I just know I'm going to end up out of sync between the two really quickly.

 

 

*Okay, while writing this I managed to save a compile a massive two scripts in a single session, but usually it's one and only one as I stated.


  • 0

#2 Greg

Greg

    Dragonborn

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1,740 posts

Posted 07 July 2018 - 08:39 PM

You might pop over to the Mod Organizer discord channel to see if this is a known issue that needs to be logged and fixed. I assume you are using Mod Organizer 2.1.3 on Nexus. You might also try Mod Organizer 2.1.4 Dev Build 5 that fixes a UVFS issue with paths starting with \, but I don't think this applies to the Papyrus compiler. The 2.1.4 dev builds mostly fix issues related to downloads and the latest version of LOOT.



#3 Haravikk

Haravikk

    Prisoner

  • Members
  • 2 posts

Posted 09 July 2018 - 05:38 AM

Thanks for the reply!

 

Unfortunately the 2.1.4 dev build doesn't seem to fix this, so I've left a bug report on the Github issue tracker here, if anyone's interested.

 

I just wanted to update the topic in case anyone else encounters this, as I've also found a workaround until the issue is fixed. You can prevent this issue by editing the Creation Kit entry in the executables list to have it save its files into the mod folder you're working within. Best way to manage this is to create a new profile for each mod you might be working on, editing the CK executable for each one to point to the correct folder.

 

I really should have been using profiles this way the entire time; since each profile only has enabled the bare minimum required for editing/testing a single mod, it greatly reduces what CK tries to load. I never believed the CK was capable of opening in less than five minutes, now it's a matter of seconds!

 

So in that way the bug has been a major benefit.


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users