Jump to content


Photo

STEP installed, works great, but I'd liike DoF and UltraWide support


  • Please log in to reply
15 replies to this topic

#1 GlassWizzard

GlassWizzard

    Citizen

  • Members
  • Pip
  • 95 posts

Posted 15 July 2018 - 11:57 AM

Hi, everything installed and works fine. But there are two things I'd really like to add.

 

What would be the best way to add DoF?

 

Also, SkyUi doesn't seem to like ultrawide resolutions, so I'm playing in 16:9 until I know how to fix it.

 

Thanks

 

Edit: I notice that DoF is actually enabled in BethINI, I guess it's not working. Also, when starting the game I get red text from the ENB saying that since the speed patch is on graphics enhancements are not enabled, I don't know if that's normal or not.

 

Edit 2: BethINI doesn't seem to be able to change the settings of the game :/


Edited by GlassWizzard, 15 July 2018 - 12:12 PM.

  • 0

#2 GlassWizzard

GlassWizzard

    Citizen

  • Members
  • Pip
  • 95 posts

Posted 15 July 2018 - 12:21 PM

I fixed bethINI, so don't worry about that.

 

"PATCH SPEEDHACK ENBoost turned on in enblocal.ini, graphic modification disabled" is the exact wording of the red text, I am assuming that's normal but I just want to make sure.


  • 0

#3 Greg

Greg

    Dragonborn

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1,824 posts

Posted 15 July 2018 - 04:08 PM

The red text is normal so don't worry about it.



#4 GlassWizzard

GlassWizzard

    Citizen

  • Members
  • Pip
  • 95 posts

Posted 16 July 2018 - 04:06 AM

Any idea why DoF doesn't work? It is enabled in Skyrimprefs.ini (bDoDepthOfField=1), also AA is set to 4 (iMultiSample=4), but I see none in game.

 

I have used nvidia inspector to make the changes the step guide mentioned.

 

Edit: I installed DynaVision and that gave me DoF, but I'm still lacking AA, shame there isn't an AA mod :/


Edited by GlassWizzard, 16 July 2018 - 04:18 AM.

  • 0

#5 Tobi

Tobi

    Necromancer

  • Members
  • PipPip
  • 114 posts

Posted 16 July 2018 - 01:32 PM

There shouldn't need to be an AA mod, it's an in game setting. Can you post screenshots?


  • 0

#6 Greg

Greg

    Dragonborn

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1,824 posts

Posted 16 July 2018 - 05:59 PM

Are you editing the SkyrimPrefs.ini used by the game? If you're using Mod Organizer, click the INI Editor button at the top and it'll open Skyrim.ini and SkyrimPrefs.ini that you should be editing. I don't know about nvidia, but on AMD cards antialiasing should be set to application controlled. I assume the same is true for nvidia as well.

 

[Display]
iMultiSample=4


#7 GlassWizzard

GlassWizzard

    Citizen

  • Members
  • Pip
  • 95 posts

Posted 17 July 2018 - 02:30 AM

Yes, I'm using MO to edit the ini, I also use BethINI, it says AA is enabled, inside the ini file the appropriate setting is enabled, the game is simply ignoring it, I'll post a screenshot soon.

 

 

There shouldn't need to be an AA mod, it's an in game setting. Can you post screenshots?

DoF is also an ingame setting but the game ignores it, I had to use DynaVision to get Dof.

 

OH and I seem to get a lot of poltergeist activity, objects moving and falling, any idea what causes that?


Edited by GlassWizzard, 17 July 2018 - 02:43 AM.

  • 0

#8 GlassWizzard

GlassWizzard

    Citizen

  • Members
  • Pip
  • 95 posts

Posted 17 July 2018 - 03:11 AM

https://images2.imgb.../xgAlfLDS_o.png


Edited by GlassWizzard, 17 July 2018 - 03:12 AM.

  • 0

#9 Greg

Greg

    Dragonborn

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1,824 posts

Posted 17 July 2018 - 07:08 AM

Physics in Skyrim is tied directly to the refresh rate of the display so you should enable vertical sync if you have a 60Hz display or lock it to 60 FPS in enblocal.ini or the video driver.



#10 GlassWizzard

GlassWizzard

    Citizen

  • Members
  • Pip
  • 95 posts

Posted 17 July 2018 - 10:13 AM

Damn, then it's another case of skyrim not caring what's in the ini file, because vsync is enabled, but my fps does go above 60, over 100 usually.


  • 0

#11 GlassWizzard

GlassWizzard

    Citizen

  • Members
  • Pip
  • 95 posts

Posted 17 July 2018 - 12:32 PM

Damn, then it's another case of skyrim not caring what's in the ini file, because vsync is enabled, but my fps does go above 60, over 100 usually.

Just to add, I have also enabled Vsync in nvidia inspector so I have no idea whats happening.

 

EDIT: I've discovered the problem, something has gone very wrong with my ini files, several copies of the whole file are contained in each one. I need to clear them and start again.

 

Here is how I think I'm supposed to do that, first delete them (from My Documents/My Games/Skyrim), then run the launcher and launch the game once. Then run bethINI and follow the instructions in the guide. Im gonna do that now.


Edited by GlassWizzard, 17 July 2018 - 12:43 PM.

  • 0

#12 GlassWizzard

GlassWizzard

    Citizen

  • Members
  • Pip
  • 95 posts

Posted 17 July 2018 - 01:02 PM

Guys could someone point me to a guide detailing how to modify the ini files manually please? This BethINI program is Satan himself, it keeps slapping everything on the end of the file, not replacing what is already there and messing up the files. No wonder the settings are never applies since I assume the game is loading the first ones it finds, which never change.

 

I have attached the files in case anyone wants to have a look.

 

Edit: Found the guide here, this is the right thing follow yes?

Attached Files


Edited by GlassWizzard, 17 July 2018 - 01:03 PM.

  • 0

#13 GlassWizzard

GlassWizzard

    Citizen

  • Members
  • Pip
  • 95 posts

Posted 17 July 2018 - 02:54 PM

I followed the INI guide, and even with proper INI files, Skyrim just doesn't care that I have Vsync enabled in there, even in nVidia Inspector.

 

I'm at a loss.


  • 0

#14 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,511 posts

Posted 17 July 2018 - 04:50 PM

The INIs, when using MO, are profile specific...meaning changing them in the default location you listed isn't going to work. You need to change the INIs within the profile you're using. This is most likely your problem for all your INI issues.

BethINI works fine when used correctly. Ensure BethINI is pointed to the correct paths on the system tab for the game/profile you're using it for.

There is a mod for ultra wide/multi-monitor support. You'll have to search for it on Nexus.

If you can't get AA that you like, you might try SMAA. ENBSeries also has its own AA within the enblocal.ini file.

#15 GlassWizzard

GlassWizzard

    Citizen

  • Members
  • Pip
  • 95 posts

Posted 18 July 2018 - 02:59 AM

I have been changing the INI's inside MO, and BethINI was pointed to the correct files.

 

I didn't delete the INI's from the My Documents folder and replace them like I said I would do. I realized I had backed up the default INI's in MO, in the default profile, so I just copied the content across to the other profile, then followed the INI guide to amend/change the appropriate settings.

 

I have forced frame limiting in nvidia inspector and it works. its not perfect because I still get screen tearing but if it stops the poltergeists then it's ok.

 

Thanks for the help guys.


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users