Jump to content


Photo

Forum Performance Issues


  • Please log in to reply
101 replies to this topic

#31 blacksol

blacksol

    Guard

  • Members
  • PipPip
  • 130 posts

Posted 29 March 2012 - 04:46 AM

Ok worked out that it is F12 to debug and on Script tab after debugging (may not be complete debug) it found these 2 errors. I tried pasting in all the script code but it crashed IE as over 6000 lines.

Couldn't copy text so am pasting in link to images of errors and lines and surrounding lines

http://img207.images...1/capturepx.png
http://img192.images.../7296/1822o.png
http://img824.images...24/428/5574.png
  • 0

#32 stoppingby4now

stoppingby4now

    Sleepy

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,281 posts

Posted 29 March 2012 - 07:08 AM

Ok worked out that it is F12 to debug and on Script tab after debugging (may not be complete debug) it found these 2 errors. I tried pasting in all the script code but it crashed IE as over 6000 lines.

Couldn't copy text so am pasting in link to images of errors and lines and surrounding lines

http://img207.images...1/capturepx.png
http://img192.images.../7296/1822o.png
http://img824.images...24/428/5574.png



I "think" I found what is causing the problem and made a change, but it's only speculation. I wish I had a machine with IE8 to test it in.

#33 blacksol

blacksol

    Guard

  • Members
  • PipPip
  • 130 posts

Posted 29 March 2012 - 09:52 PM

still getting same errors, although the debugger is playing up atm
  • 0

#34 stoppingby4now

stoppingby4now

    Sleepy

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,281 posts

Posted 29 March 2012 - 11:09 PM

From what I can tell, IE8 is throwing a fit due to some cookie code that was added using jQuery, which conflicts with the prototype library (though it's loaded after and takes precedence). I've added a noConflict statement which should make this work in IE8. One thing you can check to see if this is directly the case, is go to a post and click on the "MULTI" button. It should change color to indicate that you have selected it. If it doesn't, it is the cookie code that it is having a problem with. If it does hilight, then go to the bottom and look at the Quick Reply box. It should have a red footer with a messaging stating that you have multiple quotes available, or you can deselect them. If all of the above work, you can safely ignore the error messages that popup. When you get the error message, there should be a checkbox to allow you to ignore the message from now on, unless your work place disables it. Ignoring the message if the above are true should cause no loss in functionality, but just get rid of an annoying message. If that isn't an option, I'm going to have to find some way of being able to run IE8 to more effectively come up with a workaround/fix, as at this point it is a case of IE8 throwing unwarranted tantrums. If the the multi-quoting doesn't work and you are still getting the messages, I'm going to have to see about somehow getting a working IE8 that I can use in a VM or otherwise so I can better debug this.

#35 stoppingby4now

stoppingby4now

    Sleepy

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,281 posts

Posted 30 March 2012 - 05:57 AM

Didn't even realize it, but turns out IE9 allows you to choose the browser mode in the debugger. So I'm seeing the errors that you are getting now, and it appears to be tied to the WYSIWYG editor. When I test without that installed, I don't get any errors. It could take a long time to get that sorted and prevent the errors in the first place, but I have been able to use the editor still in IE8 mode. If you have the option to check a checkbox titled "Do not show this message again", go ahead and check that and you should be ok. I also received the error irregardless of forum theme.

#36 Bealdwine

Bealdwine

    Elder STEPsman

  • Site Founders
  • PipPipPipPipPipPip
  • 364 posts

Posted 30 March 2012 - 09:28 AM

Just a note on the WYSIWYG editor - in IE9 I can use it perfectly well but when I preview post my [return/new line]s are missing (and it has switched back to the old editor). If I then use the old editor to reinsert the [return/new line]s they show correctly in preview and when posted. Not really an issue for me but thought you might want to know. Using the STEP Blue theme if that matters.
  • 0

#37 stoppingby4now

stoppingby4now

    Sleepy

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,281 posts

Posted 30 March 2012 - 09:45 AM

Just a note on the WYSIWYG editor - in IE9 I can use it perfectly well but when I preview post my [return/new line]s are missing (and it has switched back to the old editor). If I then use the old editor to reinsert the [return/new line]s they show correctly in preview and when posted. Not really an issue for me but thought you might want to know.
Using the STEP Blue theme if that matters.

That happens to me in Firefox as well. I don't think it's hooking the preview page correctly, or at all, but will take a look.

#38 blacksol

blacksol

    Guard

  • Members
  • PipPip
  • 130 posts

Posted 01 April 2012 - 11:34 PM

yes multi button works and text appears under quick reply box, although it is light blue on a light grey background so cant catually read it unless I highlight it. No checkbox to ignore error message. Guess I'll just sart using firefox at work (have it installed but dont use it as most of our work applications dont work properly in firefox).
  • 0

#39 z929669

z929669

    Ixian Inventor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,245 posts

Posted 01 April 2012 - 11:43 PM

@work I use both Chrome and IE. Former for personal, latter for work-related stuff. Love Chrome because of Chrome sync feature (saweet!)

#40 stoppingby4now

stoppingby4now

    Sleepy

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,281 posts

Posted 01 April 2012 - 11:59 PM

If you have an option to use another browser, that should help. Until we can figure out an upgrade path for the current WYSIWYG editor, getting rid of those errors for IE8 will be tough.

#41 MontyMM

MontyMM

    High King

  • Site Founders
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,144 posts

Posted 14 April 2012 - 04:05 PM

Earlier on today, when I visited here, I got a message telling me that the server was overloaded and I should try again later. Probably just a glitch, you're not getting that sort of traffic are you?
  • 0

#42 z929669

z929669

    Ixian Inventor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,245 posts

Posted 14 April 2012 - 04:21 PM

No, that was a fluke. Not sure what happended, but let us know if it happens again. :unsure:

#43 frihyland

frihyland

    Dwemer Lord

  • Site Founders
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,087 posts

Posted 16 April 2012 - 10:21 PM

Haven't had any issues with new posts remaining flagged as new (after being read) for many days now. So one more issue put to rest.
  • 0

#44 blacksol

blacksol

    Guard

  • Members
  • PipPip
  • 130 posts

Posted 16 April 2012 - 11:05 PM

Until today the forums on the main page were showing as having new content when they didnt. This generally corrected itself later, eg say 30 minutes. This was still happening yesterday but works fine today.
  • 0

#45 z929669

z929669

    Ixian Inventor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,245 posts

Posted 16 April 2012 - 11:51 PM

I found an 'experimental' setting in the AdminCP that likely came with the update to 1.6.7: Forum Display Options > Attempt to Mark Parent Forums as Read My guess is that it is a clunky sort of a band-aid the MyBB team developed. It seems to have solved the problem


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users