Jump to content


Photo

Screen Tearing & Vsync


  • Please log in to reply
7 replies to this topic

#1 MadWizard25

MadWizard25

    Thane

  • Members
  • PipPipPipPipPipPip
  • 449 posts

Posted 19 July 2012 - 07:07 AM

I have a problem regarding screen tearing. Lately, while testing mods, i have been getting some horizontal screen tearing. Its not static, but scrolls up or down the screen when moving in game. As far as i know this is an issue when the refresh rates of the monitor and my video card refresh rate in skyrim are mis matched, but im not expert :P This has been going on for a few weeks, but have ignored it due to time constraints. I previously did not get screen tearing when using a 58 fps cap. My monitors refresh rate is 60hz My most preferred setting is capping my fps to 58 using Nvidia Inspector, which reduces stuttering and input lag for me. Its also noted that this setting is for 60hz monitors. This is odd because screen tearing should not occur at below 60 fps, as far as i know? And yet im experiencing it at 58 fps and below. I also tried capping at 60 fps but screen tearing still occurs. By default i have in game (iPresentInterval) vsync turned off, due to the input lag i get with it. And since i never go over 60 fps, i have no physics problems either. However, turning it on, or forcing vsync on using NI, does not get rid of the screen tearing either. I also tried rolling back my nvidia drivers, using a clean uninstall method, but i still occasionally get screen tearing while trying out above options. So im clueless as to why im getting tearing now, any help would be much appreciated :)
  • 0

#2 LeetMiniWheat

LeetMiniWheat

    Commander

  • Members
  • PipPipPipPip
  • 252 posts

Posted 19 July 2012 - 11:05 AM

are you running in fullscreen mode? if you're in windowed, vsync can be tricky. (for windowed, have to force it in drivers and reboot to take effect so the aero desktop gets vsync'd) and if you're using window mode and not using aero, then there's no possible way of vsync that I know of without going fullscreen or enabling aero w/ it forced Edit: and with vsync off, there will always be tearing. just sometimes more noticeable than other times. no idea why, I guess depends on how the frames are syncing up or how sensitive the viewer is to it. personally I can't play anything with it off Edit2: I also remember someone else talking about getting more noticeable screen tearing in another thread due to something, but I forget... it was about 2 weeks ago
  • 0

#3 LeetMiniWheat

LeetMiniWheat

    Commander

  • Members
  • PipPipPipPip
  • 252 posts

Posted 19 July 2012 - 11:20 AM

found it, try this thread here about screen tearing
  • 0

#4 MadWizard25

MadWizard25

    Thane

  • Members
  • PipPipPipPipPipPip
  • 449 posts

Posted 24 July 2012 - 08:08 AM

Thanks for the help LMW :) The thread you linked was very informative! I do run fullscreen. I did not realize that with vsync off you would always get tearing, no matter what. I fixed it in the end. Once again clean uninstalled drivers, installed nvidias 301 release, disabled vsync in ini, forced standard vsync with NI, triple buffer on, and pre rendered frames to 3. No tearing. Unfortunately, i get mouse lag, even with mouse acceleration off. Cap at 58fps eliminated this, but it has to be with vsync off. Ah well, the price to pay :)
  • 0

#5 LeetMiniWheat

LeetMiniWheat

    Commander

  • Members
  • PipPipPipPip
  • 252 posts

Posted 24 July 2012 - 09:11 AM

Bethesda really needs to implement a hardware mouse cursor. That would get rid of all the mouse lag regardless of your FPS/vsync, but personally I use a gamepad. I'm surprised that you still had to use the 58fps cap even with vsync off though, since vsync off should be minimal lag (Unless the pre-rendered frames thing was lagging it).
  • 0

#6 LeetMiniWheat

LeetMiniWheat

    Commander

  • Members
  • PipPipPipPip
  • 252 posts

Posted 24 July 2012 - 09:15 AM

Hmm... maybe try this: Vsync on, 58fps cap, 1 pre-rendered frame (unless you're using multi-gpu). you'll get no tearing, but you'll get some stuttering with the fps below 60hz all the time. unfortunately for lag reduction, it's always a trade-off - either tearing, or stuttering, pick your poison
  • 0

#7 Vypir

Vypir

    Prisoner

  • Members
  • 47 posts

Posted 24 July 2012 - 12:17 PM

I was the OP in the other thread.  Yes, the pre-rendered frames thing seems to introduce mouse lag.  I found the tearing to be more tolerable than the lag.  I'm almost wondering if the HDR effects in RCRN are worth it.  If I turn them off, I can be free of both tearing and mouse lag.  For some reason RCRN's HDR prevents Nvidia's VSYNC and Adaptive VSYNC from working as advertised.
  • 0

#8 MadWizard25

MadWizard25

    Thane

  • Members
  • PipPipPipPipPipPip
  • 449 posts

Posted 24 July 2012 - 01:28 PM

Ok will try 1 pre rendered frame, vsync forced on and 58fps cap. Im not using RCRN, rather a ENB profile. However, the ENB also uses HDR, so maybe this is the issue.
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users