Jump to content


Photo

MO 1.2.9 + CBBE + I fixed the broken fomod script. Here ya go.

cbbe extraction error

  • Please log in to reply
4 replies to this topic

#1 FalloutPrime

FalloutPrime

    Prisoner

  • Members
  • 28 posts

Posted 16 July 2014 - 07:29 PM

Sick of getting the error saying it can't extract a given file? Well look no further.

 

o.O I have fixed the script. O.o 

 

It was as simple as the mod creator (Caliente) overlooking a slash in one of the pathing strings that needed to be there for the file path of the brows to be correct for the structure of the archive. 

The install now works flawlessly. No errors reported at least. To fix, 1) Simply download the edited script file I have linked at the bottom of this post.

2) Open the CBBE archive you get from nexus. navigate to the fomod folder (it will already have a script.cs file in it). Delete that file.

3) Drag and drop the new script into the same place you just deleted the old one from. Close the archive.

4) Place the edited archive in your "Mod Organizer/downloads" folder.

5) Open MO, install from the downloads tab.

6) Enjoy.

 

NOTE: I have only uploaded the script, and not just a fully working archive. You must download and edit the archive yourself. This is to save people that already have the archive from having to download it again, cause nexus is freakin slow without a sub.

 

http://www.dropbox.c...3q3br/script.cs

 

ALL HAIL TANNIN FOR MAKING AN ERROR REPORTER THAT MADE THIS FIX POSSIBLE!!!

ALL HAIL CALIENTE FOR MAKING SUCH AN AWESOME MOD!!!


Edited by FalloutPrime, 16 July 2014 - 07:35 PM.

  • 0

#2 TQWorld

TQWorld

    Prisoner

  • Members
  • 2 posts

Posted 26 July 2014 - 01:39 AM

Run into an issue with CBBE and MO. When I attempt to install, I get through the GUI and as soon as it begins installing, I receive a variety of errors saying things such as, "File CalienteTools/bodySlide/CalienteArmorRed.nif could be extracted. This probably means the mod is broken though you may still get partial functionality. Please inform the mod author. Detailed Error: File doesn't exist in FOMod"  

I have tried opening the zipped file, removing the script file from the fomod folder and replacing it with the one you've linked above. I still receive the same error. 
 
I have tried downloading multiple times in the hopes that it was possibly a corrupt download. I've also tried in different browsers. Same result. 
 
The package/mod installs and works perfectly in NMM; it's just installing with MO that's giving me a hard time. I'm trying to move away from NMM to MO but this is putting the brakes on that endeavor. 
 
Any help would be greatly appreciated.

Edited by TQWorld, 26 July 2014 - 01:42 AM.

  • 0

#3 GSDFan

GSDFan

    Jarl

  • Moderators
  • PipPipPipPipPipPipPipPipPip
  • 867 posts

Posted 26 July 2014 - 09:50 AM

In the corrected script look for the following:

 

[font="'courier new';"]CopyDataFile("CalienteTools/BodySlide/CalienteArmorRef.nif", "CalienteTools/BodySlide/CalienteArmorRef.nif");[/font]

 

 

Edit to look like the following:

CopyDataFile("CalienteTools/BodySlide/CalienteArmorRef.xml", "CalienteTools/BodySlide/CalienteArmorRef.xml");

You are changing [font="'courier new';"]CalienteArmorRef.nif to [/font]CalienteArmorRef.xml

 

Solution found here



#4 TQWorld

TQWorld

    Prisoner

  • Members
  • 2 posts

Posted 26 July 2014 - 11:25 AM

Thanks for the response. I'll provide feedback once I've tested. 


  • 0

#5 FalloutPrime

FalloutPrime

    Prisoner

  • Members
  • 28 posts

Posted 26 July 2014 - 03:34 PM

Wow, wish I had checked reddit now before fixing the facepack issue! Would have saved me a lot of time. I fixed it in a different spot than the guide however. I also don't know C#.. I know some java. So I am unaware of the differences. I wonder if my fix breaks anything else... All I did was put a "/" into one of the strings so the file path for the file the script was looking for was correct... MO reports no errors after my fix though so I stopped investigating at that point. I also just install bodyslide manually for easy setup and use in MOs exe list so I never ran into that error.

 

That's a damned handy guide GSDFan Thanks!!


Edited by FalloutPrime, 26 July 2014 - 03:45 PM.

  • 0



Also tagged with one or more of these keywords: cbbe, extraction error

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users