Jump to content


Photo

Spellcasting direction wrong (STEP:Core+)

magic casting spells bugs

Best Answer elwanya , 20 August 2014 - 04:22 PM

FNIS is not installed as it is not part of STEP:Core if i'm not mistaken. i'll have a look through the other mods if they require them.

 

EDIT: Ok, i found the culprit. The "Skyrim Witcher Experience Enhanced" Mod has a buggy "Witcher" Race which f**ks up the casting and the Mod seems to be dead.

Looks like i have to create my own Geralt...

But thanks anyway for your help.

Go to the full post


  • Please log in to reply
7 replies to this topic

#1 elwanya

elwanya

    Prisoner

  • Members
  • 4 posts

Posted 20 August 2014 - 11:28 AM

Hi all,

i just reinstalled Skyrim and followed STEP:Core v2.2.9. I added RealVisionENB and some of the recommended Mods as well as some others (mainly Witcher type stuff).

Everything was done with ModOrganizer, sorted by LOOT and bashpatched with WryeBash. The only changes in the INI files are the ones described in STEP and RealVisionENB.

The game runs smoothly and there are no CTDs, even after several houres of play, but every magic i cast (be it from a staff or from my hands) goes off to the top left of where i aim (see Screenshots).

Lesser Ward, Clearvoiance and the Witcher Aard Spell seem to work correctly, but i didn't test many others.

 

The only mods i could think of which could interfere are "Dualsheath Redux" and "1hWeapons on Back" but removing them did nothing to help my problem.

 

I'm NOT new to modding but i never encountered this specific bug and google was no help.

 

My Full Modlist:

http://pastebin.com/tH9xWwWu

 

Screenshots:

http://steamcommunit...s/?id=303180934

http://steamcommunit...s/?id=303180875

http://steamcommunit...s/?id=303180915

http://steamcommunit...s/?id=303180895


  • 0

#2 redirishlord

redirishlord

    Dragonborn

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,198 posts

Posted 20 August 2014 - 01:58 PM

Are you using an animation replacer, perhaps to compliment Dual Sheath. I believe that issue comes from a replaced casting animation?

 

Also, consider this from the DSR page:

Immersive Animations - Animations to go with this mod. Please install BEFORE XP32 Maximum Skeleton, as one of the options in the mod installs an outdated version of said skeleton that could cause issues later on.


Edited by redirishlord, 20 August 2014 - 02:05 PM.

  • 0

#3 elwanya

elwanya

    Prisoner

  • Members
  • 4 posts

Posted 20 August 2014 - 03:31 PM

there should be no animation change besides dualsheath and 1hweapons on back, as far as i know. and i dont use immersive animations.

 

EDIT: i just followed the requirements-chain for dualsheath. looks like STEP doesn't warn about the requirements. installing the mods as i write this.


Edited by elwanya, 20 August 2014 - 03:41 PM.

  • 0

#4 redirishlord

redirishlord

    Dragonborn

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,198 posts

Posted 20 August 2014 - 03:48 PM

Oh, did I have it backwards, does NOT having Immersive Animations cause the problem?

 

Re- STEP instructions, if they need worded better or more complete you could post that under 2.2.9 Bugs (or even update it yourself if its wiki, just comment your edit).


  • 0

#5 elwanya

elwanya

    Prisoner

  • Members
  • 4 posts

Posted 20 August 2014 - 04:04 PM

installed requirements -> no fix

removed the whole dualsheath chain -> no fix

tried a double sexchange (tip from a reddit user) -> no fix


  • 0

#6 redirishlord

redirishlord

    Dragonborn

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,198 posts

Posted 20 August 2014 - 04:15 PM

That is odd, I've never encounterd that myself, although I thought I remembered seeing something like that mentioned in an magic casting animation replacer (name escapes me). I would start disabling non-STEP mods one at a time to determine which is the culprit ("Witcher type stuff"), & try looking at FNIS and making sure the correct boxes are checked.


  • 0

#7 Halde

Halde

    Thane

  • Members
  • PipPipPipPipPipPip
  • 360 posts

Posted 20 August 2014 - 04:18 PM

Could it be an incorrect installation of FNIS/faillure to run FNIS after installing a FNIS required mod? 


  • 0

#8 elwanya

elwanya

    Prisoner

  • Members
  • 4 posts

Posted 20 August 2014 - 04:22 PM   Best Answer

FNIS is not installed as it is not part of STEP:Core if i'm not mistaken. i'll have a look through the other mods if they require them.

 

EDIT: Ok, i found the culprit. The "Skyrim Witcher Experience Enhanced" Mod has a buggy "Witcher" Race which f**ks up the casting and the Mod seems to be dead.

Looks like i have to create my own Geralt...

But thanks anyway for your help.


Edited by elwanya, 20 August 2014 - 04:49 PM.

  • 0



Also tagged with one or more of these keywords: magic, casting, spells, bugs

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users