Jump to content


Photo

Mods without .esp files aren't loading (example, Darnified UI)


  • Please log in to reply
18 replies to this topic

#1 BishyT

BishyT

    Prisoner

  • Members
  • 4 posts

Posted 18 September 2014 - 07:21 PM

I've been encountering some issues recently with Mod Organizer when it comes to mods that don't use/require .esp files.

For example, Darnified UI 132 (.7z version) doesn't use an esp file, as it's intended to be used as a replacer.

Then there are body replacers like Robert's Male Body and HGEC. Although they include .esp files, they're not nessecarily needed, and it's also recommended that the .esp files not be used alongside Oblivion Character Overhaul v2 to avoid conflicts.

 

Anyways, i'm using the Steam version of Oblivion GOTY with OBSE. I know that OBSE is working because Blockhead works (allowing me to move the camera about in chargen). I know that the Mod Organizer OBSE hook is working, as Oblivion Character Overhaul v2 will work.

 

However, neither Darnified UI nor the body replacers i'm using have any effect, and the only thing they have in common is that they're not using .esp files.

 

Has anyone else experienced this problem? I'm using the latest version of MO, 1.2.11.


  • 0

#2 DoubleYou

DoubleYou

    Wiki Stepper

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,463 posts

Posted 18 September 2014 - 07:41 PM

You do have Automatic Archive Invalidation turned on, right?



#3 BishyT

BishyT

    Prisoner

  • Members
  • 4 posts

Posted 18 September 2014 - 10:15 PM

I believe I do. There's even a "Oblivion - Invalidation.bsa" file in the Archives tab.

 

Ok, I fixed the problem halfway through typing this message. I went to the workarounds screen and pressed the "Back-date BSAs" button, and now Darnified UI seems to be working (haven't tested the body mods yet, but i'm assuming they'll work too). It seems that the Archive Invalidation wasn't working as intended and needed a little extra push.


  • 0

#4 DoubleYou

DoubleYou

    Wiki Stepper

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,463 posts

Posted 18 September 2014 - 10:19 PM

If you click the Profiles toolbar button, does your profile have Automatic Archive Invalidation checked? Back-Date BSAs will only work for a few things in Oblivion due to its buggy system.



#5 BishyT

BishyT

    Prisoner

  • Members
  • 4 posts

Posted 18 September 2014 - 10:49 PM

Yes, I make sure the Automatic Archive Invalidation is checked every time I go to Manage Profiles. I also make sure that I actually have the profile highlighted when I do that (I only have one profile, default).


  • 0

#6 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,553 posts

Posted 18 September 2014 - 11:41 PM

hmm... make sure the mod is checked... 

open the mod folder and image that all the files that are located there are supposed to be in the data folder

 

Idk, share some pics of anything that you find important... It might help



#7 etom23

etom23

    Prisoner

  • Members
  • 1 posts

Posted 15 January 2015 - 06:33 AM

...exactly the same problem with me, and fixed with the work-around.  Is the Automatic Archive Invalidation flag supposed to stay checked permanently?  I check it, run the game and return to MO to find the flag is un-checked.  I even check it, quit MO, restart MO, check to see the flag is checked (it is) and then run the game.  It is always unchecked when I return to MO (I don't close MO while the game is running).


  • 0

#8 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,605 posts

Posted 15 January 2015 - 07:26 PM

...exactly the same problem with me, and fixed with the work-around.  Is the Automatic Archive Invalidation flag supposed to stay checked permanently?  I check it, run the game and return to MO to find the flag is un-checked.  I even check it, quit MO, restart MO, check to see the flag is checked (it is) and then run the game.  It is always unchecked when I return to MO (I don't close MO while the game is running).

I think this may actually be a bug with the way MO handles the Oblivion engine.

I can verify your findings. No manner in which way I set the flag, Automatic Archive Invalidation is always disabled when returning to MO from Oblivion. Fallout3/NV which also use this method do not have that flag reset.

Curiously I see that MO managed Oblivion for me has all the Bethesda bsa files as standard files in theArchives tab, ie. they are not greyed out as they are with Skyrim or Fallout3/NV.

 

To be honest, I have not the faintest idea of how MO's Automatic Archive Invalidation works, but it does strike me as strange the difference in behaviour with Oblivion to the other two games that use it.

 

Additionally I have noticed that the Oblivion bsa files are not shown as essential, ie. greyed out, and can therefore be deactivated. This would render the game unplayable. All other games have the bsa files used by the main *.esm files as essential and greyed out, untouchable by the user.

 

I have posted a bug report.



#9 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,553 posts

Posted 15 January 2015 - 08:28 PM

can you take the archive invalidation from TesModManager and see if that works.

I remember when I was trying MO with Oblivion the one that was included didn't really work because it would cause a crash at startup with a cleaned version of orrey or some other DLC



#10 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,605 posts

Posted 15 January 2015 - 08:58 PM

As far as I can tell the TMM bsa is just an empty file as is the one from MO. The original Archive Invalidation from Quarn actually had a dummy *.dds file in it and needed to manually add that file to the list.

I'm assuming MO magically adds this listing to the ini during runtime because the actual ini doesn't contain any bsa to the [Archive] list. I'm not even sure now if that needs to the case with MO.

It's been so long now that I have forgotten what goes wrong if you don't have AI enabled.



#11 Kesnit

Kesnit

    Prisoner

  • Members
  • 4 posts

Posted 11 September 2015 - 01:25 PM

I am having the same problem, and nothing in this thread worked. I'm using Dark-DarN UI, but nothing is changing in-game.


  • 0

#12 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,605 posts

Posted 11 September 2015 - 07:46 PM

Welcome to STEP @kesnit

Are you sure you have installed DarkUI correctly and it is enabled in the left-hand pane?

Perhaps if you provide your modlist.txt or other diagnostic material for us to examine.

 

You are using the latest 1.3.11 version of MO?



#13 Kesnit

Kesnit

    Prisoner

  • Members
  • 4 posts

Posted 11 September 2015 - 11:26 PM

Are you sure you have installed DarkUI correctly and it is enabled in the left-hand pane?


Am I sure it's installed correctly? No. I tried installing both the manual install file though MO and the omod (installing through TMM run in MO and then making a new mod from the Override folder). I did make the changes to Oblivion.ini that the mod description says to make. Running the game after installing the manual file allowed the game to run, but I didn't have the correct UI. (It was the vanilla UI.) Trying to run the game after installing the omod caused a CTD before the Bethesda video started.

It is active in the left pane.
 

 

Perhaps if you provide your modlist.txt or other diagnostic material for us to examine.


Here's my modlist.txt
 

 

# This file was automatically generated by Mod Organizer.
+DarkUId DarN
-Ayleid Arcane Archery
-Dark Arts of The Left-Hand Path
-New Races- Dremora Sheogorath Dark Seducer Golden Saint
-Optional Persuasion Minigame Add-on
+Unofficial Oblivion DLC Patches
-EWIs True Weaponry of Viscounts and Sirrahs
-NifSE v1 1 Release
-madgod powers
-Hotkey Wheel Add-On
-Elder Magic
-Dark Imperial Watch Armor
+Unofficial Shivering Isles Patch
+Unofficial Oblivion Patch
-Realistic Leveling
-Quest Award Leveller
-MiniMap v1x2x0
-MenuQue v16b
-Map Marker Overhaul
-Kvatch Rebuilt
-Harry Potter Magic
-Escape From Prison
-DarkUI Recolored
-Dark UI Supplemental Pack
-Custom Autosave
*Unmanaged: DLCBattlehornCastle
*Unmanaged: DLCFrostcrag
*Unmanaged: DLCHorseArmor
*Unmanaged: DLCMehrunesRazor
*Unmanaged: DLCOrrery
*Unmanaged: DLCShiveringIsles
*Unmanaged: DLCSpellTomes
*Unmanaged: DLCThievesDen
*Unmanaged: DLCVileLair
*Unmanaged: Knights

 

My plugins.txt

 

 

 

# This file was automatically generated by Mod Organizer.
Oblivion.esm
Unofficial Oblivion Patch.esp
Oblivion Citadel Door Fix.esp
UOP Vampire Aging & Face Fix.esp
DLCShiveringIsles.esp
Unofficial Shivering Isles Patch.esp
DLCBattlehornCastle.esp
DLCBattlehornCastle - Unofficial Patch.esp
DLCThievesDen.esp
DLCThievesDen - Unofficial Patch.esp
DLCThievesDen - Unofficial Patch - SSSB.esp
DLCMehrunesRazor.esp
DLCMehrunesRazor - Unofficial Patch.esp
DLCVileLair.esp
DLCVileLair - Unofficial Patch.esp
DLCHorseArmor.esp
DLCHorseArmor - Unofficial Patch.esp
DLCOrrery.esp
DLCOrrery - Unofficial Patch.esp
DLCSpellTomes.esp
DLCSpellTomes - Unofficial Patch.esp
DLCFrostcrag.esp
DLCFrostcrag - Unofficial Patch.esp
Knights.esp
Knights - Unofficial Patch.esp[/quote]

 

Dark-DarN UI does not make an esp, which is why it does not show up above.

 

My Oblivion.ini



Not sure if it matters, but I run the Steam version of Oblivion.

[quote]You are using the latest 1.3.11 version of MO?



Yes.


Edited by Kesnit, 11 September 2015 - 11:26 PM.

  • 0

#14 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,605 posts

Posted 12 September 2015 - 12:13 AM

The manual version of the file works just fine with MO.

Trying to install it should invoke the MO Bain installer where you will need to make your choices as to which elements to install, if you are unsure which options to pick perhaps unpack the archive first in explorer and look through the 'readme'.

 

Using MO means you no longer need to make the font changes in the oblivion.ini just use the INI Tweaks that the installer sets up.

 

So since you have a bare minimum active at the moment it looks good to go.

Just to make sure there isn't something else going on. Order you mods in the left-hand pane, so that the Unofficial patches follow immediately after the DLC they are for and then make sure the BSAs are managed by MO, you have Archive Invalidation checked and the actual BSAs are enabled in the 'Archives' tab.



#15 Kesnit

Kesnit

    Prisoner

  • Members
  • 4 posts

Posted 12 September 2015 - 07:30 AM

The manual version of the file works just fine with MO.

Trying to install it should invoke the MO Bain installer where you will need to make your choices as to which elements to install, if you are unsure which options to pick perhaps unpack the archive first in explorer and look through the 'readme'.[/quote]

 

Huh. That insn't happening. All I'm getting is the pop-up window to name the mod. I've had other mods that use the Bain installer, so I know what it looks like.

 

Using MO means you no longer need to make the font changes in the oblivion.ini just use the INI Tweaks that the installer sets up.

 

That didn't happen. I had to go in and make the changes myself.

 

Just to make sure there isn't something else going on. Order you mods in the left-hand pane, so that the Unofficial patches follow immediately after the DLC they are for and then make sure the BSAs are managed by MO, you have Archive Invalidation checked and the actual BSAs are enabled in the 'Archives' tab.

 

I'm pretty sure I did, but will double check.


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users