Jump to content


Photo

Double Attack Bug with 1-Handed Weapons

double attack bugs

  • Please log in to reply
No replies to this topic

#1 tregolani

tregolani

    Citizen

  • Members
  • Pip
  • 41 posts

Posted 09 October 2014 - 06:11 PM

Hey everyone,

 

I'm having a bit of a OP bug that I'm trying to diagnose - whenever I try to use a power attack with any bladed 1-handed weapon (sword, dagger, axe), I do a double attack.  As in, my character starts the normal attack animation, then immediately jumps into the power attack animation.  However, the attack sound plays for both, and enemies are actually hit twice due to the issue.  2-handed weapons (even fast ones like Immersive Weapons' quarterstaffs) and 1-handed maces do not display the same issues, and only attack once per power attack or normal attack.

 

I also have the issue where if I do a normal attack and then immediately strafe back and forth rapidly, I can "chain" attacks one after another without any clicks aside from the initial attack.  It's almost as if it is trying to play the animation to its fullest, and the change of direction is causing it to reset and try to play the animation again.

 

I am using SPERG as my perk overhaul mod, and due to some perks I've taken, my "weaponspeedmult" value is 1.45.  I have console'd the value (using forceAV) back to the base value of 1.0, and that seems to remove the issue for the 1-handed weapons, but obviously removes any benefit from having taken perks to increase my attack speed. 

 

I've also tried uninstalling attack animation mods, re-run FNIS, and played around with animation mods, but it doesn't seem to be linked to animations, but rather to the attack speed value. 

 

Is this just a weird limitation of the engine, or is there a way to fix this?  Load order is in my signature.


Edited by tregolani, 09 October 2014 - 06:16 PM.

  • 0



Also tagged with one or more of these keywords: double attack, bugs

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users