Jump to content


Photo

Common CTDs, Freezes, ILS and memory issues


  • Please log in to reply
184 replies to this topic

#16 saber47

saber47

    Prisoner

  • Members
  • 2 posts

Posted 15 January 2015 - 05:27 PM

Hello there,

I'm experiencing the same issue addressed in the thread. Although I'm an NMM user, I have configured it to run custom skyrim launcher using skse_loader with -forcesteamloader argument. However, the memory tweak still won't work for me. I have also tried launching skse_loader directly with -forcesteamloader in a shortcut, neither did this help.

 

My preallocated memory is still 256MB for the first block:

 

 

Below are my skse.ini settings (I have  checked it is not .ini.txt):

 

 

and here's what I get from C:\Users\Lingyi\Documents\my games\skyrim\SKSE\skse_steam_loader.log

 

 
As far as I know, this memory patch is included in 1.7.1 version of skse. Could anyone help me with this ? I have 64-bit windows 8 OS and I'm currently using Realvision ENB which use enbseries 262.
 
I realy hope I could get this memory tweak to work since I have been running about 150 mods and every once a while it will run above 256mb memory
 
Thanks ahead for any inputs on this
 
 
P.S. for the time being, I will be using SSME and it does successfully tweaked the memory, but I'm still looking for a skse.ini solution since this is likely the method that'll be maintained in future.

Edited by saber47, 15 January 2015 - 06:01 PM.

  • 0

#17 Nozzer66

Nozzer66

    Dragon Prince

  • Pack Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,501 posts

Posted 15 January 2015 - 06:24 PM

What's the path to the SKSE ini, ie where is it exactly?


  • 0

#18 BobbyTH

BobbyTH

    Prisoner

  • Members
  • 1 posts

Posted 20 January 2015 - 10:08 AM

 

Below are my skse.ini settings (I have  checked it is not .ini.txt):

 

[Memory]

DefaultHeapInitalAllocMB=768
ScrapHeapSizeMB=256

 

==============================================
 
@Saber47 >>> You are missing a vowel ( i ) in the argument DefaultHeapInitalAllocMB

Edited by BobbyTH, 20 January 2015 - 10:10 AM.

  • 2

#19 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,599 posts

Posted 21 January 2015 - 08:49 PM

updated op so that it contains info on SSME in the form of a note as well as what the SKSE.ini should contain.



#20 sa547

sa547

    Prisoner

  • Members
  • 8 posts

Posted 24 January 2015 - 04:07 AM

I think this thread should be required reading for any modder, as I, like some others, had plopped in skse.ini without realizing that we were missing something very important and thus experienced CTDs/ILS despite the settings.


  • 0

#21 saber47

saber47

    Prisoner

  • Members
  • 2 posts

Posted 25 January 2015 - 06:52 PM

 

==============================================
 
@Saber47 >>> You are missing a vowel ( i ) in the argument DefaultHeapInitalAllocMB

 

Huh! That solves the problem! Thanks so much. How stupid of me that I didn't notice that sooner. I couldn't remember where I got this wrong version from, but I copied these lines from some popular thread I found through google. I guess people who had problem with similar issues might wanna try double check their spellings. The interesting thing is that I didn't even have to do the -forcesteamloader to get this to work :)

Thanks BobbyTH!


  • 1

#22 Thenatural

Thenatural

    Citizen

  • Members
  • Pip
  • 51 posts

Posted 07 February 2015 - 01:24 PM

I think this thread should be required reading for any modder, as I, like some others, had plopped in skse.ini without realizing that we were missing something very important and thus experienced CTDs/ILS despite the settings.

Totally agreed. I was about to rip things apart and start over after going through everything trying to fix my ILS issue. This was definitely my issue. 

 

I saw SKSE on the STEP list and just went through the installer assuming SSMP was there and just set it and forgot it. 


  • 0

#23 FirstChildren

FirstChildren

    Prisoner

  • Members
  • 4 posts

Posted 18 February 2015 - 01:07 PM

I was able to get to work the Memory Patch throug skse.ini and also Memory Blocks Log, but there is a problem: in MemoryBlocksLog.log Block1 is always 256MB LESS than what I set for defaultHeapInitialAllocMB in the ini file.

EDIT: nevermind, I realized this is the way it is supposed to work XD


Edited by FirstChildren, 18 February 2015 - 01:39 PM.

  • 0

#24 minos55

minos55

    Thane

  • Members
  • PipPipPipPipPipPip
  • 351 posts

Posted 28 February 2015 - 11:33 AM

Hm i have random freezes, but my memory blocks work. Would there be any other problems that could be causing that.


  • 0

#25 tommy4tone

tommy4tone

    Prisoner

  • Members
  • 3 posts

Posted 28 February 2015 - 01:34 PM

Hi.  I've tried the above fix posted by Daedric and my log still reports 256 for block 1.  SKSE files are all located in the Skyrim directory.  I read a little bit into the ENBlocal INI/Memory guide and made the following change under [Memory]:

 

ExpandSystemMemoryX64=true

 

I get the same result as before (block reports 256 MB).  Here's what my SKSE pref file looks like:

 

ClearInvalidRegistraions=1
DefaultHeapInitialAllocMB=768
ScrapHeapSizeMB=256
iTintTextureResolution=512
WriteMinidumps=1
EnableContainerCategorization=1

 

The game launches fine, intro is good, and gameplay is smooth with no problems YET.  The issue is I hit an ILS when I try to enter Skyrim for the first time outside of Helgen Keep.  I'm using STEP 2.2.9 WITHOUT any of the DLC's.  I've been careful to use only mods and/or options that don't require the DLC's.  I followed the installation order exactly and have sorted the plugins properly. 

 

Any ideas are appreciated.


  • 0

#26 Nozzer66

Nozzer66

    Dragon Prince

  • Pack Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,501 posts

Posted 28 February 2015 - 03:16 PM

Try the -forcesteamloader in the arguments field for SKSE in the executables.


  • 0

#27 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,599 posts

Posted 28 February 2015 - 03:39 PM

Hi.  I've tried the above fix posted by Daedric and my log still reports 256 for block 1.  SKSE files are all located in the Skyrim directory.  I read a little bit into the ENBlocal INI/Memory guide and made the following change under [Memory]:

 

ExpandSystemMemoryX64=true

 

Can you link where you found the info.

By today it should be ExpandSystemMemoryX64=false

because the MEM function is no longer needed and may cause issues with SKSE memory tweaks



#28 tommy4tone

tommy4tone

    Prisoner

  • Members
  • 3 posts

Posted 28 February 2015 - 08:23 PM

@Jarl,

 

This fix is what I was referring to above "I've tried the above fix posted by Daedric and my log still reports 256 for block 1".  My executables window looks identical to that on page 1 of this thread in Daedric's post.

 

@Daedric,

 

http://wiki.step-pro...ocal_INI/Memory is the link to the instructions for setting that line of code to true.  If it does nothing (and since it hasn't helped me), I'll set it back to false.

 

Any other ideas? 

 

Thanks in advance.


  • 0

#29 Nozzer66

Nozzer66

    Dragon Prince

  • Pack Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,501 posts

Posted 28 February 2015 - 11:33 PM

The names aren't Daedric and Jarl. They're just titles. Much like yours at the moment is Prisoner. :) They'll change with post number. :)

 

Ok next thing is what's the exact path to you SKSE.ini? And another easy mistake to make is this one. are you showing file extensions? If not, turn them on. Make sure your SKSE.ini isn't SKSE.ini.txt by mistake. 

 

It's an easy mistake to make.

 

EDIT: also is that exactly how you have the SKSE.ini set up? As you put in the post?

 

Try something like this:

 

[General]

ClearInvalidRegistrations=1

 

[Memory]

DefaultHeapInitialAllocMB=768

ScrapHeapSizeMB=256

 

[Display]

iTintTextureResolution=512 *Though this seems smallish. Most use 1024 or 2048 here*

 

[Debug]

WriteMiniDumps=1

 

[Interface]

EnableContainerCategorization=1


Edited by Nozzer66, 28 February 2015 - 11:40 PM.

  • 0

#30 tommy4tone

tommy4tone

    Prisoner

  • Members
  • 3 posts

Posted 01 March 2015 - 01:20 AM

Nozzer, thanks for the heads up on name convention (duh) :-)

 

Anyway, problem fixed!  I did two things:

 

-what you suggested

-then this little tidbit about skse and mod organizer shown here: http://[General] Cle...pHeapSizeMB=256

 

I was always able to run skse as an executable from MO.  The issue was, I started STEP using NMM.  After it didn't work, I installed MO and merged all the mods into it and started the installation process all over again.  BUT, I didn't revisit part 2C in the guide, so I totally missed the specific instructions for installing SKSE scripts into the MO folder.

 

Anyway, thanks for the help!  I was able to enter Skyrim form Helgen Keep.


  • 0


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users