Jump to content


Photo

MO unable to start SKSE

skse

  • Please log in to reply
19 replies to this topic

#1 ichibeng

ichibeng

    Citizen

  • Members
  • Pip
  • 10 posts

Posted 05 May 2015 - 08:45 AM

Using MO, followed all the STEP guide.

 

Launch SKSE through MO, but it launch SkyrimLauncher instead.

 

I have tried almost everything that has been suggested in forum.

 

Kindly help. Thanks.


Edited by ichibeng, 05 May 2015 - 08:46 AM.

  • 0

#2 DoubleYou

DoubleYou

    Wiki Stepper

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,463 posts

Posted 05 May 2015 - 11:50 AM

You need to launch Steam and login first.



#3 ichibeng

ichibeng

    Citizen

  • Members
  • Pip
  • 10 posts

Posted 05 May 2015 - 12:39 PM

You need to launch Steam and login first.

Yup. Already done that. 

 

No matter how many times I try to load SKSE through MO, it will run skyrimLauncher.

 

1. Steam folder wasn't in Program Files (x86)

2. MO/SKSE/Steam run in administrative mode

3. SKSE\skse.ini have been created both in MO mod folder and Skyrim\Data\SKSE folder

4. skse plugin on top of load order.

 

I'm basically run out of idea how to make this happen.


  • 0

#4 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 11,280 posts

Posted 05 May 2015 - 01:42 PM

Do you have the force steam loader parameter added?

#5 ichibeng

ichibeng

    Citizen

  • Members
  • Pip
  • 10 posts

Posted 05 May 2015 - 01:55 PM

Do you have the force steam loader parameter added?

Wow. Thank you so much. It works like a charm.

 

BTW, why it wasn't mention in any sticky post regarding this problem?

 

Probably adding a link in the STEP guide for the parameter editing?


  • 0

#6 DoubleYou

DoubleYou

    Wiki Stepper

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,463 posts

Posted 05 May 2015 - 02:02 PM

It is in a sticky here: http://forum.step-pr...-memory-issues/



#7 ichibeng

ichibeng

    Citizen

  • Members
  • Pip
  • 10 posts

Posted 05 May 2015 - 02:28 PM

I think it still not solving my problem.

 

Either using  -forcesteamloader or " -forcesteamloader".

 

After launching SKSE through MO, there was no Launcher window pop-up.

 

But, at the Menu, when I enter getSKSEversion command, it cant detect.

 

Which mean, it wasnt SKSE.

 

Hmmm... the binary was correct.

The SKSE can be load outside of MO.

I can start vanilla Skyrim.

 

Anything I have missed?


  • 0

#8 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 11,280 posts

Posted 05 May 2015 - 02:47 PM

Do you get the SKSE messages at the top of the screen?

#9 Nozzer66

Nozzer66

    Dragon Lord

  • Pack Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,180 posts

Posted 05 May 2015 - 05:38 PM

 

3. SKSE\skse.ini have been created both in MO mod folder and Skyrim\Data\SKSE folder

 

Are you saying you created the SKSE.ini twice? No need to do that. Just the once via MO is enough.


  • 0

#10 ichibeng

ichibeng

    Citizen

  • Members
  • Pip
  • 10 posts

Posted 05 May 2015 - 07:41 PM

Are you saying you created the SKSE.ini twice? No need to do that. Just the once via MO is enough.

Yeah, reading through the previous post reveal that only in MO  was counted. I have deleted the one in Skyrim\Data.

 

 

Do you get the SKSE messages at the top of the screen?

 

Hmm. I saw some messages but it looks like ENB related. White font.


Edited by ichibeng, 05 May 2015 - 07:43 PM.

  • 0

#11 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,607 posts

Posted 05 May 2015 - 07:53 PM

It is in a sticky here: http://forum.step-pr...-memory-issues/

It's also here in the Mod Organizer wiki.

 

Try creating a new option in the 'Executables' list that points to skse_loader.exe and add the -forcesteamloader switch.

Make sure you create a new option, not modify an existing one. (named differently so as to make the difference obvious) Close the 'Executables' list and select the new option and see if that produces the same issue.

 

This is to ensure your changes are being applied, as the edits suggested above may not have been saved. (highly unlikely, but just to check)



#12 ichibeng

ichibeng

    Citizen

  • Members
  • Pip
  • 10 posts

Posted 05 May 2015 - 08:31 PM

v5LMX8M.jpg

 

pZGU5i0.jpg

 

Still load Launcher instead of SKSE.


  • 0

#13 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,607 posts

Posted 05 May 2015 - 08:44 PM

Ok, so to be absolutely sure here, you do have SKSE installed correctly?

 

There should be the following files in the Skyrim folder:

skse_1_9_32.dll
skse_steam_loader.dll
skse_loader.exe

 

The only thing I can think of is MO can't find skse_loader.exe and is defaulting to the Skyrim launcher.

 

I can replicate the launcher loading ONLY when I'm not logged into Steam, but as you have stated you have already checked that detail, I'm getting close to having no more ideas.



#14 ichibeng

ichibeng

    Citizen

  • Members
  • Pip
  • 10 posts

Posted 05 May 2015 - 09:01 PM

gvc6W9l.jpg

 

Yeah same here. I have no idea why MO can't launch SKSE.

 

Previously I'm using NMM but realize the way it handle mod is not as efficient as MO.

Then I uninstall Skyrim, install MO and import from NMM before get rid of it.

 

Everything went smooth. The STEP guide, ENB, FNIS Launcher, TES5edit etc.

But on the very last step, to actually test/play the game after working on it for 2 days, MO can't launch SKSE.

 

I can accept complicated,common things like CTD, freeze screen.

 

But a simple program launch... probably I overestimate myself hahaha.


  • 0

#15 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,607 posts

Posted 05 May 2015 - 09:26 PM

Just out of curiosity, before you started MO and after you have re-installed Skyrim, did you run the launcher to generate the default ini files?





Also tagged with one or more of these keywords: skse

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users