Jump to content


Photo

Double Launcher when running through MO


Best Answer GSDFan , 09 August 2015 - 12:20 AM

The proper way to use MO, Oblivion and OBSE is to set the “Launch Mechanism” in the workarounds tab to Script extender and Launch the game from Steam. This means that you mod in MO and run the game from Steam. You also need to enable the Steam community in game option in Steams Oblivion settings.

 

If you try to run the game from the MO configured “OBSE” shortcut you will get the “You are trying to use a Steam version of Oblivion. Steam users should launch the game through Steam, not by running obse_loader.exe. If OBSE fails to load, go to Steam > Settings > In Game and check the box marked "Enable Steam community in game". Please see the instructions in obse_readme.txt for more information.” message and the loader will exit.

 

If you run the shortcut “Oblivion launcher” the launcher will open as usual. If play is pressed it will close and open again and when play is pressed the game will start.

 

If the MO configured shortcut “Oblivion” is run the configuration utility will open up and you can run the game from here.

 

In all of the above situations you should not be running the game from here. Steam needs to be the mechanism to do this.

 

My theory on this, whether right or wrong, is that Steam launches the game, then the "in game community" which in turn allows obse_1_2_416.dll and obse_steam_loader.dll to do their work. The file obse_loader.exe is not needed for the Steam version of the game. It is for the retail version of the game only and should be deleted.

 

Running the game from Steam will allow the launcher to run first. At this point MO has not been loaded and if you view the Data files only the vanilla game directory will be seen. The launcher is reading the Oblivion.ini in the "My Games" folder and DLCList.txt and Plugins.txt from C:\Users\username\AppData\Local\Oblivion folder. Any changes made here will be written to those files and not the ones in the active MO profile.

 

Pressing the play button will allow the game to start, which in turn launches the 'in game community" and then allow the OBSE_XXXX.dlls to load, which will load MO as a script extender from the games vanilla directory. MO should now be active and the VFS and all of the MO mods should be loaded.

 

 

Go to the full post


  • Please log in to reply
16 replies to this topic

#1 Matriga

Matriga

    Citizen

  • Members
  • Pip
  • 26 posts

Posted 27 May 2015 - 07:20 AM

When I launch Oblivion through MO I get a double launcher. One pops up, I click play, a second launcher pops up, I click play. When I get into the game, none of my mods have taken effect. 

What am I doing wrong? :(  Everything is showing up in the right pane under the data tab, and all of my plugins are activated.


  • 1

#2 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,605 posts

Posted 28 May 2015 - 12:33 AM

Are there all the settings in the 'Executables' list for the OBSE, Launcher & actual game? You should have those three, assuming you have OBSE installed.

Ideally from MO you would choose the OBSE as the starting method and that will launch the actual game, not the launcher. If you don't have OBSE, the game executable should be used and in this case the launcher is never called.

 

If you are using an ENB or other patcher such as HiAlgo Boost, perhaps you have their inis looking to add the launcher as the preferred exe to run?



#3 Matriga

Matriga

    Citizen

  • Members
  • Pip
  • 26 posts

Posted 29 May 2015 - 11:28 PM

Well, I have the Anthology. If I patch to the steam version from my disks? I get these errors when I try to launch it. I've since switched and just use the disk version without patching it up, and everything is working perfectly :) thanks


  • 0

#4 DoubleYou

DoubleYou

    Wiki Stepper

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,463 posts

Posted 30 May 2015 - 07:44 AM

Hmmm... I wonder if the anthology version have different AppID?



#5 Groppstopper

Groppstopper

    Prisoner

  • Members
  • 5 posts

Posted 01 August 2015 - 07:07 PM

I am having this same problem with the steam version of Oblivion and I can't simply go buy the anthology version to solve it. Does anyone have any fixes for this?

 

I have all the executables in the menu "Oblivion" "Oblivion Launcher" and "OBSE." Load order seems to be fine. I just get the two launchers. OBSE run as long as it is installed even if you launch oblivion.exe or at least that is what the readme.txt tells me and all the guides. launching through obse gives me and error anyways that tells me to launch through the regular steam launcher. Unfortunately, I get the two launchers and my mods can't load. 

 

Any help would be appreciated!


Edited by Groppstopper, 01 August 2015 - 07:11 PM.

  • 0

#6 DoubleYou

DoubleYou

    Wiki Stepper

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,463 posts

Posted 02 August 2015 - 05:39 PM

Try this:

  1. Install Oblivion to a location where you have full User Account Control of it.
  2. Launch Oblivion to create INIs and make sure Oblivion does not CTD for whatever reason.
  3. Install OBSE and launch it to make sure OBSE works
  4. Install Mod Organizer (MO) (preferably to the Oblivion directory)
  5. Launch MO
  6. MO will present a window asking you to select the game you wish to manage. Select Oblivion, which should be automatically recognized. If it is not, you may use the browse function to find your game folder and select it.
  7. First time users will receive a message to show the tutorial. It is highly recommended to do so.
  8. Click the wrench Wrench_MO.png button in the toolbar, and select the Nexus tab.
  9. Check automatically log in box and insert your Nexus username and password.
  10. Also click the Associate with "Download with Manager" links button.
  11. Go to the Workarounds tab and make sure Steam App ID says 22330.
  12. Change Load Mechanism to Script Extender.
  13. Uncheck Force-enable game files and click OK to exit settings.
  14. Turn on Archive Invalidation by clicking the profile Profiles_MO.png button in the toolbar and check Automatic Archive Invalidation. Repeat this for all new profiles you create.
  15. Go to the Archives tab in the right pane and make sure that:
  • Have MO manage archives is checked
  • All BSAs are checked
  • Drag and drop the Archive Invalidation BSA in the top group to the absolute top of that list. Otherwise AI will not work.

If it doesn't work, it may be that the Steam version will not work at all. I don't have the Steam version (I'm a retail disc guy whenever possible), but everyone with the Steam version seems to be having trouble lately.



#7 GSDFan

GSDFan

    Jarl

  • Moderators
  • PipPipPipPipPipPipPipPipPip
  • 782 posts

Posted 03 August 2015 - 05:21 AM

12a restart MO to make sure it writes its files to the games Data OBSE Plugins folder.



#8 Groppstopper

Groppstopper

    Prisoner

  • Members
  • 5 posts

Posted 04 August 2015 - 09:05 PM

That seemed to work as far as getting my mods to load into the game but now I seem to be having problems with OBSE loading. I've installed it as directed in the readme.txt but it's not loading. It seems that a lot of people have an issue with this as well. Hmph, very frustrating steam! Are there any workarounds to solve this problem. Thank for responding and getting the double launcher problem solved. That is a huge relief, now if only OBSE would launch.


  • 0

#9 DoubleYou

DoubleYou

    Wiki Stepper

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,463 posts

Posted 05 August 2015 - 02:59 PM

Obse plugin must be installed to the data directory in this setup. This includes oblivion reloaded. Doing that, does that solve the issue?

#10 Groppstopper

Groppstopper

    Prisoner

  • Members
  • 5 posts

Posted 06 August 2015 - 05:51 PM

I assume you.re referring to the "data" folder in the OBSE.zip folder being merged with the game's natural data folder. I have it there, it's done exactly how the readme.txt from silverlock.org explains. Here are the files in the Oblivion folder:

 

obse_1_2_416.dll

obse_editor_1_2.dll

obse_loader.exe

obse_loader.log

obse_steam_loader.dll

 

In the data folder I have

OBSE>

    obse.ini

    plugins>

        hook.dll

        mo_path.txt

 

Is something wrong with this?


  • 0

#11 DoubleYou

DoubleYou

    Wiki Stepper

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,463 posts

Posted 06 August 2015 - 07:42 PM

Nothing wrong with that. That is all good, but I'm assuming you are looking for evidence that OBSE is or is not working, since you say it is not working. I need to know how you know it isn't working (unless, of course, it is working).



#12 Groppstopper

Groppstopper

    Prisoner

  • Members
  • 5 posts

Posted 06 August 2015 - 10:11 PM

Several mods I am using tell me it is not once I load in. I also ran the OBSE tester and it couldn't detect any version of OBSE running. 


  • 0

#13 DoubleYou

DoubleYou

    Wiki Stepper

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,463 posts

Posted 07 August 2015 - 10:19 PM

Try launching Oblivion like you normally would through Steam. Is OBSE active then?



#14 Matriga

Matriga

    Citizen

  • Members
  • Pip
  • 26 posts

Posted 08 August 2015 - 07:52 PM

To report on my own current experiences:

1) OBSE plugins do not get registered when installed with MO. You have to install them manually.

2) Following the above steps to set up MO to run with Oblivion WILL get OBSE working (Tested with OBSE Test Plugin). 

In my opinion, MO is not a viable modding option for the Steam version of Oblivion. Wrye Bash is the way to go. 

I am, however, working on a guide to modding Oblivion (For Morroblivion) on another site. I am dead set on using MO for this guide, and making it work with the Steam version. 

I'll gladly provide a link to anyone who sends me a PM, so they can monitor the progress of the guide. 

DoubleYou, thanks for your help, sir. 


  • 0

#15 Groppstopper

Groppstopper

    Prisoner

  • Members
  • 5 posts

Posted 08 August 2015 - 08:30 PM

Well, I guess I will fiddle around with Wrye Bash and see if I can get that running right. Thanks for all of the help everyone! 


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users