Jump to content


Photo
Fallout_NV

fINIp NV (Fallout INI Project New Vegas) by DoubleYou

doubleyou ini

  • This topic is locked This topic is locked
19 replies to this topic

#1 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,471 posts

Posted 21 September 2015 - 11:18 AM

Mod Source:
fINIp NV (Fallout INI Project New Vegas) by DoubleYou
 

 

fINIp NV

 
fINIp NV (Fallout INI Project New Vegas) is an attempt to restore decency to the Fallout New Vegas INI configuration files. Sadly, Obsidian Entertainment screwed up its INIs. You would think that their INI creation method via the FalloutNVLauncher would be completely error free, as how could they mess up what essentially is a simple text file? but it isn't. They are chock full of uh-ah-choo! sneeze-worthy lines.
 
Enter fINIp NV. We spinned the files that Fallout New Vegas uses to create your presets, twirled them into a sensible order, and whirled away most of the errors. This removes a large portion of the obsolete and redundant lines that the FalloutNVLauncher erroneously applies to the INI files.
 
Installation:

  • Download the main file.
  • Run the installer.
  • Follow the on-screen instructions.
  • Read any warnings carefully!
  • Once the installer has completed, the FalloutNVLauncher will automatically run to generate your new INI files.
  • If using Mod Organizer, copy the generated Fallout.ini and FalloutPrefs.ini files to your <ModOrganizer>\profiles\<Profile-Name> directory.

Once this is done, please add any and all desired tweaks, as these are NOT tweaked outside of default tweaks. This mod cleans up the INI creation process. It doesn't add tweaks. Archive Invalidation will need to be redone.
 
Uninstallation:

  • Replace your Fallout.ini and FalloutPrefs.ini files with the backups you should have made according to the warnings in installation and go to step 3. If you neglected to heed my warnings, verify integrity of game cache and go to step 2.
  • Run the FalloutNVLauncher and select your preset.
  • If using Mod Organizer, copy the new Fallout.ini and FalloutPrefs.ini from your Documents\My Games\FalloutNV directory to your <ModOrganizer>\profiles\<Profile-Name> directory.
  • Eat salt and vinegar chips.


#2 brandonpotter0

brandonpotter0

    Prisoner

  • Members
  • 13 posts

Posted 10 November 2015 - 06:20 PM

I just tried to install this, but the installer isnt detecting where I have Fallout NV installed to. 

 

C:\Program Files (x86)\Steam\steamapps\common\Fallout New Vegas\Fallout New Vegas <- This is where I have it installed, but the installer says its not there.....


  • 0

#3 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,471 posts

Posted 10 November 2015 - 07:59 PM

Remove the extra Fallout New Vegas.

#4 brandonpotter0

brandonpotter0

    Prisoner

  • Members
  • 13 posts

Posted 10 November 2015 - 11:14 PM

Remove the extra Fallout New Vegas.

That seemed to make it work. Thank you ^^ My game seems to run better now!


  • 0

#5 Tario

Tario

    Prisoner

  • Members
  • 8 posts

Posted 18 November 2015 - 11:58 AM

Sad but i have to say it. I was following instructions then i was amazed by how clear the ini files were, and of course nothing suspicious there. Next... I Launched game, it launched normally but somehow faster... I though okay... Then im trying to start new game and i am getting white screen on pip boy, and character creation menus. Of course its not the only problem. My game reverted to english[no big deal actually] and of course all subtitles dissapeared from game.

 

I did everything ln the instruction i maked Archive invalidation again, game launched after instalation but still this dont worked. Any ideas?

I dont know if should i post my load order here becouse with this i dont know if this should matter here.


Edited by Tario, 18 November 2015 - 12:31 PM.

  • 0

#6 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,471 posts

Posted 18 November 2015 - 06:54 PM

I really am sorry. I forgot about other languages, and they won't be able to use this in its current state, which will be resolved in an update.

You need to add the sLanguage line back in from before install. Retrieve it from your backup.

#7 Tario

Tario

    Prisoner

  • Members
  • 8 posts

Posted 19 November 2015 - 11:29 AM

Hmm, okay, and  this will also help with white screen on pip boy/racemenu/Terminal? Becouse with old files everything is fine but after your fix it is not.


  • 0

#8 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,471 posts

Posted 19 November 2015 - 11:46 AM

Correct IIRC.



#9 Tario

Tario

    Prisoner

  • Members
  • 8 posts

Posted 19 November 2015 - 12:53 PM

Okay... Well, i tried, it didint worked still white menus.

I tried to change it few times, and it dosent let me to change this, after startup its always reverted to state without that line.

 

 

Okay i managed to fix the language thing by enabling Lang esp in files which in fact was disabled by your ini thing[becouse i was having it disabled in my game files but file was always loaded becouse falloutNv.esm and ini was scripted to use that regardless in ini file.]

 

But... White screens are still present. And of course backup dosent make any sense becouse i have to validate files regardless becouse you ini file somehow appears even after it deletion.

 

When i delete that file then start fallout normaly it will just set my settings again and... file is just back where it was, magicaly.


Edited by Tario, 19 November 2015 - 01:10 PM.

  • 0

#10 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,471 posts

Posted 19 November 2015 - 08:58 PM

Thanks for the report. I forgot how that Fallout New Vegas is a special case: it always recopies the Fallout_default.ini (located in the main Fallout New Vegas game directory) back as the Fallout.ini when you run the Fallout Launcher. Adding the line to Fallout_default.ini should fix that.



#11 Tario

Tario

    Prisoner

  • Members
  • 8 posts

Posted 20 November 2015 - 06:58 AM

I did what you said here but... Still it fixed the ini files but the same problem is still present.

Still white pip boy screen and white character creation screen.

I added archive invalidation it was in the file when launched line with language and bloadfacesxxxx was also under the general but this still dosent seem to work with your ini's.


  • 0

#12 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,471 posts

Posted 20 November 2015 - 09:47 AM

Could you post your INIs in spoiler tags?

[spoiler]
text
[/spoiler]


#13 Tario

Tario

    Prisoner

  • Members
  • 8 posts

Posted 20 November 2015 - 12:33 PM

Fallout.ini - Normal one.

FalloutPrefs

 

 

Do you also want to look at your program made one?


  • 0

#14 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,471 posts

Posted 20 November 2015 - 07:23 PM

Interesting. Maybe I'll have to install a foreign language sometime, as I thought for sure they would use the sLanguage setting to change the language, but from your INI there, it says ENGLISH.
 
To solve the language issue, it seems, add the Fallout_lang.esp line to the Fallout_default.ini in the main Fallout New Vegas game directory:

[General]
sTestFile2=FalloutNV_lang.esp

The Pipboy issue is typically caused by incorrect archive invalidation. From your INIs, modifying the following lines in Fallout_default.ini will fix that:

[Archive]
sArchiveList=Fallout - Textures.bsa, Fallout - Textures2.bsa, Fallout - Meshes.bsa, Fallout - Voices1.bsa, Fallout - Sound.bsa,  Fallout - Misc.bsa
sInvalidationFile=

Your Fallout_default.ini should look like this once you've applied these changes:

 

Fallout New Vegas is a nasty bugger the way they force copy Fallout_default.ini



#15 Tario

Tario

    Prisoner

  • Members
  • 8 posts

Posted 21 November 2015 - 01:11 AM

That one with

 

[General]
sTestFile2=FalloutNV_lang.esp

 

I know becouse i can enable that by simpli enabling esp, i think its not a big deal actualy but even if it is disabled it is activated automaticly by main fallout esm becouse of that line i think. Becouse mainly its disabled in my load order.

 

Okay, that thing with saying that my language is english where in fact it isint. Weird right? Steam version sayis en/pl/cz/ru and version says to be english but subtitles are my language always was.

I'll check later if this works and then reply


Edited by Tario, 21 November 2015 - 02:09 AM.

  • 0



Also tagged with one or more of these keywords: fallout_nv, doubleyou, ini

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users