Jump to content


Photo

STEP Mod Compilation


  • Please log in to reply
27 replies to this topic

#1 EssArrBee

EssArrBee

    Incompatibilism Manager

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,721 posts

Posted 22 November 2015 - 10:44 PM

The last few months the STEP Staff has been slowly talking about a compilation of STEP mods that can help reduce the time it takes to install STEP. This has come together recently in the form a compilation that includes ~20 mods. So far we kept it mostly secret, but now that we are getting ready to update again it is time to tell everyone what we are doing.

Right now the compilation is made up of mods that do not include plugins. Also, the mods are older and finished so they won't be getting updates. As we expand it, maybe more diverse mods will be included, but combining those into one may cause issues. Also, mods that are already compilations will not be included i.e. The Ruffled Feather, Book of Silence. The problem is getting permission. Every mod included right now either gives permission on the mod page or the author gave permission to STEP.

If you want to test out what we already have then pick it up here: STEP v2.10 dev version. Identical to the 2.2.9.1 release version with Ultimate HD Fire Effects and Ultimate HD Torch added.

The readme lists every mod included in order from the guide. It also lists every file and mod it came from. If you want to install the Extended compilation then you still need the Core compilation.

Current mod list as of STEP 2.2.9.1:



#2 elwaps

elwaps

    Commander

  • Members
  • PipPipPipPip
  • 223 posts

Posted 23 November 2015 - 06:26 AM

Sounds great! Where in the load order should we put this one? The first one is from 2D, the last one from 2L, that's why I'm asking.


  • 0

#3 Genius384

Genius384

    Guard

  • Members
  • PipPip
  • 163 posts

Posted 23 November 2015 - 10:10 AM

Very cool.  Nice work, STEP team.


  • 0

#4 EssArrBee

EssArrBee

    Incompatibilism Manager

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,721 posts

Posted 23 November 2015 - 12:26 PM

Sounds great! Where in the load order should we put this one? The first one is from 2D, the last one from 2L, that's why I'm asking.

It will be designed to install in place of the STEP Patches. The hope is to do an installer with the patches and compilation in one place to reduce the amount of downloads you need.



#5 henriquerpc

henriquerpc

    Prisoner

  • Members
  • 14 posts

Posted 23 November 2015 - 02:29 PM

Wooow!! That's awesome! 

I was thinking about how great it would be to have a mod compilation for STEP. But after realizing the amount of work it would take to get authorization and put it together, I thought it would never happen. Kudos to you guys, STEP is incredible! Thank you for the hard work!

Is this going to be a part of STEP 2.2.9.2?


  • 0

#6 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,126 posts

Posted 23 November 2015 - 02:34 PM

Yes. It's finished and we're just finalizing it in the installer now.



#7 henriquerpc

henriquerpc

    Prisoner

  • Members
  • 14 posts

Posted 23 November 2015 - 02:36 PM

Great! Thanks again


  • 0

#8 elwaps

elwaps

    Commander

  • Members
  • PipPipPipPip
  • 223 posts

Posted 23 November 2015 - 04:41 PM

Hyped for 2.2.9.2 :)


  • 0

#9 Spock

Spock

    Jarl

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 556 posts

Posted 23 November 2015 - 10:15 PM

Thank you very much for this!

 

The installer somehow doesn't let me install the extended patch though. There are also some potential issues with install order: I am currently testing parallax additioins to STEP, but Vivid landscapes for example has to be installed before trap fixes but after ruins clutter improved. Maybe placing it at the end of the texture mods might be preferrable.


  • 0

#10 EssArrBee

EssArrBee

    Incompatibilism Manager

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,721 posts

Posted 23 November 2015 - 10:23 PM

Thank you very much for this!

 

The installer somehow doesn't let me install the extended patch though. There are also some potential issues with install order: I am currently testing parallax additioins to STEP, but Vivid landscapes for example has to be installed before trap fixes but after ruins clutter improved. Maybe placing it at the end of the texture mods might be preferrable.

The Extended Patch looks for all the required mods, so you need all the dependencies for it to be available.



#11 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,126 posts

Posted 23 November 2015 - 10:26 PM

If you can't install the Patch in the new installer, then you're missing something the Patch requires. The mod compilation is specifically set up for STEP and the FOMOD requires this to be installed at the end of the Guide. It's the only place for it. There shouldn't be any issues for mods that are specifically in STEP. As always, if you add mods on top of STEP, then you'll have to figure out what you need to do for your own setup.



#12 Spock

Spock

    Jarl

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 556 posts

Posted 23 November 2015 - 10:43 PM

Hmm... the patch says there is no missing master. Does the fomod installer check for mod names or plugins?

 

I'm just saying that figuring that out might become more difficult and hinder compatibility with packs.


Edited by Spock, 23 November 2015 - 10:48 PM.

  • 0

#13 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,126 posts

Posted 23 November 2015 - 10:51 PM

Plugins. So if you've merged any of them, then that would be a reason it's not working. You also have to answer, "yes" that you did install Realistic Ragdoll & Force. The Extended Patches require:

 

  • Dawnguard.esm
  • HearthFires.esm
  • Unofficial Skyrim Legendary Edition Patch.esp
  • Clothing & Clutter Fixes.esp
  • Cutting Room Floor.esp
  • Guard Dialogue Overhaul.esp
  • Invisibility Eyes Fix.esp
  • Weapons & Armor Fixes_Remade.esp
  • Complete Crafting Overhaul_Remade.esp
  • RealisticWaterTwo.esp
  • aMidianBorn_ContentAddon.esp
  • ExplosiveBoltsVisualized.esp
  • Animated Weapon Enchants.esp
  • DeadlySpellImpacts.esp
  • dD - Enhanced Blood Main.esp
  • Book Covers Skyrim.esp
  • AOS.esp
  • Improved Combat Sounds v2.2.esp
  • ADS.esp
  • Bring Out Your Dead - Legendary Edition.esp
  • TheChoiceIsYours.esp
  • The Paarthurnax Dilemma.esp
  • BetterQuestObjectives.esp


#14 Spock

Spock

    Jarl

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 556 posts

Posted 23 November 2015 - 10:59 PM

Yep, got all those. I just tried again, it doesn't let me choose the extended options.

 

Extracting the extended patch and installing it manually works (no crashes).


Edited by Spock, 23 November 2015 - 11:04 PM.

  • 0

#15 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,126 posts

Posted 23 November 2015 - 11:15 PM

  1. Are all the mod plugin listed above checked in the right pane?
  2. Did you answer "yes" that you installed Realistic Ragdoll & Force?
  3. What version of MO are you using?
  4. Are you using the internal installer (you shouldn't see any messages about "external installer")?
  5. Are there any error messages at the bottom in the message pane?



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users