Jump to content


Photo

Super slow and clumsy wiki around 5:00pm CET


  • Please log in to reply
13 replies to this topic

#1 Kesta

Kesta

    Knight

  • Mod Author
  • Pip
  • 487 posts

Posted 05 May 2016 - 11:23 AM

I know Darth matthias also mentioned this one day, but there is a moment of th day, every day, when the wiki is ridiculously slow. The slowdown isn't that much of an issue, except that you need 3 minutes to load a page.

 

However, trying to have changes accounted for on a page at this moment is a real struggle. Needless to say that this is usually  the time when I go back home and update a few pages while eating kellogs before actually playing... ^^

 

Any idea what could be causing this, and if you can solve it on your end ?


  • 0

#2 Darth_mathias

Darth_mathias

    Emperor

  • VIP-Supporter
  • PipPipPipPipPipPipPipPipPipPipPip
  • 4,080 posts

Posted 05 May 2016 - 11:27 AM

yes it happens at around 5pm GMT been going on for awhile now wikis get ridiculously slow but forums do not. Personally I think it could be heavy traffic caused by our American cousins when they wake up and come online.


Edited by Darth_mathias, 05 May 2016 - 11:31 AM.

  • 0

#3 TechAngel85

TechAngel85

    Akatosh

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,987 posts

Posted 05 May 2016 - 11:39 AM

I don't know what causes it, but I experience it was well. This actually happens throughout the day sometimes. It could be a combination of heavy traffic and the wiki refreshing itself, which it does every so often. It makes working on the wiki a rather annoy process sometimes. I've been on it all morning doing some work.



#4 phazer11

phazer11

    High King

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 3,110 posts

Posted 05 May 2016 - 09:10 PM

You know this might have something to do with the CPU thrashing Zed mentioned.


  • 0

#5 z929669

z929669

    Ixian Inventor

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,062 posts

Posted 06 May 2016 - 04:11 PM

It is likely the daily backup or other daily routine that is causing the slowdown (5 GMT = about Midnight US time).

 

I will ask s4n to maybe run the maintenance stuff a few hours later ... not sure if this is the issue or not though right now.



#6 Darth_mathias

Darth_mathias

    Emperor

  • VIP-Supporter
  • PipPipPipPipPipPipPipPipPipPipPip
  • 4,080 posts

Posted 06 May 2016 - 04:30 PM

It is likely the daily backup or other daily routine that is causing the slowdown (5 GMT = about Midnight US time).

 

I will ask s4n to maybe run the maintenance stuff a few hours later ... not sure if this is the issue or not though right now.

personally I find more an slight annoyance then a major issue cause for me a least my wife usually get home from work at 5pm which mean i have to stop what I am doing anyway.


Edited by Darth_mathias, 06 May 2016 - 04:31 PM.

  • 0

#7 TechAngel85

TechAngel85

    Akatosh

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,987 posts

Posted 06 May 2016 - 05:51 PM

The thing is, I sometimes experience it throughout the day. When I'm off that day and working on the wiki for the day, I'll notice it at various times. Usually always happens between 11am and noon CST. The wiki becomes so unresponsive that I'll get 504 errors for 10 to 20 minutes before it returns to normal. I noticed this today, as well, before I left for work. Time out errors is telling me it's CPU load on the server.

The rest if the internet works as expected during these time frames so it'll not my ISP, either.

#8 stoppingby4now

stoppingby4now

    Sleepy

  • Founder
  • PipPipPipPipPipPip
  • 2,419 posts

Posted 06 May 2016 - 09:36 PM

I just implemented a fix to the site backups so that they won't affect Wiki performance anymore.


  • 0

#9 Kesta

Kesta

    Knight

  • Mod Author
  • Pip
  • 487 posts

Posted 07 May 2016 - 05:02 AM

Thanks  :unworthy: We'll see of this work :P

 

 

It wasn't the latency the main offender. The day I posted the thread, The whole wiki kept gaving me 504 errors for more than two hours ^^ (thankfully, it don't do that everyday, but this time was really awful).


  • 0

#10 z929669

z929669

    Ixian Inventor

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,062 posts

Posted 13 May 2016 - 09:40 AM

Any user-side updates on this? Are you experiencing any more 504 or other major slow-downs ... anyone?



#11 TechAngel85

TechAngel85

    Akatosh

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,987 posts

Posted 13 May 2016 - 09:42 AM

I haven't but I haven't been on the wiki all day since to determine that. I will say the responsiveness seems better.



#12 Darth_mathias

Darth_mathias

    Emperor

  • VIP-Supporter
  • PipPipPipPipPipPipPipPipPipPipPip
  • 4,080 posts

Posted 13 May 2016 - 09:45 AM

i've not been online much at about 5pm lately when this usually happens i'll try today and report back.


  • 0

#13 Kesta

Kesta

    Knight

  • Mod Author
  • Pip
  • 487 posts

Posted 13 May 2016 - 10:59 AM

I haven't been wikiing as much as the week when I posted the OP since then, but the few times I've edited the wiki during the "hours of doom" I didn't experience the crazy lag I used too, so it's looking good. Probably going to wiki a lot those next 3 days (long weekend  :celebration: ), so I will hopefully confirm this soon :)


  • 0

#14 Darth_mathias

Darth_mathias

    Emperor

  • VIP-Supporter
  • PipPipPipPipPipPipPipPipPipPipPip
  • 4,080 posts

Posted 13 May 2016 - 02:00 PM

everything seemed to work ok today loaded and logged in fairly quickly during the "hours of doom" as Kesta would say.


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users