Jump to content


Photo

Saving very slow because of RaceMenu


  • Please log in to reply
8 replies to this topic

#1 justfun

justfun

    Prisoner

  • Members
  • 25 posts

Posted 25 June 2016 - 07:45 PM

Recently I set up SR:LE again and added a few mods and fixes from the extended guide. Most of the things are running fine and I am having quite some fun playing the game, but there are still some issues I have to sort out.

 

A really bothersome problem is how long it takes to save the game. When doing a manual save I have to wait up to 15 seconds. I use the mod Autosave Manager to bypass the possibly buggy quicksafe function: It does manual saves in regular intervals and meanwhile pauses scripts. Saving is a little bit faster when not overwriting a save game but still too long for my system.

 

I tracked the problem down to RaceMenu and its integrated mod NetImmersive Override. After disabling the scripts and SKSE files saving worked fine again and manual saves take less than one second.

 

It may be only my setup because there are almost no topics on this issue online. Can anybody help?

 

Disabling RaceMenu would force me to revert back to XPMS from XPMSE and I would like to avoid messing around too much with my running save game.

 

Thanks!


Edited by justfun, 25 June 2016 - 07:45 PM.

  • 0

#2 reddvilzz

reddvilzz

    Jarl

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 870 posts

Posted 25 June 2016 - 09:10 PM

Maybe try removing the Autosave Manager itself to see the if it helps?
Most people don't use any auto save, even in SR:LE guide neo recommends to disable auto save and just do manually routine save.

I'm fairly new in this forum but after reading this and that any kind of auto save deemed to be bad.
  • 0

#3 Greg

Greg

    Dragonborn

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1,910 posts

Posted 25 June 2016 - 11:16 PM

Loading an autosave is believed by some to cause issues, but disabling autosave may also cause visual glitches because the engine runs some special rendering logic during the autosave that isn't run at any other time. The DynDOLOD thread has some discussion on this starting at this post.

 

This post from Groovtama goes into some detail on the reason auto and quick saves may take longer with XPMSE.



#4 justfun

justfun

    Prisoner

  • Members
  • 25 posts

Posted 26 June 2016 - 10:03 AM

The post from Groovtama is describing quicksaves but I am asking about manual saves. These take considerably more time depending on NetImmersive Override.

 

I did some more testing with my setup in one affected cell and it gets even more complicated:

 

Quicksaves do take the most time as Groovtama described, 10 seconds in this case.

 

A manual save from within the game with the mod Autosave Manager as well as the mod CASM - Cipscis' Automatic Save Manager takes about 5 seconds. There is no difference wether an existing save file is overwritten or a new one is created.

 

A manual save to a new file from the menu takes about 1 second.

 

What's strange: If do a manual save from the menu and overwrite a save file done the same way everything works fine and it once more takes 1 second. But if I choose to overwrite a manual save file done from within the game by one of the save game managers it takes as long as it would have if it is done from within the game, about 5 seconds.

 

At first I supposed manual saving from the menu is just faster because the game and its scripting is totally paused. But the different times for overwriting a save game make me ask if something different is at work and there might be another solution to be able to do fast manual saves from within the game.


Edited by justfun, 26 June 2016 - 10:04 AM.

  • 0

#5 justfun

justfun

    Prisoner

  • Members
  • 25 posts

Posted 26 June 2016 - 01:25 PM

I have to correct myself: In certain situations even manual through the menu take longer than normal. Just now in the Riften Ratway I had:

Manual save per menu: 5 seconds (to a new file as well as overwriting an old manual-per-menu save file)

Manual save per mod: 13 seconds

Quicksave: 13 seconds

 

(Without NetImmersive Override any save option takes 1 to 2 seconds.)


  • 0

#6 justfun

justfun

    Prisoner

  • Members
  • 25 posts

Posted 27 June 2016 - 11:18 AM

Did some more testing - and the surprising action of a restart of the computer did the trick. All different kinds of saves were back to normal. Left the computer running doing other things and started Skyrim up again after a few hours and saving took once again a long time.

 

Strange problem. But at least I now know how to prevent it.


Edited by justfun, 27 June 2016 - 11:19 AM.

  • 0

#7 reddvilzz

reddvilzz

    Jarl

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 870 posts

Posted 27 June 2016 - 11:52 AM

Did some more testing - and the surprising action of a restart of the computer did the trick. All different kinds of saves were back to normal. Left the computer running doing other things and started Skyrim up again after a few hours and saving took once again a long time.

Strange problem. But at least I now know how to prevent it.

Well looks like my windows 10 pc when left for a period of time it will eats ram up to 50%, checked the task manager nothing heavy application opened. The only solution is to restart.

What windows are you using?
  • 0

#8 justfun

justfun

    Prisoner

  • Members
  • 25 posts

Posted 28 June 2016 - 05:53 AM

A freshly set up Windows 10 x64. But in my case the OS does not use more RAM after running for hours than it does after a restart. I know that buggy programs can lead to memory leaks but perhaps there can be other causes too. Perhaps it is only a problem of the specific configuration of my system or my Skyrim mods. I wrote the mod author of RaceMenu a message and pointed to this thread, maybe he/she can help.


  • 0

#9 niner8167

niner8167

    Prisoner

  • Members
  • 1 posts

Posted 24 November 2018 - 01:22 AM

Did some more testing - and the surprising action of a restart of the computer did the trick. All different kinds of saves were back to normal. Left the computer running doing other things and started Skyrim up again after a few hours and saving took once again a long time.

 

Strange problem. But at least I now know how to prevent it.

 

This thread is super old now, but if it helps anyone else--I realized this issue was happening for me whenever my mod manager was open. The restart helped at first, but after about 30 minutes the issue began again. I was able to stop the issue once I closed out of my mod manager (Vortex). 


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users