Jump to content


Photo

Very strange CTD on new game start with Skyrim Unbound


Best Answer dunc001 , 15 July 2016 - 03:15 PM

UPDATE - FIXED (NEARLY...)

 

So having spent much time reading and trying various 'fixes' none of which worked, including reinstalling the DX End User Runtime (June 2010) then the DX files from the Skyrim directory, then 2010 again; various ini settings in various ini's; crash fixes 11 through 12b4; just SKSE memory patch; and so on I alighted upon THIS THREAD detailing pretty much exactly the same issues as I was having.  And I found one thing mentioned late on in the thread which I hadn't tried.  I replaced the 305 enb files with those from 262 et voila, crashes gone completely.  In every profile.  In vanilla through Steam.  Gone.

 

Now this leaves me happy that I can actually get into the game and play test, but sad because with .262 I don't have any options really for VW compatible ENBs :(

Go to the full post


  • Please log in to reply
17 replies to this topic

#1 dunc001

dunc001

    Knight

  • Citizen
  • Pip
  • 466 posts

Posted 11 July 2016 - 06:14 AM

I say very strange for several reasons, not least because for the past three months I have been building, refining and testing a huge build based off SRLE and SRLE Extended plus many worlds/quests/locations mods plus Legacy of the Dragonborn and a lot more besides.  Skyrim Unbound has been in there from the start and I have never once had a CTD on start.  I have had the occasional one during play testing at various stages entirely down to VRAM overload but nothing like what is happening now.  I am reaching out in the hope that someone far more clever than me and more well versed in dealing with CTD issues can at least point me in the direction of what might be happening.

 

THE CRASH

 

The crash now occurs every time I try to start a new game (I have no saves as I am still testing and tweaking so I delete all saves before each start).  Skyrim loads up fine, I wait patiently on the ridge above Helgen in ruins for a few minutes to let all of the MCM menus initialise, etc and once the final message disappears from the top left I enter the MCM menu > Skyrim Unbound > Start your adventure (it makes absolutely no difference what Unbound options I select, or if I pick a completely random start).  This then takes me to RaceMenu and again it makes no difference what character I create or whether I just leave it all at default and click done.  I name my character (or leave it as Prisoner/Adenturer, makes no difference) and click Accept.  Camera pans back round to the brazier, I see one or two items/spells being added in the top left and then I am firmly back on my desktop.  Every time.

 

NOW HERE'S WHERE IT GETS WEIRD

 

So I know what you're thinking.  You're looking at my modwatch and going to tell me it's script overload or an out of memory crash.  Think again.  Up until two nights ago everything was loading fine, I could start anywhere with any character - no issue.  What did I do in between times?  I edited Enhanced Landscapes Merged.esp to completely remove three worldspace blocks outside Solitude to revert them back to Vanilla in game to fix major clipping issues with Solitude Expansion.  I installed Play Random Idle, reinstalled XPMSE, reinstalled Realistic Animation Project Idles for random idle support, added CR for the Player NPC record to carry the Skyrim Unbound record forward to ensure it wasn't being overwritten by anything, added CR for the child races from RS Children to fix the shiny potato head issue caused by Height Adjusted Races, updated Crash Fixes, removed Revenge of the Enemies and all associated patches and CR, added AAE instead and added the relevant AAE patches and CR.  Reran LOOT, reran FNIS/Bashed Patch/ASIS/DSR, loaded everything up in xEdit and sorted masters on everything.  So nothing fundamental changed from the last successful start, yet now as described above it crashes every time.

 

NOW HERE's WHERE IT GETS EVEN WEIRDER

 

So after wasting an entire day removing Play Random Idle, reinstalling XPMSE again with just the options as detailed in SRLE, reinstalling RAP Idles without random support, downloading and reinstalling USLEEP, Unbound, SKSE, RaceMenu, Crash Fixes and anything else I thought might have been corrupted still with no change I decided to try unbound on a Vanilla with essentials profile.  And with absolutely NOTHING ELSE loaded I am getting exactly the same crash, every time.  This is on just the core files with USLEEP, SKSE, FISS, SkyUI, Crash Fixes, Bug Fixes, RaceMenu and Skyrim Unbound, nothing else, and all of these are fresh installs.  WTF?

 

So some more tests:

 

Vanilla esms only - Helgen>Character Creation>No crash

Vanilla esms, USLEEPSKSESkyUI, Crash Fixes, etc -  ...>No crash

As above with RaceMenu - ...>No crash

As above with Skyrim Unbound - ...>CRASH!

 

Also then tried Unbound without RaceMenu - ...>CRASH!

 

Remember this is with fresh downloads/installation of all the aforementioned files.

 

NOW THIS IS WHERE IT GETS EVEN WEIRDERER

 

So as a last resort I decided to completely delete my entire steamapps Skyrim folder and restore my Vanilla backup (yes I followed every letter of the SRLE guide so I have a backup - thanks NEO).  I then reinstalled SKSE and ENBoost (No ENB for now) and rechecked all of the ini files to ensure the correct settings.  I left the SKSE memory patch in there, the correct settings in enblocal.ini as per the Crash Fixes instructions, Crash Fixes settings as per guide. These were Vanilla esms, so recleaned them all as per SRLE.  So all is now back to a completely fresh clean setup.

 

So I load up the Vanilla Essentials profile - SKSE, USLEEP, FISS, SkyUI, Crash Fixes, Bug Fixes, RaceMenu, Skyrim Unbound - and start a new game.  This time it runs through everything and starts without a hitch, no crash.  Skyrim Unbound Completed.  All great I think breathing a huge sigh of relief.  I open up my full profile (which obviously now also benefits from the fresh reinstall of Skyrim and all of the aforementioned core files) and start a new game. And there's my desktop again.  FFS :(

 

So I switch immediately back to the Vanilla Essentials profile without changing anything, start a new game, and the crash is there again as well.  How can this be happening?  Can something in the main profile be causing some sort of corruption in one of the core files which once it's happened in the main profile then affects the Vanilla profile as well?

 

OTHER STUFF

 

I am not seeing any Crash Fixes popup messages when the crash occurs, it is instant.  Crash Fixes installed is currently 12 Beta 3.

I have papyrus logging enabled to try and catch it but I can't see anything in there at all that might give a clue (unless I'm missing something).  I am at work right now but I will upload a log to pastebin this evening.

My modwatch (in my signature) is up to date as of this morning.

There are many merged plugins in the build which obviously won't mean anything to you so I have created a Dropbox folder with screenshots of what is contained within each merge.  Each merge has been individually CR'd if required, and load order optimised pre-merge.  I like to think I know what I'm doing.  There are no errors on any of the merges when checked in xEdit with the complete load order loaded in.  Some of the merges have changed slightly since I took the screenshots but nothing fundamental.

The CR on the build is a merge of the prebuilt SRLE and SRLEX CR files with any records from plugins I'm not using removed, plus a my own CR on all of the additional stuff which took me about two weeks.  I'm fairly confident it is robust even if it's not perfect.

My system is i5 4440 @ 3.2Ghz, 16Gb RAM, GTX970 4Gb, 2x250Gb SSD (Skyrim on a dedicated SSD, nothing else), Win10

Steam overlay is disabled

No AV, just Windows Defender

MO, SKSE_loader, etc all set to run as Administrator

ParkControl active on max performance (all cores unparked)

 

I sincerely hope someone can spot something I haven't because I really need to get some sleep some time soon...


Edited by dunc001, 11 July 2016 - 06:18 AM.

  • 0

#2 Joat_Mon

Joat_Mon

    Guard

  • Guest
  • 194 posts

Posted 11 July 2016 - 08:13 AM

Crash Fixes 12.3 my be a problem, you could try 12.4 or go back to 11.


  • 0

#3 dunc001

dunc001

    Knight

  • Citizen
  • Pip
  • 466 posts

Posted 11 July 2016 - 08:21 AM

Crash Fixes 12.3 my be a problem, you could try 12.4 or go back to 11.

First thing on the list for tonight


  • 0

#4 dunc001

dunc001

    Knight

  • Citizen
  • Pip
  • 466 posts

Posted 11 July 2016 - 02:37 PM

Nope, no difference with CF v11, v12 b3 or v12 b4 - same crash.  I've posted the crash log contents in the Nexus Crash Fixes forum thread in the hope that Meh can point to something.


  • 0

#5 dunc001

dunc001

    Knight

  • Citizen
  • Pip
  • 466 posts

Posted 11 July 2016 - 03:08 PM

OK, even WEIRDERERER now - I've just tried a new start on the Vanilla Essentials profile and again with Skyrim Unbound exactly the same crash. Disable Unbound in MO and the vanilla start runs through fine, character creation with RaceMenu fine, start playing.  So then I thought I'd download Random Alternate Start and see what happens with it enabled.  As soon as I click Yes to start a new game Skyrim crashes with a Windows 'Skyrim has stopped working' popup.  WTabsoluteF?!!  It's like Skyrim is forcing me to do the Vanilla start and nothing else will do...


  • 0

#6 Nebulous112

Nebulous112

    Jarl

  • VIP-Supporter
  • PipPipPip
  • 1,450 posts

Posted 11 July 2016 - 03:16 PM

I have heard of a crash upon start like this if you have two alternate start mods installed at the same time, like Live Another Life and Skyrim Unbound.
  • 0

#7 dunc001

dunc001

    Knight

  • Citizen
  • Pip
  • 466 posts

Posted 11 July 2016 - 03:50 PM

Nope, just the one unless I'm missing something.  I've just tried on the Vanilla Essentials profile using either Random Alternate Start or Quick Start and both cause a crash at different times - RAS as soon as I click Yes to start a new game, Quick Start as soon as I try to exit the Helgen cave into Skyrim.  On my full profile I have also just tried disabling Unbound and starting a new game on the Vanilla start and it starts up fine albeit with the crazy physics on the carriage ride so I never actually get to Helgen!  But given that I was spinning above Skyrim at a hundred miles an hour and the strain that must put on my GPU it didn't crash at all.  I tried to coc Whiterun from the carriage but I died instantly :P  It's definitely an alternate start issue but why is it happening on the Vanilla profile with no other mods enabled?


Edited by dunc001, 11 July 2016 - 03:51 PM.

  • 0

#8 dunc001

dunc001

    Knight

  • Citizen
  • Pip
  • 466 posts

Posted 12 July 2016 - 06:47 PM

UPDATE

 

So after two days of uninstalling and reinstalling practically everything from scratch including redownloading Steam and Skyrim I have finally managed to track down the cause of the crashes.  However I have no solution as yet so any help would be gratefully accepted!

 

As soon as I remove d3d9.dll from the Skyrim folder the crashes are gone completely.  I can play though on a vanilla start and breathe the fresh air of freedom on exiting the cave, but as soon as I add it back in I get as far as the door to Helgen Keep and then am banished to the desktop.  I can repeat this on any profile, including alternate start mods which crash as soon as I try to use the LAL bed, etc.

 

So why has this suddenly started happening now?  I've been running the wrapper version of ENB Series 305 since day 1 (about four mounths), so why in the last two days has it started causing crashes?  I should point out that I redownloaded the ENB files several times today just to make sure.

 

I get the same results if I use the injector version too.  I have tried reinstalling he DirectX End User Runtime (June 2010) twice, i have double and triple checked my inis (ExpandSystemMemoryX64=false), I have made sure enbhost.exe is set to run as administrator.  I do however have this on the Properties for pretty much every downloaded file in my various Skyrim and tools directories:

 

YqTsujH.png

 

I'm pretty sure this wasn't there before!  I have checked my windows update history and there doesn't appear to have been an update preceding the start of my problems?  Anyway, clicking the Unblock button on everything to do with ENB still hasn't made any difference.

 

So why is d3d9.dll all of a sudden causing this problem now, and why strangely does it only cause the crash either on trying to leave the initial vanilla start location (into the keep) or when transporting from any alternate start 'room'?

 

And more importantly what, if anything, can I do about it?  Obviously, ENB aside, if i can't have d3d9.dll I can't have ENBoost or Crash Fixes UseOSAllocators=1 which is kind of a gamebreaker for me :(  I'd hate to think after four months getting to this point where I am in final play testing for this ludicrous build that at the last minute I find I am never actually going to get to play it...


Edited by dunc001, 12 July 2016 - 06:49 PM.

  • 0

#9 Nebulous112

Nebulous112

    Jarl

  • VIP-Supporter
  • PipPipPip
  • 1,450 posts

Posted 12 July 2016 - 06:56 PM

I wouldn't run enbhost.exe or anything else to do with Skyrim or MO as administrator. Having certain things run through MO as administrator (or even MO itself) can cause weird permissions issues when everything interacts together.

Also do you have your whole Steam, MO, and Skyrim Utilities folders excluded from all of your Antivirus / Antimalware?
  • 0

#10 dunc001

dunc001

    Knight

  • Citizen
  • Pip
  • 466 posts

Posted 13 July 2016 - 12:31 AM

Hmm, OK. I'll try removing run as administrator from everything. I had only set it in an attempt to get it working again though, previously only MO and TES5Edit were set to run as admin. And yes, my complete steamapps/common/Skyrim folder and my tools folder where everything else to do with Skyrim live are both excluded in my AV.

 

Edit - Nope, removing all Run As Administrator flags on all of the related exe's makes no difference.


Edited by dunc001, 13 July 2016 - 12:41 AM.

  • 0

#11 GrantSP

GrantSP

    The antipodean

  • VIP-Supporter
  • PipPipPipPipPipPipPipPipPipPipPip
  • 4,302 posts

Posted 13 July 2016 - 01:21 AM

Can you clarify something please?

You initially said:

 

 

As soon as I remove d3d9.dll from the Skyrim folder the crashes are gone completely.

but later on you then say:

 

 

I get the same results if I use the injector version too.

Since the Injector version does not use the D3D9.dll there must be something else triggering your crash and your removing that file is only coincidental.

Or did you forget to remove that file when you installed the Injector version, in which case we're back to square one.

 

What ever the case, start a vanilla game with your ENB installed, from the desktop not via MO, and see if any issues arise, if not then the problem rests in one of the mods or an INI setting perhaps. Then we can do the "load by half" method and try to pinpoint which mod is causing it.


  • 0

#12 dunc001

dunc001

    Knight

  • Citizen
  • Pip
  • 466 posts

Posted 13 July 2016 - 01:40 AM

Grant, it is absolutely nothing to do with MO or modded build load order.  I completely wiped all trace of Steam and the core Skyrim installation off my machine yesterday, then downloaded and reinstalled, Skyrim downloaded through Steam not from my DVD.  I then set it all up completely pure Vanilla.  I then launched Skyrim through Steam and played through the vanilla start right through and out of the cave, no issues whatsoever.  I then added in the three ENB files from the wrapper version and nothing else.  First of all I can't now load the save which I made outside the cave, secondly I can play through the Vanilla start but as soon as I click to open the door to Helgen keep I'm back at my desktop.  This is on pure vanilla, through Steam, freshly installed.  The ENB files are also fresh from the main ENB site, and I have redownloaded three times to rule out corruption.  As soon as I remove d3d9.dll again I can load the saves, and I can play through again.  I can also then run any of the profiles through MO including vanilla essentials with LAL and I have no crash.

 

I have also tried the injector version of the ENB files (carefully removing all the wrapper files first) and with them in I get exactly the same crash results on the vanilla game through Steam.

 

Prior to three days ago I had run many heavily modded profiles through MO with 305 wrapper and various ENBs with no issue whatsoever. 


Edited by dunc001, 13 July 2016 - 01:42 AM.

  • 0

#13 Nebulous112

Nebulous112

    Jarl

  • VIP-Supporter
  • PipPipPip
  • 1,450 posts

Posted 14 July 2016 - 05:41 PM

Just an idea...have you tried reinstalling the DX9 runtimes?
  • 0

#14 dunc001

dunc001

    Knight

  • Citizen
  • Pip
  • 466 posts

Posted 15 July 2016 - 03:15 PM   Best Answer

UPDATE - FIXED (NEARLY...)

 

So having spent much time reading and trying various 'fixes' none of which worked, including reinstalling the DX End User Runtime (June 2010) then the DX files from the Skyrim directory, then 2010 again; various ini settings in various ini's; crash fixes 11 through 12b4; just SKSE memory patch; and so on I alighted upon THIS THREAD detailing pretty much exactly the same issues as I was having.  And I found one thing mentioned late on in the thread which I hadn't tried.  I replaced the 305 enb files with those from 262 et voila, crashes gone completely.  In every profile.  In vanilla through Steam.  Gone.

 

Now this leaves me happy that I can actually get into the game and play test, but sad because with .262 I don't have any options really for VW compatible ENBs :(


  • 0

#15 reddvilzz

reddvilzz

    General

  • Citizen
  • PipPip
  • 870 posts

Posted 17 July 2016 - 01:03 AM

UPDATE - FIXED (NEARLY...)

So having spent much time reading and trying various 'fixes' none of which worked, including reinstalling the DX End User Runtime (June 2010) then the DX files from the Skyrim directory, then 2010 again; various ini settings in various ini's; crash fixes 11 through 12b4; just SKSE memory patch; and so on I alighted upon THIS THREAD detailing pretty much exactly the same issues as I was having. And I found one thing mentioned late on in the thread which I hadn't tried. I replaced the 305 enb files with those from 262 et voila, crashes gone completely. In every profile. In vanilla through Steam. Gone.

Now this leaves me happy that I can actually get into the game and play test, but sad because with .262 I don't have any options really for VW compatible ENBs :(

Sometimes I'm also having the same issue like that. But what fixed it for me is just reinstalling the enb with my enb organizer. Because if I don't reinstall the enb I will have CTD everytime my loading is finished. I'm also using enb 305
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users