Jump to content


Photo

Shadow Details vs. Performance Problem


  • Please log in to reply
17 replies to this topic

#1 Nachtfrost

Nachtfrost

    Prisoner

  • Members
  • 40 posts

Posted 10 April 2012 - 05:05 AM

Hi guys!
First of all (cause this is my first post on this forum) I wanna say that I've been following the development of STEP with great interest over the last few weeks. Therefore I want to thank The Compiler and all the supporting members of the project/forum for their effort to share the discovered enhancements for Skyrim.

I've posted the following problem already on the Nexus forum but so far I didn't get a proper solution.

[Copied from Nexus]
I have a similar problem. Yesterday I tried out Skyrim for the first
time and wanted to test out the optimal graphic settings before really
beginning to play. I only used the old 1.1 version of Skyrim with latest
graphic drivers installed. So I set everything to ultra except 4x AA
(because I don't notice a difference in-game) with 4x SSAA and Quality
Ambient Occlusion through the nVidia Control Panel. I hadn't done any
ini-tweaks or mods installed so far. I just started a new game and ran
straight to Whiterun (because I had heard that it's a good place to test
out performance). So my average FPS (with FRAPS) was 50 and never
dropping under 30. Changing single graphic settings, I quickly noticed
that changing AA, SSAA, AF or Ambient Occlusion barely affected my FPS
at all (either way). The game ran fluidly so far.

Unfortunately, when I got out of Whiterun at sunset, and when the rays
of the sun broke through the branches of a nearby tree my fps dropped to
20-22!!! I made a quicksave and changed the shadow settings from ultra
to high and gained 40 fps!!! running around the area of whiterun with up
to 80 fps. I wanna know if it's possible that this setting can cripple
my gpu so much? (I know that shadows are a big fps killer, but 40
fps???) Besides I think my rig should be able to deal with ultra
shadows. I saw youtube-videos of ppl who had the exact rig as mine and
could run everything on ultra + many graphic mods.



So here's my rig:

Windows 7 64bit

ASUS P8Z68 V-Pro

i7-2600k @3,4ghz

16 gb ram

Geforce GTX 580 1,5 gb VRAM

Corsair GS600
WD Caviar Black 500 GB



Also, I played with the native 1920x1080 resolution on a single monitor,
real time virus scan was disabled, there weren't any other programs
running in backgound (except FRAPS), energy option was set for high
performance and my gpu wasn't overheating. My overall time in-game was
estimated 30-45 minutes. I had to leave Vsync enabled to avoid too many
fps fluctuations.
[/copied from Nexus)

Added: Also the official HD Texture Pack was not installed. The game runs fine as long as the fps stay above 30 minimum. Going further down I notice a change of game pace. I'm not much of a pc expert so I hope that there is an easy explanation for the problem. (Maybe the new patches will be enough to change the problem, you think?)

I admit that I'm a little bit sad right now cause I bought this rig just 6 month ago (so shortly after Skyrim was released) for a huge amount of money. I was thinking that this would be more than enough to run Skyrim on ultra at least without mods/hd texture packs/ultra ini tweaks. Unfortunately, I get the feeling that a single graphic card can do **** these days, even if you spend money like hell for it.

Thanks already! Your work is very much appreciated!
  • 0

#2 Bealdwine

Bealdwine

    Elder STEPsman

  • Site Founders
  • PipPipPipPipPipPip
  • 364 posts

Posted 10 April 2012 - 05:29 AM

@Nachtfrost
Hi and welcome to the wacky world of Skyrim performance. I'm afraid even people with 'uber' PC kit have found that Skyrim can stretch their system resources, partly because of the nature of advanced 3d graphics and partly due to some rather poor coding and design on Bethesda's part.

I know it can be a tedious thing, but if you read through some past threads both here and on the Nexus & Official forums you will find much mention of problems incured and solutions found for these issues.

Note especially that shadows in Skyrim are rendered using the CPU (main PC processor chip) and not by the graphics card. Also that game performance can be strongly influenced by the amount of VRAM (dedicated graphics card memory) available, however your cards 1.5Gb should be sufficient until you seriously stretch it with Hi-Res texture mods.

Even on Ultra shadows in the game are very poorly handled and rendered, however some improvements to the base code of the game have been made through the Bethesda Updates and it is worth allowing the game to update - although we could argue all day over which update version is best to run at this time ;)

Personally I envy your PC rig and fps results and to be honest in your position I would simply turn FRAPS off and enjoy the game as your experience is going to be more than pleasant :) In fact you may want to limit your fps to not exceed your monitor refresh rate for the best results. Happy 'rimming :)
  • 0

#3 MadWizard25

MadWizard25

    Thane

  • Members
  • PipPipPipPipPipPip
  • 449 posts

Posted 10 April 2012 - 05:55 AM

Hey Nachtfrost and welcome to the forums! Nice rig btw *envy*

Bummer to hear about your issues. But yeah, ultra shadows will cause even the most uber rigs to squeal with pain. Its been posted before on these forums, but this set of instructions at nexus helped me gain about 10-15fps on a high shadow setting. Skyrim by default puts me on ultra, which i cant handle with all the mods, but i really cant tell the difference with this tweaked shadow setting set to high vs vanilla ultra.

https://skyrim.nexus...file.php?id=283


Other than that, take a look at the Good Performance Hunting thread on the Guides & Info subforum here, some good tips there. 40 fps loss/ gain is a huge difference though. I can imagine 20, but 40, wow. But then again, might just be your rigs setup, one of its quirks.

Also, you mention quality settings for AO, and changing that to performance didnt change your fps? I find that very strange. Jumping from performance AO to quality AO usually results in a large fps hit, even on high end cards. Are you sure your NI setting are being properly applied?

Good luck!
  • 0

#4 Nachtfrost

Nachtfrost

    Prisoner

  • Members
  • 40 posts

Posted 10 April 2012 - 03:53 PM

Well, first of all thank you! I will update Skyrim and see where it gets me. I want to install STEP anyway, so I can kiss ultra shadows away anyway, I guess. :whistling:

@MadWizard:

Also, you mention quality settings for AO, and changing that to
performance didnt change your fps? I find that very strange. Jumping
from performance AO to quality AO usually results in a large fps hit,
even on high end cards. Are you sure your NI setting are being properly
applied?

I'm not quite sure now. I didn't use nVidia inspector but the nVidia control panel. I also often pressed ALT + TAB to change these settings while the game was still running. Does the panel really apply AO then? It may be that there was a minor fps hit of 1 or 2 fps but it happened that just looking around (even in an interior area) made the fps waver +/- 3, so I can't tell the cause.

Hope that I wasn't fooled by the control panel.
  • 0

#5 Nachtfrost

Nachtfrost

    Prisoner

  • Members
  • 40 posts

Posted 10 April 2012 - 06:29 PM

Quick update and new question: Something went wrong the last time. Changing AO and SSAA affects my performance indeed. Changing both of them 1 step down to Performance/2xSSAA gets me a +18 fps increase, changing only one of them +6/7 fps. Guess I had to restart everytime. This time I also used ini-tweaks from the last STEP-release. Somehow I could not make out a performance difference between the tweaked high shadows vs. normal ultra shadows (tested only outdoor). Also, is it normal that the Skyrim launcher detects the tweaked high shadows as ultra because of the changed resolution? I discovered that Whiterun isn't a good place to test performance for me. Fps rarely dropped under the 58 fps-mark. My rig has more struggles with areas like Riverwood.
  • 0

#6 blacksol

blacksol

    Guard

  • Members
  • PipPip
  • 130 posts

Posted 10 April 2012 - 08:11 PM

Try not to use the Skyrim Launcher to tweak your settings as it resets them when you press certain buttons (and even when you open it) and so makes testing pretty hard, unless your testing default High v Ultra settings.
  • 0

#7 Nachtfrost

Nachtfrost

    Prisoner

  • Members
  • 40 posts

Posted 11 April 2012 - 02:34 AM

@blacksol: I know about that, but I didn't actually change anything in the launcher.
  • 0

#8 MadWizard25

MadWizard25

    Thane

  • Members
  • PipPipPipPipPipPip
  • 449 posts

Posted 12 April 2012 - 04:37 AM

No, your shadow should be seen as high in the skyrim launcher if you use the high shadow tweak. If its being seen as ultra, your tweaks are being overrun. And no, resolution will not have an effect on the name of the shadow quality, if your talking about screen resolution, If its shadow resolution, then 2048 should be detected as high, i think ultra defaults to 4096. If you using high shadows with 4096 shadow resolution then that might be why its being detected as ultra, that or your tweaks are being overrun. Your best bet is to tweak the ini manually, or using WB, and then totally bypass the skyrim launcher by launching via skse. That, or mark your ini's as read only before you open the launcher. Also delete the SkyrimPrefs.ini found in steam/.../common/skyrim/Skyrim folder as it can overwrite the inithat are in your Documents folder. Hope this helps!
  • 0

#9 Nachtfrost

Nachtfrost

    Prisoner

  • Members
  • 40 posts

Posted 12 April 2012 - 09:38 AM

Ok, I did all this and I assume you're right with this statement:

If you using high shadows with 4096 shadow resolution then that might be why its being detected as ultra

For me though, the tweaked high shadows are worthless then (considering performance).
  • 0

#10 Bealdwine

Bealdwine

    Elder STEPsman

  • Site Founders
  • PipPipPipPipPipPip
  • 364 posts

Posted 21 April 2012 - 11:11 AM

Just an added question on this topic. While I have learnt to live with (ignore) the terrible object shadows in the world one of the most intrusive problems I encounter is with self-shadowing. By that I mean the shadows on my character that are cast from the model or objects being carried (shield, helm, etc). These are very blocky and have a tendency to 'shimmer' in a distracting way in 3rd person view.

I can't recall seeing this in any of the many posts I've read on shadow tweaking but is there a way to disable only self-shadowing rather than all shadows displaying on the player character (so as not to lose shadow effects from other objects like buildings and trees)?
  • 0

#11 torminater

torminater

    Dragon Prince

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,222 posts

Posted 22 April 2012 - 03:53 AM

No problem. Go to your prefs.ini. Under Display add: bActorSelfShadowing=0 Should work right away. If not, then the command might be added to the ini. Just try it out. The worst that can happen is that it doesn't work!
  • 0

#12 Bealdwine

Bealdwine

    Elder STEPsman

  • Site Founders
  • PipPipPipPipPipPip
  • 364 posts

Posted 22 April 2012 - 09:26 AM

Thank you Torm I will try that once this weekend of work is over ;) I hate to remove details... very anti-step, lol, but these shadows are just too distracting.
  • 0

#13 torminater

torminater

    Dragon Prince

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,222 posts

Posted 29 April 2012 - 03:57 PM

@ Bealdwine: did this tweak work the way it should?
  • 0

#14 Vond

Vond

    Nyarlathotep

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 678 posts

Posted 29 April 2012 - 04:22 PM

I tried that option and didn't have it do anything at all sadly
  • 0

#15 torminater

torminater

    Dragon Prince

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,222 posts

Posted 29 April 2012 - 04:29 PM

then that's another useless ini tweak... -.-' IIIIIII hatem... edit: have you tried any other values? like 2? in some cases 2 means off...
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users