Jump to content


Photo

DynDOLOD Skyrim Special Edition

dyndolod lod special edition sse

  • Please log in to reply
369 replies to this topic

#361 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,276 posts

Posted 03 April 2020 - 03:05 PM

kind of, it does the quick cycling but it's much less noticeable and it's mainly on snow mounds in the distance, just a little shuddering of a white shape in the distance when I'm moving

 

If this isn't an easy fix I understand and I can live with it, just wanted some experienced eyes on it :)

Now that sounds the usual z-fighting between terrain and object LOD. Both these things are inherent to how the engine works. There are INI settings that try to affect that z-fighting, but it is better to cover that up with extra fog/clouds added by mods.


  • 0

#362 Illana

Illana

    Citizen

  • Citizen
  • 15 posts

Posted 04 April 2020 - 11:46 AM

Oh and this one has been bugging me a lot but it seems with Dyndolod enabled I crash consistently while in the Rigmor version of Cyrodil (not checked BS version yet)

 

I have a net framework crash dump if that's of any use to you


  • 0

#363 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,276 posts

Posted 04 April 2020 - 12:08 PM

Oh and this one has been bugging me a lot but it seems with Dyndolod enabled I crash consistently while in the Rigmor version of Cyrodil (not checked BS version yet)

 

I have a net framework crash dump if that's of any use to you

Q: Game: ILS or CTD
 
A: Do not use the experimental TreeFullFallBack setting without understanding what it does and what it is for. 
 
A: If heap memory is not the cause of CTD see ..DynDOLOD\Docs\DynDOLOD-README.txt for checking if a missing or invalid nif model used for dynamic LOD is the cause. 
 
A: Large load orders with many plugins might surpass the reference handle cap. SSE Engine fixes prints a warning. See https://www.reddit.c...gnosing_one_of/ Setting Temporary=1 in ..DynDOLOD\Edit Scripts\DynDOLOD\DynDOLOD_[GameMode].ini may help in these situations, however converting large new land plugins to ESM is the preferred solution. 
 
A: If there are problems saving in Skyrim Special Edition, install SSE Engine Fixes 4.8 or newer and set SaveGameMaxSize = true in the EngineFixes.ini. Alternatively add/set [SaveGame] uiCompression=1 in Skyrim.INI to change from the default 2 for LZ4 to 1 for zlib compression. 0 means no compression like games are saved in Skyrim.
 
See readme as mentioned in FAQ answers. Use the .Net Crash log to identify the cause. If for some reason it is not caused by third party meshes/plugin/mod let me know.

Edited by sheson, 04 April 2020 - 12:09 PM.

  • 0

#364 Illana

Illana

    Citizen

  • Citizen
  • 15 posts

Posted 04 April 2020 - 12:28 PM

I'm not used to reading the net crash log yet but here goes:

 

Unhandled native exception occurred at 0x7FF67821FE45 (SkyrimSE.exe+28FE45) on thread 20992! - error message

 

Possible relevant objects (3)
{
  [   0]    NiNode(Name: `Scene Root`)
  [   1]    TESObjectSTAT(FormId: 1B003BF4, File: `DynDOLOD.esm`)
  [   1]    TESObjectREFR(FormId: AA02BD36, File: `DynDOLOD.esp`, BaseForm: TESObjectSTAT(FormId: 1B003BF4, File: `DynDOLOD.esm`))
}

 

Faulting modules? Those look like base/ref ids if im not mistaken, where would these be located?

 

The logfile for the lodgen has no errors in it for RigmorCyrodil


  • 0

#365 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,276 posts

Posted 04 April 2020 - 03:11 PM

I'm not used to reading the net crash log yet but here goes:

 

Unhandled native exception occurred at 0x7FF67821FE45 (SkyrimSE.exe+28FE45) on thread 20992! - error message

 

Possible relevant objects (3)
{
  [   0]    NiNode(Name: `Scene Root`)
  [   1]    TESObjectSTAT(FormId: 1B003BF4, File: `DynDOLOD.esm`)
  [   1]    TESObjectREFR(FormId: AA02BD36, File: `DynDOLOD.esp`, BaseForm: TESObjectSTAT(FormId: 1B003BF4, File: `DynDOLOD.esm`))
}

 

Faulting modules? Those look like base/ref ids if im not mistaken, where would these be located?

 

The logfile for the lodgen has no errors in it for RigmorCyrodil

It doesn't get any better than this.

 

The NIF used by base record 1B003BF4 seems to have a NiNode root block.

 

Did you check if the DynDOLOD log contains messages like 'Root block of meshes\..\*.nif is NiNode' as explained in the DynDOLOD readme?

 

If there is no such message in the log, just look up the base record 1B003BF4 in xEdit and check what NIF it defines.

 

Convert the NiNode to a BSFadeNode with NifSkope as suggested in the DynDOLOD readme.


Edited by sheson, 04 April 2020 - 03:12 PM.

  • 0

#366 Illana

Illana

    Citizen

  • Citizen
  • 15 posts

Posted 04 April 2020 - 03:33 PM

It doesn't get any better than this.

 

The NIF used by base record 1B003BF4 seems to have a NiNode root block.

 

Did you check if the DynDOLOD log contains messages like 'Root block of meshes\..\*.nif is NiNode' as explained in the DynDOLOD readme?

 

If there is no such message in the log, just look up the base record 1B003BF4 in xEdit and check what NIF it defines.

 

Convert the NiNode to a BSFadeNode with NifSkope as suggested in the DynDOLOD readme.

Man I love it when there's such a definitive answer, will get going with this and report back

 

o7


  • 0

#367 Illana

Illana

    Citizen

  • Citizen
  • 15 posts

Posted 04 April 2020 - 04:25 PM

It doesn't get any better than this.

 

The NIF used by base record 1B003BF4 seems to have a NiNode root block.

 

Did you check if the DynDOLOD log contains messages like 'Root block of meshes\..\*.nif is NiNode' as explained in the DynDOLOD readme?

 

If there is no such message in the log, just look up the base record 1B003BF4 in xEdit and check what NIF it defines.

 

Convert the NiNode to a BSFadeNode with NifSkope as suggested in the DynDOLOD readme.

 

 

Man I love it when there's such a definitive answer, will get going with this and report back

 

o7

Ok so after investigation Dyndolod is referencing this nif:

 

bstamriel\lod\ayleid set\arbridge01_lod.nif

 

Opened up the dyndolod.esm in CK also and it threw me this error:

 

MODELS: Could not find model bstamriel\lod\ayleid set\arbridge01_lod.nif

 

I searched all my folders and unpacked the rigmor.bsa as well and there's no such folder as "bstamriel"

 

The only place I found that nif referenced was here:

 

rigmorcr\meshes\terrain\rigmor_cyrodiil\ayleidruins\arbridge01.nif

 

And this was contained in the bsa of the rigmor mod.

 

This nif is already in BSFadeNode format

 

 

So either I've done something wrong in generating the dyndolod output or maybe dyndolod is programmed with the wrong path for rigmor of cyrodil?


  • 0

#368 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,276 posts

Posted 04 April 2020 - 05:34 PM

Ok so after investigation Dyndolod is referencing this nif:
 
bstamriel\lod\ayleid set\arbridge01_lod.nif
 
Opened up the dyndolod.esm in CK also and it threw me this error:
 
MODELS: Could not find model bstamriel\lod\ayleid set\arbridge01_lod.nif
 
I searched all my folders and unpacked the rigmor.bsa as well and there's no such folder as "bstamriel"
 
The only place I found that nif referenced was here:
 
rigmorcr\meshes\terrain\rigmor_cyrodiil\ayleidruins\arbridge01.nif
 
And this was contained in the bsa of the rigmor mod.
 
This nif is already in BSFadeNode format
 
 
So either I've done something wrong in generating the dyndolod output or maybe dyndolod is programmed with the wrong path for rigmor of cyrodil?

Not sure how .Net Crash log would know that the root block is called "Scene Root" and a NiNode without actually having loaded a NIF.
 
Use the xEdit Asset Browser that is started with CTRL+F3 to search through all BSA for a file.
 
DynDOLOD only ever uses paths/file it finds or that are defined in other plugins.
 
Check the reference AA02BD36 in xEdit. It's EditorID of the form [plugin name]_[form id] will tell you the source plugin and form id - you will need to prepend the form id with the load order id of the mentioned plugin.
Check its base record and what NIF it defines.

A missing NIF can also cause CTD.

If all else fails, remove the reference(s) from DynDOLOD.esp using the base record, thought it would be better to fix the cause.

Edited by sheson, 04 April 2020 - 05:36 PM.

  • 0

#369 Illana

Illana

    Citizen

  • Citizen
  • 15 posts

Posted 05 April 2020 - 08:40 AM

Not sure how .Net Crash log would know that the root block is called "Scene Root" and a NiNode without actually having loaded a NIF.
 
Use the xEdit Asset Browser that is started with CTRL+F3 to search through all BSA for a file.
 
DynDOLOD only ever uses paths/file it finds or that are defined in other plugins.
 
Check the reference AA02BD36 in xEdit. It's EditorID of the form [plugin name]_[form id] will tell you the source plugin and form id - you will need to prepend the form id with the load order id of the mentioned plugin.
Check its base record and what NIF it defines.

A missing NIF can also cause CTD.

If all else fails, remove the reference(s) from DynDOLOD.esp using the base record, thought it would be better to fix the cause.

I'm learning so much here, never knew the ctrl f3 thing to browse bsa. Appreciate you taking the time to go through this with me.

 

I fixed the affected nifs and converted them to BSfadeNodes but now after redoing the dyndolod process (remade the textures too) I got something like "Dyndolod couldn't find master files". Then I realised I was outside in the save, went back in and back out and it's successfully initialised.

 

CTD appears to be fixed too.

 

Once again much appreciate your help here and I've learned a lot!


  • 0

#370 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,276 posts

Posted 05 April 2020 - 09:32 AM

I'm learning so much here, never knew the ctrl f3 thing to browse bsa. Appreciate you taking the time to go through this with me.

 

I fixed the affected nifs and converted them to BSfadeNodes but now after redoing the dyndolod process (remade the textures too) I got something like "Dyndolod couldn't find master files". Then I realised I was outside in the save, went back in and back out and it's successfully initialised.

 

CTD appears to be fixed too.

 

Once again much appreciate your help here and I've learned a lot!

Great that you got everything solved now. Enjoy.


  • 0



Also tagged with one or more of these keywords: dyndolod, lod, special, edition, sse

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users