Jump to content


Photo

2 Problems, texture transparency and ugly black lines - [SOLVED]


  • Please log in to reply
28 replies to this topic

#1 acindron

acindron

    Citizen

  • Members
  • Pip
  • 68 posts

Posted 10 January 2013 - 08:11 PM

Hey all, new here. I just started using Skyrim on PC and I've been trying to follow STEP to the best of my ability. I'm not really good with a lot of this stuff so your help would be much appreciated! The problem I'm having right now are texture transparencies and ugly black lines around hands (usually when have magic equipped) and sometimes elsewhere, like the sky. Here are some examples.

You can see the black lines I'm talking about here. Rather subtle but not aesthetically pleasing either.

Posted Image

And here are some shots of the texture transparency:

Posted Image

https://i.imgur.com/FS4l8.jpg



My computer is running on a NVIDIA GeForce GTX 670. It's driver is updated to the most recent, (310.90)

Below are some of my settings and mods. If you see anything else that would cause a red flag for S.T.E.P, even not regarding my graphic problems, please let me know! Again, I'm not great at this.




Looking forward to hearing from you!
Thanks so much
  • 0

#2 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,623 posts

Posted 10 January 2013 - 08:21 PM

Modify a few of your SkyrimPref.ini parameters and then check again for the the issues:

bFloatPointRenderTarget=1
bTreesReceiveShadows=1
bDrawLandShadows=1
bShadowsOnGrass=1
fGamma=1.0000

These are necessary for ENBs. If you don't like the shadow options, you can leave them on "0" but bFloatPointRenderTarget has to be set to 1. Our ENB Guide may be helpful.

EDIT: Here is how to clean your dirty mods: https://www.creation...uide_-_TES5Edit

#3 acindron

acindron

    Citizen

  • Members
  • Pip
  • 68 posts

Posted 10 January 2013 - 08:34 PM

Modify a few of your SkyrimPref.ini parameters and then check again for the the issues:

bFloatPointRenderTarget=1
bTreesReceiveShadows=1
bDrawLandShadows=1
bShadowsOnGrass=1
fGamma=1.0000

These are necessary for ENBs. If you don't like the shadow options, you can leave them on "0" but bFloatPointRenderTarget has to be set to 1.

EDIT: Here is how to clean your dirty mods: https://www.creation...uide_-_TES5Edit


Hey techangel85, thanks for the quick reply!

You know- I set those all to 1 before. I don't know how they were changed back to zero. When does Skyrim reset those values? I wonder if I have to do the entire STEP modifications over again. :(
Anyhow, I put them all back at 1 and the problems still seems to persist. Take a look here: https://i.imgur.com/U1hq7.jpg

You can still see the lines if you look close enough, and obviously the transparent hands.

p.s. Thank you for the cleaning guide! I was looking at a video on YouTube how to do that. I've been putting it off for a while now. I should really get to it.
  • 0

#4 z929669

z929669

    Ixian Inventor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,313 posts

Posted 10 January 2013 - 08:38 PM

set your ini files to read only .... Do you get the above artifacts only with ENB?

#5 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,623 posts

Posted 10 January 2013 - 08:42 PM

Hey techangel85, thanks for the quick reply!

You know- I set those all to 1 before. I don't know how they were changed back to zero. When does Skyrim reset those values? I wonder if I have to do the entire STEP modifications over again. :(
Anyhow, I put them all back at 1 and the problems still seems to persist. Take a look here: https://i.imgur.com/U1hq7.jpg

You can still see the lines if you look close enough, and obviously the transparent hands.

p.s. Thank you for the cleaning guide! I was looking at a video on YouTube how to do that. I've been putting it off for a while now. I should really get to it.

You're welcome! Skyrim will reset the INIs whenever you open the launcher and change any settings. It's recommended to change the INI files to "read-only" to prevent Skyrim from overwriting your edits. If they have been overwritten, simply go through the INI Tweaks again on the guide and then change the files to read-only.

I'm not really sure what is causing this issue though, I'll have to do some more research and get back to you unless someone with more experience chimes in. :thumbsup:

#6 acindron

acindron

    Citizen

  • Members
  • Pip
  • 68 posts

Posted 10 January 2013 - 08:49 PM

set your ini files to read only ....

Do you get the above artifacts only with ENB?

Thank you! Did that now. Re-entered all the lost values for STEP.
I never even thought about trying it without ENB. How stupid of me. It seems like the ENB IS causing the transparency issue!
But the lines are still appearing within the hands... see here: https://i.imgur.com/ybIaI.jpg

Edit: Regarding transparency, I was just viewing the Nexus thread for Project ENB and found this..

"SSAO with the ENB Series produces some graphical errors on transparent objects. Currently there is not a fix for it, but according to the developer, Mr. Boris V., a solution is possible but we don't have an ETA yet. Sorry."

Just in case anyone in the future is having this issue, there ya go. :)

Hey techangel85, thanks for the quick reply!

You know- I set those all to 1 before. I don't know how they were changed back to zero. When does Skyrim reset those values? I wonder if I have to do the entire STEP modifications over again. :(
Anyhow, I put them all back at 1 and the problems still seems to persist. Take a look here: https://i.imgur.com/U1hq7.jpg

You can still see the lines if you look close enough, and obviously the transparent hands.

p.s. Thank you for the cleaning guide! I was looking at a video on YouTube how to do that. I've been putting it off for a while now. I should really get to it.

You're welcome! Skyrim will reset the INIs whenever you open the launcher and change any settings. It's recommended to change the INI files to "read-only" to prevent Skyrim from overwriting your edits. If they have been overwritten, simply go through the INI Tweaks again on the guide and then change the files to read-only.

I'm not really sure what is causing this issue though, I'll have to do some more research and get back to you unless someone with more experience chimes in. :thumbsup:


I must have looked over that in the STEP manual. I had no idea I was supposed to set it to read-only! Thank you. :)
  • 0

#7 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,623 posts

Posted 10 January 2013 - 09:01 PM

I don't think it's in the current STEP to set the files to read-only. It will be in the next release. :)

You can disable SSAO in the enbseries.ini file if you want to keep using Project ENB. Find the [EFFECT] section and look for EnableAmbientOcclusion=true and change it to false.

Personally, I use SkyRealism with the Cinematic preset. It's a really good and stable ENB. I don't like the over-saturated colors in Project ENB. If you haven't yet, I'd highly recommend you reading through our ENB Guide. I just finished updating it.

#8 acindron

acindron

    Citizen

  • Members
  • Pip
  • 68 posts

Posted 10 January 2013 - 09:19 PM

I don't think it's in the current STEP to set the files to read-only. It will be in the next release. :)

You can disable SSAO in the enbseries.ini file if you want to keep using Project ENB. Find the [EFFECT] section and look for EnableAmbientOcclusion=true and change it to false.

Personally, I use SkyRealism with the Cinematic preset. It's a really good and stable ENB. I don't like the over-saturated colors in Project ENB. If you haven't yet, I'd highly recommend you reading through our ENB Guide. I just finished updating it.

Is that one compatible with Climates of Tamriel?
  • 0

#9 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,623 posts

Posted 10 January 2013 - 09:26 PM

Yes it is! SkyRealism is compatible with all the major lighting and weather mods; Climates of Tamriel (CoT), Realistic Lighting with Customization (RLwC), and Realistic Colors and Real Nights (RCRN). I personally use RCRN with my installation. CoT will not be a part of the STEP installation in the next release because lighting and weather mods are too personal of a choice. We'll eventually offer optional packs for these types of mods.

#10 acindron

acindron

    Citizen

  • Members
  • Pip
  • 68 posts

Posted 10 January 2013 - 09:47 PM

Yes it is! SkyRealism is compatible with all the major lighting and weather mods; Climates of Tamriel (CoT) Realistic Lighting with Customization (RLwC), and Realistic Colors and Real Nights (RCRN). I personally use RCRN with my installation. CoT will not be a part of the STEP installation in the next release because lighting and weather mods are too personal of a choice. We'll eventually offer optional packs for these types of mods.

Thanks! I'm going to try installing it now.

I really wish I knew where those ugly lines were coming from though. :( I couldn't find anything about on Nexus.


  • 0

#11 acindron

acindron

    Citizen

  • Members
  • Pip
  • 68 posts

Posted 10 January 2013 - 09:58 PM

Hey techangel, I installed it and it looks alright so far. I used the 'Warm' preset but it's a bit unsaturated and grim for me. What kind of monitor do you have? I'm wondering if I'm using the correct settings for that. I have an Asus 24" HDMI and I'm using "Standard Mode", every other mode seems a bit off for Skyrim. As far as the line artifacts go, I'm wondering if it has something to do with my anti-alias settings. Could you possibly look over them and tell me if they're alright? And should I have FXAA enabled or disabled? Thank you guys so much, you've been so helpful so far. :) Also, take a look at the texture on NPC faces: https://i.imgur.com/4zFLG.jpg Seems off... what do you think?
  • 0

#12 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,623 posts

Posted 10 January 2013 - 10:30 PM

I use a laptop for gaming so I don't really have to mess around with monitor settings. I use the cinematic preset with SkyRealism though. I've never tried to the warm preset. Cinematic seem to be a good balance of colors and vibrancy and has the most natural feel, in my opinion. As far as the artifacts and NPC goes, I'll have to look more into all your settings. I've never seen this before so you've provided a challenge.

#13 z929669

z929669

    Ixian Inventor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,313 posts

Posted 11 January 2013 - 01:00 AM

Hey techangel,

I installed it and it looks alright so far. I used the 'Warm' preset but it's a bit unsaturated and grim for me. What kind of monitor do you have? I'm wondering if I'm using the correct settings for that. I have an Asus 24" HDMI and I'm using "Standard Mode", every other mode seems a bit off for Skyrim.

I created ENB presets for use with the major lighting mods (most evolved for RLwC), including simple instructions to get set up to use ENB. Just read the description.

As far as the line artifacts go, I'm wondering if it has something to do with my anti-alias settings. Could you possibly look over them and tell me if they're alright? And should I have FXAA enabled or disabled?

You should disable FXAA and use SMAA (instuctions as above). Your driver settings should be suspect for the graphic anomolies you are eeing, unless it is mod related (i.e., do you get this in a vanilla setup?), and I use ATI graphics, so I am not privy to the Nvidia Inspector settings. For ATI, we try to leave most graphics-related settings to be application controlled. AA and AF can be matched by driver though, probably V-sync too, but I would leave that alone unless you are getting tearing.

When in doubt, revert all INIs back to default (same with Nvidia Inspector) and see if that fixes. As a last measure, revert to a clean vanilla install and test.

#14 acindron

acindron

    Citizen

  • Members
  • Pip
  • 68 posts

Posted 11 January 2013 - 01:07 AM

Thanks to you both! Will try out those options.
  • 0

#15 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,623 posts

Posted 11 January 2013 - 03:57 AM

Your nVidia Inspector settings look fine. Here are two really great guides for nvidia users: https://www.geforce....ook-even-better https://www.geforce....m-tweak-guide#1 As for your artifact issues and shadow issues on NPCs, you have a lot of none-STEP mods and many that I've never heard of...try disabling/uninstalling any of your mods that modify the NPCs and player. This includes all face meshes, hair mods, etc. Then test. If the issues are gone, re-enable the mods one by one until you find the mods that are causing the issues. If none of this works, then I would suggest you do what Z said. Return to vanilla Skyrim (no mods) and default settings in the INIs and your video card. Then start installing mods in small groups, testing after each group is installed to see when these issues return. This way you can narrow it down and find the culprit mod, INI setting, or video card setting. I can guarantee, though, if you're using the STEP INI Tweaks and only those tweaks then the INI is not the issue. This may take some work, but it's just trial and error when you're first starting out.


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users