Jump to content


Photo

2 Problems, texture transparency and ugly black lines - [SOLVED]


  • Please log in to reply
28 replies to this topic

#16 acindron

acindron

    Citizen

  • Members
  • Pip
  • 68 posts

Posted 11 January 2013 - 04:26 AM

I reset everything to vanilla. The lines were still there. All my Nvidia drivers are up to date. I don't know what the problem could possibly be. I had the problem before I updated the Nvidia driver too. Very confused at this point.
  • 0

#17 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,626 posts

Posted 11 January 2013 - 04:32 AM

Was that a complete uninstall and reinstall of Skyrim? Also, have you used DDSopt or any other texture optimizer on any of the vanilla textures? Does it happen in other games or just Skyrim?

#18 acindron

acindron

    Citizen

  • Members
  • Pip
  • 68 posts

Posted 11 January 2013 - 05:11 AM

It wasn't a complete re-install. I turned off all mods/plugins, removed all ENB files, set Nvidia game settings back to default, and I even tried using an older Nvidia driver. I'm going to do a complete uninstall/re-install now but I don't think it will fix the problem. I've uploaded a video to YouTube to show you what the problem is now. The lines aren't appearing around my hands in first person but there is definitely something wrong with them and I think it's an indication that the lines will appear again.

See here: 

Can you see the problem? It's very subtle and you'll have to look on full screen but I don't think that's normal.

BTW I've never used any texture optimizer.
  • 0

#19 acindron

acindron

    Citizen

  • Members
  • Pip
  • 68 posts

Posted 11 January 2013 - 08:13 AM

Fresh install, still have the problem... dang Re-installed all my mods, re-did STEP and now I'm dealing with this... https://i.imgur.com/RF9Ms.jpg Lines are back too if my AA is set above 2x. Something's up and it doesn't have to do with mods. But I've been trying to fix this for last 4 hours or so. :P I'm about to go insane now. Posted on Nvidia's site too. Haven't heard back. I don't understand. I have a very powerful rig here. My video card is high end. Why would it give me trouble if I set my AA to higher than 2x? I wonder if the Nvidia inspector has anything to do with it? There's so many settings in different places. I have the AA set from launcher, the anisotropic filtering as well. AA is set to 2x, anisotropic filtering is set to 16 samples (so I didn't edit that option in SkyrimPrefs.ini where you set 16 to 0 or whatever) I guess I'll give this another shot later on. I am beyond lost right now. Lol. Thanks again for your help so far.
  • 0

#20 z929669

z929669

    Ixian Inventor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,314 posts

Posted 11 January 2013 - 11:21 AM

@acindron
At this point, you need to uninstall all mods and revert to a clean vanilla install. IMPORTANT: delete your existing INIs!

If you follow the clean install procedure, you will not have the graphics glitches any more. If you do, then it is related to your hardware or your GPU drivers.

;)

#21 torminater

torminater

    Dragon Prince

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,222 posts

Posted 11 January 2013 - 12:15 PM

The black lines you are referring to popped up with I think the 1.7 update of skyrim. It's artifacting caused by light sources like fires, torches or spells. There is no fix I know for that except turning of AA. I tried hundreds of ini tweaks and couldn't get it working.
  • 0

#22 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,626 posts

Posted 11 January 2013 - 03:47 PM

I've been leaning more towards a hardware issue too. That's why I asked it there are these or other problems in other games. Are you running any other post-processors beside ENB (FXAA, SMAA, RCRN, etc). If not and torminator is correct, then turn off AA and use SMAA for now. Before than follow Z's recommendation and do a 100% clean install. If it's still an issue it's one of two things: torminator's suggestion which can be fixed by turning off AA and using SMAA (hopefully) or it's a hardware issue.

#23 acindron

acindron

    Citizen

  • Members
  • Pip
  • 68 posts

Posted 12 January 2013 - 03:02 AM

It's not like this on other games. I did a fresh install and I still have the same problems. By hardware issue do you mean that I may have a faulty video card or that my drivers may not be compatible? This video card is brand new and the temps are fine so that's a little scary to hear. I've found others who have run across the same problem but mention that it has to do with AA settings being above 4. I'm not sure where I'm supposed to set my AA settings. If I set them in Nvidia inspector, and choose override application, then what's entered in the launcher doesn't matter, right? I found this from another forum: "Hello, anyone who has an Nvidia card will get the black lines/pixals around fire and healing spells, you will also get a few black lines around burned down houses and sometimes dragons. It is an anti-aliasing problem caused by having 8xAA on, putting the game to 4xAA fixes this. I think 1.6 caused this problem. regardless of what nvidia drivers you use you will have this problem. so until nvidia or bethesda fix it just play using 4xaa. EDIT: Skyrim does support FXAA in the launcher options not through the Nvidia control panel, but i advise using 4xaa in game and using 2x supersample transparency from the nvidia control panel. If you use multisample transparency alot of NPC's are see through, this is an engine bug and cannot be fixed. Also FXAA blurs everything too much."
  • 0

#24 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,626 posts

Posted 12 January 2013 - 03:15 AM

If it's not doing it in other games then it's most likely not a hardware issue. If this is the case and AA is the problem, is the problem fixed by turning AA off? Also, if you force AA through the driver the Launcher AA should be set to 0/off. If turning off the AA does indeed fix the issue (you said you were getting it with 2x AA), then turn it off and use SMAA (https://wiki.step-pr...de:ENB#tab=SMAA) until the issue is fixed by nVidia or Bethesda. EDIT: I've done some more research and confirmed it is an AA issue with nVidia drivers since update 1.6. Most claim if you turn it down to 4x or lower that the issue is fixed. However, if you still have the issue at 2x AA with it turned off in the Launcher then do as I suggested and use SMAA. SMAA is better than FXAA and doesn't have the blur effects of FXAA either. Since SMAA doesn't use the nVidia drivers it shouldn't cause the same issue.

#25 acindron

acindron

    Citizen

  • Members
  • Pip
  • 68 posts

Posted 12 January 2013 - 10:40 AM

Do I keep regular AA on with SMAA or do I turn it off everywhere (inspector?)
 
Isn't the patch 1.8 now? If it was 1.6, you'd think they would have fixed it by now! The weird thing is I don't remember ever having these issues since building this PC back in August and I know I've used more than 8 AA in the past.

Edit: Installed SMAA, now getting CTD whenever I try to open Launcher or SKSE. Lol. I deleted my Skyrim.ini and SkyrimPrefs.ini to see if that was the problem, it wasn't. I reverted everything back to normal in Nvidia Inspector, turned off all active plugins, and verified integrity of game. Still getting CTD!

Skyrim and I aren't getting along lately. :(

PapyrusLog
[01/12/2013 - 10:53:31AM] Papyrus log opened (PC)
[01/12/2013 - 10:53:31AM] Update budget: 1.200000ms (Extra tasklet budget: 1.200000ms, Load screen budget: 500.000000ms)
[01/12/2013 - 10:53:31AM] Memory page: 128 (min) 512 (max) 76800 (max total)
Doesn't look like there was enough time for anything of value to be logged. Lol.
  • 0

#26 acindron

acindron

    Citizen

  • Members
  • Pip
  • 68 posts

Posted 12 January 2013 - 11:49 AM

Update: I think I've got it! SMAA fixed a lot of the problems! My hands are still transparent in some areas but I think that is unfixable due to SSAO with ENB. Is there a way to turn off DoF in first person so my hands don't get blurred though? You guys are terrific, btw. I'm glad I can finally play Skyrim again. :)
  • 0

#27 z929669

z929669

    Ixian Inventor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,314 posts

Posted 12 January 2013 - 12:37 PM

Update: I think I've got it! SMAA fixed a lot of the problems! My hands are still transparent in some areas but I think that is unfixable due to SSAO with ENB. Is there a way to turn off DoF in first person so my hands don't get blurred though?

You guys are terrific, btw. I'm glad I can finally play Skyrim again. :)

[EFFECT]

EnableDepthOfField=false


#28 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,626 posts

Posted 12 January 2013 - 02:47 PM

If you followed the steps on the ENB Guide for installing SMAA, your AA should be turned off via the INI edits it has you do. What Z said! You can also turn off SSAO in the same manner if it's causing too much of an issue for you: EnableAmbientOcclusion=false

#29 xxbmxx

xxbmxx

    Prisoner

  • Members
  • 1 posts

Posted 29 September 2013 - 08:30 PM

hey guys i realize this issue has already been solved, but i was having the same issue as OP and after reading everyones input, i came up with an alternate solution if one does not want to set up the MSAA with enb.  So, what i did: Completely turn off AA in the skyrim settings. Open up AMD Catalyst control center(i dont have nvidia but i would assume they have the same thing), go to the gaming section, then 3D application settings. in this window you can tell catalyst to override application settings for AA, and then simply select whatever level and method of AA you desire, click apply. And voila. You will now have as high AA as you want enabled in skyrim, but without the nasty black lines. Long story short, turn off AA in skyrim settings, open up graphics card control center and tell it to override game application settings with the settings you choose in the control center. *on a side note, i want to thank everyone who contributed with this thread, i just got a new graphics card yesterday, so naturally i went nutso with mods for skyrim. I noticed this issue and was pissed cuz i thought it was a faulty graphics card, come to find out, just another one of Bethesda's silly little bugs that everyone has come to love oh so much.
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users