Jump to content


Photo

Mesh problem : All female guard use wrong armor texture.


Best Answer azzendix , 08 December 2016 - 02:49 PM

Thanks for your help. 

 

I got an answer from user "ishmaeltheforsaken" at Nexus forum. 

https://forums.nexus...ure/?p=45438055

 

 

Okay, so, the problem was not what I had thought it was, but I did figure it out regardless. It's a relatively simple fix in the CK, but you should probably alert whoever converted the meshes, because it would be far better to fix it in the mesh.

 
The problem is that the CK expects the different parts of a mesh to be in a certain order. In the case of the guard armor, the armor itself is indexed at 0, and the body is indexed at 1.
 
The UNP meshes commit two sins: first, the indices of the armor and the body are swapped. This is the main reason the game can't swap out the texture set (in fact, it likely IS swapping out the texture set; it's just applying the new texture to the body rather than to the armor).
 
The second sin the UNP meshes commit (the far more serious one, since it's not an easy fix in NifSkope like the first issue) is that it actually breaks the armor mesh into two separate parts. The second part is the very bottom of the hauberk, where the cloth gets kind of ragged. I have no idea why this was done, but I imagine there was probably a good reason for it. Whatever that good reason was, however, it really needs to be a single model part.
 
The CK fix is to edit the ArmorAddon records to account for those two problems (and I'm gonna do that for you and upload the .esp to dropbox). But a plugin fix absolutely should not be required. This is on the original modeler to fix in a good way.
 

 

However, I found another UNP mesh replacer that working perfectly. I'm switching to use it instead of using this fix.

It is UNP Female Armors SE.

 

Thanks to both of you. Mator and TechAngel85.

Go to the full post


  • Please log in to reply
11 replies to this topic

#1 azzendix

azzendix

    Citizen

  • Citizen
  • 29 posts

Posted 07 December 2016 - 10:22 PM

Hello, I need some help.

 

I'm playing Skyrim SE on PC. 

All female guard use wrong armor texture(Stormcloak armor) after installing UNP Body Fit Armors.

Can someone give me advice to fix it? How to make it use correct texture?

 

I also uploaded 2 mesh files from that mod. (meshes\armor\stormcloaks\cuirassf_0.nif and cuirassf_1.nif)

Download link : https://ufile.io/687c7

 

Before

h4yGDrR.jpg

G6Vja4O.jpg

 

After

YypdPsl.jpg

p0wksoD.jpg


  • 0

#2 azzendix

azzendix

    Citizen

  • Citizen
  • 29 posts

Posted 07 December 2016 - 10:57 PM

I have no clue how to use NIFscope fix it. If anyone knows please help.


  • 0

#3 Mator

Mator

    General

  • Mod Author
  • PipPip
  • 625 posts

Posted 08 December 2016 - 12:02 AM

I have no clue how to use NIFscope fix it. If anyone knows please help.

It wouldn't be a NIFskope fix, it would probably be an ESP fix (in TES5Edit).  If it is actually that the guard armor meshes/textures were overwritten you can just delete the nif/dds for each armor.


  • 0

#4 azzendix

azzendix

    Citizen

  • Citizen
  • 29 posts

Posted 08 December 2016 - 12:56 AM

Thank you so much for answering me.

 

Yes, I can just delete cuirassf_0.nif,cuirassf_1.nif from that mod but I want to use these files. Any way to fix it?

I think mod author(of mesh replacer) just do something wrong with NIF files. That make it link to wrong armor texture.

 

I also uploaded mesh file from Skyrim and that mod. If you understand about nif file, Can you look at it?

Download link : https://mega.nz/#!Jg...tDS8s3DQS8r2Mdo

 

About SSEedit, This mod contains only meshes. I think it doesn't overwrite any record. 


Edited by azzendix, 08 December 2016 - 12:58 AM.

  • 0

#5 Mator

Mator

    General

  • Mod Author
  • PipPip
  • 625 posts

Posted 08 December 2016 - 01:31 AM

Oh, ok, that's possible I guess.

 

I think you could use nifskope to change the texture on the model if that is indeed the issue.  You probably want to look for the TriShape node and the diffuse texture path on it.  There may be more than one texture path.  Just expand the nif tree until you find a file path to a texture.  :)


  • 0

#6 azzendix

azzendix

    Citizen

  • Citizen
  • 29 posts

Posted 08 December 2016 - 01:53 AM

I can't see any texture name like stormcloakscuirassdawnstarf.dds(Dawnstar) or stormcloakscuirassriftenf.dds(Riften) or anything that link to female guard armor texture. 

Where should I look next?

 

Here is the screenshot from NIFscope.

4DuXjGX.png


Edited by azzendix, 08 December 2016 - 01:54 AM.

  • 0

#7 Mator

Mator

    General

  • Mod Author
  • PipPip
  • 625 posts

Posted 08 December 2016 - 03:12 AM

You checked all the BSShaderTextureSet nodes?  If so then I'm not sure.  ¯\_(ツ)_/¯

 

Sorry I can't help more, but nifskope really isn't my area of expertise.  Maybe someone else can chime in.  (you could also try posting on r/skyrimmods, the Nexus Mods forums, or the Bethesda forums)


  • 0

#8 azzendix

azzendix

    Citizen

  • Citizen
  • 29 posts

Posted 08 December 2016 - 08:38 AM

Yes, I checked all of BSShaderTextureSet nodes.

Anyway, Thanks for your help, Mator. I will post it in other places too.

 

For this topic, I still looking for any information. Please post it if you know something.


  • 0

#9 TechAngel85

TechAngel85

    Akatosh

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,936 posts

Posted 08 December 2016 - 10:43 AM

Are you using MO?

 

Nvm, this is SE. The only possible answers are:  1) a plugin is changing the mesh and/or texture paths for guard's clothing or  2) a mod is providing that texture.

 

Load your entire load order up in xEdit. You can find the armors under the Armor tree. Use Skyrim.esm and sort by Editor ID or Name to find what you're looking for more quickly. The EditorID is the armor's name in the CK. The Name is its name while in-game. Make sure nothing is changing the MOD2 - Model Filename. That's the mesh the armor will use. If it's different from Skyrim.esm, then that plugin is changing the mesh. Just look for the armors that are affected to make sure there aren't any changes on the MOD2 and MO2S records.

 

I think what you're looking for is "ArmorGuardCuirass*". If you open up the armor tree in Skyrim.esm and sort by EditorID, scroll down until you see "ArmorGuardCuirass...". There are the 8 different guard armors. All of them use the same model, but a different texture. Make sure there isn't a plugin changing the texture used.



#10 azzendix

azzendix

    Citizen

  • Citizen
  • 29 posts

Posted 08 December 2016 - 02:49 PM   Best Answer

Thanks for your help. 

 

I got an answer from user "ishmaeltheforsaken" at Nexus forum. 

https://forums.nexus...ure/?p=45438055

 

 

Okay, so, the problem was not what I had thought it was, but I did figure it out regardless. It's a relatively simple fix in the CK, but you should probably alert whoever converted the meshes, because it would be far better to fix it in the mesh.

 
The problem is that the CK expects the different parts of a mesh to be in a certain order. In the case of the guard armor, the armor itself is indexed at 0, and the body is indexed at 1.
 
The UNP meshes commit two sins: first, the indices of the armor and the body are swapped. This is the main reason the game can't swap out the texture set (in fact, it likely IS swapping out the texture set; it's just applying the new texture to the body rather than to the armor).
 
The second sin the UNP meshes commit (the far more serious one, since it's not an easy fix in NifSkope like the first issue) is that it actually breaks the armor mesh into two separate parts. The second part is the very bottom of the hauberk, where the cloth gets kind of ragged. I have no idea why this was done, but I imagine there was probably a good reason for it. Whatever that good reason was, however, it really needs to be a single model part.
 
The CK fix is to edit the ArmorAddon records to account for those two problems (and I'm gonna do that for you and upload the .esp to dropbox). But a plugin fix absolutely should not be required. This is on the original modeler to fix in a good way.
 

 

However, I found another UNP mesh replacer that working perfectly. I'm switching to use it instead of using this fix.

It is UNP Female Armors SE.

 

Thanks to both of you. Mator and TechAngel85.


  • 0

#11 TechAngel85

TechAngel85

    Akatosh

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,936 posts

Posted 08 December 2016 - 03:13 PM

Yep. That's basically the direction I was having you head. That user just skipped ahead in my troubleshooting (or got to that point himself). I had to be a mesh or record fix, but I agree that this is something which should be fixed by the author of the mod. You should take a moment to report your findings on their Nexus page.



#12 azzendix

azzendix

    Citizen

  • Citizen
  • 29 posts

Posted 08 December 2016 - 03:37 PM

Sure. I will send that link to the mod author.


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users