Jump to content


Photo

Black Circles, z-fighting and texture shimmering


  • Please log in to reply
351 replies to this topic

#346 Aegison

Aegison

    Prisoner

  • Members
  • 4 posts

Posted 11 March 2016 - 07:11 AM

OK. Got it working with your initial settings and normal load times. It turns out I had some of the threaded options enabled in the new 305 enb. Those, together with your ini settings, caused my ILS. Thanks for your help!
  • 0

#347 dropadred

dropadred

    Prisoner

  • Members
  • 6 posts

Posted 07 June 2016 - 04:35 AM

I have to admit, guys, I am tired...I have a huge problems with mountain texture flickering - especially in the Whiterun - it is just so overwhelming...so I have tried guide and I have set all values as in the guide (NearDistance 25 as well), but I cannot say it was any better in the Whiterun (leaving dragonsreach and stopping at the stairs looking on the beautiful scenery).

 

I have tried Exalerion's settings and it...kinda works...in the Whiterun it is little bit better, but still really bad (especially when I am using enhanced camera and I have head bob turned on).

When I am outside or just somewhere outside the city it is really good, yet not perfect, not with these extreme settings...

 

 

Skyrim.ini

[Display]

fNearDistance=25.0000

 

SkyrimPrefs.ini
[TerrainManager]
fTreeLoadDistance=150000.0000
fBlockMaximumDistance=1000000.0000
fBlockLevel1Distance=280000.0000
fBlockLevel0Distance=140000.0000
fSplitDistanceMult=10.0000
 
For me these settings solve the Z-Fighting issue pretty much, it's still not noiseless but none of Skyrim's distant terrain will ever be noiseless..
fNearDistance does most of the work though. When I lower it the Z-Fighting gets more noticeable again. I just cranked the TerrainManager settings up even more for better looking mountains.
But also the number and size of your texturemods causes more Z-Fighting. When playing Vanilla Skyrim, I don't see any Z-Fighting.

 

Thinking about it...maybe replacing distant LOD textures...and as far as the LOD hi-res textures go, I am using

https://www.nexusmod...rim/mods/58818/

and the highest resolution version.


  • 0

#348 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,624 posts

Posted 07 June 2016 - 05:19 AM

Skyrim Enhanced Camera will override the fNearDistance setting.

Try these settings:
[TerrainManager]
fBlockLevel0Distance=50000
fBlockLevel1Distance=72500
fBlockMaximumDistance=94000
fSplitDistanceMult=1.5


#349 dropadred

dropadred

    Prisoner

  • Members
  • 6 posts

Posted 07 June 2016 - 06:42 AM

I will try and report back..

 

In the meantime, how override ? I hava set it to 25 and I can definitely see the texture clipping as Gopher has shown in his video on the topic. I can see, I will look into the .ini file and find its near distance setting as well.

 

...

Update: I have tried it, I have deactivated the override in the EC ini file, I have set your settings and it is not gone, but better...I do not mind clipping, I have no reason to be sticked to the textures..


Edited by dropadred, 07 June 2016 - 02:35 PM.

  • 0

#350 KorruptkSwades

KorruptkSwades

    Prisoner

  • Members
  • 31 posts

Posted 28 July 2016 - 07:16 PM

I have to admit, guys, I am tired...I have a huge problems with mountain texture flickering - especially in the Whiterun - it is just so overwhelming...so I have tried guide and I have set all values as in the guide (NearDistance 25 as well), but I cannot say it was any better in the Whiterun (leaving dragonsreach and stopping at the stairs looking on the beautiful scenery).

 

I have tried Exalerion's settings and it...kinda works...in the Whiterun it is little bit better, but still really bad (especially when I am using enhanced camera and I have head bob turned on).

When I am outside or just somewhere outside the city it is really good, yet not perfect, not with these extreme settings...

 

Thinking about it...maybe replacing distant LOD textures...and as far as the LOD hi-res textures go, I am using

https://www.nexusmod...rim/mods/58818/

and the highest resolution version.

hows your fps with fTreeLoadDistance=150000.0000 ? ive  always read that fTreeLoadDistance=40k is better for killing the stutering, so ive never tried higher.


  • 0

#351 Bezado

Bezado

    Prisoner

  • Members
  • 1 posts

Posted 17 August 2016 - 01:34 AM

Hello everyone!

 

Some interesting testing and remembering a couple things might shed some more light on this mysterious Z-Fighting issue within Skyrim with the mountain flicker at distance and water.

 

So I had this issue for awhile, recently reverted back to using my ENB with some changes to the enblocal.ini where I changed the following settings to improve performance on my system because I was only getting around 30 FPS with my heavily moded Skyrim of 267 fully working no problems MODS and on Ultra settings.

 

The following changes to improve my FPS -

UseDefferedRendering=false

 

Changing the above I got much improved FPS but noticed still some flickering, so I went into my AMD driver settings and under Gaming I clicked on my previous added exe of TESV.exe ( if you do not have one add it ) and changed "Surface Format Optimization - OFF" and set Anti-Aliasing Method to Supersampling, also checked my vsync was enabled and made sure OpenGL Triple Buffering was off and Morphological Filtering OFF.  Not sure about Nvidia users (sorry AMD user here).

 

Started back up SKyrim and Viola no flickering! Now for the reverse test using enblocal.ini I set the setting back for
UseDefferedRendering=true ..............AS soon as I enabled that in enblocal.ini my game was back to flickering! So this means because my driver settings are set for use application settings the changes done to enable DefferedRendering must have turned something back on, whether it's an ENB AA option controled by the ENB or some setting within the defferedRendering it was the culprit in giving the flickering again for me at least, however;  the driver settings set as shown above and false for differedrendering I got no flicker.

 

Tested further and ENB off and driver settings set to Optimize surface format with AA or FXAA enabled resulted in the flickering again.

 

Hope my info helps on this situation.


  • 0

#352 torminater

torminater

    Dragon Prince

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,222 posts

Posted 27 October 2016 - 11:57 PM

NEW UPDATE:

I have tried the Skyrim Special Edition, and there seems to be no more z-fighting or shadow striping for me. As if that is linked to the fixes towards the shadow processing or has something to do with the new 64bit engine, I cannot say for sure. If you have further insight, please share below.

 

I've not tried any mods yet. I have heard that clutter seems to flicker a lot now, if the Unofficial patches are installed, e.g. in Dragonsreach.


  • 0


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users