Jump to content


Photo

Dynamic Distant Objects LOD - DynDOLOD for Skyrim and Enderal 2.84

dyndolod lod skyrim enderal skyrim se skyrim vr

  • Please log in to reply
429 replies to this topic

#46 mctoomies

mctoomies

    Watcher

  • Citizen
  • 5 posts

Posted 23 September 2017 - 12:03 PM

I am getting  "waiting for LODGenx64.exe to finish ..." and then "Gave up waiting for LODGen_SSE_Tamriel_Log.txt to become available. Then the Exit/save prompt comes up but the system is still running lods.

 

I am running ultra/large/custom trees and it seems to time out? I deleted everything in the cache folder for the ultra static trees but your recommendation in another post is to edit a .pas in the cache folder...not sure where to go from here.


Edited by mctoomies, 23 September 2017 - 12:07 PM.

  • 0

#47 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,439 posts

Posted 23 September 2017 - 12:08 PM

I am getting  "waiting for LODGenx64.exe to finish ..." and then "Gave up waiting for LODGen_SSE_Tamriel_Log.txt to become available. Then the Exit/save prompt comes up but the system is still running lods.

 

I am running ultra/large/custom trees and it seems to time out? I deleted everything in the cache folder for the ultra static trees but your recommendation above is to edit a .pas in the cache folder...not sure where to go from here.

If you run ultra tree LODs with full model fall back it can take an extra long time for LODGen.exe to complete the worldspace because of all the data to process. DynDOLOD just gives up waiting after a while. If you are using MO, do not close DynDOLOD.exe until all LODGen.exe finished.

 

If you bring the LODGen.exe command prompt(s) to the front you can watch it doing its thing. Once it finished, the last couple log lines should be

Log ended at ...

Code: 0

Edited by sheson, 23 September 2017 - 12:09 PM.

  • 0

#48 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,439 posts

Posted 30 September 2017 - 10:11 AM

DynDOLOD 2.33 contains the latest fixes from last test version that fixes the Exception in unit userscript line 305 and includes the latest xEdit/LODGen updates.


  • 0

#49 XenolithicYardZone

XenolithicYardZone

    Noble

  • Citizen
  • 30 posts

Posted 30 September 2017 - 01:27 PM

Hey sheson,

hoping you can help me again with your wonderful mod. 

 

Your Compatibility - Works out of the box list suggest two mods:

Perfect Whiterun

The Pines of Whiterun

Both have 1 listed next to them which stands for - Custom mesh rules included in DynDOLOD. Rules for this mod are added to the mesh rules list automatically if needed when using the 'Default', 'Low', 'Medium' or 'High' buttons.

 

Unfortunately, I can't seem to generate any LODs for either of them. Only the full 3D models pop up when I get close. I have tried both "Medium" and "High" preset while generating LODs but no luck. I am using Enhanced Vanilla Trees (custom installation) along with its corresponding billboards installed. Both mods use EVT's meshes/textures. I have followed GamerPoets detailed tutorial and my DynDOLOD output is perfect except this. I even successfully generated LOD for a personally modified version of TNF Breezehome I am using even though it isn't listed anywhere on your mod page. 

 

I switched to 2.33 today but same story. Since you've listed both mods, I am guessing LODs can be generated for them which means I am most probably doing something wrong or missing something obvious. Apologies if this has been asked before. Any help would be much appreciated. 

 

Thanks. 


Edited by XenolithicYardZone, 30 September 2017 - 01:32 PM.

  • 0

#50 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,439 posts

Posted 30 September 2017 - 02:15 PM

Hey sheson,

hoping you can help me again with your wonderful mod. 

 

Your Compatibility - Works out of the box list suggest two mods:

Perfect Whiterun

The Pines of Whiterun

Both have 1 listed next to them which stands for - Custom mesh rules included in DynDOLOD. Rules for this mod are added to the mesh rules list automatically if needed when using the 'Default', 'Low', 'Medium' or 'High' buttons.

 

Unfortunately, I can't seem to generate any LODs for either of them. Only the full 3D models pop up when I get close. I have tried both "Medium" and "High" preset while generating LODs but no luck. I am using Enhanced Vanilla Trees (custom installation) along with its corresponding billboards installed. Both mods use EVT's meshes/textures. I have followed GamerPoets detailed tutorial and my DynDOLOD output is perfect except this. I even successfully generated LOD for a personally modified version of TNF Breezehome I am using even though it isn't listed anywhere on your mod page. 

 

I switched to 2.33 today but same story. Since you've listed both mods, I am guessing LODs can be generated for them which means I am most probably doing something wrong or missing something obvious. Apologies if this has been asked before. Any help would be much appreciated. 

 

Thanks. 

If this is Skyrim, then please upload the ..DynDOLOD\Logs\DynDOLOD_TES5_log.txt

 

If this is Skyrim SE: the compatibility list and rules only apply to Skyrim. You can try renaming the TES5 rules to SSE and hope for the best.

 

The rules name have the esp plugin filename without spaces and special characters in them. For example rename

..DynDOLOD\Edit Scripts\DynDOLOD\rules\DynDOLOD_TES5_whiterunsprucebyrevan1199esp.ini to DynDOLOD_SSE_whiterunsprucebyrevan1199esp.ini

 

When clicking low, medium, high a list of loaded rules is printed to the log. You should see the plugin name in that list when things are working as they should.


Edited by sheson, 30 September 2017 - 02:16 PM.

  • 1

#51 XenolithicYardZone

XenolithicYardZone

    Noble

  • Citizen
  • 30 posts

Posted 30 September 2017 - 03:05 PM

If this is Skyrim, then please upload the ..DynDOLOD\Logs\DynDOLOD_TES5_log.txt

 

If this is Skyrim SE: the compatibility list and rules only apply to Skyrim. You can try renaming the TES5 rules to SSE and hope for the best.

 

The rules name have the esp plugin filename without spaces and special characters in them. For example rename

..DynDOLOD\Edit Scripts\DynDOLOD\rules\DynDOLOD_TES5_whiterunsprucebyrevan1199esp.ini to DynDOLOD_SSE_whiterunsprucebyrevan1199esp.ini

 

When clicking low, medium, high a list of loaded rules is printed to the log. You should see the plugin name in that list when things are working as they should.

Thanks for the reply. 

 

Good old Skyrim. Here's the log file - https://pastebin.com/Du8xCAav

 

Latest DynDOLOD run I used The Pines of Whiterun(Whiterun Ferns.esp) but I had the same issue even when I used Perfect Whiterun(Whiterunsprucebyrevan1199.esp).

 

What am I doing wrong? 


Edited by XenolithicYardZone, 30 September 2017 - 03:08 PM.

  • 0

#52 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,439 posts

Posted 30 September 2017 - 06:40 PM

 

What am I doing wrong? 

Nothing, this is a bug. Will upload new version 2.34 shortly. Uploaded the new version 2.34 which should fix that bug.


Edited by sheson, 30 September 2017 - 06:55 PM.

  • 1

#53 XenolithicYardZone

XenolithicYardZone

    Noble

  • Citizen
  • 30 posts

Posted 01 October 2017 - 02:54 AM

Nothing, this is a bug. Will upload new version 2.34 shortly. Uploaded the new version 2.34 which should fix that bug.

Brilliant. Just tried the new version with both mods and its creating LODs just fine. Only problem is that its not using EVT's billboards to generate the LODs. There's a clear color and size mismatch between the LODs generated for these two mods and the rest of the LODs generated using EVT's billboards. I am using EVT's custom large trees which both mods use. 

 

I thought the billboards from Indistinguishable Vanilla Billboards were being used to create the LODs (even though most of its billboards are overwritten by EVT's) but I still get the exact same LODs for both these mods with or w/o IVB enabled. Small, dark green vanilla looking LODs compared to EVT's large, light green LODs. 

 

How do I get DynDOLOD to use EVT's billboards to generated LODs for these mods? 


Edited by XenolithicYardZone, 01 October 2017 - 03:09 AM.

  • 0

#54 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,439 posts

Posted 01 October 2017 - 03:49 AM

Brilliant. Just tried the new version with both mods and its creating LODs just fine. Only problem is that its not using EVT's billboards to generate the LODs. There's a clear color and size mismatch between the LODs generated for these two mods and the rest of the LODs generated using EVT's billboards. I am using EVT's custom large trees which both mods use. 
 
I thought the billboards from Indistinguishable Vanilla Billboards were being used to create the LODs (even though most of its billboards are overwritten by EVT's) but I still get the exact same LODs for both these mods with or w/o IVB enabled. Small, dark green vanilla looking LODs compared to EVT's large, light green LODs. 
 
How do I get DynDOLOD to use EVT's billboards to generated LODs for these mods?


It uses the billboards that are installed. Check the log for an entry for each tree that looks like this
  
TreePineForest01 [TREE:0001306D] meshes\landscape\trees\srg_treepineforest01.nif
	Billboard found
	LOD4: textures\terrain\lodgen\skyrim.esm\srg_treepineforest01_0001306d.dds
	LOD8: textures\terrain\lodgen\skyrim.esm\srg_treepineforest01_0001306d.dds
	LOD16: textures\terrain\lodgen\skyrim.esm\srg_treepineforest01_0001306d.dds
So make sure the correct textures\terrain\lodgen\skyrim.esm\srg_treepineforest01_0001306d.dds is installed for the full model tree meshes\landscape\trees\srg_treepineforest01.nif.
In case of EVT make sure to install its billboard archive with the exact same install options as the main archive.

Also use the tree LOD brightness drop down to adjust how dark or bright tree LOD is overall.

Edited by sheson, 01 October 2017 - 05:17 AM.

  • 0

#55 XenolithicYardZone

XenolithicYardZone

    Noble

  • Citizen
  • 30 posts

Posted 01 October 2017 - 07:10 AM

It uses the billboards that are installed. Check the log for an entry for each tree that looks like this
  

TreePineForest01 [TREE:0001306D] meshes\landscape\trees\srg_treepineforest01.nif
	Billboard found
	LOD4: textures\terrain\lodgen\skyrim.esm\srg_treepineforest01_0001306d.dds
	LOD8: textures\terrain\lodgen\skyrim.esm\srg_treepineforest01_0001306d.dds
	LOD16: textures\terrain\lodgen\skyrim.esm\srg_treepineforest01_0001306d.dds
So make sure the correct textures\terrain\lodgen\skyrim.esm\srg_treepineforest01_0001306d.dds is installed for the full model tree meshes\landscape\trees\srg_treepineforest01.nif.
In case of EVT make sure to install the billboard archive with the exact same install options as the main archive.

Also use the tree LOD brightness drop down to adjust how dark or bright tree LOD is overall.

 

All TreePineForest entries in my log seem to be directed to use billboard textures from EVT. Had a look at the dds textures and they seem to match as well. As I said, this is only happening with LODs generated for these two mods. All other LODs everywhere in and around Whiterun and Skyrim in general are fine. Brightness isn't an issue elsewhere either. I left it a 0 during LOD generation and the rest of the LODs are fine. Its just the LODs generated for these two mods that are much darker and half the size but when you get close, the full tree models jump to the proper size and color of my EVT trees. 

 

Forgot to take a pic before I deleted my Dyn o/p folder. I'll try reinstalling EVT with different options and the corresponding billboards. Otherwise I'll go back to Skysight Simply Bigger Trees to check if it fixes the problem. Let you know in a bit. 

 

 


  • 0

#56 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,439 posts

Posted 01 October 2017 - 07:31 AM

All TreePineForest entries in my log seem to be directed to use billboard textures from EVT. Had a look at the dds textures and they seem to match as well. As I said, this is only happening with LODs generated for these two mods. All other LODs everywhere in and around Whiterun and Skyrim in general are fine. Brightness isn't an issue elsewhere either. I left it a 0 during LOD generation and the rest of the LODs are fine. Its just the LODs generated for these two mods that are much darker and half the size but when you get close, the full tree models jump to the proper size and color of my EVT trees. 
 
Forgot to take a pic before I deleted my Dyn o/p folder. I'll try reinstalling EVT with different options and the corresponding billboards. Otherwise I'll go back to Skysight Simply Bigger Trees to check if it fixes the problem. Let you know in a bit.


If a tree LOD does not match the full model, the wrong billboard dds/txt is installed for that full model tree - or there simply is no better billboard dds/txt available. It really is that straight forward.

The txt file defines the size among other things. For example, if you selected the "large" option of EVT when you installed the full models, you also need to select the "large" option when installing its billboards from the "billboard generator" archive.

Works for me without problem in the tests.

Edited by sheson, 01 October 2017 - 07:32 AM.

  • 0

#57 XenolithicYardZone

XenolithicYardZone

    Noble

  • Citizen
  • 30 posts

Posted 01 October 2017 - 01:46 PM

If a tree LOD does not match the full model, the wrong billboard dds/txt is installed for that full model tree - or there simply is no better billboard dds/txt available. It really is that straight forward.

The txt file defines the size among other things. For example, if you selected the "large" option of EVT when you installed the full models, you also need to select the "large" option when installing its billboards from the "billboard generator" archive.

Works for me without problem in the tests.

You're right. It should be a straight forward process but for some reason that hasn't been the case for me. I understand tree LODs have to match the full model or they won't look right. If I installed a tree mod like EVT/SSBT and used vanilla billboards, the size/color of the generated LODs would be all wrong. I get that. But that's the thing - pine trees everywhere else in my game have matching LODs so the correct billboards are indeed being used.

 

Its just the pine LODs generated for these two mods that are the problem. And they don't even have their own billboards, correct? Your rules and whichever billboards are installed are used to generate LODs for these mod, right? 

 

Anyway, I re-installed EVT with simply the large, lush trees options and nothing else. Installed the corresponding large, lush billboards. Same issue. Switched over to SSBT and its billboards. Still no luck. Here are half a dozen screenshots I took (first 4 are with EVT and the other 2 are with SSBT):

https://imgur.com/a/lNaNc

Check the size/color difference between the pine tree LODs inside Whiterun generated for Pines of Whiterun compared to the rest of the properly generated ones all around it. 


Edited by XenolithicYardZone, 01 October 2017 - 01:52 PM.

  • 0

#58 XenolithicYardZone

XenolithicYardZone

    Noble

  • Citizen
  • 30 posts

Posted 01 October 2017 - 02:06 PM

Just to add to my post above, I am also using the Whiterun Forest mod which is listed on your compatible out of the box mods list and as you can see in the pics above, LODs for its pine trees are generated just fine with both EVT's and SSBT's billboards. 


Edited by XenolithicYardZone, 01 October 2017 - 02:09 PM.

  • 0

#59 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,439 posts

Posted 01 October 2017 - 02:12 PM

Just to add to my post above, I am also using the Whiterun Forest mod which is listed on your compatible out of the box mods list and as you can see in the pics above, LODs for its pine trees are generated just fine with both EVT's and SSBT's billboards.


Upload the new log, so I can check, maybe the assignment is still not entirely correct.

Also upload ..DynDOLOD\Edit Scripts\Export\LODGen_TES5_Tamriel.txt

Edited by sheson, 01 October 2017 - 02:16 PM.

  • 0

#60 XenolithicYardZone

XenolithicYardZone

    Noble

  • Citizen
  • 30 posts

Posted 01 October 2017 - 11:21 PM

Upload the new log, so I can check, maybe the assignment is still not entirely correct.

Also upload ..DynDOLOD\Edit Scripts\Export\LODGen_TES5_Tamriel.txt

Installed DynDOLOD, DynDOLOD Resources, EVT (custom large), EVT billboards (custom large) from scratch. Medium preset selected while generating LODs. Perfect Whiterun's pine tree LODs still don't match the rest of the pine tree LODs generated using EVT's billboards. 

 

DynDOLOD log - https://pastebin.com/LQStCgze

 

LOGGen_TES5_Tamriel.text - https://mega.nz/#!km...nc7UN5g-X365SwA

Sorry, had to upload it to Mega.nz because the text file was too big for pastebin and other text uploading sites.  


Edited by XenolithicYardZone, 01 October 2017 - 11:30 PM.

  • 0



Also tagged with one or more of these keywords: dyndolod, lod, skyrim, enderal, skyrim se, skyrim vr

4 user(s) are reading this topic

0 members, 4 guests, 0 anonymous users