Jump to content


Photo

BethINI (by DoubleYou)

skyrim fallout 4 fallout new vegas fallout 3 oblivion skyrim se

  • Please log in to reply
1066 replies to this topic

#1036 Diana_TES_GotH

Diana_TES_GotH

    Jarl

  • Mod Authors
  • PipPipPipPipPipPipPipPipPip
  • 671 posts

Posted 04 June 2019 - 07:38 AM

Actually, there are only 2 for Skyrim SE. I need to remove fLightLODMaxStartFade from the tooltip for Skyrim SE. fLightLODRange goes in Skyrim.ini (or SkyrimCustom.ini) and fLightLODStartFade goes into SkyrimPrefs.ini. Add them together, you get the light fade distance.

I realize this is referencing an older post, but I am curious why BethINI is editing fLightLODStartFade in the SkyrimPrefs.ini when it is actually listed in the  Skyrim_Default.ini (SSE)? 


Edited by Diana_TES_GotH, 04 June 2019 - 07:40 AM.

  • 0

#1037 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,624 posts

Posted 04 June 2019 - 10:28 AM

I think you are confused. Skrim_Default.ini is only used in the creation of your INI files by the Launcher. So whether or not anything is in it is irrelevant. fLightLODStartFade is best in SkyrimPrefs.ini, or else the value in it will be overwritten.

#1038 Diana_TES_GotH

Diana_TES_GotH

    Jarl

  • Mod Authors
  • PipPipPipPipPipPipPipPipPip
  • 671 posts

Posted 04 June 2019 - 10:50 AM

I think you are confused. Skrim_Default.ini is only used in the creation of your INI files by the Launcher. So whether or not anything is in it is irrelevant. fLightLODStartFade is best in SkyrimPrefs.ini, or else the value in it will be overwritten.

I was just curious for the most part, but it does actually generate in my Skyrim.ini C:\Users\diana\Documents\My Games\Skyrim Special Edition when I run and complete the launcher settings.
 

 7dv9uui.png


  • 0

#1039 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,624 posts

Posted 04 June 2019 - 03:55 PM

The setting is valid as such, but it will be overwritten by the value in SkyrimPrefs.ini. See here: https://wiki.step-pr...SkyrimPrefs.ini

#1040 FlooWAP

FlooWAP

    Prisoner

  • Members
  • 2 posts

Posted 08 June 2019 - 04:23 AM

Hi, I installed (extracted) the newest BethINI Version over my older one, started it up and linked everything with MO2 which I use for Fallout 4. I am playing with english voices and text, but for some reason, after starting the game it had changed to german (my System language is german, but never changed Fallouts 4 language to german).

I looked in BethINI under the custom section and language. There something changed it to „ger“. I changed it back to „en“. Now ingame the text is english again but I have missing voices.

I haven’t installed any new mods, only change was installing the newest BethINI version.

Somebody knows, what happend here?
  • 0

#1041 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,624 posts

Posted 08 June 2019 - 10:52 AM

I need to see your INI files. Please post them in spoilers:

[spoiler]
contents of INI file
[/spoiler]


#1042 Diana_TES_GotH

Diana_TES_GotH

    Jarl

  • Mod Authors
  • PipPipPipPipPipPipPipPipPip
  • 671 posts

Posted 16 June 2019 - 12:03 AM

I am now receiving an Error! BethINI failed to safely modify your INI files! BethINI will now restore your INI files to how they were at startup

 

log.txt


Edited by Diana_TES_GotH, 16 June 2019 - 12:09 AM.

  • 0

#1043 isa

isa

    Prisoner

  • Members
  • 1 posts

Posted 16 June 2019 - 02:47 AM

I had a quick look at Diana's problems on the MO2 discord, since the problem seems to have coincided with a new development build from a few days ago.

 

The most telling test we did was to just start BethINI, then click "Default". The Skyrim.ini file then becomes a pristine copy of Skyrim_Default.ini, which doesn't look right to me. Looking at the code `Spin()` should at least be writing `sLocalSavePath` and a couple more things right after the `FileCopy`. It seems to eventually call `refreshGUI()`, which changes the `uGridsToLoad` widget, which should be picked up in BethINI.ahk to write `uGridsToLoad` under `[General]`.

 

None of that is happening. The consequence of course is that `FixINI()` then tries to readback `uGridsToLoad`, fails, and then logs the message and displays a dialog.

 

So it looks like the `FileCopy` succeeds, but the subsequent `IniWrite` fail, which I can't explain. This is complicated by the fact that BethINI has no error checking for writes, making this difficult to diagnose. It's also unclear as to why this started happening in the past few days. I'm not aware of any recent changes to MO2 that could have caused this, but I'll keep an eye out.


  • 0

#1044 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,624 posts

Posted 16 June 2019 - 05:08 AM

That log file is extremely disconcerting. It seems that a huge amount of code that should be getting executed, and that is assumed to be getting executed, is getting completely ignored. BethINI should never have worked before this time if this is the case. Are you saying that BethINI has worked for you before, Diana? If so, did you check your INI files to verify that it worked? Can you use one of the older versions of BethINI successfully? Try version 2.9. It's possible that it could be a problem with Autohotkey's updates, but I can't imagine what. At least the check worked and alerted you of the error. What version of Windows are you on, and what anti-virus are you using?

#1045 Diana_TES_GotH

Diana_TES_GotH

    Jarl

  • Mod Authors
  • PipPipPipPipPipPipPipPipPip
  • 671 posts

Posted 16 June 2019 - 12:57 PM

That log file is extremely disconcerting. It seems that a huge amount of code that should be getting executed, and that is assumed to be getting executed, is getting completely ignored. BethINI should never have worked before this time if this is the case. Are you saying that BethINI has worked for you before, Diana? If so, did you check your INI files to verify that it worked? Can you use one of the older versions of BethINI successfully? Try version 2.9. It's possible that it could be a problem with Autohotkey's updates, but I can't imagine what. At least the check worked and alerted you of the error. What version of Windows are you on, and what anti-virus are you using?

BethINI has always worked for me. AL did remind me that it may actually be an issue brought on by the latest Windows updates. I'm not certain what other programs are no longer working for me since this latest windows cumulative update.

Windows specifications: Windows 10 Pro version 1903, OS build 18362.175

Updates installed 06/11/2019 were June 11, 2019—KB4503293 (OS Build 18362.175)Security Update for Adobe Flash Player: June 11, 2019 and Windows Malicious Software Removal Tool.

 

Installed on 6/14/2019 A-Volute - SoftwareComponent - 4/15/2019 12:00:00 AM - 1.3.1.0

 

I have no other AV installed other than Windows Defender.


Edited by Diana_TES_GotH, 16 June 2019 - 01:27 PM.

  • 0

#1046 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,624 posts

Posted 16 June 2019 - 04:28 PM

Okay. That is a possibility, because the functions that are failing are core Windows functions GetPrivateProfileString and WritePrivateProfileStringA. I am on Windows 10 Pro version 1809.

 

Edit: Actually, GetPrivateProfileString is working just fine because it is reading the INI files correctly. Just the writing to the INI files is broken, WritePrivateProfileStringA.


Edited by DoubleYou, 16 June 2019 - 04:34 PM.


#1047 Diana_TES_GotH

Diana_TES_GotH

    Jarl

  • Mod Authors
  • PipPipPipPipPipPipPipPipPip
  • 671 posts

Posted 17 June 2019 - 10:20 AM

Okay. That is a possibility, because the functions that are failing are core Windows functions GetPrivateProfileString and WritePrivateProfileStringA. I am on Windows 10 Pro version 1809.

 

Edit: Actually, GetPrivateProfileString is working just fine because it is reading the INI files correctly. Just the writing to the INI files is broken, WritePrivateProfileStringA.

A clean install of Windows 10 seems to have fixed my previous issue with BethINI.


  • 0

#1048 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,624 posts

Posted 17 June 2019 - 11:09 AM

What build are you on now?

#1049 Diana_TES_GotH

Diana_TES_GotH

    Jarl

  • Mod Authors
  • PipPipPipPipPipPipPipPipPip
  • 671 posts

Posted 17 June 2019 - 08:59 PM

What build are you on now?

I'm on the exact same build: Windows 10 Pro version 1903, OS build 18362.175. It's just that this time I performed a clean install instead of settling for all the updates. It actually seems to have also fixed a bug I had when logging in to my account, my desktop would be hidden behind the Lock Screen image. So, apparently these minor issues I have been tolerating were part of a larger problem that continued to be exaccerbated with each new update.


  • 0

#1050 Naiolia

Naiolia

    Prisoner

  • Members
  • 2 posts

Posted 24 June 2019 - 11:26 PM

Hi, I am using BethINI for SSE and I would like to edit fSandboxCylinderTop and fSandboxCylinderBottom as per "Multiple Floors Sandboxing", but I can't find these values in the Custom tab (the section should be General)?

I have added them directly to my skyrim.ini and skyrimcustom.ini files, I just wanted to check that this was the correct way to add a tweak that's not listed, and to make sure there's not an important reason that it's not listed?

Thank you so much, BethINI is wonderful!


  • 0



Also tagged with one or more of these keywords: skyrim, fallout 4, fallout new vegas, fallout 3, oblivion, skyrim se

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users