Jump to content


Photo

Problem with Mod Organizer 2 and OBSE

mod organizer

  • Please log in to reply
10 replies to this topic

#1 ProNoob47

ProNoob47

    Prisoner

  • Members
  • 3 posts

Posted 02 June 2018 - 02:09 PM

I use MO2 and have some texture and mesh mods installed, some mods that require OBSE and archive invalidation invalidated.

 
Since you can't launch Steam Oblivion via obseloader.exe, I put all OBSE files into the Oblivion folder and tried the fix about going to workarounds, selecting script extender as 'load mechanism' and select Steam.exe as 'binary' with -applaunch 22330 in the 'arguments' field and launching Oblivion that way.
 
When I start through that launcher, OBSE works...but all my other mods do not get loaded into the game.
 
If I start Oblivion through MO2 with Oblivion.exe or OblivionLauncher.exe then my texture and meshes mods work but OBSE does not.
 
I also have WyreBash added to my Mod Organizer and when I start Oblivion though WyreBash, OBSE isn't working as well but my non-OBSE-dependent mods do work.
 
I simply can't get my mods and OBSE to work at the same time.
 
Does anyone know a fix?

Edited by ProNoob47, 02 June 2018 - 02:10 PM.

  • 0

#2 Greg

Greg

    Dragonborn

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1,840 posts

Posted 02 June 2018 - 10:19 PM

Unfortunately, I think this is still an open issue that has not been completely resolved yet. I think OBSE works fine from Mod Organizer 2 with the retail (CD) and GOG versions of Oblivion but it does not work with the Steam version and it may not be quite so easy to fix.



#3 baronaatista

baronaatista

    Jarl

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 576 posts

Posted 16 June 2018 - 01:34 PM

I have the GOG version and I'm trying to get everything to work but it is proving challenging... OBSE seems to work, as do plugin files (I've got Alternative Beginnings installed and running) but for some reason texture mods do not appear in-game.  

 

This is while actually launching OBSE through MO2... other methods all seem to wind up loading OBSE and no other mods.

 

I also have the standard stability section of OBSE plugins installed regularly in MO2 but not sure how to test if they're actually working.


  • 0

#4 baronaatista

baronaatista

    Jarl

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 576 posts

Posted 16 June 2018 - 02:05 PM

...I said that wrong... Oblivion launcher through MO gets me installed textures and plugin files but no OBSE.  The launcher outside MO seems to get me neither... though I'm not certain how to test if OBSE is working properly (I was using the depedency + notification in Alt. Beginnings) ... getobseversion isn't a working command?

 

Please tell me there is a way to get this working!  Bought the GOG version specifically hoping it would ease some of the OBSE / MO woes.


  • 0

#5 baronaatista

baronaatista

    Jarl

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 576 posts

Posted 16 June 2018 - 02:37 PM

Sorry for multiple posts.  Setting the load mechanism to 'script extender' in MO2 and launching OBSE through MO2 seems to have solved my issue.


  • 0

#6 krk1234

krk1234

    Prisoner

  • Members
  • 5 posts

Posted 05 August 2018 - 03:35 PM

The problem is that MO2 will not generate hook.dll in the OBSE plugin folder. You need to use MO1 to mod Oblivion if you want to use OBSE. If using MO1 and having set it to run as script extension, it will load all your mods active in MO as one big mod. All OBSE plugins will need to be installed manually.

 

Hope that helped you.


  • 0

#7 TheWickedGamer

TheWickedGamer

    Prisoner

  • Members
  • 12 posts

Posted 01 October 2018 - 05:08 PM

Found this fix for MO2, it's funky as hell, but it works:

 

https://forums.nexus...zer-2-and-obse/


  • 0

#8 Greg

Greg

    Dragonborn

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1,840 posts

Posted 01 October 2018 - 08:07 PM

There have some discussions on this by the MO2 devs and I don't think they've found a reliable workaround for it yet. I seem to recall the issue may be that obseloader or something is completing before the hooking process can even start, but this happens only with the Steam version. I seem to recall it works fine with the retail and GOG versions of Oblivion.



#9 baronaatista

baronaatista

    Jarl

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 576 posts

Posted 02 October 2018 - 12:04 PM

Appreciate the advice - I wound up getting most things to work with GOG and MO2, and was really excited... until I ran into an issue with MenuQue that I just could not solve - it wasn't able to inject .xml code or something?

 

Anyway I wound up going back to Wrye Bash, which worked flawlessly of course... until I finished the 'facelift' and was doing some testing before installing the rest of my mods.  Everything smooth as butter, I was starting to get really excited.  Only to find that I would hit a 'crash wall' after 10-20 minutes of exploring in the open world, no matter what direction I went.  

 

I really would love to play Oblivion again, I just don't have the time to pull apart my installation AGAIN and find out what's going wrong.  I'm guessing it's something memory related, but I played with settings on OSR to no avail... anyway I'm not looking for help anymore, I've given up on Oblivion for the moment and have turned my attentions back to Skyrim SE which seems to be getting moving again.  I still have my Oblivion install with WB, I might come back to it sometime.


  • 0

#10 TheWickedGamer

TheWickedGamer

    Prisoner

  • Members
  • 12 posts

Posted 06 October 2018 - 07:51 AM

Appreciate the advice - I wound up getting most things to work with GOG and MO2, and was really excited... until I ran into an issue with MenuQue that I just could not solve - it wasn't able to inject .xml code or something?

 

Anyway I wound up going back to Wrye Bash, which worked flawlessly of course... until I finished the 'facelift' and was doing some testing before installing the rest of my mods.  Everything smooth as butter, I was starting to get really excited.  Only to find that I would hit a 'crash wall' after 10-20 minutes of exploring in the open world, no matter what direction I went.  

 

I really would love to play Oblivion again, I just don't have the time to pull apart my installation AGAIN and find out what's going wrong.  I'm guessing it's something memory related, but I played with settings on OSR to no avail... anyway I'm not looking for help anymore, I've given up on Oblivion for the moment and have turned my attentions back to Skyrim SE which seems to be getting moving again.  I still have my Oblivion install with WB, I might come back to it sometime.

Back to Wrye (and OBMM for FOMODs) for me too, it just works better. As for your crashes, are you using the 4gb memory patch?

4GB Patch – NTCore


  • 0

#11 Greg

Greg

    Dragonborn

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1,840 posts

Posted 06 October 2018 - 09:55 AM

If I'm not mistaken, I think the GOG version already has the 4GB patch applied.





Also tagged with one or more of these keywords: mod organizer

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users