Jump to content


Photo

xLODGen - Terrain LOD beta for FNV, FO3, FO4, FO4VR, TES5, SSE, TES5VR, ENDERAL


  • Please log in to reply
597 replies to this topic

#586 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,366 posts

Posted 31 May 2019 - 11:11 AM

I just wanted to report that something seems to be wonky in 0.43. I created Terrain LOD with 0.43 the other day and when I did a short check I noticed that almost all diffuse texture files look like this:

dlc03farharbor.4.-1.1.dds

 

or at best like this:

dlc03farharbor.4.-1.17.dds

 

Whereas the same exact files look like this in 0.42:

dlc03farharbor.4.-1.1.dds

 

and

dlc03farharbor.4.-1.17.dds

 

There were no error messages during generation and the log didn't contain any errors either. These results can be reliably reproduced and the only change was the version of xLODGen being used, I didn't change/update any mods or changed my version of Mod Organizer 2 and I didn't change any settings within xLODGen as well.

Beta 44 should fix that. It is something that broke in xEdit itself, so that is good find.


Edited by sheson, 31 May 2019 - 11:11 AM.

  • 0

#587 El_Rizzo

El_Rizzo

    Citizen

  • Members
  • Pip
  • 86 posts

Posted 31 May 2019 - 11:57 AM

Good to know and glad I was of some help.


  • 0

#588 kranazoli

kranazoli

    Commander

  • Members
  • PipPipPipPip
  • 291 posts

Posted 01 June 2019 - 05:26 AM

Hi,

 

After 1st run, with 44 I after xLODGEN finished, I didn't have meshes folder, just textures.

Now, I am doing a 2nd turn.

 

With 43 I didn't have issue like that.

 

Is the issue at my side?!

Strange...

 

Thank You!


  • 0

#589 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,366 posts

Posted 01 June 2019 - 06:10 AM

Hi,

 

After 1st run, with 44 I after xLODGEN finished, I didn't have meshes folder, just textures.

Now, I am doing a 2nd turn.

 

With 43 I didn't have issue like that.

 

Is the issue at my side?!

Strange...

 

Thank You!

If you check the log I bet there will be some kind of message that might give us a clue.


Edited by sheson, 01 June 2019 - 06:13 AM.

  • 0

#590 kranazoli

kranazoli

    Commander

  • Members
  • PipPipPipPip
  • 291 posts

Posted 01 June 2019 - 06:21 AM

If you check the log I bet there will be some kind of message that might give us a clue.

Second turn is still working, ATM just textures folder was made.

I'll check it.

 

I get the 1st one. It's full of that kind of message:

 

"[16:24] [MarkarthWorld] Running "E:\SSE Steam - Tools\xLODGen\Edit Scripts\LODGenx64.exe" "E:\SSE Steam - Tools\xLODGen\Edit Scripts\LODGen_Terrain_MarkarthWorld.txt"
[16:24] <Error: Could not execute "E:\SSE Steam - Tools\xLODGen\Edit Scripts\LODGenx64.exe" "E:\SSE Steam - Tools\xLODGen\Edit Scripts\LODGen_Terrain_MarkarthWorld.txt">
[16:24] [MarkarthWorld] Terrain LOD meshes generation error: System Error.  Code: 2.
A rendszer nem talᬪa a megadott f᪬t"

 

Indeed. LODGenx64.exe?!

 

I have:

 

xLODGen.exe

xLODGenx64.exe

 

But, not LODGenx64.

 

Finished. The same. Just textures. Now, I'll try rename the EXE file.

 

No. My mother! I saw wrong folder...

 

"E:\SSE Steam - Tools\xLODGen\Edit Scripts\LODGenx64.exe"

 

Yes, it is there...

 

"LODGen_Terrain_MarkarthWorld.txt"

 

Also.

 

Maybe an issue, with MO2 newest Alpha version?! (I'll check with 43)


Edited by kranazoli, 01 June 2019 - 06:32 AM.

  • 0

#591 kranazoli

kranazoli

    Commander

  • Members
  • PipPipPipPip
  • 291 posts

Posted 01 June 2019 - 06:45 AM

Second turn is still working, ATM just textures folder was made.

I'll check it.

 

I get the 1st one. It's full of that kind of message:

 

"[16:24] [MarkarthWorld] Running "E:\SSE Steam - Tools\xLODGen\Edit Scripts\LODGenx64.exe" "E:\SSE Steam - Tools\xLODGen\Edit Scripts\LODGen_Terrain_MarkarthWorld.txt"
[16:24] <Error: Could not execute "E:\SSE Steam - Tools\xLODGen\Edit Scripts\LODGenx64.exe" "E:\SSE Steam - Tools\xLODGen\Edit Scripts\LODGen_Terrain_MarkarthWorld.txt">
[16:24] [MarkarthWorld] Terrain LOD meshes generation error: System Error.  Code: 2.
A rendszer nem talᬪa a megadott f᪬t"

 

Indeed. LODGenx64.exe?!

 

I have:

 

xLODGen.exe

xLODGenx64.exe

 

But, not LODGenx64.

 

Finished. The same. Just textures. Now, I'll try rename the EXE file.

 

No. My mother! I saw wrong folder...

 

"E:\SSE Steam - Tools\xLODGen\Edit Scripts\LODGenx64.exe"

 

Yes, it is there...

 

"LODGen_Terrain_MarkarthWorld.txt"

 

Also.

 

Maybe an issue, with MO2 newest Alpha version?! (I'll check with 43)

Just now started again with v43 and yet I have meshes folders. It it will okay, it's enough for me.


  • 0

#592 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,366 posts

Posted 01 June 2019 - 06:45 AM

Second turn is still working, ATM just textures folder was made.

I'll check it.

 

I get the 1st one. It's full of that kind of message:

 

"[16:24] [MarkarthWorld] Running "E:\SSE Steam - Tools\xLODGen\Edit Scripts\LODGenx64.exe" "E:\SSE Steam - Tools\xLODGen\Edit Scripts\LODGen_Terrain_MarkarthWorld.txt"
[16:24] <Error: Could not execute "E:\SSE Steam - Tools\xLODGen\Edit Scripts\LODGenx64.exe" "E:\SSE Steam - Tools\xLODGen\Edit Scripts\LODGen_Terrain_MarkarthWorld.txt">
[16:24] [MarkarthWorld] Terrain LOD meshes generation error: System Error.  Code: 2.
A rendszer nem talᬪa a megadott f᪬t"

 

Indeed. LODGenx64.exe?!

 

I have:

 

xLODGen.exe

xLODGenx64.exe

 

But, not LODGenx64.

 

Finished. The same. Just textures. Now, I'll try rename the EXE file.

 

No. My mother! I saw wrong folder...

 

"E:\SSE Steam - Tools\xLODGen\Edit Scripts\LODGenx64.exe"

 

Yes, it is there...

 

"LODGen_Terrain_MarkarthWorld.txt"

 

Also.

 

Maybe an issue, with MO2 newest Alpha version?! (I'll check with 43)

Somehow LODGenx64.exe is missing from 44. Get 45.


Edited by sheson, 01 June 2019 - 06:45 AM.

  • 0

#593 kranazoli

kranazoli

    Commander

  • Members
  • PipPipPipPip
  • 291 posts

Posted 02 June 2019 - 08:13 AM

I was away, sry!

 

Just now saw the new version. I'll try. But, you know xLODGEN it's not 15 minutes, or maybe I'll try just Tamriel...

 

Later, I will give feedback. (After work, and others)

 

But, really thanks for your support Sheson!


  • 0

#594 El_Rizzo

El_Rizzo

    Citizen

  • Members
  • Pip
  • 86 posts

Posted 02 June 2019 - 03:54 PM

 

 

Just now saw the new version. I'll try. But, you know xLODGEN it's not 15 minutes, or maybe I'll try just Tamriel...

You can always reduce your settings to speed up the process for testing or only create LOD for a chunk instead of an entire worldspace, that way you can test very fast.


  • 0

#595 ravensm

ravensm

    Prisoner

  • Members
  • 1 posts

Posted 03 June 2019 - 07:40 PM

im getting an error message when i try to run the program.

 

"Fatal: could not open registry key: \SOFTWARE\Bethesda Softworks\Fallout4\

 This can happen after Steam updates, run the game's launcher to restore registry settings"

 

the problem is that i dont have fallout 4..im running this through MO2 for Skyrim SE

 

sooo....lol help?

 

ohhh fixed it, add an argument in MO2 executables, add -SSE


Edited by ravensm, 03 June 2019 - 07:53 PM.

  • 0

#596 Mebantiza

Mebantiza

    Citizen

  • Members
  • Pip
  • 82 posts

Posted 11 June 2019 - 10:32 PM

So, here is my latest generation.  Rel 45 default settings.

Custom World Space DX1\DX5  1k/256

 

Tree Mod - Enhanced Vanilla Trees (Custom) not SSE version. 

Billboards Generated with EVT (Skyrim Classic Billboard Generator).

 

 

9-1560309277-137659771.jpeg

 

Beach texture has been changed, no longer the sandy color in subsquent images

 

 

9-1560309357-1520252710.jpeg

 

 

Finally got EVTs tree lods working properly in this worldspace. Dyndolod 2.64

 

9-1560309359-538741935.jpeg

 

 

Object LOD has no trouble displaying the Large - Long Bridge in high detail the lower right. That model was scaled between 2 - 3x its standard size in order to span that space with the one model.

 

9-1560309365-856172455.jpeg

 

This was interesting to me, as the world map now displays the current weather properly. There is a overcast rain storm in progress below, and the map shows black overcast clouds accurately. Something I have never had happen before.

 

 9-1560309369-1622630555.jpeg

 

 

General view looking Northwards.

 

 

 

 

Im probably doing all kinds of things wrong here, not an elite modder like everyone else, but, to my un-trained eye it looks ok I guess.


Edited by Mebantiza, 11 June 2019 - 10:37 PM.

  • 0

#597 Mebantiza

Mebantiza

    Citizen

  • Members
  • Pip
  • 82 posts

Posted 19 June 2019 - 06:51 PM

I have a SSE specific question regarding Tree LODs and their dimensions.

 

 
I use a billboard generator from skyrim classic to generate LODs for SSE, as it is the only available resource for my tree mod atm, and, it returned a number of files from LODgen. It is saying, not divisible by 4*. However, unlike, a 'regular' DDS, which can easily cause a CTD  with irregular dimensions, these lods, do not seem to be causing a CTD, even though they files are of all manner of irregular dimensions. 
 
Is it advisable to change the offenders to 256 x (xxx) or 128 x (xxx)? Being LODs, I have no idea if this will cause any visual issues when generating Lods off of them. Or is there some technical reason they might need to be left alone? Like I say, no CTD, but, SSE does not like irregular dimensions for DDS files, but, seems to tolerate them if they LOD DDS files, which is a new one to me.
I am unclear if I go into the source file, change the lods to SSE friendly dimensions, and then rerun the utility, if I will end up with odd looking or sized tree lods as a result.
 
 
* From SSE nif optimizers DDS scan.
 
Thanks.

  • 0

#598 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,366 posts

Posted 20 June 2019 - 01:06 AM

 

I have a SSE specific question regarding Tree LODs and their dimensions.

 

 
I use a billboard generator from skyrim classic to generate LODs for SSE, as it is the only available resource for my tree mod atm, and, it returned a number of files from LODgen. It is saying, not divisible by 4*. However, unlike, a 'regular' DDS, which can easily cause a CTD  with irregular dimensions, these lods, do not seem to be causing a CTD, even though they files are of all manner of irregular dimensions. 
 
Is it advisable to change the offenders to 256 x (xxx) or 128 x (xxx)? Being LODs, I have no idea if this will cause any visual issues when generating Lods off of them. Or is there some technical reason they might need to be left alone? Like I say, no CTD, but, SSE does not like irregular dimensions for DDS files, but, seems to tolerate them if they LOD DDS files, which is a new one to me.
I am unclear if I go into the source file, change the lods to SSE friendly dimensions, and then rerun the utility, if I will end up with odd looking or sized tree lods as a result.
 
 
* From SSE nif optimizers DDS scan.
 
Thanks.

 

Billboard textures are LOD assets that are never used directly but always being put on a texture atlas if things work correctly.

The texture atlas has the correct dimensions.


  • 0


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users