Jump to content


Photo

FNIS and Mod Organizer 2, error 5.

fnis mo2 skyrim

  • Please log in to reply
9 replies to this topic

#1 Kagemanden

Kagemanden

    Prisoner

  • Members
  • 6 posts

Posted 12 August 2018 - 02:04 AM

Hello, I am yet another of the minority that is cursed with the error 5 when using Mod Organizer 2 and FNIS

 

 

This is the error in question: Error  5  Access to path 'D:\Spil og Steam\steamapps\common\Skyrim\data\tools\GenerateFNIS_for_Users\MyPatches.txt' denied

 

I've tried to mess around with the admin rights...I've tried to mess around with the security, UAC and the antivirus (I use bitdefender and malwarebytes. Yes two, sue me.)

No other program besides FNIS have any issues running as an executable. I've tried to pick through every thread I can find for any solution, but I've yet to find a working one for me. If anyone is able to provide me with guidance, then I'd gladly accept.

 

Oh and none of my folders are placed in the program files.

 

 

EDIT: For some reason I cannot upload the logs.


Edited by Kagemanden, 12 August 2018 - 02:06 AM.

  • 0

#2 Greg

Greg

    Dragonborn

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1,867 posts

Posted 12 August 2018 - 10:23 AM

The first question is whether you are really getting access denied because you don't have rights to the file or whether you are getting access denied because the antivirus software has the file locked while it slowly grinds through double scans? To find out, disable both bitdefender and malwarebytes (just turn them completely off) and try again.

 

Note that I suggest removing anything related to FNIS from any "FNIS output" mods, overwrite, and the game's data folder and then reinstalling FNIS to start clean. I recommend this because any files that were created by the last run may be owned by Administrators and you may not have rights to these files. I also want to clean up everything so that none of the generated files interfere with a new run and to ensure none of the standard FNIS files have been modified in any way.

 

If you are thinking about running anything as administrator, I suggest you reconsider. I recommend running everything as a standard user because you don't need admin rights to run the game or any of the tools. Also note that if you run anything from Mod Organizer as an administrator, Mod Organizer must also run as an administrator or Windows blocks the virtual file system hooks.

 

Are you using the FNSI RedirectFiles option? This is theoretically the recommended way to run GenerateFNISForUsers, but I was never able to get it to work reliably. This isn't directly related to your issue, but I couldn't get FNIS to find any animations when using the RedirectFiles option.



#3 Kagemanden

Kagemanden

    Prisoner

  • Members
  • 6 posts

Posted 13 August 2018 - 12:29 AM

Thank you for taking the time to look at my issue Greg. I've tried turning both bitdefender and malwarebytes off, but this did not seem to fix the issue. I've tried completely emptying the overwrite and re-installing FNIS. I've tried the FNIS Redirect option, but it did not seem to have any effect.

 

I just tried to do all of the things you suggested at once and it has changed that I'm now able to interact somewhat with the FNIS exe, but as I try to generate the files I now get the ERROR(5): Access to path 'D:\Spil og Steam\steamapps\common\Skyrim\data\tools\GenerateFNIS_for_Users\temporary_logs\skeleton.hkx' was denied.

 

It was definitely something in the overwrite causing the last issue though.


  • 0

#4 Kagemanden

Kagemanden

    Prisoner

  • Members
  • 6 posts

Posted 13 August 2018 - 01:01 AM

I missed around more a little bit and now I've received this error: Generator: D:\Spil og steam\Mod Organizer\mods\FNIS Behavior\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe

>>Warning: Bad installation. Generator not run from <Skyrim_Data>\Tools\GenerateFNIS_for_Users. If you use a mod manager, run FNIS from its list of supported tools.<<
Skyrim 32bit: ??.??.?? - D:\Spil og steam\steamapps\common\Skyrim\ (Steam)
Expected generator path: D:\Spil og steam\steamapps\common\Skyrim\data\tools\GenerateFNIS_for_Users
 
I'm fairly certain you install it correctly by installing it like any other mod in MO2, or am I wrong? Then adding it as an executable.
 
Also FNIS can't locate any files.

  • 0

#5 Greg

Greg

    Dragonborn

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1,867 posts

Posted 14 August 2018 - 05:22 PM

Yes, you should install FNIS in Mod Organizer just like any other mod. After it's installed, you can go to the Data tab in the right pane, scroll down to find Generate FNIS For Users.exe, right click, and Add As Executable or something like that.

 

You might also try moving Mod Organizer out of the Steam folder. I know the virtual file system does not work correctly if Mod Organizer is installed in the Skyrim folder and there have been a few odd reports that it might not work correctly if it's installed in the Steam folder. Steam and Skyrim should be fine where you have them so you might try something like D:\Tools\ModOrganizer to see if this helps.

 

This is how I have FNIS configured in the Modify Executables dialog:

 

Title: GenerateFNISforUsers

Binary: D:\Tools\ModOrganizer\mods\FNIS Behavior\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe

Start in: D:\Tools\ModOrganizer\mods\FNIS Behavior\

Arguments:

 

That is, the Argument option is blank and the Start in option should point to the base FNIS folder. In my case I named the mod FNIS Behavior.



#6 Kagemanden

Kagemanden

    Prisoner

  • Members
  • 6 posts

Posted 17 August 2018 - 06:53 AM

Now I'm back to square one, honestly it seems to me the only option I have left is to re-install everything. Windows 10 has messed up an essential part too much for me to be able to revert it, is my guess.


  • 0

#7 Kagemanden

Kagemanden

    Prisoner

  • Members
  • 6 posts

Posted 18 August 2018 - 02:13 AM

I fixed it. I'm going to put the fix here, so everyone else might be able to use it as a guide if they have the same issue as I do.

 

Essentially, first thing to do is disable your antivirus when doing this (could also try just adding an exclusion/exception rule). Then what I did was that I first disabled all mods in MO2, then I slowly enabled them one at a time. Everytime I enabled a mod I ran FNIS to check whether or not it was causing the error. What I learned from this was that the only fix to this issue is to simply delete ALL of the mods that FNIS might've tried interacting or reading. If you don't, then you'll still get the error. ALL MODS that have anything to do with animations NEEDS to be deleted and re-downloaded, including FNIS itself. Even skeleton mods like XPMSE (I think that's what it's called) needs to be deleted and downloaded again. If you have a mod that manages animations, then it needs to be deleted and downloaded again. You also need to get rid of all the FNIS files in the overwrite. (Or just move overwrite, then have FNIS write files, then move overwrite back and say no to all.)


Edited by Kagemanden, 18 August 2018 - 02:16 AM.

  • 0

#8 Greg

Greg

    Dragonborn

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1,867 posts

Posted 18 August 2018 - 08:35 PM

I just read my original post and what I wrote isn't clear at all so I apologize for this.

 

The issue you are running into is most likely because GenerateFNISForUsers is overwriting the files in the original skeleton and animation mods so these mods must be installed fresh before you run GenerateFNISForUsers. Apparently this affects some users but not others, although it may depend on the specific mods installed. I do know that Fore added the RedirectFiles option to force all writes into a dedicated folder and this is the recommended way to run GenerateFNISForUsers, but I have not been able to get this to work correctly. The way this should work is as follows:

  1. Double click the FNIS mod, go into the FileTree tab, and rename fnis.ini0 to fnis.ini
  2. Close the dialog
  3. Double click the FNIS mod, go to the INI files tab, and edit fnis.ini
  4. Change 'RedirectFiles=... to RedirectFiles=C:\ModOrganizer\mods\FNIS_Output
  5. Close the dialog
  6. Create an empty FNIS_Output mod and ensure this mod is not checked
  7. Run GenerateFNISForUsers and you see a line stating the RedirectFiles option is enabled
  8. When GenerateFNISForUsers completes, verify FNIS_Output contains all the files and activate the mod

When I follow the steps above, GenerateFNISForUsers seems to run normally but it does not detect any animations for some reason. If I disable the RedirectFiles option, GenerateFNISForUsers detects and generates all the animations just fine with the caveat that I have to remember to reinstall all animation and skeleton mods from scratch if I need to run GenerateFNISForUsers again.



#9 Kagemanden

Kagemanden

    Prisoner

  • Members
  • 6 posts

Posted 23 August 2018 - 02:47 AM

That's odd, I did exactly those steps and it worked fine for me. I've found that, that method tends to be a good alternative if your overwrite is messed up. What I did was that I basically created a new mod with all of my overwrite files, then did the FNIS_Output and made it have a higher priority than the newly created mod with my overwrite files. Are you remembering to remove ' from redirectfiles? So it's no longer 'commented'.


Edited by Kagemanden, 23 August 2018 - 02:47 AM.

  • 0

#10 Project579

Project579

    Prisoner

  • Members
  • 42 posts

Posted 01 September 2018 - 04:12 AM

You can also run FNIS in MO2 without touching anything and it will work.


  • 0



Also tagged with one or more of these keywords: fnis, mo2, skyrim

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users