Jump to content


Photo

FNIS won't run


  • Please log in to reply
26 replies to this topic

#1 hardtroll

hardtroll

    Guard

  • Members
  • PipPip
  • 152 posts

Posted 12 November 2018 - 10:28 AM

1st = I was not sure about where to post this topic, so if o moderator think it is the wrong place, he can move it or tell me to move it the the correct section.

 

Well, after 2 week of following Nordic Guide (long time cause I read almost  everything on mods and forum about compatibility....etc), I am close to the end and my game is very nice looking, almost 4k, smooth running and with the gameplay I WANT !!!

 

But now I have a problem with FNIS. I installed the mod as told in the gamer poet video, then run FNIS 1st time = everything was good. I generate the patch. Then I do other staff, finish some texture picking....etc

 

Now I try to repatch. But BOOM, FNIS won't run again. WHY ???? After different try, I uninstall it, and re-install it, but that time, FNIS won't run at the first time !!! I post here a pics of MO2,     so you can see messages at the bottom of the image.

Very annoying.

 

What can make FNIS not running ?


  • 0

#2 Shadriss

Shadriss

    High King

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,495 posts

Posted 12 November 2018 - 01:07 PM

Well, can we start by having the pics you promised? :) Hard to troubleshoot the messages if we can't see them.


  • 0

#3 hardtroll

hardtroll

    Guard

  • Members
  • PipPip
  • 152 posts

Posted 12 November 2018 - 07:41 PM

Well, can we start by having the pics you promised? :) Hard to troubleshoot the messages if we can't see them.

AAARRRGGG,  sorry !!! here it is =  http://image.noelsha...035925-fnis.jpg


  • 0

#4 Greg

Greg

    Dragon Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,024 posts

Posted 12 November 2018 - 09:17 PM

Open the FNIS mod and select the INI-Files tab. Do you have InstantExecute=1 or 'InstantExecute=1 in fnis.ini? If you see 'InstantExecute=1 (the line starts with a single quote), the option is commented out so you can ignore it. If the single quote isn't present at the start of the line, you enabled the option to run GenerateFNIS_for_Users without the UI -- meaning it just runs, tries to generate the animations, and exits. This may not be the issue, but it's a place to start.

 

Do you have moddrop client installed? I just read a note on the FNIS page stating that FNIS checks whether you have the moddrop client installed. If you do, FNIS aborts the first time you run it with an appropriate warning but it refuses to run again until you uninstall the moddrrop client, uninstall FNIS, clean up all FNIS-related data, and reinstall FNIS fresh.



#5 hardtroll

hardtroll

    Guard

  • Members
  • PipPip
  • 152 posts

Posted 12 November 2018 - 10:19 PM

Open the FNIS mod and select the INI-Files tab. Do you have InstantExecute=1 or 'InstantExecute=1 in fnis.ini? If you see 'InstantExecute=1 (the line starts with a single quote), the option is commented out so you can ignore it. If the single quote isn't present at the start of the line, you enabled the option to run GenerateFNIS_for_Users without the UI -- meaning it just runs, tries to generate the animations, and exits. This may not be the issue, but it's a place to start.

 

Do you have moddrop client installed? I just read a note on the FNIS page stating that FNIS checks whether you have the moddrop client installed. If you do, FNIS aborts the first time you run it with an appropriate warning but it refuses to run again until you uninstall the moddrrop client, uninstall FNIS, clean up all FNIS-related data, and reinstall FNIS fresh.

Well, I am not sure to find the fnis.ini. Here is the pic where I look http://image.noelsha...42079040-aa.jpg

Have FNIS.ini0 file, impossible to read. You can check the way on the top of the pic. I think this is the correct position ?

 

I don't yhink I have moddrop client, let me check


  • 0

#6 hardtroll

hardtroll

    Guard

  • Members
  • PipPip
  • 152 posts

Posted 12 November 2018 - 10:32 PM

after check, I never install moddrop


  • 0

#7 hardtroll

hardtroll

    Guard

  • Members
  • PipPip
  • 152 posts

Posted 13 November 2018 - 12:07 AM

Well, I am not sure to find the fnis.ini. Here is the pic where I look http://image.noelsha...42079040-aa.jpg

Have FNIS.ini0 file, impossible to read. You can check the way on the top of the pic. I think this is the correct position ?

 

I don't yhink I have moddrop client, let me check

After some research,  I double click on FNIS behavior SE in the left MO2 panel, and click ini-files tab......there is nothing inside !!! No fnis.ini 

So...........as I checked before, (see post above), the FNIS.ini0 file maybe something wrong; no ?? How to clear this and have ini files work correctly ?


  • 0

#8 hardtroll

hardtroll

    Guard

  • Members
  • PipPip
  • 152 posts

Posted 13 November 2018 - 12:54 AM

ok. After reading another post about this (and where Greg was the main helper too ! ) , I rename FNIS.ini0 to FNIS.ini. 'FNIS ini file. Also I change a line as mentionned in this post and do RedirectFiles=E:\SteamLibrary\steamapps\common\MO2\mods\FNIS_Output, wich I am not very sure to be coorect. ROGHT NOW, if I go to the initab, I see the FNIS.ini and is like this =

'

'IMPORTANT: To take effect, this file (FNIS.ini0) has to be copied MANUALLY to Skyrim\Data\FNIS.ini. Then edit FNIS.ini.

'For NMM Virtual Install or MO users: FNIS.ini has to go to "real" SKYRIM\Data (NOT inside the virtual mod folders!)

'Note: All lines starting with ' are comments. To activate a parameter you have to remove the apostrophe (e.g. "PSCD=1")

'

'PSCD implements "Proper Spell Cast Direction" fix based on www.nexusmods.com/skyrim/mods/68794

'That allows the player to cast spells or shoot arrows even if the target is VERY well above or below

'Downside: when using camera mods or certain animation replacers, the bending might look unnatural

'Users who want the vanilla bend limits rather then the PSCD fix can switch this fix off here (PSCD=0)

'Default PSCD=0 (DO NOT use "Proper Spell Cast Direction")

'

'PSCD=1

'

'File Redirection allows you to put FNIS generated files into a seperate folder (should be outside of the Skyrim "Data")

'This supports different profiles in MO (and Vortex?)

'The following parameter defines the root directory for the resultant files. For example

'Default (no file redirection possible)

'

RedirectFiles=E:\SteamLibrary\steamapps\common\MO2\mods\FNIS_Output

'

'Instant Execution will run FNIS without having to click either "Update FNIS Behavior" or "Exit".

'The FNIS window will only pop up if FNIS has to report error or warnings.

'This is a feature primarily for Vortex, but can be used otherwise.

'It is recommended that you use this feature only from a windows .bat file, because otherwise you will not see when FNIS is done.

'Default (regular windows operation)

'

'InstantExecute=1

 

But FNIS still not running

Make me crazy !!!!!!!!!!


  • 0

#9 hardtroll

hardtroll

    Guard

  • Members
  • PipPip
  • 152 posts

Posted 13 November 2018 - 10:01 PM

Open the FNIS mod and select the INI-Files tab. Do you have InstantExecute=1 or 'InstantExecute=1 in fnis.ini? If you see 'InstantExecute=1 (the line starts with a single quote), the option is commented out so you can ignore it. If the single quote isn't present at the start of the line, you enabled the option to run GenerateFNIS_for_Users without the UI -- meaning it just runs, tries to generate the animations, and exits. This may not be the issue, but it's a place to start.

 

Do you have moddrop client installed? I just read a note on the FNIS page stating that FNIS checks whether you have the moddrop client installed. If you do, FNIS aborts the first time you run it with an appropriate warning but it refuses to run again until you uninstall the moddrrop client, uninstall FNIS, clean up all FNIS-related data, and reinstall FNIS fresh.

I am running out of solution now .....!! I really can't see why FNIS is not rtunning. Just try to open and it exit. No error message......feel lost !


  • 0

#10 Greg

Greg

    Dragon Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,024 posts

Posted 13 November 2018 - 10:17 PM

Have you tried running it outside of Mod Organizer to see if you can get the UI? I should also mention that you really don't need fnis.ini so you can leave it named as fnis.ini0. The only reason you'd rename it to fnis.ini is if you want to override any of the settings.



#11 hardtroll

hardtroll

    Guard

  • Members
  • PipPip
  • 152 posts

Posted 13 November 2018 - 10:23 PM

Have you tried running it outside of Mod Organizer to see if you can get the UI? I should also mention that you really don't need fnis.ini so you can leave it named as fnis.ini0. The only reason you'd rename it to fnis.ini is if you want to override any of the settings.

 

 

The very 1st time I run it, 6 days ago maybe it works. Only one time ( I got the window FNIS, like in the video and follow everything).

 

Well ho to run it out of MO, not sure to understand ?


Edited by hardtroll, 13 November 2018 - 10:28 PM.

  • 0

#12 hardtroll

hardtroll

    Guard

  • Members
  • PipPip
  • 152 posts

Posted 13 November 2018 - 10:38 PM

AWell I just un'installed FNIS, reinstall it, and still same. Something seems happen, but won't launch. And no error message .....


Have you tried running it outside of Mod Organizer to see if you can get the UI? I should also mention that you really don't need fnis.ini so you can leave it named as fnis.ini0. The only reason you'd rename it to fnis.ini is if you want to override any of the settings.

OK. I have been the the MO2/mods/FNIS folder, and open FNIS.exe and I got the FNIS yellow window !!! So It is something related to MO2 ?


here is a link of the opened FNIS window and FNIS path    http://image.noelsha...7-fnis-prob.jpg


  • 0

#13 hardtroll

hardtroll

    Guard

  • Members
  • PipPip
  • 152 posts

Posted 13 November 2018 - 10:56 PM

Have you tried running it outside of Mod Organizer to see if you can get the UI? I should also mention that you really don't need fnis.ini so you can leave it named as fnis.ini0. The only reason you'd rename it to fnis.ini is if you want to override any of the settings.

Another useful information. When I go to data panel in MO, tolls, generateFNISforuseres, then FNISuser exe (as in the video) and add as executable it no work. But if I try the option open/execute, .....it is not working too ! So i can run it from the mo2 folder, but not from the mo2 app....ununderstanble. What should I do ? (I want FNIS to be able to install Pretty combat animation, but I can play the game now, no CTD)


  • 0

#14 hardtroll

hardtroll

    Guard

  • Members
  • PipPip
  • 152 posts

Posted 14 November 2018 - 11:49 PM

Well, can we start by having the pics you promised? :) Hard to troubleshoot the messages if we can't see them.

If you have time to look....I am running out of solution !!!


  • 0

#15 Shadriss

Shadriss

    High King

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,495 posts

Posted 16 November 2018 - 10:30 AM

1st = I was not sure about where to post this topic, so if o moderator think it is the wrong place, he can move it or tell me to move it the the correct section.

 

Well, after 2 week of following Nordic Guide (long time cause I read almost  everything on mods and forum about compatibility....etc), I am close to the end and my game is very nice looking, almost 4k, smooth running and with the gameplay I WANT !!!

 

But now I have a problem with FNIS. I installed the mod as told in the gamer poet video, then run FNIS 1st time = everything was good. I generate the patch. Then I do other staff, finish some texture picking....etc

 

Now I try to repatch. But BOOM, FNIS won't run again. WHY ???? After different try, I uninstall it, and re-install it, but that time, FNIS won't run at the first time !!! I post here a pics of MO2,     so you can see messages at the bottom of the image.

Very annoying.

 

What can make FNIS not running ?

The messages at the bottom of MO2 indicate that MO2 is running properly - they just say that it spawned the process (FNIS) and waited for it to complete. In MO2's eyes, that means that the process shut down, which it did. That said, the problem MUST be in FNIS, and for that, you might have better luck asking in the Nexus Forums than here... I've never had problems with the program, and assuming that the GamerPoet video you used is up to date and that you followed all listed instructions, this is more likely something that the author can help with than us. Especially since you verified you aren't (and have never) using ModDrop.

 

Thinking on it, I do have one question - which version of Skyrim are we talking about here (LE or SE) and are you using the matching version of FNIS?


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users