Jump to content


Photo

dyndolod sse water reflection problem

dyndolod reflection

  • Please log in to reply
20 replies to this topic

#1 munha666

munha666

    Prisoner

  • Members
  • 10 posts

Posted 20 November 2018 - 08:11 AM

hey there, im having a strange problem where the water reflection got all messed up after some play time, and/ or after fast travel. uninstalling dyndolod resolves the issue. it can easily be seem in solstheim. i suspect it has to do with reflection of lods as dyndolod is about lods
  • 0

#2 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,522 posts

Posted 20 November 2018 - 08:20 AM

hey there, im having a strange problem where the water reflection got all messed up after some play time, and/ or after fast travel. uninstalling dyndolod resolves the issue. it can easily be seem in solstheim. i suspect it has to do with reflection of lods as dyndolod is about lods

Aha.


  • 0

#3 munha666

munha666

    Prisoner

  • Members
  • 10 posts

Posted 20 November 2018 - 10:51 AM

the process i used was the documented:
0 installed papyrus util and dyndolod resources in load order
1 generated texgen output and added to the load order
2 generated dyndolod output, high preset, added to load order

maybe its sse engine limitation? without dyndolod game at distance look like ****
  • 0

#4 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,522 posts

Posted 20 November 2018 - 11:29 AM

>a strange problem where the water reflection got all messed up

 

This does not mean anything to anybody else without any screenshots. There are no similar reports in years.

 

Do some basic troubleshooting:

 

Make the Skyrim.INI and SkyrimPrefs.INI default again. 

 

Is it really the cube map LOD reflections having a problem? Turn off LOD via console tll

 

Does the LOD itself look OK? The LOD is static and does not change when mid game. If the LOD is still OK but the LOD reflection not, it means generating the cube map has a problem.

 

Disable/Hide/Remove the generated Meshes only, leave the plugins in the load order. What happens now?

 

Disable/Hide/Remove the generated Textures only, leave the meshes/plugins in the load order. What happens now other then the expect missing purple textures?

 

Disable/Hide/Remove the plugins only. What happens now?

 

Test with vanilla game and only DynDOLOD.


Edited by sheson, 20 November 2018 - 11:30 AM.

  • 0

#5 munha666

munha666

    Prisoner

  • Members
  • 10 posts

Posted 29 November 2018 - 08:04 PM

some pics of the problem, my inis are ultra default, only customization is ugrids 7 and largereference 21

https://steamuserima...6A5608E4B478EB/

https://steamuserima...96673BCAE5463A/

https://steamuserima...150451D28B86E6/

https://steamuserima...4542124F519D61/

https://steamuserima...DB64A6ED51F98A/

https://steamuserima...90116C25433961/

notice the smudged reflections of sky (breflectsky=0 in inis), also the dividing line in reflections, also ****ed up cube map reflection in map screen, also strange reflection glow in water during night
  • 0

#6 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,522 posts

Posted 30 November 2018 - 03:55 AM

some pics of the problem, my inis are ultra default, only customization is ugrids 7 and largereference 21

https://steamuserima...6A5608E4B478EB/

https://steamuserima...96673BCAE5463A/

https://steamuserima...150451D28B86E6/

https://steamuserima...4542124F519D61/

https://steamuserima...DB64A6ED51F98A/

https://steamuserima...90116C25433961/

notice the smudged reflections of sky (breflectsky=0 in inis), also the dividing line in reflections, also ****ed up cube map reflection in map screen, also strange reflection glow in water during night


Make the Skyrim.INI and SkyrimPrefs.INI default again to reset the mentioned settings to normal values and possible others.

Only then does it make sense to do the other troubleshooting steps already suggested.
 
DynDOLOD does not change how reflections work, image spaces etc. It generates static object and tree LOD and adds some references to the world.
However it will carry for World and Cell data from the highest plugins at the time of generation.

Useful troubleshooting includes testing with a default game and default INIs and then generate DynDOLOD for it.


Edited by sheson, 30 November 2018 - 05:57 AM.

  • 0

#7 munha666

munha666

    Prisoner

  • Members
  • 10 posts

Posted 11 December 2018 - 10:59 PM

tried reverting ini to default didnt made difference. what i found is, the smudge/line in the reflections is actually... mountains reflection. looks like the cube map got messed up in its properties of position i guess
  • 0

#8 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,522 posts

Posted 12 December 2018 - 05:01 AM

Test if hiding the static object LOD meshes\terrain\dlc2solstheimworld\objects\ makes a difference. 

 

If doesn't change anything put it back. Then disable just DynDOLOD.esp and see if that makes a difference. If it does open DynDOLOD.esp in xEdit and right click remove the worldspace DLC2SolstheimWorld and see if that changes anything.

 

If not do the same with DynDOLOD.esm.

 

If non of it changed anything the problem is caused by something else.


  • 0

#9 munha666

munha666

    Prisoner

  • Members
  • 10 posts

Posted 12 December 2018 - 09:25 PM

deactivating dyndolod.esp solves the issue. the issue happens in tamriel and solstheim, can be easily seem in college winterhold. i guess can live with these reflections, no **** distance fof me
  • 0

#10 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,522 posts

Posted 13 December 2018 - 04:45 AM

Since all data in the DynDOLOD plugins is copied from the other plugins in the load order, it is possible to trace down to the source of problem.

 

As already suggested remove the worldspace from the plugin and check if it makes a difference. If it does, restore the plugin from backup. 

Then remove the persistent cell. Again, if it changes anything restore from the backup made just before the change. Then start removing reference in batches from the persistent cell. 

Then move on to the temporary cells, same procedure.

Backup the plugin if the error still keeps happening. Restore plugin from backup in case the problem went away and remove other records. That way you will hopefully end up with a singe record that causes the problem.

 

Keep in mind that in 4 years nobody else ever reported such issues, so the source is something obscure.


Edited by sheson, 13 December 2018 - 04:46 AM.

  • 0

#11 munha666

munha666

    Prisoner

  • Members
  • 10 posts

Posted 13 December 2018 - 01:52 PM

i dont get it, i removed every worldspace in dyndolod.esp in sseedit, and dynamic lods where still there, issue also still there
  • 0

#12 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,522 posts

Posted 13 December 2018 - 02:09 PM

The entire dynamic LOD of a worldspace is done by all the references in the persistent cell. 0000D74 for Tamriel/Skyrmi and 040142EC for DLC2SolstheimWorld/Solstheim.

 

If that data removed waterfalls, fires, windmill fans etc should be gone.

 

You might have a second plugin (in MO Overwrite folder?) that loads after the one you are editing.


  • 0

#13 munha666

munha666

    Prisoner

  • Members
  • 10 posts

Posted 20 January 2019 - 07:54 PM

after numerous tests with version 2.54, if i generate dyndolod with high preset and remove the two lines related to the rules of water, the problem is gone, some weird interaction between lod rules of water and realistic water two
  • 0

#14 munha666

munha666

    Prisoner

  • Members
  • 10 posts

Posted 20 January 2019 - 09:50 PM

sorry i was wrong problem still persists
  • 0

#15 munha666

munha666

    Prisoner

  • Members
  • 10 posts

Posted 22 January 2019 - 08:35 PM

i finally found the culprit it is static tree lod with treefullfallback=0

i was using it because sfo lods look like ass ****

when treefullfallback=1 problem is gone this time i double tested

so maybe some next dyndolod version will correct this? dyndolod is essential for not **** skyrim lods

maybe you could take a second born?
  • 0



Also tagged with one or more of these keywords: dyndolod, reflection

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users